Solved '5.1 Dolby Digital +' via Intel iGPU to HDMI to AV Receiver, Realtek USB Audio for noobs by a noob.


HumourMe

Member
Local time
6:55 PM
Posts
1
OS
Windows 11 Pro
Edit: Try this first if you have been mucking about with drivers/ registry etc already.

Go into safe mode, without the AV attached, then in device manager removed all references to the AV from monitors and audio.
If like me you have introduced two hardware IDs for one device this will have confused the OS.

I've not found this described elsewhere and it was only when reading about driver loading priority that I understood what was not happening correctly.

The steps below might help too, however, the procedure above made the solution stable and boot order (PC or AV first) irrelevant. It is also the simplest and quickest.




Hopefully this is the right board. So many places this could go. It builds upon this Windows 10 post, the use case being slightly different as this is HDMI via an Intel iGPU. I only came across the post when I was mostly done. And of course this is Windows 11 which may have its own quirks.

At the least this summarises some of the things you need to put in place and highlights why something might go wrong if seeking a similar solution. This took me a couple of weeks of trial and error to work through the requirements to get this working and I explored many combinations. I reinstalled Windows 11 at least 5 times to tidy up and also recover from excessive registry tidying, so I thought I’d record the process to save anyone else some blind alleys and also act as a reference just in case I need to repeat this. Of course I’m very open to someone saying “you are such a noob you should do this” as now I might understand ‘why’! If your audio isn’t ‘USB’ based or you go straight to analogue (not HDMI or SPDIF) there are established / easier solutions to enable Surround Sound.

The motivation was to get 5.1 surround sound from an amplifier via Windows 11. The Audio Visual receiver might have an additional screen as output, however, I ran with a ‘Ghost’ virtual screen. This was at a lower resolution so I ‘extended desktops’ and positioned it to the top right of my existing screen (so screen 1 top right is adjacent to ‘ghost’ 2, bottom left). That way I didn’t lose the mouse or move apps off the visible space.

My old Amplifier (Onkyo TX-SR607) can decode various Dolby and DTS formats as well as directly receive PCM to 7.1. The Dolby format that seemed to work was Dolby Digital +. I’ve not yet got consistent sound from reported Dolby TrueHD, which is what Atmos should default to by design. DTS is recognised. What definitely didn’t work was using the surround apps Dolby Access or DTS Sound Unbound with 2+ channels.

There are two potential physical digital connection options. via SPDIF/Toslink or by HDMI. SPDIF needs encoding and is I think 2-channel. HDMI can handle more than two channels and can be ‘lossless’ so this was my focus. Why digital? Sound starts off analogue, it is digitally encoded and the fewer transformations before it becomes analogue again (at the speakers) the purer it will be. In my case I needed to purchase a small add-on PCI card to enable SPDIF which I used to compare with the HDMI solution. Later on I discovered that switching to this borked the HDMI. I’d still like to do this as I could set up a two channel setup and a multichannel setup and switch between them on the receiver. However, for now my focus has been on a stable HDMI connection.

For an encoded source, with an Audio Visual receiver/decoder/amplifier (AV) , you have the choice between PC software/hardware decodes or AV decodes. For headphone surround sound the PC works and you can use the Dolby or DTS app to activate this. I didn’t test speakers connected directly to the motherboard or soundcard, however, these should both be similar (but need to be setup).

HDMI: to successfully receive Dolby you need to pass ‘bitstream’. To pass bitstream there are a few requirements. I’ll get to these but you might want to skip ahead and try them first. The first part of the instructions are what I did when stuff didn’t work. I now suspect that I could have gone directly to Step 2 for a trial run. Step 0 & 1 are then what to do when 2 & 3 don’t work.



Step 0: Preparation:

  • Add a shortcut for the control panel to your taskbar (start |type ‘control panel’ |right click, add to taskbar). This can be used to quickly open ‘Sounds’ and the Device manager to get ‘sounds’ (along the way somehow, I added a desktop link directly to ‘Sounds’). Windows key + X is another way to easily get there.
  • Next download the excellent utility CRU. The first time using this is just really practice. It is here for a belt and braces approach, just in case. It might not be necessary but if you later need to edit functionality you can use this.
  • Make sure your AV is connected via HDMI. [Optional] Your AV may require a ‘fake monitor’ plugged in. Amazon/Google for ‘HDMI dummy plug’. Mine didn’t need this but I didn’t know that at the time and it was just another element to vary/verify.


Step 1: Preparing the Extended Display Identification Data file and driver (.inf) file.
  • Open CRU
  • Select the AV monitor (top left)
  • Export the AV settings to an inf file and an exe file (bottom left). This ideally will be enough, if your AV reported correctly and was information complete. Otherwise you might need to add missing information.
Congratulations you’ve just made an EDID implementation file and a driver. Now you need to bypass Windows 11 restrictions to install, it to see if it is good enough. Check out the CRU thread and install directory for more information and also examples.
  • Updating the Monitor information
    • [Option A - EDID exe] Run the exe and reboot. Carry on from Step 2.
    • [Option B – using a custom driver] - You need to turn off driver signing. To do so follow this.
      • Home or Pro (easier Pro method below)
        1. Start your computer and then keep pressing the F8 key before Windows starts. You will see the Advanced Options screen.
        2. Choose Troubleshoot > Advanced options > Startup Settings and click the Restart button.
        3. When your computer restarts you’ll see a list of options. Press 7 on your keyboard to select Disable driver signature enforcement.
        4. After an automatic reboot you’ll be able to install unsigned drivers for this session.
        5. Now to use the shortcut that we started with. Open Control panel| Device manager| Monitors. You should see two ‘Generic PnP monitor’. We now need to identify our target and update it.
        6. Right click| Properties| Details [Property dropdown ‘Hardware IDs’] for both of them to try to spot which one is the target.
        7. When you know which one it is then install the driver using …Properties| Update driver| Browse … | [navigate to location] | let me pick … and select the driver. If it works your “Monitor” should now have the correct name. This information is subsequently read by the Audio inputs and outputs.
  • [weird bullet I can't remove!]
    • Note it is possible to add the group policy editor to home. At least I’ve seen references to doing so, so if it sounds useful google it.
      • Pro alternative
        1. Open the group policy editor (if you don’t know how google how to do this)
        2. Enable ‘Allow administrators to override Device Installation Restriction policies’
        3. Follow above section from 5-7
        4. Disable policy? Personally I toggle it off when I don’t need it, for security.
        5. Lock in the driver change using “prevent installation of devices that match any of these device IDs”

Why consider option B 'home or pro' ? The ‘fake monitor’ becomes named in Device manager, which allows a relatively fast reset for the device by simply ‘uninstalling’ in device manager then detecting new hardware.

Step 2: Setup
  1. Keep the AV/Monitor powered on and reboot. I think mine needs to be on before the PC boots, to be properly recognised. Sometimes I had to reboot twice. Any advice to avoid this is welcomed.
  2. Open Device Manager again.
  3. Go to Sound, Video and Game controllers. I had three ‘HD Audio Driver for Display Audio’.
  4. Right click each Properties | Power management | untick ‘allow computer to turn off …’. If you don’t do this, then the sound element may be put to sleep. Only rebooting got me past this, sometimes several times.
  5. If after a reboot if these revert then you need to create a custom power plan and specify that the screens are turned off only after a long period of inactivity. To do this use your handy Control panel shortcut, choose power options, create a power plan … make sure the screens are ‘never’ turned off (while the PC is on).
Step 3: Configuration and Resetting

If everything is working we can now configure “HD Audio Driver for Display Audio” which might even be named correctly. If you can’t see this option then it might be an EDID tweak required. See ‘other tweaks’ below though as it might be one of them that made my setup work.
  1. Open Sounds via the Control panel. Disable any device you are unlikely to use (right click, disable) . That was just for neatness.
  2. Right click the target AV and choose Configure [speakers].
  3. Select the maximum number of speakers (technically channels) your AV can handle (in my case 7.1, even though I only have 5.1 speakers ... again as a noob it is possible that I should have specified 5.1), tick everything on the next two screens (all speakers, full range): this is about information flow to the AV which should do all the work, down mixing if necessary and handling crossover. I read the AV manual many times and cross compared to speaker specs. Run any autotune / room positioning setup options if you haven't already.
  4. Next Properties … check the encoded formats. If you don’t see what you want, revert to CRU and editing. There are examples in the unzipped folder. If you click the blue speaker icon, under levels, the volume is available for each (virtual) speaker. There should be no need to mess with these at least until testing. Under Advanced I choose 16 bit, 48000Hz as this is compatible with most formats. For Bitstream==Dolby I had to tick ‘Exclusive mode’. I ticked both options. With none ticked I got PCM. IMPORTANT make sure Spatial Sound is ‘off’; thinking that it needed to be activated was my biggest sidetrack.
Other tweaks: Other tweaks remaining from blind alleys explored. I don’t think these have an affect on HDMI output, however, it is possible they may be requirements.
  • An up to date Realtek driver pack (in my case from ROG message boards). I think I was aiming at the wrong target at this stage.
  • Uninstalled/Disabled Sonic Studio 3 and other Asus bloatware (with a focus on A-volute, Nahimic) via a combination of Startup/Services/Scheduled tasks (and if using Windows 11 Pro set up policies in the gpedit to stop them returning). I’m left with Asus Sonic Studio Companion, disabled in Device Manager Sonic Studio Virtual Mixer & A-Volute Nh3 Audio Effects Component, disabled in Services Nahimic service, disabled in Task Scheduler NahimicScv[32/64]Run. Nahimic in particular is very difficult to suppress, but that is another topic.

Step 4 Testing that seemed to verify success:
  • I used videos from the Dolby App (helpfully tells me I’m not using Atmos although I can hear surround). I can enable Home Theater, however, switching to another app results in silence. Do not enable this. In this situation resetting and/or rebooting might be needed. If stuck in ‘Home theater’ and only being able to choose 2.1 as an alternative you might have to go through configuration 2x, the first getting an error. My receiver indicates Dolby Digital + with spatial sound off.
  • Next Netflix App. The opening scenes from Baby Driver (an entertaining film) also reports as Dolby Digital + 5.1.
  • Youtube Music is Multi channel PCM although really 2.0.
  • Switching back to Netflix resumes DD+.
  • Now Amazon Music … again Multi Channel PCM
  • Back to Netflix and DD+ resumes.
  • Finally using several DVDs via VLC after some configuration, Dolby D Surround 2.0 for intros switching to DD+ 5.1 for films (If anything tells me this is a near superseded format The Matrix Reloaded, still unwrapped, is a hint).
(VLC configuration Reddit link here).​

And if settings revert to ‘Digital Audio (HDMI)’ 2 channel output this may be caused by ...
  • Use of spatial sound options.
  • Switching to another digital speaker (e.g. Realtek Digital Output via SPDIF).
    • For now, this particular problem went away after I went into safe mode, without the AV attached, then in device manager removed all references to the AV from monitors and audio. I suspected that while trying to address the issue I had introduced two hardware IDs and this confused the OS. If it returns I'll edit this again.
  • Power options.
You will probably have to reboot to enable changes and/or see if they stick. If they are as expected then investigate drivers.

If you are still reading here and have been as frustrated as I was then I hope this helps you.
 
Windows Build/Version
Windows 11 Pro v21H2
Last edited:

My Computer

System One

  • OS
    Windows 11 Pro
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom
    CPU
    i5-12600k (Overclocked to 5200Ghz)
    Motherboard
    ROG Strix z690-A Gaming WiFi D4
    Memory
    Corsair 16Gb x 2
    Graphics Card(s)
    iGPU
    Sound Card
    Motherboard to Onkyo TX-SR607 to 5.1 Speakers
    Monitor(s) Displays
    Asus MZ27AQ
    Screen Resolution
    2560 x 1440
    Hard Drives
    2x Seagate FireCuda 530 ZP1000GM30013
    PSU
    Corsair 850w
    Case
    Fractal Design Define 7 Compact
    Cooling
    AIO
    Keyboard
    Logitech K120
    Mouse
    Kensington Expert
    Internet Speed
    350Mbps
    Browser
    Chrome/Edge
    Antivirus
    Windows Defender
Top Bottom