Auto play not keeping window open


larrydonline

Member
VIP
Local time
1:20 AM
Posts
48
OS
Windows 11
I've set System/Bluetooth & Devices/Auto Play/Chose Auto Play Defaults/Removable Drive to "Open Folder To View Files (File Explorer)". Today when I plugged in USB drive the window opened briefly and then closed. I check the setting above and it was not set. So I set it again to open folder to view files.

When I plugged the USB in again a window opened to show the files and then immediately closed. I checked the setting and it was still set to "open folder". I don't know why it's acting that way. It should open the window and leave it open but it's not. What is the fix for this? Please.

Window 11 v.21H2 build 22000.556
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell 8940
    CPU
    3.70 gigahertz Intel Core i9-10900K
    Motherboard
    Board: Dell Inc. 0KV3RP A00 Serial Number: /9TND853/CNFCW0006H00SE/ Bus Clock: 100 megahertz
    Memory
    65272 Megabytes Usable Installed Memory
    Graphics Card(s)
    Intel(R) UHD Graphics 630 [Display adapter] NVIDIA GeForce RTX 2070 SUPER [Display adapter]
    Sound Card
    Multimedia Intel(R) Display Audio NVIDIA High Definition Audio NVIDIA Virtual Audio Device (Wave Extensible) (WDM) Realtek(R) Audio WsAudio_Device
    Monitor(s) Displays
    Dell

glasskuter

Well-known member
Pro User
VIP
Local time
3:20 AM
Posts
2,273
Location
The Lone Star State of Texas
OS
Windows 11 Pro 21H2 22000.832
Try going to autoplay- at bottom of page set to default. Restart computer. Go back to autoplay and set everything again to what you want and see if it will hold.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 21H2 22000.832
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 m.2 2230-256+1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 21H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium

larrydonline

Member
VIP
Thread Starter
Local time
1:20 AM
Posts
48
OS
Windows 11
Are you saying "reset all default apps"? restart and set again? The Default Apps list must have a hundred apps listed.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell 8940
    CPU
    3.70 gigahertz Intel Core i9-10900K
    Motherboard
    Board: Dell Inc. 0KV3RP A00 Serial Number: /9TND853/CNFCW0006H00SE/ Bus Clock: 100 megahertz
    Memory
    65272 Megabytes Usable Installed Memory
    Graphics Card(s)
    Intel(R) UHD Graphics 630 [Display adapter] NVIDIA GeForce RTX 2070 SUPER [Display adapter]
    Sound Card
    Multimedia Intel(R) Display Audio NVIDIA High Definition Audio NVIDIA Virtual Audio Device (Wave Extensible) (WDM) Realtek(R) Audio WsAudio_Device
    Monitor(s) Displays
    Dell

glasskuter

Well-known member
Pro User
VIP
Local time
3:20 AM
Posts
2,273
Location
The Lone Star State of Texas
OS
Windows 11 Pro 21H2 22000.832
Sorry I wasn't clear. I left something out. I'm talking about control panel- default programs-change autoplay settings. When you 'reset all default' from this Autoplay page, it doesn't change ALL your apps, only the ones affecting autoplay. Make sure that 'use autoplay for all media and devices' is checked on this page.

This is the old way of changing autoplay settings from back in the windows 7 days and may not fix a thing, but it's worth trying.

2 other things to try: try another usb drive and
Ensure that Shell Hardware Detection service is running
Type services.msc in Start Search to run the Services console. Locate the Shell Hardware Detection, and ensure that the Service Status is running, and Startup Type is Automatic. If not, start the service and change the Startup Type setting accordingly.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 21H2 22000.832
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 m.2 2230-256+1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 21H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium

larrydonline

Member
VIP
Thread Starter
Local time
1:20 AM
Posts
48
OS
Windows 11
OK, I think that was the path I took. It appears to be doing what it should do now. A reboot might have helped settle it down. Thank you.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell 8940
    CPU
    3.70 gigahertz Intel Core i9-10900K
    Motherboard
    Board: Dell Inc. 0KV3RP A00 Serial Number: /9TND853/CNFCW0006H00SE/ Bus Clock: 100 megahertz
    Memory
    65272 Megabytes Usable Installed Memory
    Graphics Card(s)
    Intel(R) UHD Graphics 630 [Display adapter] NVIDIA GeForce RTX 2070 SUPER [Display adapter]
    Sound Card
    Multimedia Intel(R) Display Audio NVIDIA High Definition Audio NVIDIA Virtual Audio Device (Wave Extensible) (WDM) Realtek(R) Audio WsAudio_Device
    Monitor(s) Displays
    Dell
Top Bottom