DirectX Runtime Installation Issue - dxerror.log and directx.log


lecs

New member
Local time
2:31 PM
Posts
1
Visit site
OS
Windows 11
HI! 🖖
I recently upgraded my gaming PC from Win 10 to Win 11 N version 22H2 (build 22621.1265) with a full wipe of previous data. I'm a sim-driver enthusiast, so I downloaded Assetto Corsa Competizione from my Steam account. When I tried to launch the game, I got a message stating that the Direct X Runtime installation was missing.
To solve this problem I downloaded the suite from Microsoft but unfortunately it returns me the infamous DXerror.log and directx.log message.

After that I've trying almost every single solution finded on web, including:
  • Change the HKEY_LOCAL_MACHINE key (both "Installed version" and "Version")
  • Net Framework repair tool
  • Switch the services named "Performance log and alerts" from manual to automatic
  • Switch the services named "Virtual Disc" from manual to automatic
  • Install Media Feature Pack
  • Install Graphic Feature from "Optional features"
  • Enable Windows functionality like Net.Framework 3.5 and DirectPlay
  • Run a scan from CMD with sfc / scannow and restrore health
  • Install all the Vc Redist c++ since 2005
  • Dowload the offline version of Runtime, place it in a C: folder and try to install it having the same problem. Until run the program in compatibility mode (XP Service Pack 3) and receive none error message. Despite this I have the feeling that nothing has changed. I can tell from the launch of Assetto Corsa, so the game tries to install Direct X material every time for a few seconds to be really ready

Nothing of the above actions worth the solution of the problem. Reading the DXerror.log the problem is:
"module: dxupdate(Mar 30 2011), file: dxupdate.cpp, line: 2234, function: RegisterDLL
Failed API: LoadLibraryEx()
Error: (193) - %1 is not a valid Win32 application.
Unable to load C:\Windows\system32\xactengine2_0.dll."


After that I restore the .dll file, both the 32 and 64 bit but nothing. Reading online I found that this dll needs to register. So I have tryied to do so with the regsvr32 command but Windows find this dll "not compatible" with this version.

Just for the context I solved the problem totally random, adding two dlls to the installation folder of the game: mfplat and resampledmo. Despite that, is there anything I can still do to correctly install that damn Runtime? I'm afraid I'll have problems installing other games in the future, having to add dlls until I find the solution.

Thanks and sorry for my poor english, I'm from Italy!! ❤️
 
Windows Build/Version
Win 11 N version 22H2 (build 22621.1265)

My Computer

System One

  • OS
    Windows 11
Back
Top Bottom