Edge lags when I play 4k videos on Netflix?


Citrusflavour01

Active member
Local time
6:06 AM
Posts
20
Visit site
OS
Windows 11
I can watch 1440p HDR content smoothly on Edge but the video becomes choppy once the resolution hits 2160p. My PC is definitely strong enough to stream 4k content. I'm on the latest version of Windows 11 and I believe I have the correct edge settings to watch 4k content.
 

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    Ryzen 9 5900X
    Motherboard
    GIGABYTE B550 Aorus Pro V2
    Memory
    Corsair Vengeance RGB PRO 32GB (4x8GB) DDR4 3200MHz C16
    Graphics Card(s)
    MSI GeForce RTX 3070 Ti VENTUS 3X 8G OC
    Screen Resolution
    2560 x 1440
    Hard Drives
    NVMe Gen 4 Sabrent Rocket 1TB (boot)
    NVMe Gen 3 ADATA 512GB (secondary)
    PSU
    RM750x Corsair
    Case
    Corsair CW-9060051
    Cooling
    Corsair iCUE SP120 RGB + iCUE H150i Elite CAPELLIX
    Keyboard
    Logitech G213 PRODIGY
    Mouse
    Logitech G502 Hero
    Browser
    Edge
  • Operating System
    Windows 11
    Computer type
    PC/Desktop
    CPU
    Ryzen 5 5600X
    Motherboard
    MAG B550 TOMAHAWK
    Memory
    G.Skill Gaming Memory Ripjaws V 32GB (2x16GB) 3600mhz CL18
    Graphics card(s)
    MSI Radeon RX 6500 XT Mech 2X 4G OC
    Screen Resolution
    1080p

Coolmistry

Active member
Local time
10:06 PM
Posts
15
Location
London UK
Visit site
OS
Windows 11
Maybe in your Edge setting is off for 'Use hardware acceleration when available' try check in your Edge setting > System and Performance.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    EVGA
    CPU
    i9 11900K
    Motherboard
    EVGA Z590 FTW
    Memory
    Corsair DDR4 3600mhz XMP 32GB
    Graphics Card(s)
    Sli 2 x NVIDIA RTX2080Ti Foundtion Editon
    Sound Card
    Realtek and EVGA NU Audio
    Monitor(s) Displays
    Acer Predator Z35 35-inch Curved G-Sync
    Screen Resolution
    2560 x 1050 G-Sync
    Hard Drives
    M.2 Samsung Pro 500gb
    M.2 Samsung Pro 250gb
    Westdigtal WD Green HDD 500gb
    PSU
    EVGA SuperNOVA 1300 X3
    Case
    EVGA case D77
    Cooling
    EVGA CLC 380 Liquid / Water CPU Cooler
    Keyboard
    EVGA Z10
    Mouse
    EVGA Torq X10
    Internet Speed
    850mbp
    Browser
    Mircosoft Edges Google and Bing
    Antivirus
    Kaspersky Internet
    Other Info
    Logitech Z906 THX 5.1 Surround Sound Speakers SPDIF

ShamrockRig

R H Semi
Power User
Local time
10:06 PM
Posts
1,231
Location
Scotland/Eire
Visit site
OS
11
I can watch 1440p HDR content smoothly on Edge but the video becomes choppy once the resolution hits 2160p. My PC is definitely strong enough to stream 4k content. I'm on the latest version of Windows 11 and I believe I have the correct edge settings to watch 4k content.
whats youre internet speeds like?
 

My Computer

System One

  • OS
    11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom
    CPU
    10700k@5.2
    Motherboard
    Gigabyte Gaming X Z490
    Memory
    Viper Steelseries 32gb@ 3600mhz
    Graphics Card(s)
    Gigabyte 2070 Super 8GB, +200 core + 600 memory
    Monitor(s) Displays
    ASUS 4k HDR, Two 1080p Benq and Samsung
    Screen Resolution
    3840x2160/2560x1440/1920x1080
    Hard Drives
    Adata XPG SX8200 PRO 1tb
    Samsung EVO 870 500GB
    PSU
    Corsair RX 650
    Case
    NZXT h510
    Cooling
    CM HYPER 212 RGB
    Keyboard
    Razer Ornata Chroma
    Mouse
    Steelseries Rival 710

Citrusflavour01

Active member
Thread Starter
Local time
6:06 AM
Posts
20
Visit site
OS
Windows 11

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    Ryzen 9 5900X
    Motherboard
    GIGABYTE B550 Aorus Pro V2
    Memory
    Corsair Vengeance RGB PRO 32GB (4x8GB) DDR4 3200MHz C16
    Graphics Card(s)
    MSI GeForce RTX 3070 Ti VENTUS 3X 8G OC
    Screen Resolution
    2560 x 1440
    Hard Drives
    NVMe Gen 4 Sabrent Rocket 1TB (boot)
    NVMe Gen 3 ADATA 512GB (secondary)
    PSU
    RM750x Corsair
    Case
    Corsair CW-9060051
    Cooling
    Corsair iCUE SP120 RGB + iCUE H150i Elite CAPELLIX
    Keyboard
    Logitech G213 PRODIGY
    Mouse
    Logitech G502 Hero
    Browser
    Edge
  • Operating System
    Windows 11
    Computer type
    PC/Desktop
    CPU
    Ryzen 5 5600X
    Motherboard
    MAG B550 TOMAHAWK
    Memory
    G.Skill Gaming Memory Ripjaws V 32GB (2x16GB) 3600mhz CL18
    Graphics card(s)
    MSI Radeon RX 6500 XT Mech 2X 4G OC
    Screen Resolution
    1080p

Citrusflavour01

Active member
Thread Starter
Local time
6:06 AM
Posts
20
Visit site
OS
Windows 11
Maybe in your Edge setting is off for 'Use hardware acceleration when available' try check in your Edge setting > System and Performance.
It is enabled and I also tried turning it off but that made no difference.
 

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    Ryzen 9 5900X
    Motherboard
    GIGABYTE B550 Aorus Pro V2
    Memory
    Corsair Vengeance RGB PRO 32GB (4x8GB) DDR4 3200MHz C16
    Graphics Card(s)
    MSI GeForce RTX 3070 Ti VENTUS 3X 8G OC
    Screen Resolution
    2560 x 1440
    Hard Drives
    NVMe Gen 4 Sabrent Rocket 1TB (boot)
    NVMe Gen 3 ADATA 512GB (secondary)
    PSU
    RM750x Corsair
    Case
    Corsair CW-9060051
    Cooling
    Corsair iCUE SP120 RGB + iCUE H150i Elite CAPELLIX
    Keyboard
    Logitech G213 PRODIGY
    Mouse
    Logitech G502 Hero
    Browser
    Edge
  • Operating System
    Windows 11
    Computer type
    PC/Desktop
    CPU
    Ryzen 5 5600X
    Motherboard
    MAG B550 TOMAHAWK
    Memory
    G.Skill Gaming Memory Ripjaws V 32GB (2x16GB) 3600mhz CL18
    Graphics card(s)
    MSI Radeon RX 6500 XT Mech 2X 4G OC
    Screen Resolution
    1080p

Coolmistry

Active member
Local time
10:06 PM
Posts
15
Location
London UK
Visit site
OS
Windows 11
Mmm try clean your Edge cached in your Clear browser data?
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    EVGA
    CPU
    i9 11900K
    Motherboard
    EVGA Z590 FTW
    Memory
    Corsair DDR4 3600mhz XMP 32GB
    Graphics Card(s)
    Sli 2 x NVIDIA RTX2080Ti Foundtion Editon
    Sound Card
    Realtek and EVGA NU Audio
    Monitor(s) Displays
    Acer Predator Z35 35-inch Curved G-Sync
    Screen Resolution
    2560 x 1050 G-Sync
    Hard Drives
    M.2 Samsung Pro 500gb
    M.2 Samsung Pro 250gb
    Westdigtal WD Green HDD 500gb
    PSU
    EVGA SuperNOVA 1300 X3
    Case
    EVGA case D77
    Cooling
    EVGA CLC 380 Liquid / Water CPU Cooler
    Keyboard
    EVGA Z10
    Mouse
    EVGA Torq X10
    Internet Speed
    850mbp
    Browser
    Mircosoft Edges Google and Bing
    Antivirus
    Kaspersky Internet
    Other Info
    Logitech Z906 THX 5.1 Surround Sound Speakers SPDIF

ShamrockRig

R H Semi
Power User
Local time
10:06 PM
Posts
1,231
Location
Scotland/Eire
Visit site
OS
11
Try using the netflix app and see if the problem persists?
 

My Computer

System One

  • OS
    11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom
    CPU
    10700k@5.2
    Motherboard
    Gigabyte Gaming X Z490
    Memory
    Viper Steelseries 32gb@ 3600mhz
    Graphics Card(s)
    Gigabyte 2070 Super 8GB, +200 core + 600 memory
    Monitor(s) Displays
    ASUS 4k HDR, Two 1080p Benq and Samsung
    Screen Resolution
    3840x2160/2560x1440/1920x1080
    Hard Drives
    Adata XPG SX8200 PRO 1tb
    Samsung EVO 870 500GB
    PSU
    Corsair RX 650
    Case
    NZXT h510
    Cooling
    CM HYPER 212 RGB
    Keyboard
    Razer Ornata Chroma
    Mouse
    Steelseries Rival 710

Citrusflavour01

Active member
Thread Starter
Local time
6:06 AM
Posts
20
Visit site
OS
Windows 11
Mmm try clean your Edge cached in your Clear browser data?
Already did that
Try using the netflix app and see if the problem persists?
I installed the Netflix app and it seems to work fine only if the video isn't in full-screen mode. I can adjust the window size so that it's almost full-screen though.
 

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    Ryzen 9 5900X
    Motherboard
    GIGABYTE B550 Aorus Pro V2
    Memory
    Corsair Vengeance RGB PRO 32GB (4x8GB) DDR4 3200MHz C16
    Graphics Card(s)
    MSI GeForce RTX 3070 Ti VENTUS 3X 8G OC
    Screen Resolution
    2560 x 1440
    Hard Drives
    NVMe Gen 4 Sabrent Rocket 1TB (boot)
    NVMe Gen 3 ADATA 512GB (secondary)
    PSU
    RM750x Corsair
    Case
    Corsair CW-9060051
    Cooling
    Corsair iCUE SP120 RGB + iCUE H150i Elite CAPELLIX
    Keyboard
    Logitech G213 PRODIGY
    Mouse
    Logitech G502 Hero
    Browser
    Edge
  • Operating System
    Windows 11
    Computer type
    PC/Desktop
    CPU
    Ryzen 5 5600X
    Motherboard
    MAG B550 TOMAHAWK
    Memory
    G.Skill Gaming Memory Ripjaws V 32GB (2x16GB) 3600mhz CL18
    Graphics card(s)
    MSI Radeon RX 6500 XT Mech 2X 4G OC
    Screen Resolution
    1080p

Fabler2

Well-known member
Power User
VIP
Local time
10:06 PM
Posts
2,207
Visit site
OS
Win 11 Pro & Dev.
Have you checked your CPU temps? Might be throttling in a bit when it's streaming.
 

My Computers

System One System Two

  • OS
    Win 11 Pro & Dev.
    Computer type
    Laptop
    Manufacturer/Model
    ASUS VivoBook
    CPU
    AMD Ryzen 7 3700U with Radeon Vega Mobile Gfx
    Motherboard
    ASUSTeK COMPUTER INC. X509DA (FP5)
    Memory
    12GB
    Graphics Card(s)
    RX Vega 10 Graphics
    Monitor(s) Displays
    Generic PnP Monitor (1920x1080@60Hz)
    Screen Resolution
    1920x1080@60Hz
    Hard Drives
    Samsung 980 1 TB PCIe 3.0 NVMe M.2
    Internet Speed
    25 Mbps
    Browser
    Edge
    Antivirus
    Defender
  • Operating System
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    ACER NITRO
    CPU
    AMD Ryzen 7 5800H / 3.2 GHz
    Motherboard
    CZ Scala_CAS (FP6)
    Memory
    16 GB (2 x 8 GB) DDR4 SDRAM 3200 MHz
    Graphics card(s)
    NVIDIA GeForce RTX 3060 6 GB GDDR6 SDRAM
    Sound Card
    Realtek Audio. NVIDIA High Definition Audio
    Monitor(s) Displays
    15.6" LED backlight 1920 x 1080 (Full HD) 144 Hz
    Screen Resolution
    1920 x 1080 (Full HD)
    Hard Drives
    Samsung 970 Evo Plus 2TB NVMe M.2
    PSU
    180 Watt, 19.5 V
    Mouse
    Lenovo Bluetooth
    Internet Speed
    25 Mbps
    Browser
    Edge
    Antivirus
    Defender

Citrusflavour01

Active member
Thread Starter
Local time
6:06 AM
Posts
20
Visit site
OS
Windows 11
Have you checked your CPU temps? Might be throttling in a bit when it's streaming.
I will monitor the temps and give an update afterwards
 

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    Ryzen 9 5900X
    Motherboard
    GIGABYTE B550 Aorus Pro V2
    Memory
    Corsair Vengeance RGB PRO 32GB (4x8GB) DDR4 3200MHz C16
    Graphics Card(s)
    MSI GeForce RTX 3070 Ti VENTUS 3X 8G OC
    Screen Resolution
    2560 x 1440
    Hard Drives
    NVMe Gen 4 Sabrent Rocket 1TB (boot)
    NVMe Gen 3 ADATA 512GB (secondary)
    PSU
    RM750x Corsair
    Case
    Corsair CW-9060051
    Cooling
    Corsair iCUE SP120 RGB + iCUE H150i Elite CAPELLIX
    Keyboard
    Logitech G213 PRODIGY
    Mouse
    Logitech G502 Hero
    Browser
    Edge
  • Operating System
    Windows 11
    Computer type
    PC/Desktop
    CPU
    Ryzen 5 5600X
    Motherboard
    MAG B550 TOMAHAWK
    Memory
    G.Skill Gaming Memory Ripjaws V 32GB (2x16GB) 3600mhz CL18
    Graphics card(s)
    MSI Radeon RX 6500 XT Mech 2X 4G OC
    Screen Resolution
    1080p

ShamrockRig

R H Semi
Power User
Local time
10:06 PM
Posts
1,231
Location
Scotland/Eire
Visit site
OS
11
Have you checked your CPU temps? Might be throttling in a bit when it's streaming.
If its cpu temps that are causing the issue with this i will eat my hat.
More chance of it being a leprechaun
 

My Computer

System One

  • OS
    11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom
    CPU
    10700k@5.2
    Motherboard
    Gigabyte Gaming X Z490
    Memory
    Viper Steelseries 32gb@ 3600mhz
    Graphics Card(s)
    Gigabyte 2070 Super 8GB, +200 core + 600 memory
    Monitor(s) Displays
    ASUS 4k HDR, Two 1080p Benq and Samsung
    Screen Resolution
    3840x2160/2560x1440/1920x1080
    Hard Drives
    Adata XPG SX8200 PRO 1tb
    Samsung EVO 870 500GB
    PSU
    Corsair RX 650
    Case
    NZXT h510
    Cooling
    CM HYPER 212 RGB
    Keyboard
    Razer Ornata Chroma
    Mouse
    Steelseries Rival 710

Fabler2

Well-known member
Power User
VIP
Local time
10:06 PM
Posts
2,207
Visit site
OS
Win 11 Pro & Dev.
If its cpu temps that are causing the issue with this i will eat my hat.
More chance of it being a leprechaun
Thanks for that sarcastic comment. Much appreciated. Still it won't hurt to check will it?
 

My Computers

System One System Two

  • OS
    Win 11 Pro & Dev.
    Computer type
    Laptop
    Manufacturer/Model
    ASUS VivoBook
    CPU
    AMD Ryzen 7 3700U with Radeon Vega Mobile Gfx
    Motherboard
    ASUSTeK COMPUTER INC. X509DA (FP5)
    Memory
    12GB
    Graphics Card(s)
    RX Vega 10 Graphics
    Monitor(s) Displays
    Generic PnP Monitor (1920x1080@60Hz)
    Screen Resolution
    1920x1080@60Hz
    Hard Drives
    Samsung 980 1 TB PCIe 3.0 NVMe M.2
    Internet Speed
    25 Mbps
    Browser
    Edge
    Antivirus
    Defender
  • Operating System
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    ACER NITRO
    CPU
    AMD Ryzen 7 5800H / 3.2 GHz
    Motherboard
    CZ Scala_CAS (FP6)
    Memory
    16 GB (2 x 8 GB) DDR4 SDRAM 3200 MHz
    Graphics card(s)
    NVIDIA GeForce RTX 3060 6 GB GDDR6 SDRAM
    Sound Card
    Realtek Audio. NVIDIA High Definition Audio
    Monitor(s) Displays
    15.6" LED backlight 1920 x 1080 (Full HD) 144 Hz
    Screen Resolution
    1920 x 1080 (Full HD)
    Hard Drives
    Samsung 970 Evo Plus 2TB NVMe M.2
    PSU
    180 Watt, 19.5 V
    Mouse
    Lenovo Bluetooth
    Internet Speed
    25 Mbps
    Browser
    Edge
    Antivirus
    Defender

ShamrockRig

R H Semi
Power User
Local time
10:06 PM
Posts
1,231
Location
Scotland/Eire
Visit site
OS
11
Thanks for that sarcastic comment. Much appreciated. Still it won't hurt to check will it?
Sorry did I say in my post not to check it? Didn't think so. Just highly doubt it. Like highly. If it is...then there's a massive issue with that cpu or cooler/paste. 4k streaming uses pretty much nothing extra on the cpu as far as my system goes. Ima say he's using no more than 10% cpu power at an absolute push. If temps are an issue there there..yup 😂
 

My Computer

System One

  • OS
    11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom
    CPU
    10700k@5.2
    Motherboard
    Gigabyte Gaming X Z490
    Memory
    Viper Steelseries 32gb@ 3600mhz
    Graphics Card(s)
    Gigabyte 2070 Super 8GB, +200 core + 600 memory
    Monitor(s) Displays
    ASUS 4k HDR, Two 1080p Benq and Samsung
    Screen Resolution
    3840x2160/2560x1440/1920x1080
    Hard Drives
    Adata XPG SX8200 PRO 1tb
    Samsung EVO 870 500GB
    PSU
    Corsair RX 650
    Case
    NZXT h510
    Cooling
    CM HYPER 212 RGB
    Keyboard
    Razer Ornata Chroma
    Mouse
    Steelseries Rival 710

ShamrockRig

R H Semi
Power User
Local time
10:06 PM
Posts
1,231
Location
Scotland/Eire
Visit site
OS
11
On a 2nd note, I'd maybe try using a different hdmi or display port cable and see if that's the issue, try other ports on the gpu/monitor too, I doubt temps are an issue on the cpu/gpu , and if you have two systems like you do, ima say you know some stuff. Atleast basic, temps etc. Also maybe try it on you're 2nd pc if possible?
also is the 4k screen separate to your usual day to day 1440p monitor? Or is it a 4k monitor? Try checking the refresh rate too just in case. Again doubt it but worth a look
 

My Computer

System One

  • OS
    11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom
    CPU
    10700k@5.2
    Motherboard
    Gigabyte Gaming X Z490
    Memory
    Viper Steelseries 32gb@ 3600mhz
    Graphics Card(s)
    Gigabyte 2070 Super 8GB, +200 core + 600 memory
    Monitor(s) Displays
    ASUS 4k HDR, Two 1080p Benq and Samsung
    Screen Resolution
    3840x2160/2560x1440/1920x1080
    Hard Drives
    Adata XPG SX8200 PRO 1tb
    Samsung EVO 870 500GB
    PSU
    Corsair RX 650
    Case
    NZXT h510
    Cooling
    CM HYPER 212 RGB
    Keyboard
    Razer Ornata Chroma
    Mouse
    Steelseries Rival 710

Citrusflavour01

Active member
Thread Starter
Local time
6:06 AM
Posts
20
Visit site
OS
Windows 11
I will monitor the temps and give an update afterwards
Have you checked your CPU temps? Might be throttling in a bit when it's streaming.
CPU is around 36 °C and it uses an average of 6%
On a 2nd note, I'd maybe try using a different hdmi or display port cable and see if that's the issue, try other ports on the gpu/monitor too, I doubt temps are an issue on the cpu/gpu , and if you have two systems like you do, ima say you know some stuff. Atleast basic, temps etc. Also maybe try it on you're 2nd pc if possible?
also is the 4k screen separate to your usual day to day 1440p monitor? Or is it a 4k monitor? Try checking the refresh rate too just in case. Again doubt it but worth a look
It looks like I can watch it on my main 1440p monitor but I then can't watch anything in 4k quality. For whatever reason, I can't stream any 4k content in full-screen mode on any screen. I use a 4k hdr tv as a second monitor.
 

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    Ryzen 9 5900X
    Motherboard
    GIGABYTE B550 Aorus Pro V2
    Memory
    Corsair Vengeance RGB PRO 32GB (4x8GB) DDR4 3200MHz C16
    Graphics Card(s)
    MSI GeForce RTX 3070 Ti VENTUS 3X 8G OC
    Screen Resolution
    2560 x 1440
    Hard Drives
    NVMe Gen 4 Sabrent Rocket 1TB (boot)
    NVMe Gen 3 ADATA 512GB (secondary)
    PSU
    RM750x Corsair
    Case
    Corsair CW-9060051
    Cooling
    Corsair iCUE SP120 RGB + iCUE H150i Elite CAPELLIX
    Keyboard
    Logitech G213 PRODIGY
    Mouse
    Logitech G502 Hero
    Browser
    Edge
  • Operating System
    Windows 11
    Computer type
    PC/Desktop
    CPU
    Ryzen 5 5600X
    Motherboard
    MAG B550 TOMAHAWK
    Memory
    G.Skill Gaming Memory Ripjaws V 32GB (2x16GB) 3600mhz CL18
    Graphics card(s)
    MSI Radeon RX 6500 XT Mech 2X 4G OC
    Screen Resolution
    1080p

jimbo45

Well-known member
Power User
VIP
Local time
10:06 PM
Posts
2,400
Location
Hafnarfjörður IS
Visit site
OS
Windows XP,7,10,11 Linux Arch Linux
Hi there
Frequency of your monitor (e.g "refresh rate") could be a problem once you start getting into UHD 4K / 4K HDR etc. Some of these settings might have to be set by the monitors own hardware setup menu and not in Windows - use the menu button on the handset. here should be a frequency selector -- note settings first before playing around in case you hose things up and start watching a lovely black screen !!!!

I assume that your internet connection is good --- not just what the ISP can deliver but what you are getting at the computer.

Cheers
jimbo
 

My Computer

System One

  • OS
    Windows XP,7,10,11 Linux Arch Linux
    Computer type
    PC/Desktop
    CPU
    2 X Intel i7

Citrusflavour01

Active member
Thread Starter
Local time
6:06 AM
Posts
20
Visit site
OS
Windows 11
Hi there
Frequency of your monitor (e.g "refresh rate") could be a problem once you start getting into UHD 4K / 4K HDR etc. Some of these settings might have to be set by the monitors own hardware setup menu and not in Windows - use the menu button on the handset. here should be a frequency selector -- note settings first before playing around in case you hose things up and start watching a lovely black screen !!!!

I assume that your internet connection is good --- not just what the ISP can deliver but what you are getting at the computer.

Cheers
jimbo
Well, I use 155hz on my main display and 60hz on my secondary display. It plays fine on my main display but not on my secondary one at all! I'm going to go through the settings in my secondary display and see if I can find an issue there. Putting it in full-screen just kills the smoothness 🤦‍♂️
 

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    Ryzen 9 5900X
    Motherboard
    GIGABYTE B550 Aorus Pro V2
    Memory
    Corsair Vengeance RGB PRO 32GB (4x8GB) DDR4 3200MHz C16
    Graphics Card(s)
    MSI GeForce RTX 3070 Ti VENTUS 3X 8G OC
    Screen Resolution
    2560 x 1440
    Hard Drives
    NVMe Gen 4 Sabrent Rocket 1TB (boot)
    NVMe Gen 3 ADATA 512GB (secondary)
    PSU
    RM750x Corsair
    Case
    Corsair CW-9060051
    Cooling
    Corsair iCUE SP120 RGB + iCUE H150i Elite CAPELLIX
    Keyboard
    Logitech G213 PRODIGY
    Mouse
    Logitech G502 Hero
    Browser
    Edge
  • Operating System
    Windows 11
    Computer type
    PC/Desktop
    CPU
    Ryzen 5 5600X
    Motherboard
    MAG B550 TOMAHAWK
    Memory
    G.Skill Gaming Memory Ripjaws V 32GB (2x16GB) 3600mhz CL18
    Graphics card(s)
    MSI Radeon RX 6500 XT Mech 2X 4G OC
    Screen Resolution
    1080p
Top Bottom