Got a couple of "Windows was not properly shut down" notices, and don't understand them.


@Try3 I've got it, it was "powercfg /sleepstudy"
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    Dell Latitude 7430
@Try3 Thanks. I dunno, I guess I'm probably just being obsessive at the end of the day. So I read the Modern Standby article and watch the Linus video. I don't actually get any those battery-draining problems. My problem seems to be that often something happens to cause the system to execute a "dirty shut-down" rather than a "clean" one, and I don't know what it is. Is the machine slipping into some version of sleep or Modern Standby right before shutting-down, which causes the problem? I've disabled sleep altogether on my machine now, maybe that will solve it.

1 Please post your PowerCfg -a results.

2 Please use the Event viewer, Custom view I suggested to check that the computer is going to sleep when you tell it to.

3 If it proves relevant, you can also monitor shutdowns & restarts in Event viewer using another Custom view.
This is the Custom view definition. You can import it into Event viewer in the same way as the previous one I gave you.
Power - Starts, shutdowns.zip


Denis
 

Attachments

  • Power - Starts, shutdowns.zip
    1.1 KB · Views: 1

My Computer

System One

  • OS
    Windows 11 Home x64 Version 23H2 Build 22631.3447
@Try3 Maybe it's worth sharing the file it generated for me. Sorry, doesn't look like I can upload HTML here so it'll have to be Dropbox this time.

I notice there seem to be "Hybrid Shutdown"s immediately before the erroneous shut-downs, more-or-less in every instance. And it also does seem to be entering sleep immediately before shutting-down...
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    Dell Latitude 7430
William,

No thanks.
I don't use SleepStudy reports and have never noticed anybody using them to diagnose anything.

it also does seem to be entering sleep immediately before shutting-down
Event viewer is your friend for such investigations.
There will be no seem about it.


Denis
 

My Computer

System One

  • OS
    Windows 11 Home x64 Version 23H2 Build 22631.3447

My Computer

System One

  • OS
    Windows 11 Home x64 Version 23H2 Build 22631.3447
@Try3

Alright, let's go with Event Viewer. So I think you meant the Custom View that you shared here. I'll import both those Custom Views and see what it shows me.

And here's the "powercfg -a" result. I'd put it in a previous reply to you, but I think as an edit, so that's probably why you missed it. Are they all "not supported" because I've turned-off sleep completely in my Control Panel?
 

Attachments

  • states.txt
    651 bytes · Views: 1

My Computer

System One

  • OS
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    Dell Latitude 7430
I think this is your number one priority. None of your other power issues will make any sense until this one is resolved.

let's go with Event Viewer. So I think you meant the Custom View that you shared here. I'll import both those Custom Views and see what it shows me.
Yes, there & the one in post #22 above.

[If you ever want to link to a post in the forum then look in its top-right corner to see its # number then right click on it & select copy link.
You can then post the link in your new post to make sure people know what you are referring to.
For example, you just asked me a question in your post #27.

Are they all "not supported" because I've turned-off sleep completely in my Control Panel?
No.
They are all not supported because there is a serious problem.
The following sleep states are available on this system:
Hibernate

The following sleep states are not available on this system:
Standby (S1)
The system firmware does not support this standby state.

Standby (S2)
The system firmware does not support this standby state.

Standby (S3)
The system firmware does not support this standby state.

Standby (S0 Low Power Idle)
The system firmware does not support this standby state.

Hybrid Sleep
Standby (S3) is not available.
The hypervisor does not support this standby state.

Fast Startup
This action is disabled in the current system policy.

You would notmally have either
S3 Sleep
or
So Modern standby [=S0 Low power idle] [=S0ix]
and the only time I've seen neither is when I have deliberately disabled S0ix [some people were lucky enough to find that doing so enabled S3 Sleep but I was not lucky].
Is that what you've done?


I have to go out and saw up some tree trunks,
Denis
 

My Computer

System One

  • OS
    Windows 11 Home x64 Version 23H2 Build 22631.3447
@Try3

Likewise my day's reached its end. I'll answer tomorrow. In the meantime, here's a ZIP with my results of the Custom Views you gave me.
 

Attachments

  • event viewer custom views.7z
    31.2 KB · Views: 1

My Computer

System One

  • OS
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    Dell Latitude 7430
here's a ZIP with my results of the Custom Views you gave me
Only you know when you have told your computer to sleep / wake / shutdown / start etc so only you can interpret the results shown in the Custom views.

Denis
 

My Computer

System One

  • OS
    Windows 11 Home x64 Version 23H2 Build 22631.3447
Event ID 41 isn't recorded or the bug check code is zero. This behavior might indicate a power supply problem.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    HP Pavilion
    CPU
    AMD Ryzen 7 5700G
    Motherboard
    Erica6
    Memory
    Micron Technology DDR4-3200 16GB
    Graphics Card(s)
    NVIDIA GeForce RTX 3060
    Sound Card
    Realtek ALC671
    Monitor(s) Displays
    Samsung SyncMaster U28E590
    Screen Resolution
    3840 x 2160
    Hard Drives
    SAMSUNG MZVLQ1T0HALB-000H1
Event ID 41 isn't recorded or the bug check code is zero. This behavior might indicate a power supply problem.

Freebooter,

William has a power configuration problem in that the computer has neither S0ix nor S3 Sleep.
Posts #27, #28.


All the best,
Denis
 

My Computer

System One

  • OS
    Windows 11 Home x64 Version 23H2 Build 22631.3447
Most, if not all, the problems like this, can be totally eliminated by the proper Setup on Day One.
I learned that lesson many years ago now, and what I learned has served me well for many years, and many versions of Windows.

Over the years, since my first PC Help Forum, I've probably read a thousand posts concerning "Sleep" and/or "Hibernation".
Both seem to be poorly written and on occasions can cause real Problems.
So I just make sure that I have nothing to do with either one. Both are 100% disabled on all 12 of my PC's. (five desktops and seven Laptops)
Like most appliances, a PC should have two operating conditions....ON and OFF, NO sleep and NO hibernation.
If it's not going to be used for a while, just shut it OFF. Especially, Over Night.

And, Microsoft didn't make the shutdown operation a really simple one.
So, in defense against MS's incompetence, I use a simple shortcut to the "Shutdown.exe" command.
I then put that shortcut in my Taskbar for easy access and instant operation.
Here's that shortcut....you can make it for yourself and put it on your desktop, or in your taskbar.

%windir%\System32\shutdown.exe /s /t 1

Yes, there are three spaces in that command, and they are necessary.
Good Luck,
TM 😎 :
PS: In your "Power Management" select NEVER for either Sleep or Hibernate. That will end a lot of problems.
 

My Computer

System One

  • OS
    Win-11/Pro/64, Optimum 11 V5, 23H2 22631.3374
    Computer type
    PC/Desktop
    Manufacturer/Model
    Home Made w/Gigabyte mobo/DX-10
    CPU
    AMD FX 6350 Six Core
    Motherboard
    Gigabyte, DX-10, GA-78LMT-USB3
    Memory
    Crucial, 16 GB
    Graphics Card(s)
    NVIDEA GeForce 210, 1GB DDR3 Ram.
    Sound Card
    Onboard
    Monitor(s) Displays
    24" Acer
    Screen Resolution
    1280x800
    Hard Drives
    Crucial SSD 500GB, SanDisk 126GB SSD, Toshiba 1TB HD
    PSU
    EVGA 500 W.
    Case
    Pac Man, Mid Tower
    Cooling
    AMD/OEM
    Keyboard
    101 key, Backlit/ Mechanical Switches/
    Mouse
    Logitech USB Wireless M310
    Internet Speed
    Hughes Net speed varies with the weather
    Browser
    Firefox 64x
    Antivirus
    Windows Defender, Super Anti Spyware
    Other Info
    Given to me as DEAD, and irreparable.
    Rebuilt with Gigabyte mobo, AMD cpu, 16GB ram and 500GB Crucial SSD.
Dell Latitude 7430.

Reliability Monitor has given me two of the following notices over the course of the last week:

"Critical Event > Windows was not properly shut down".
Very likely hybrid sleep! Please try this command: powercfg /H off
 

My Computers

System One System Two

  • OS
    Windows 11 Pro x64 23H2
    Computer type
    PC/Desktop
    CPU
    Ryzen 9 5900X
    Motherboard
    ASRock B550 PG Velocita (UEFI-BIOS P3.40)
    Memory
    32 GB G.Skill F4-3200C16D-32GVR
    Graphics Card(s)
    Sapphire Nitro+ Radeon RX 6750 XT
    Monitor(s) Displays
    Alienware AW3423DWF OLED ultrawide
    Hard Drives
    Western Digital Black SN850 1 TB NVMe SSD
    PSU
    eVGA Supernova 750 G3
    Case
    Corsair 275R
    Internet Speed
    VTel FTTH 1 Gb down and 1 Gb up
  • Computer type
    PC/Desktop
    CPU
    Ryzen 7 5800X3D
    Motherboard
    Asus ROG Strix B550-F Gaming (UEFI-BIOS version 3607)
    Memory
    32 GB (2x16 GB G.Skill TridentZ Neo)
    Graphics card(s)
    Sparkle Titan Arc A770 16 GB
    Hard Drives
    Samsung 970 Pro 512 GB NVMe SSD
    PSU
    eVGA Supernova 650 GQ
    Case
    Fractal Focus G
@TechnoMage2021 Thanks. That was my hunch at least, and I have actually completely disabled all sleep options on the PC now, through Control Panel and also in the BIOS. I thought I was being neurotic to do so, but it seems by your take that I'm justified in doing so.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    Dell Latitude 7430
@Try3 So the only adjustments I've made is to change Control Panel's "Power Options" as the picture below shows, as well as disabling the PC's sleep-option in the BIOS.

Screenshot (84).jpg
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    Dell Latitude 7430
@Try3 I wouldn't really know what to make of the Custom Views, not having ever looked at anything like that before. Reliability Monitor gives me time-stamps for the "Event 41" notifications, and then it gives me further time-stamps for when the actual "Event 41" occurred. I tried to match those time-stamps with the Custom Views; but for one thing, sometimes the times given by the Custom Views were as much as a couple of hours out-of-sync with Reliability Monitor. I tried my best to extract the relevant entries from the Custom Views that matched the Reliability Monitor entries. Attached are a few samples, the "5-7" indices referring to the fact that I have had a total of 7 instances of "Event 41" in total. The corresponding Reliability Monitor time-stamps are as follows

7, notification time-stamp 2703 0240, referencing event at 2603 1605
6, notification time-stamp 2603 1413, referencing event at 2603 1409
5, notification time-stamp 2603 1059, referencing event at 2503 1451
[DDMM HHMM]

For sample "5" there was no corresponding data at all in the "shutdowns" Custom View for the event time-stamp, so I just took the data that corresponded with the notification time-stamp for that one.

Took me an hour to make those samples and I have pretty heavy doubts that they're going to be able to help me at all.
 

Attachments

  • samples.7z
    21.6 KB · Views: 1

My Computer

System One

  • OS
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    Dell Latitude 7430
@Try3
I'm going to settle with just turning off sleep. I can't continue down all these rabbit-warrens. It's not worth it for me. I'm going to settle for unsatisfactory and just hope for the best. I've got too many other things to do. Thanks for your help.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    Dell Latitude 7430
Back
Top Bottom