Solved Internet Randomly Disconnects


Thief

Member
Local time
9:34 PM
Posts
5
OS
Windows 11
Randomly my WiFi just cuts out, I've tried updating my drivers and windows. Idk if it's my adapter or my pc. I know it's not my Router nor is there interference. Every time it goes out it also does not let me open my settings or the little quick bar in the bottom right, and I have to fully restart my pc for it to reconnect. My Windows Version is 21H2 (OS Build 22000.739) and Im using a USB Adapter called TP-Link.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    AMD Ryzen 5 2600 Six-Core Processor, 3400 Mhz
    Motherboard
    B450 AORUS M
    Memory
    24.0 GB
    Graphics Card(s)
    NVIDIA GeForce GTX 1650

imanlien2020

Active member
Member
Local time
8:34 PM
Posts
166
OS
Windows 10 current
for the last couple windows updates i had the issue where when I would start my PC it would connect to the internet for a second then i would get the World Icon meaning network Not connected right, well then It would do its background processes and after about 5 minutes the network would connect. I was using UXthemepatcher and using themes and installing icon packs via 7tsp installer. well my PC after like 2 updates or 2 weeks ago it took a rubbish and I had to totally reinstall deleting my drive and starting new, Now Im not using any of those things not even winaero tweaker, and my internet connects immediately. So not sure if your using any of those. I know I read a few places that Microsoft is trying to prevent users from installing our own themes etc because well one control and if you do use them more likely than not it will mess up your PC. So thats all I knowso if any of that helps you. If I can help you further ill try, otherwise sorry for the issue but hey its Windows..lol
 

My Computer

System One

  • OS
    Windows 10 current
    Computer type
    PC/Desktop
    Manufacturer/Model
    AMD
    CPU
    AMD Ryzen 7 5800X 8 Core
    Motherboard
    Gigabyte X570 Aorus Pro WiFi
    Memory
    32 GB
    Graphics Card(s)
    PCI Express 3.0 x16: PowerColor RX Vega 56 Red Dragon
    Sound Card
    Realtek ALC1220 and AMD Greenland - High Definition Audio Controller
    Monitor(s) Displays
    2 - 27 inch Westinghouse
    Screen Resolution
    1920 x 1080
    Hard Drives
    2 SSD - 2 TB each
    1 HDD - 2 TB
    Keyboard
    logitech
    Mouse
    logitech
    Internet Speed
    200 MB
    Browser
    Microsoft Edge
    Antivirus
    Avast Premium

glasskuter

Well-known member
Power User
VIP
Local time
8:34 PM
Posts
1,823
Location
The Lone Star State of Texas
OS
Windows 11 Pro 21H2 22000.739
Try resetting your network adapters and your ip address.

If neither of these helps, the adapter may be failing. I have used those little usb thingies in the past with great success, but they are not as strong as a dedicated wireless card.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 21H2 22000.739
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900
    Memory
    32 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 m.2 2230-256+1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 21H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    standard
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Antivirus
    Defender+MWB Premium

Berton

Well-known member
Member
VIP
Local time
7:34 PM
Posts
662
Location
Wyoming
OS
Win11 Pro RTM x64
Randomly my WiFi just cuts out, I've tried updating my drivers and windows. Idk if it's my adapter or my pc. I know it's not my Router nor is there interference. Every time it goes out it also does not let me open my settings or the little quick bar in the bottom right, and I have to fully restart my pc for it to reconnect. My Windows Version is 21H2 (OS Build 22000.739) and Im using a USB Adapter called TP-Link.
Windows 11 Version is 21H2 (OS Build 22000.739), Windows 10 is also Version 21H2 but different Build number.

Use of the USB dongle/adapter does suggest Wi-Fi/Wireless is involved [Yes, there are such adapters for the Ethernet/RJ45 connection] and could be either the wrong USB port is in use [USB 2 or USB 3], USB has issues or that the adapter itself has an issue. Do the USB ports work with other devices? How has the Router capabilityreliability been tested? Having to reboot to get things working properly also suggests an issue with Windows itself.
 

My Computers

System One System Two

  • OS
    Win11 Pro RTM x64
    Computer type
    Laptop
    Manufacturer/Model
    Dell Vostro 3400
    CPU
    Intel Core i5
    Memory
    8GB
    Hard Drives
    256GB SSD NVMe
  • Operating System
    Windows 11 Pro RTM x64
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Vostro 5890
    CPU
    Intel Core i5
    Memory
    16GB
    Graphics card(s)
    Onboard, no VGA
    Monitor(s) Displays
    21"
    Hard Drives
    512GB SSD NVMe, 2TB WDC HDD
    Browser
    Firefox, Edge
    Antivirus
    Windows Defender/Microsoft Security

Thief

Member
Thread Starter
Local time
9:34 PM
Posts
5
OS
Windows 11
for the last couple windows updates i had the issue where when I would start my PC it would connect to the internet for a second then i would get the World Icon meaning network Not connected right, well then It would do its background processes and after about 5 minutes the network would connect. I was using UXthemepatcher and using themes and installing icon packs via 7tsp installer. well my PC after like 2 updates or 2 weeks ago it took a rubbish and I had to totally reinstall deleting my drive and starting new, Now Im not using any of those things not even winaero tweaker, and my internet connects immediately. So not sure if your using any of those. I know I read a few places that Microsoft is trying to prevent users from installing our own themes etc because well one control and if you do use them more likely than not it will mess up your PC. So thats all I knowso if any of that helps you. If I can help you further ill try, otherwise sorry for the issue but hey its Windows..lol
I used to but that was before Windows 11 was a thing so now I don't, and I literally just reset my entire pc and it still does it. It did start after I updated Windows so I'm betting it is Windows but I'm not too sure what to do cause I've done everything I could think of to fix it.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    AMD Ryzen 5 2600 Six-Core Processor, 3400 Mhz
    Motherboard
    B450 AORUS M
    Memory
    24.0 GB
    Graphics Card(s)
    NVIDIA GeForce GTX 1650

Thief

Member
Thread Starter
Local time
9:34 PM
Posts
5
OS
Windows 11
Try resetting your network adapters and your ip address.

If neither of these helps, the adapter may be failing. I have used those little usb thingies in the past with great success, but they are not as strong as a dedicated wireless card.
I'll give both of those a shot. As for the adapter I'm honestly just using it till I got a new Motherboard because I was hardwired but then I moved to a place where I can not hardwire my pc so I figured it could just hold me over until then. So I'm hoping its not it but if it is then I'm probably just going to end up buying the new motherboard sooner than later.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    AMD Ryzen 5 2600 Six-Core Processor, 3400 Mhz
    Motherboard
    B450 AORUS M
    Memory
    24.0 GB
    Graphics Card(s)
    NVIDIA GeForce GTX 1650

Berton

Well-known member
Member
VIP
Local time
7:34 PM
Posts
662
Location
Wyoming
OS
Win11 Pro RTM x64
Desktops didn't normally come with Wireless adapters until a few years ago, I got an ASUS from their business line which was the first for me, some 6 years ago, now have a Dell with Win11 that has it.
 

My Computers

System One System Two

  • OS
    Win11 Pro RTM x64
    Computer type
    Laptop
    Manufacturer/Model
    Dell Vostro 3400
    CPU
    Intel Core i5
    Memory
    8GB
    Hard Drives
    256GB SSD NVMe
  • Operating System
    Windows 11 Pro RTM x64
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Vostro 5890
    CPU
    Intel Core i5
    Memory
    16GB
    Graphics card(s)
    Onboard, no VGA
    Monitor(s) Displays
    21"
    Hard Drives
    512GB SSD NVMe, 2TB WDC HDD
    Browser
    Firefox, Edge
    Antivirus
    Windows Defender/Microsoft Security

Thief

Member
Thread Starter
Local time
9:34 PM
Posts
5
OS
Windows 11
Windows 11 Version is 21H2 (OS Build 22000.739), Windows 10 is also Version 21H2 but different Build number.

Use of the USB dongle/adapter does suggest Wi-Fi/Wireless is involved [Yes, there are such adapters for the Ethernet/RJ45 connection] and could be either the wrong USB port is in use [USB 2 or USB 3], USB has issues or that the adapter itself has an issue. Do the USB ports work with other devices? How has the Router capability reliability been tested? Having to reboot to get things working properly also suggests an issue with Windows itself.
I have tried multiple different USB ports and I have tested all of them, so I don't think it's something to do with those. As for router I ran speedtest by ookla on my laptop using the onboard wifi card and the dongle from multiple areas and I barely lost anything from going close to my router to going where my Desktop was and of course I also ran it on my desktop, and it was the same as my laptop so it seems to be good. I was also thinking it had something to do with windows because it started happening after an update but I was unsure.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    AMD Ryzen 5 2600 Six-Core Processor, 3400 Mhz
    Motherboard
    B450 AORUS M
    Memory
    24.0 GB
    Graphics Card(s)
    NVIDIA GeForce GTX 1650

Thief

Member
Thread Starter
Local time
9:34 PM
Posts
5
OS
Windows 11
Ok so far what glasskuter said to do slightly fixed it. It still happens but ALOT lest often so I can live with it. So I'll Mark the thread As solved.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    AMD Ryzen 5 2600 Six-Core Processor, 3400 Mhz
    Motherboard
    B450 AORUS M
    Memory
    24.0 GB
    Graphics Card(s)
    NVIDIA GeForce GTX 1650
Top Bottom