Solved Local Network Problems When Hyper-V is Enabled


hsehestedt

Well-known member
Guru
VIP
Local time
8:57 AM
Posts
2,917
Location
Texas, USA
OS
Win11 Pro 24H2
I've been struggling with something for at least a year and just wondering if others have run into this and have any solution.

The issue is that I have a constantly recurring network issue. Here is the scenario:

I have multiple desktop machines in one room. They are connected to my home network using Ethernet.

I also have a laptop that uses WiFi to connect to the home network.

If I remote desktop to my desktop computers from the laptop, everything works great including transferring files over that remote desktop connection. However, if I instead map a network drive to those desktops, I get some weird behavior. I can navigate through directories on the mapped drive just fine, but if I try to copy a file to the desktop systems, file explorer opens a progress window, but it will never make any forward progress. It just sits there forever without actually copying the file.

On the laptop, I have Hyper-V enabled. In Hyper-V I have a virtual switch that allows access to my local network and to the Internet by using the WiFi adapter. I have the option selected to share that WiFi connection with Windows management.

If I now uninstall Hyper-V, my network problems go away. So somehow, having Hyper-V enabled is causing these network issues, but for the life of me I have no idea why.

I should also note that with Hyper-V enabled, other network activity such as accessing the Internet, works just fine. It just seems to be mapping drives to other systems on the local network that is affected.

Anyone have thoughts on this?
 

My Computers

System One System Two

  • OS
    Win11 Pro 24H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Kamrui Mini PC, Model CK10
    CPU
    Intel i5-12450H
    Memory
    32GB
    Graphics Card(s)
    No GPU - Built-in Intel Graphics
    Sound Card
    Integrated
    Monitor(s) Displays
    HP Envy 32
    Screen Resolution
    2560 x 1440
    Hard Drives
    1 x 2TB NVMe SSD
    1 x 4TB NVMe SSD
    1 x 4TB 2.5" SSD
    PSU
    120W "Brick"
    Keyboard
    Corsair K70 Mechanical Keyboard
    Mouse
    Logitech MX Master 3
    Internet Speed
    1Gb Up / 1 Gb Down
    Browser
    Edge
    Antivirus
    Windows Defender
  • Operating System
    Win11 Pro 23H2
    Computer type
    Laptop
    Manufacturer/Model
    Lenovo ThinkBook 13x Gen 2
    CPU
    Intel i7-1255U
    Memory
    16 GB
    Graphics card(s)
    Intel Iris Xe Graphics
    Sound Card
    Realtek® ALC3306-CG codec
    Monitor(s) Displays
    13.3-inch IPS Display
    Screen Resolution
    WQXGA (2560 x 1600)
    Hard Drives
    2 TB 4 x 4 NVMe SSD
    PSU
    USB-C / Thunderbolt 4 Power / Charging
    Mouse
    Buttonless Glass Precision Touchpad
    Keyboard
    Backlit, spill resistant keyboard
    Internet Speed
    1Gb Up / 1Gb Down
    Browser
    Edge
    Antivirus
    Windows Defender
    Other Info
    WiFi 6e / Bluetooth 5.1 / Facial Recognition / Fingerprint Sensor / ToF (Time of Flight) Human Presence Sensor
Look in the Virtual Switch Manager and click on your External switch, Then check that " Allow management OS to share this network adapter " is checked

2023-02-12_221420.png
 

My Computer

System One

  • OS
    Win 10
Thanks for the suggestion, but as I noted in my original post, I already have that option selected. Also, if it was not selected, I woudn't have partial connectivity as I noted.

In the meantime, I've done further testing. If I remove the External Network connection, then the connectivity from the physical machine wrks just fine, so it is definitely some sort of issue related to enabling the external network connection in Hyper-V.
 

My Computers

System One System Two

  • OS
    Win11 Pro 24H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Kamrui Mini PC, Model CK10
    CPU
    Intel i5-12450H
    Memory
    32GB
    Graphics Card(s)
    No GPU - Built-in Intel Graphics
    Sound Card
    Integrated
    Monitor(s) Displays
    HP Envy 32
    Screen Resolution
    2560 x 1440
    Hard Drives
    1 x 2TB NVMe SSD
    1 x 4TB NVMe SSD
    1 x 4TB 2.5" SSD
    PSU
    120W "Brick"
    Keyboard
    Corsair K70 Mechanical Keyboard
    Mouse
    Logitech MX Master 3
    Internet Speed
    1Gb Up / 1 Gb Down
    Browser
    Edge
    Antivirus
    Windows Defender
  • Operating System
    Win11 Pro 23H2
    Computer type
    Laptop
    Manufacturer/Model
    Lenovo ThinkBook 13x Gen 2
    CPU
    Intel i7-1255U
    Memory
    16 GB
    Graphics card(s)
    Intel Iris Xe Graphics
    Sound Card
    Realtek® ALC3306-CG codec
    Monitor(s) Displays
    13.3-inch IPS Display
    Screen Resolution
    WQXGA (2560 x 1600)
    Hard Drives
    2 TB 4 x 4 NVMe SSD
    PSU
    USB-C / Thunderbolt 4 Power / Charging
    Mouse
    Buttonless Glass Precision Touchpad
    Keyboard
    Backlit, spill resistant keyboard
    Internet Speed
    1Gb Up / 1Gb Down
    Browser
    Edge
    Antivirus
    Windows Defender
    Other Info
    WiFi 6e / Bluetooth 5.1 / Facial Recognition / Fingerprint Sensor / ToF (Time of Flight) Human Presence Sensor
Okay, I was up all night trying to figure this out and I got it, so I'm going to post the solution to my own problem here, just in case anyone stumbles on this looking to resolve the same issue.

The solution was simple (once I knew what it was): Go into the settings for the WiFi adapter and disable "Packet Coalescing".

Summary:

Symptom: SOME network connectivity will not function properly over WiFi. Access to the Internet and Remote Desktop to other systems on the local LAN are not affected, however, if you try to copy data to shares on other computers, that will fail.

Conditions: This issue can happen if you have Hyper-V enabled on your system AND you have created a Virtual Switch of the type "External". As a test to verify that this is the cause of your network problems, simply temporarily remove the External Network type from within Hyper-V Manager > Virtual Switch Manager. If the problem goes away, then this is the issue.

Resolution: If you removed the External Network above for testing, feel free to re-create that network at any time. In the meantime, go into your WiFi adapter settings and DISABLE the setting called "Packet Coalescing".

What WiFi adapters are affected by this issue?

I have no idea. However, I do know that not all adapters seem to be affected. I have a laptop with an Intel AX210 WiFi adapter that IS affected by this issue. However, I have another system that has an older Intel AC 7265 and even with Packet Coalescing enabled on that adapter, the issue is not present on that system.
 

My Computers

System One System Two

  • OS
    Win11 Pro 24H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Kamrui Mini PC, Model CK10
    CPU
    Intel i5-12450H
    Memory
    32GB
    Graphics Card(s)
    No GPU - Built-in Intel Graphics
    Sound Card
    Integrated
    Monitor(s) Displays
    HP Envy 32
    Screen Resolution
    2560 x 1440
    Hard Drives
    1 x 2TB NVMe SSD
    1 x 4TB NVMe SSD
    1 x 4TB 2.5" SSD
    PSU
    120W "Brick"
    Keyboard
    Corsair K70 Mechanical Keyboard
    Mouse
    Logitech MX Master 3
    Internet Speed
    1Gb Up / 1 Gb Down
    Browser
    Edge
    Antivirus
    Windows Defender
  • Operating System
    Win11 Pro 23H2
    Computer type
    Laptop
    Manufacturer/Model
    Lenovo ThinkBook 13x Gen 2
    CPU
    Intel i7-1255U
    Memory
    16 GB
    Graphics card(s)
    Intel Iris Xe Graphics
    Sound Card
    Realtek® ALC3306-CG codec
    Monitor(s) Displays
    13.3-inch IPS Display
    Screen Resolution
    WQXGA (2560 x 1600)
    Hard Drives
    2 TB 4 x 4 NVMe SSD
    PSU
    USB-C / Thunderbolt 4 Power / Charging
    Mouse
    Buttonless Glass Precision Touchpad
    Keyboard
    Backlit, spill resistant keyboard
    Internet Speed
    1Gb Up / 1Gb Down
    Browser
    Edge
    Antivirus
    Windows Defender
    Other Info
    WiFi 6e / Bluetooth 5.1 / Facial Recognition / Fingerprint Sensor / ToF (Time of Flight) Human Presence Sensor
Thank you for that! I just turned off packet coalescing, just in case :-)
 

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Homebuilt
    CPU
    AMD Ryzen 7 3800XT
    Motherboard
    ASUS ROG Crosshair VII Hero (WiFi)
    Memory
    32GB
    Graphics Card(s)
    EVGA GeForce GTX 1080 Ti
  • Operating System
    Windows 11 Education
    Computer type
    Laptop
    Manufacturer/Model
    Dell Inspiron 7773
    CPU
    Intel i7-8550U
    Memory
    32GB
    Graphics card(s)
    Nvidia Geforce MX150
    Sound Card
    Realtek
    Monitor(s) Displays
    17"
    Screen Resolution
    1920 x 1080
    Hard Drives
    Toshiba 512GB NVMe SSD
    SK Hynix 512GB SATA SSD
    Internet Speed
    Fast!
See post #2 in link below I made a while back.


Just fixing coalescing may help downloads but not always uploads. The link above covers both.

Also see older Windows 10 post

 

My Computer

System One

  • OS
    Windows 10 Pro + others in VHDs
    Computer type
    Laptop
    Manufacturer/Model
    ASUS Vivobook 14
    CPU
    I7
    Motherboard
    Yep, Laptop has one.
    Memory
    16 GB
    Graphics Card(s)
    Integrated Intel Iris XE
    Sound Card
    Realtek built in
    Monitor(s) Displays
    N/A
    Screen Resolution
    1920x1080
    Hard Drives
    1 TB Optane NVME SSD, 1 TB NVME SSD
    PSU
    Yep, got one
    Case
    Yep, got one
    Cooling
    Stella Artois
    Keyboard
    Built in
    Mouse
    Bluetooth , wired
    Internet Speed
    72 Mb/s :-(
    Browser
    Edge mostly
    Antivirus
    Defender
    Other Info
    TPM 2.0
@cereberus, apologies for the slow response. I completely missed your post. I only noticed it when I came back here to post an update.

My update was going to be to note the fact that the problem returned for me. After more experimenting I noticed that disabling packet coalescing was only a temporary solution. It actually turns out that altering any setting that causes a reset of the WiFi adapter will cause everything to work temporarily.

However, your post about disabling Large Send Offload Version 2 (IPv4) and Large Send Offload Version 2 (IPv6) caught me by surprise. I tried that and now all is well even several reboots later.

So for anyone following this thread, here is a full summary:

Symptom

Note that this problem happens ONLY if I go into Hyper-V Manager > Virtual Switch Manager, and I create an "External" virtual switch. The virtual switch does NOT need to be assigned to any VM, in fact, I don't need to even have any VMs created on the system. Just the mere existence of the External virtual switch is enough.

With this virtual switch present, if I connect to a share on another computer, I can successfully copy files from that share to the laptop. I can also copy small files to the share. By small, I mean files of about 2 MB and smaller. If I attempt to copy anything larger, say 10 MB, the copy will start, then it sits there for several minutes, then it copies maybe another half a MB, pauses several minutes, then copies a little bit more, etc. To copy a 10 MB file may take 5+ minutes.

Here is where it gets even stranger: If I go to the computer with the share and I remote desktop into the laptop, and then try the file copy again, it will work perfectly normally.

In addition, if I do anything on the laptop that resets the WiFi adapter, for example, if I change a setting on the WiFi adapter, then the copy will suddenly resume and run to completion. As an example, say I start a large file copy of 10 GB. The copy pauses (hangs) as I described above. Now I go into the WiFi settings and alter some setting. That causes the WiFi adapter to reset. Bang - the copy will immediately resume and run without any further pauses. However, this working condition is only temporary.

If I remove the Hyper-V external switch, then this problem will never ever happen.

Solution

The solution is to implement the settings noted by cereberus. To be very specific, do the following:

Go to Control Panel > Network and Internet > Network Connection. Right-click on the Network Bridge and select Properties. Select the virtual Ethernet adapter and then click on Configure. Go to the Advanced tab. Disable both Large Send Offload Version 2 (IPv4) and Large Send Offload Version 2 (IPv6).
 

My Computers

System One System Two

  • OS
    Win11 Pro 24H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Kamrui Mini PC, Model CK10
    CPU
    Intel i5-12450H
    Memory
    32GB
    Graphics Card(s)
    No GPU - Built-in Intel Graphics
    Sound Card
    Integrated
    Monitor(s) Displays
    HP Envy 32
    Screen Resolution
    2560 x 1440
    Hard Drives
    1 x 2TB NVMe SSD
    1 x 4TB NVMe SSD
    1 x 4TB 2.5" SSD
    PSU
    120W "Brick"
    Keyboard
    Corsair K70 Mechanical Keyboard
    Mouse
    Logitech MX Master 3
    Internet Speed
    1Gb Up / 1 Gb Down
    Browser
    Edge
    Antivirus
    Windows Defender
  • Operating System
    Win11 Pro 23H2
    Computer type
    Laptop
    Manufacturer/Model
    Lenovo ThinkBook 13x Gen 2
    CPU
    Intel i7-1255U
    Memory
    16 GB
    Graphics card(s)
    Intel Iris Xe Graphics
    Sound Card
    Realtek® ALC3306-CG codec
    Monitor(s) Displays
    13.3-inch IPS Display
    Screen Resolution
    WQXGA (2560 x 1600)
    Hard Drives
    2 TB 4 x 4 NVMe SSD
    PSU
    USB-C / Thunderbolt 4 Power / Charging
    Mouse
    Buttonless Glass Precision Touchpad
    Keyboard
    Backlit, spill resistant keyboard
    Internet Speed
    1Gb Up / 1Gb Down
    Browser
    Edge
    Antivirus
    Windows Defender
    Other Info
    WiFi 6e / Bluetooth 5.1 / Facial Recognition / Fingerprint Sensor / ToF (Time of Flight) Human Presence Sensor
@cereberus, apologies for the slow response. I completely missed your post. I only noticed it when I came back here to post an update.

My update was going to be to note the fact that the problem returned for me. After more experimenting I noticed that disabling packet coalescing was only a temporary solution. It actually turns out that altering any setting that causes a reset of the WiFi adapter will cause everything to work temporarily.

However, your post about disabling Large Send Offload Version 2 (IPv4) and Large Send Offload Version 2 (IPv6) caught me by surprise. I tried that and now all is well even several reboots later.

So for anyone following this thread, here is a full summary:

Symptom

Note that this problem happens ONLY if I go into Hyper-V Manager > Virtual Switch Manager, and I create an "External" virtual switch. The virtual switch does NOT need to be assigned to any VM, in fact, I don't need to even have any VMs created on the system. Just the mere existence of the External virtual switch is enough.

With this virtual switch present, if I connect to a share on another computer, I can successfully copy files from that share to the laptop. I can also copy small files to the share. By small, I mean files of about 2 MB and smaller. If I attempt to copy anything larger, say 10 MB, the copy will start, then it sits there for several minutes, then it copies maybe another half a MB, pauses several minutes, then copies a little bit more, etc. To copy a 10 MB file may take 5+ minutes.

Here is where it gets even stranger: If I go to the computer with the share and I remote desktop into the laptop, and then try the file copy again, it will work perfectly normally.

In addition, if I do anything on the laptop that resets the WiFi adapter, for example, if I change a setting on the WiFi adapter, then the copy will suddenly resume and run to completion. As an example, say I start a large file copy of 10 GB. The copy pauses (hangs) as I described above. Now I go into the WiFi settings and alter some setting. That causes the WiFi adapter to reset. Bang - the copy will immediately resume and run without any further pauses. However, this working condition is only temporary.

If I remove the Hyper-V external switch, then this problem will never ever happen.

Solution

The solution is to implement the settings noted by cereberus. To be very specific, do the following:

Go to Control Panel > Network and Internet > Network Connection. Right-click on the Network Bridge and select Properties. Select the virtual Ethernet adapter and then click on Configure. Go to the Advanced tab. Disable both Large Send Offload Version 2 (IPv4) and Large Send Offload Version 2 (IPv6).
I recommend the coalescing steps as well. It varies but I needed both.

Its great to be able to declare "Been there, done that, got the T-shirt" on this subject LOL
 

My Computer

System One

  • OS
    Windows 10 Pro + others in VHDs
    Computer type
    Laptop
    Manufacturer/Model
    ASUS Vivobook 14
    CPU
    I7
    Motherboard
    Yep, Laptop has one.
    Memory
    16 GB
    Graphics Card(s)
    Integrated Intel Iris XE
    Sound Card
    Realtek built in
    Monitor(s) Displays
    N/A
    Screen Resolution
    1920x1080
    Hard Drives
    1 TB Optane NVME SSD, 1 TB NVME SSD
    PSU
    Yep, got one
    Case
    Yep, got one
    Cooling
    Stella Artois
    Keyboard
    Built in
    Mouse
    Bluetooth , wired
    Internet Speed
    72 Mb/s :-(
    Browser
    Edge mostly
    Antivirus
    Defender
    Other Info
    TPM 2.0

Latest Support Threads

Latest Tutorials

Back
Top Bottom