Placing an item on desktop (sometimes) displaces desktop icons


hsehestedt

Well-known member
Power User
VIP
Local time
7:32 AM
Posts
1,330
Location
Texas, USA
Visit site
OS
Windows 11 Pro 22H2
I have an odd issue that I cannot seem to determine a cause for. Wondering if anyone else has noticed this, and more importantly, identified a solution.

Scenario:

Windows 11 22H2 with the latest (Nov 2022) updates. I have no shell enhancements or programs installed that should alter the desktop experience. Desktop settings are set to not sort icons, to align icons to grid, but NOT to auto arrange icons. PC is an 11th Gen i7-11700K using only the Intel XE graphics with 128GB RAM.

Let's assume that my desktop looks like the image below, with these icons positioned in the upper left corner:

IM1.jpg

Now, I drag an item to desktop as in the illustration below. Note that I am placing this item nowhere near the upper left corner of the screen.

IM2.jpg

However, for some reason this SOMETIMES causes all my icons to shift down one position as you see here:

IM3.jpg

Please note that this does not happen all the time. In fact, it's hard to reproduce it. In the screenshot I actually had to emulate the problem manually by moving the icons down one slot to illustrate the issue. But it happens often enough to be real annoying.

Now, if I save something else to the desktop (not by dragging it to a specific spot on the desktop), it will be placed in that upper left corner, ruining the organization that I have.

Has anyone seen this and identified a resolution?
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 22H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Home Built
    CPU
    Intel i7-11700K
    Motherboard
    ASUS Prime Z590-A
    Memory
    128GB Crucial Ballistix 3200MHz DRAM
    Graphics Card(s)
    No GPU - CPU graphics only (for now)
    Sound Card
    Realtek (on motherboard)
    Monitor(s) Displays
    HP Envy 32
    Screen Resolution
    2560 x 1440
    Hard Drives
    1 x 1TB NVMe Gen 4 x 4 SSD
    1 x 2TB NVMe Gen 3 x 4 SSD
    2 x 512GB 2.5" SSDs
    2 x 8TB HD
    PSU
    Corsair HX850i
    Case
    Corsair iCue 5000X RGB
    Cooling
    Noctua NH-D15 chromax.black cooler + 10 case fans
    Keyboard
    CODE backlit mechanical keyboard
    Mouse
    Logitech MX Master 3
    Internet Speed
    1Gb Up / 1 Gb Down
    Browser
    Chromium Edge
    Antivirus
    Windows Defender
    Other Info
    Additional options installed:
    WiFi 6E PCIe adapter
    ASUS ThunderboltEX 4 PCIe adapter
  • Operating System
    Dual Boot Windows 11 Pro 22H2 and Windows 10 Pro 22H2
    Computer type
    Laptop
    Manufacturer/Model
    HP Spectre x360 15-BL012DX
    CPU
    Intel i7-7500U
    Memory
    32GB
    Graphics card(s)
    Dual Intel HD 620 and Nvidia GeForce 940MX
    Sound Card
    Built-in Realtek HD Audio
    Monitor(s) Displays
    4k 15-inch
    Screen Resolution
    4k (3840 x 2160)
    Hard Drives
    1TB Seagate FireCuda 510 NVMe SSD
    Internet Speed
    1Gb Up / 1Gb Down
    Browser
    Chromium Edge
    Antivirus
    Windows Defender
    Other Info
    RAM Upgraded from 16GB to 32GB WiFi Upgraded from WiFi 5 to WiFi 6 SSD upgraded from 512GB NVMe SSD to 1TB Seagate FireCuda 510 NVMe SSD

kelper

Active member
Member
Local time
1:32 PM
Posts
351
Location
The Highlands of Scotland
Visit site
OS
Windows 11 22H2 Pro
Could the icon cache file be corrupted? I can't reproduce your bug.
 

My Computer

System One

  • OS
    Windows 11 22H2 Pro
    Computer type
    Laptop
    Manufacturer/Model
    Acer Swift SF114-34
    CPU
    Pentium Silver N6000
    Memory
    4GB
    Screen Resolution
    1920 x 1080
    Hard Drives
    none
    Internet Speed
    13Mbps
    Browser
    Brave
    Antivirus
    Webroot Secure Anywhere

Latest Support Threads

Top Bottom