Two W11 PCs, Consistent Wrong Location, Time Incorrect


ChuckWheat

Active member
Local time
5:58 AM
Posts
5
OS
Windows 11
Version 23H2 (OS Build 22631.3593) on both Surface Book Performance Base and Ryzen 7000 desktop PC.

Hello all. I have a perplexing problem that cropped up in the last few days. Bear with me I may not know the proper terminology.
Two PCs behave the same: consistently showing the same completely wrong location with Microsoft's location services or anything that uses it (maps app, weather app, system time). It says I'm three hours ahead of my current time zone (USA Pacific), and always at a very precise location that doesn't change (somewhere in Toronto, Canada). Any help or advice would be greatly appreciated. I'm prepared to do anything.

I have tried the steps that I could find in searching:
  • Disconnecting, killing, uninstalling VPN program (proton) on both
  • Using a different network (phone hotspot with different ISP)
  • Set Time Zone / Time Automatically
  • Location Services on and off
  • Clear Location History
  • Restarting
  • New offline user account
  • Taking the laptop to a coffee shop
  • Setting default location
  • Wi-Fi > ethernet, ethernet > Wi-Fi
  • Uninstalling Maps, reinstalling Maps
  • SFC /scannow, no corruption
Other details:
  • Using Edge browser and using Bing Maps or Google Maps shows correct location.
  • Booting the machines in Linux gets the correct time zone and time.
  • Other machines on the network (Android phones, iMac, Linux PCs) all are time and location correct.
  • My router has the correct time.
 
Windows Build/Version
Version 23H2 (OS Build 22631.3593
Last edited:

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    AMD Ryzen 9 7950X
    Motherboard
    Asus X670e-A
    Memory
    96GB (2 x 48 GB) DDR5-6000 CL32 DDR5 Memory
    Graphics Card(s)
    EVGA GTX 1060 SC ACX 6GB
    Monitor(s) Displays
    4 +1
    Screen Resolution
    1200x1920@60 1920x1080@60 3840x2160@60 1920x1080@60 1920x1080@144
    Hard Drives
    Crucial T700 2 TB M.2
    Samsung 970 Evo 1 TB
    PSU
    SeaSonic PRIME Titanium 850W
    Case
    Corsair Crystal 570X
    Cooling
    Corsair H100i PRO
    Keyboard
    Ducky One2 Mini, Corsair K70 Rapid,
    Mouse
    ROCCAT Kone XTD
    Internet Speed
    300Mb/s
    Browser
    chrome, firefox, etc.
  • Operating System
    Windows 11 / Fedora 40 KDE
    Computer type
    Laptop
    Manufacturer/Model
    Microsoft Surface Book Performance Base
    CPU
    Intel i7-6600u
    Memory
    16GB
    Graphics card(s)
    Nvidia GTX 965m
    Screen Resolution
    3000x2000@60
    Hard Drives
    512GB SSD
    Internet Speed
    300Mb/s
    Browser
    chrome, firefox, etc
This is off the top my head. If you are using a Microsoft Account in Windows to login make sure your country is correctly set.


MS account. countryjpg.png
 

My Computer

System One

  • OS
    Windows 11 Pro
    Computer type
    PC/Desktop
    Manufacturer/Model
    Homebuilt
    CPU
    Intel Core i9 13900K
    Motherboard
    Asus ProArt Z790 Creator WiFi - Bios 2002
    Memory
    Corsair Dominator 64gb 5600MT/s DDR5 Dual Channel
    Graphics Card(s)
    Sapphire NITRO+ AMD Radeon RX 7900 XTX Vapor-X 24GB
    Sound Card
    External Fiio K5 Pro ESS DAC - Headphone Amplifier
    Monitor(s) Displays
    Panasonic MX950 Mini LED 55" TV 120hz
    Screen Resolution
    3840 x 2160 120hz
    Hard Drives
    Samsung 980 Pro 2TB (OS)
    Samsung 980 Pro 1TB (Files)
    Lexar NZ790 4TB
    LaCie d2 Professional 6TB external - USB 3.1
    PSU
    Corsair RM1200x Shift
    Case
    Corsair RGB Smart Case 5000x (white)
    Cooling
    Corsair iCue H150i Elite Capellix XT
    Keyboard
    Logitech K860
    Mouse
    Logitech MX Ergo Trackball
    Internet Speed
    Fibre 900/500 Mbps
    Browser
    Microsoft Edge Chromium
    Antivirus
    Bitdefender Total Security
    Other Info
    Logitech Brio 4K Webcam
    Orico 10-port powered USB 3.0 hub

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    AMD Ryzen 9 7950X
    Motherboard
    Asus X670e-A
    Memory
    96GB (2 x 48 GB) DDR5-6000 CL32 DDR5 Memory
    Graphics Card(s)
    EVGA GTX 1060 SC ACX 6GB
    Monitor(s) Displays
    4 +1
    Screen Resolution
    1200x1920@60 1920x1080@60 3840x2160@60 1920x1080@60 1920x1080@144
    Hard Drives
    Crucial T700 2 TB M.2
    Samsung 970 Evo 1 TB
    PSU
    SeaSonic PRIME Titanium 850W
    Case
    Corsair Crystal 570X
    Cooling
    Corsair H100i PRO
    Keyboard
    Ducky One2 Mini, Corsair K70 Rapid,
    Mouse
    ROCCAT Kone XTD
    Internet Speed
    300Mb/s
    Browser
    chrome, firefox, etc.
  • Operating System
    Windows 11 / Fedora 40 KDE
    Computer type
    Laptop
    Manufacturer/Model
    Microsoft Surface Book Performance Base
    CPU
    Intel i7-6600u
    Memory
    16GB
    Graphics card(s)
    Nvidia GTX 965m
    Screen Resolution
    3000x2000@60
    Hard Drives
    512GB SSD
    Internet Speed
    300Mb/s
    Browser
    chrome, firefox, etc
@ChuckWheat

Please check your settings in this panel below. First, turn OFF Set Time Zone Automatically. The next two sub-switches should then appear. Set your correct time zone with the drop arrow on the right. Then set Adjust for DST to ON, and the next two settings to ON. Now, you may have to use the Sync now button, and if that doesn't do everything the way you want it, open Control Panel, choose Date and Time, and Change the date and time, and when you're done, hit OK. Then restart. All should be well.

Clipboard 01.jpg
 

My Computers

System One System Two

  • OS
    11 Pro 24H2 26100.1150
    Computer type
    PC/Desktop
    Manufacturer/Model
    Lenovo ThinkCentre M920S SFF
    CPU
    i7-9700 @ 3.00GHz
    Motherboard
    Lenovo 3132
    Memory
    32GBDDR4 @ 2666MHz
    Graphics Card(s)
    Intel HD 630 Graphics onboard
    Sound Card
    Realtek HD Audio
    Monitor(s) Displays
    LG E2442
    Screen Resolution
    1920x1080
    Hard Drives
    1 x Samsung 970 EVO PLUS 500GB NVMe SSD, 1 x WD_BLACK SN770
    250GB NVMe SSD (OS and programs), 1 x WD_BLACK SN770
    500GB NVMe SSD (Data)
    Case
    Lenovo SFF
    Keyboard
    Cherry Stream TKL JK-8600US-2 Wired
    Mouse
    LogiTech M510 wireless
    Internet Speed
    Fast (for fixed wireless!)
    Browser
    Chrome, sometimes Firefox
    Antivirus
    Malwarebytes Premium & Defender (working together beautifully!)
  • Operating System
    11 Pro 24H2 26100.1150
    Computer type
    PC/Desktop
    Manufacturer/Model
    Lenovo ThinkCentre M920S SFF
    CPU
    i5-8400 @ 2.80GHz
    Motherboard
    Lenovo 3132
    Memory
    32GB DDR4 @ 2600MHz
    Graphics card(s)
    Intel HD 630 Graphics onboard
    Sound Card
    Realtek High Definition Audio onboard
    Monitor(s) Displays
    LG FULL HD (1920x1080@59Hz)
    Screen Resolution
    1920 x 1080
    Hard Drives
    1 x Samsung 970 EVO PLUS NVMe; 1 x Samsung 980 NVMe SSD
    Case
    Lenovo Think Centre SFF
    Mouse
    LogiTech M510 wireless
    Keyboard
    Cherry Stream TKL JK-8600US-2 Wired
    Internet Speed
    Fast (for fixed wireless!)
    Browser
    Chrome
    Antivirus
    Malwarebytes Premium and MS Defender, beautiful together
@ChuckWheat

Please check your settings in this panel below. First, turn OFF Set Time Zone Automatically. The next two sub-switches should then appear. Set your correct time zone with the drop arrow on the right. Then set Adjust for DST to ON, and the next two settings to ON. Now, you may have to use the Sync now button, and if that doesn't do everything the way you want it, open Control Panel, choose Date and Time, and Change the date and time, and when you're done, hit OK. Then restart. All should be well.

View attachment 96906
Done. Yes, this corrects the time, but Location in apps is still incorrect in the same way as before. For now I'll keep this manual time for convenience. Thank you.
 

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    AMD Ryzen 9 7950X
    Motherboard
    Asus X670e-A
    Memory
    96GB (2 x 48 GB) DDR5-6000 CL32 DDR5 Memory
    Graphics Card(s)
    EVGA GTX 1060 SC ACX 6GB
    Monitor(s) Displays
    4 +1
    Screen Resolution
    1200x1920@60 1920x1080@60 3840x2160@60 1920x1080@60 1920x1080@144
    Hard Drives
    Crucial T700 2 TB M.2
    Samsung 970 Evo 1 TB
    PSU
    SeaSonic PRIME Titanium 850W
    Case
    Corsair Crystal 570X
    Cooling
    Corsair H100i PRO
    Keyboard
    Ducky One2 Mini, Corsair K70 Rapid,
    Mouse
    ROCCAT Kone XTD
    Internet Speed
    300Mb/s
    Browser
    chrome, firefox, etc.
  • Operating System
    Windows 11 / Fedora 40 KDE
    Computer type
    Laptop
    Manufacturer/Model
    Microsoft Surface Book Performance Base
    CPU
    Intel i7-6600u
    Memory
    16GB
    Graphics card(s)
    Nvidia GTX 965m
    Screen Resolution
    3000x2000@60
    Hard Drives
    512GB SSD
    Internet Speed
    300Mb/s
    Browser
    chrome, firefox, etc

Attachments

  • Capture.PNG
    Capture.PNG
    252.3 KB · Views: 2

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3880
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 nvme+256gb SKHynix m.2 nvme /External +512gb Samsung m.2 sata+1tb Kingston m2.nvme
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
see screenshot
Ok. It seems this won't override the wrong location, but if I also disable location for "desktop apps", the Auto Dark Mode theme switcher I like to use will grab the Default Location specified there and work as expected. The other Apps like Maps and Weather won't grab this default location, and if turned off, the app then requests it back on to show location. Weather at least has its own default location setting.
The night light setting for location sunrise and sunset time seem stuck on the wrong location still regardless of its Location Privacy setting enabled or disabled.
I'm going to continue searching for solutions, but this at least helps a little. Thank you.

Additional Details:
My Microsoft Account information page with devices linked to my account "Devices -> Find my device" shows these devices at the same wrong location.

Tried:
  • Restarting Geolocation service, setting it to Automatic start
  • Clearing Microsoft Account Location History (incorrect entries here, downloaded the data)
Looks like this is a known problem for years:

Similar, and more recent:

Might be an update. The first wrong location logged from my Microsoft Account Location History was on the same day as an update. 2024-05 Cumulative Update for Windows 11 Version 22H2 for x64-based Systems (KB5037771).
I'm currently reverting that update and testing again.
 
Last edited:

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    AMD Ryzen 9 7950X
    Motherboard
    Asus X670e-A
    Memory
    96GB (2 x 48 GB) DDR5-6000 CL32 DDR5 Memory
    Graphics Card(s)
    EVGA GTX 1060 SC ACX 6GB
    Monitor(s) Displays
    4 +1
    Screen Resolution
    1200x1920@60 1920x1080@60 3840x2160@60 1920x1080@60 1920x1080@144
    Hard Drives
    Crucial T700 2 TB M.2
    Samsung 970 Evo 1 TB
    PSU
    SeaSonic PRIME Titanium 850W
    Case
    Corsair Crystal 570X
    Cooling
    Corsair H100i PRO
    Keyboard
    Ducky One2 Mini, Corsair K70 Rapid,
    Mouse
    ROCCAT Kone XTD
    Internet Speed
    300Mb/s
    Browser
    chrome, firefox, etc.
  • Operating System
    Windows 11 / Fedora 40 KDE
    Computer type
    Laptop
    Manufacturer/Model
    Microsoft Surface Book Performance Base
    CPU
    Intel i7-6600u
    Memory
    16GB
    Graphics card(s)
    Nvidia GTX 965m
    Screen Resolution
    3000x2000@60
    Hard Drives
    512GB SSD
    Internet Speed
    300Mb/s
    Browser
    chrome, firefox, etc
Reverting the update did not solve it.

I think I will submit a bug report to Microsoft if that is possible.

At least my computers appear to be in a nice neighborhood.
 

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    AMD Ryzen 9 7950X
    Motherboard
    Asus X670e-A
    Memory
    96GB (2 x 48 GB) DDR5-6000 CL32 DDR5 Memory
    Graphics Card(s)
    EVGA GTX 1060 SC ACX 6GB
    Monitor(s) Displays
    4 +1
    Screen Resolution
    1200x1920@60 1920x1080@60 3840x2160@60 1920x1080@60 1920x1080@144
    Hard Drives
    Crucial T700 2 TB M.2
    Samsung 970 Evo 1 TB
    PSU
    SeaSonic PRIME Titanium 850W
    Case
    Corsair Crystal 570X
    Cooling
    Corsair H100i PRO
    Keyboard
    Ducky One2 Mini, Corsair K70 Rapid,
    Mouse
    ROCCAT Kone XTD
    Internet Speed
    300Mb/s
    Browser
    chrome, firefox, etc.
  • Operating System
    Windows 11 / Fedora 40 KDE
    Computer type
    Laptop
    Manufacturer/Model
    Microsoft Surface Book Performance Base
    CPU
    Intel i7-6600u
    Memory
    16GB
    Graphics card(s)
    Nvidia GTX 965m
    Screen Resolution
    3000x2000@60
    Hard Drives
    512GB SSD
    Internet Speed
    300Mb/s
    Browser
    chrome, firefox, etc
Have you tried totally changing your region/currency/language or whatever the options are? Rebooting and changing back to the correct settings. Set your location etc to Australia or somewhere (it’s nice here)

I throw this at you because you have tried most everything else.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 Build: 22631.3880
    Computer type
    PC/Desktop
    Manufacturer/Model
    Sin-built
    CPU
    Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz (4th Gen?)
    Motherboard
    ASUS ROG Maximus VI Formula
    Memory
    32.0 GB of I forget and the box is in storage.
    Graphics Card(s)
    Gigabyte nVidia GeForce GTX 1660 Super OC 6GB
    Sound Card
    Onboard
    Monitor(s) Displays
    4 x LG 23MP75 1 x 24" LG M38H 1 x 32" LF6300 TV Monitor 1 x Wacom Pro 22" Tablet
    Screen Resolution
    All over the place
    Hard Drives
    2 x WD something Something 8TB HDD's / 2 x WD something Something 4TB HDD's / 1 x EVO 1TB SSD / 2 x QVO 1TB SSD's / 1 x EVO 250 GB SSD / 2 x QVO 1TB (External Hub) / 1 x EVO 1TB (Portable Backup Case)
    PSU
    Silverstone 1500
    Case
    NZXT Phantom 820 Full-Tower Case
    Cooling
    Noctua NH-D15 Elite Class Dual Tower CPU Cooler / 6 x EziDIY 120mm / 2 x Corsair 140mm somethings / 1 x 140mm Thermaltake something / 2 x 200mm Corsair.
    Keyboard
    Corsair K95 / Logitech diNovo Edge Wireless
    Mouse
    Logitech G402 / G502 / Mx Masters / MX Air Cordless
    Internet Speed
    100/40Mbps
    Browser
    All sorts
    Antivirus
    Kaspersky Premium
    Other Info
    I’m on a horse.
  • Operating System
    Windows 11 Pro 22621.2215
    Computer type
    Laptop
    Manufacturer/Model
    LENOVO Yoga 7i EVO OLED 14" Touchscreen i5 12 Core 16GB/512GB
    CPU
    Intel Core 12th Gen i5-1240P Processor (1.7 - 4.4GHz)
    Memory
    16GB LPDDR5 RAM
    Graphics card(s)
    Graphics processor is an Intel Iris Xe
    Sound Card
    optimized with Dolby Atmos®
    Screen Resolution
    QHD 2880 x 1800 OLED
    Hard Drives
    M.2 512GB
    Other Info
    …still on a horse.
Yes, this corrects the time, but Location in apps is still incorrect in the same way as before.
After changing it there, I would try turning it off in all the apps. Restart Then turn the location in the apps back on again. Restart again to see if location is then correct in the apps.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3880
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 nvme+256gb SKHynix m.2 nvme /External +512gb Samsung m.2 sata+1tb Kingston m2.nvme
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
IP address corresponds to your location ?

For example I live 300km away from my wired internet provider and 3000km away from my wireless internet provider.
 
Last edited:

My Computer

System One

  • OS
    Microsoft Windows 11 Home
    Computer type
    PC/Desktop
    Manufacturer/Model
    MSI MS-7D98
    CPU
    Intel Core i5-13490F
    Motherboard
    MSI B760 GAMING PLUS WIFI
    Memory
    2 x 16 Patriot Memory (PDP Systems) PSD516G560081
    Graphics Card(s)
    GIGABYTE GeForce RTX 4070 WINDFORCE OC 12G (GV-N4070WF3OC-12GD)
    Sound Card
    Bluetooth Аудио
    Monitor(s) Displays
    INNOCN 15K1F
    Screen Resolution
    1920 x 1080
    Hard Drives
    WD_BLACK SN770 250GB
    KINGSTON SNV2S1000G (ELFK0S.6)
    PSU
    Thermaltake Toughpower GF3 1000W
    Case
    CG560 - DeepCool
    Cooling
    ID-COOLING SE-224-XTS / 2 x 140Mm Fan - rear and top; 3 x 120Mm - front
    Keyboard
    Corsair K70 RGB TKL
    Mouse
    Corsair KATAR PRO XT
    Internet Speed
    100 Mbps
    Browser
    Firefox
    Antivirus
    Microsoft Defender Antivirus
    Other Info
    https://www.userbenchmark.com/UserRun/66553205
I'm inclined to believe that Proton VPN was the cause, and that somehow it has set your location in such a way that it is still being used in your system, perhaps even on your router (since both devices are doing it, it's time to look externally from them to find the root cause).

Is your ISP supplying a device (router / residential gateway) that you use, or do you have your own, personal router behind their modem?
 

My Computers

System One System Two

  • OS
    Windows 11 23H2 Current build
    Computer type
    PC/Desktop
    Manufacturer/Model
    HomeBrew
    CPU
    AMD Ryzen 9 3950X
    Motherboard
    MSI MEG X570 GODLIKE
    Memory
    4 * 32 GB - Corsair Vengeance 3600 MHz
    Graphics Card(s)
    EVGA GeForce RTX 3080 Ti XC3 ULTRA GAMING (12G-P5-3955-KR)
    Sound Card
    Realtek® ALC1220 Codec
    Monitor(s) Displays
    2x Eve Spectrum ES07D03 4K Gaming Monitor (Matte) | Eve Spectrum ES07DC9 4K Gaming Monitor (Glossy)
    Screen Resolution
    3x 3840 x 2160
    Hard Drives
    3x Samsung 980 Pro NVMe PCIe 4 M.2 2 TB SSD (MZ-V8P2T0B/AM) } 3x Sabrent Rocket NVMe 4.0 1 TB SSD (USB)
    PSU
    PC Power & Cooling’s Silencer Series 1050 Watt, 80 Plus Platinum
    Case
    Fractal Design Define 7 XL Dark ATX Full Tower Case
    Cooling
    Arctic Liquid Freezer III 420 RGB + Air 3x 140mm case fans (pull front) + 1x 120 mm (push back) and 1 x 120 mm (pull bottom)
    Keyboard
    SteelSeries Apex Pro Wired Gaming Keyboard
    Mouse
    Logitech MX Master 3S | MX Master 3 for Business
    Internet Speed
    AT&T LightSpeed Gigabit Duplex Ftth
    Browser
    Nightly (default) + Firefox (stable), Chrome, Edge , Arc
    Antivirus
    Defender + MB 5 Beta
  • Operating System
    ChromeOS Flex Dev Channel (current)
    Computer type
    Laptop
    Manufacturer/Model
    Dell Latitude E5470
    CPU
    Intel(R) Core(TM) i5-6300U CPU @ 2.40GHz, 2501 Mhz, 2 Core(s), 4 Logical Processor(s)
    Motherboard
    Dell
    Memory
    16 GB
    Graphics card(s)
    Intel(R) HD Graphics 520
    Sound Card
    Intel(R) HD Graphics 520 + RealTek Audio
    Monitor(s) Displays
    Dell laptop display 15"
    Screen Resolution
    1920 * 1080
    Hard Drives
    Toshiba 128GB M.2 22300 drive
    INTEL Cherryville 520 Series SSDSC2CW180A 180 GB SATA III SSD
    PSU
    Dell
    Case
    Dell
    Cooling
    Dell
    Mouse
    Logitech MX Master 3S (shared w. Sys 1) | Dell TouchPad
    Keyboard
    Dell
    Internet Speed
    AT&T LightSpeed Gigabit Duplex Ftth

Latest Support Threads

Latest Tutorials

Back
Top Bottom