Solved w11: odd behaviour when exiting 3d game


daNutz

Member
Local time
11:46 AM
Posts
2
OS
Windows 11
Hi,

Please see below gif that shows the weird "focus" behaviour that happens when i exit a game.. it only happens in windows 11, anyone know how to get rid of it as its really f@cking annoying..
  • AMD 5950x
  • Nvidia 3080FE (latest drivers)

The first black screen is me switching back into the game, the focus rubbish is when i exit (close) the game. this is one a triple screen thus you dont see the game.

Ive tried 3 different drivers from Nvidia and that doesnt affect it, using windows 10 with the same drivers doesn’t have the same issue. all default settings.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    AMD 5950x
    Motherboard
    Asus
    Memory
    Corsair
    Graphics Card(s)
    Nvidia 3080 FE

johnlgalt

Antidisestablishmentarianistentarianist
Power User
VIP
Local time
6:46 AM
Posts
2,351
Location
3rd Rock
OS
Windows 11 21H2
I have dual monitors, one that is 4K and the other that is 1440p, and I have this any time the 1440p either gets manually refreshed or I power it off and on - regardless of going into / out of games or not. That last little focus loss at the end of the video is exactly what I see happen - and I can reproduce it 100% of the time by simply powering off the 1440p at any given moment.

Do you have G-Sync on for the nVidia driver and / or Freesync enabled in the AMD drivers? Try turning those off (temporarily, just to test) to see if that helps. I really suspect that variable refresh rates may account for some of this, as the driver noticed that you're in game and kicks freesync / G-Sync into high gear - but across all monitors connected to the GPU, regardless of their use in-game or not.
 

My Computers

System One System Two

  • OS
    Windows 11 21H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    HomeBrew
    CPU
    AMD Ryzen 9 3950X
    Motherboard
    MSI MEG X570 GODLIKE
    Memory
    4 * Corsair Vengeance 32 GB 3600 MHz
    Graphics Card(s)
    EVGA GeForce RTX 3080 Ti XC3 ULTRA GAMING (12G-P5-3955-KR)
    Sound Card
    Realtek® ALC1220 Codec
    Monitor(s) Displays
    Eve Spectrum ES07D02 280 Hz QHD | Eve Spectrum ES07D03 4K Gaming Monitor
    Screen Resolution
    1440p | 4k
    Hard Drives
    3x Samsung 980 Pro NVMe PCIe 4 M.2 2 TB SSD (MZ-V8P2T0B/AM)
    PSU
    PC Power & Cooling’s Silencer Series 1050 Watt, 80 Plus Platinum
    Case
    Fractal Design Define 7 XL Dark ATX Full Tower Case
    Cooling
    ZXT KRAKEN Z73 73.11 CFM Liquid CPU Cooler (3x 120 mm push top) + Air 3x 140mm case fans (pull front) + 1x 120 mm (push back) and 1 x 120 mm (pull bottom)
    Keyboard
    SteelSeries Apex Pro Wired Gaming Keyboard
    Mouse
    Logitech MX Master 3 for Business
    Internet Speed
    Logitech MX Master 3 for Business
    Browser
    Nightly (default) + Firefox (stable),Chrome, Edge/ß/Dev/Canary
    Antivirus
    Defender
  • Operating System
    Windows 10 x64 Pro build 21H1
    Computer type
    Laptop
    Manufacturer/Model
    Dell Latitude E5470
    CPU
    Intel(R) Core(TM) i5-6300U CPU @ 2.40GHz, 2501 Mhz, 2 Core(s), 4 Logical Processor(s)
    Motherboard
    Dell
    Memory
    16 GB
    Graphics card(s)
    Intel(R) HD Graphics 520
    Sound Card
    Intel(R) HD Graphics 520 + RealTek Audio
    Monitor(s) Displays
    Dell laptop display 15"
    Screen Resolution
    1920 * 1080
    Hard Drives
    Toshiba 128GB M.2 22300 drive
    INTEL Cherryvill 520 Series SSDSC2CW180A 180 GB SATA III SSD
    PSU
    Dell
    Case
    Dell
    Cooling
    Dell
    Mouse
    Logitech MX Master (shared) | Dell TouchPad
    Keyboard
    Dell
    Internet Speed
    AT&T LightSpeed Gigabit Duplex
    Browser
    Edge Chromium | Chrome | Firefox Nightly | Brave
    Antivirus
    Defender + MB4

daNutz

Member
Thread Starter
Local time
11:46 AM
Posts
2
OS
Windows 11
I have dual monitors, one that is 4K and the other that is 1440p, and I have this any time the 1440p either gets manually refreshed or I power it off and on - regardless of going into / out of games or not. That last little focus loss at the end of the video is exactly what I see happen - and I can reproduce it 100% of the time by simply powering off the 1440p at any given moment.

Do you have G-Sync on for the nVidia driver and / or Freesync enabled in the AMD drivers? Try turning those off (temporarily, just to test) to see if that helps. I really suspect that variable refresh rates may account for some of this, as the driver noticed that you're in game and kicks freesync / G-Sync into high gear - but across all monitors connected to the GPU, regardless of their use in-game or not.
Thank you!

I didnt think about a second screen i have duplicating screen one, that i use for online racing but rarely use... as soon as i unplugged it, the issue went away!
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    AMD 5950x
    Motherboard
    Asus
    Memory
    Corsair
    Graphics Card(s)
    Nvidia 3080 FE
Top Bottom