W11 seems to have broken US-International keyboard for me


Buxbaum666

New member
Local time
8:21 AM
Posts
4
OS
Windows 11
Hi,
I'm German but prefer using US keyboards for programming so I'm using United States-International to still be able to type Umlauts and ß and whatnot. But since the update to Windows 11, this is broken for me. The dead keys (" ' ~ ` etc) behave as if I pressed them twice. Usually with US-International, pressing " followed by a produces an ä. Now, pressing " just results in "". Strangely, this does not seem to be a system-wide problem, in the search bar of the start menu it works as it should. It also works in the Search bar of Windows Explorer BUT not in the address bar or when renaming files. It works properly everywhere in the Files app, including the search bar, address bar and when renaming files. It does not work in browsers and text editors.

US-International keyboard layout is definitely installed and active. Any pointers as to where I could start troubleshooting this?
 
Windows Build/Version
Version 21H2 (OS Build 22000.493)

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    Intel i5-10600K
    Memory
    32GB
    Keyboard
    Glorious GMMK-TKL
    Mouse
    Logitech G502 Hero
    Browser
    Firefox
I have a laptop whose multi-lingual keyboard can act up strangely too. Lucky me, it seldom happens and disappears after reboot. So, I am guessing that it is a W11 glitch that gets triggered by a multiplicity of factors that have to come together to produce that strange behavior.

What you are describing is a lot worse, and I am guessing that it may be the keyboard driver. You may want to probe further in that direction. Good luck (y)
 

My Computer

System One

  • OS
    Windows 10 Pro
As a work round can you use the Ascii codes, I have $ not gbp on mine so I press alt+0163 to get £ sign
 

My Computers

System One System Two

  • OS
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    Alienware M18 R1
    CPU
    13th Gen Core i9 13900HX
    Memory
    32GB DDR5 @4800MHz 2x16GB
    Graphics Card(s)
    Geforce RTX 4090HX 16GB
    Sound Card
    Nvidia HD / Realtek ALC3254
    Monitor(s) Displays
    18" QHD+
    Screen Resolution
    25660 X 1600
    Hard Drives
    C: KIOXIA (Toshiba) 2TB KXG80ZNV2T04 NVMe PCIe M.2 SSD
    D: KIOXIA (Toshiba) 2TB KXG80ZNV2T04 NVMe PCIe M.2 SSD
    Case
    Dark Metallic Moon
    Keyboard
    Alienware M Series per-key AlienFX RGB
    Mouse
    Alienware AW610M
    Browser
    Chrome and Firefox
    Antivirus
    Norton
    Other Info
    Killer E3000 Ethernet Controller
    Killer Killer AX1690 Wi-Fi Network Adaptor Wi-Fi 6E
    Bluetooth 5.2
    Alienware Z01G Graphic Amplifier
  • Operating System
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    Alienware Area 51m R2
    CPU
    10th Gen i-9 10900 K
    Memory
    32Gb Dual Channel DDR4 @ 8843MHz
    Graphics card(s)
    Nvidia RTX 2080 Super
    Sound Card
    Nvidia
    Screen Resolution
    1920 x 1080
    Hard Drives
    Hard Drive C: Samsung 2TB SSD PM981a NVMe
    Hard Drive D:Samsung 2TB SSD 970 EVO Plus
    Mouse
    Alienware 610M
    Browser
    Chrome
    Antivirus
    Norton
As a work round can you use the Ascii codes, I have $ not gbp on mine so I press alt+0163 to get £ sign
Yes, this might work for the occasional character but it's not feasible when you're actually typing a longer German text. Funny enough, right now it works fine even in Firefox and Explorer. I have absolutely no idea what triggers this.

What you are describing is a lot worse, and I am guessing that it may be the keyboard driver. You may want to probe further in that direction. Good luck
It's a GMMK tenkeyless USB keyboard. I don't think there's a specific driver for it, device manager just lists some generic "HID keyboard device" entries.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    Intel i5-10600K
    Memory
    32GB
    Keyboard
    Glorious GMMK-TKL
    Mouse
    Logitech G502 Hero
    Browser
    Firefox
Hi,
I'm German but prefer using US keyboards for programming so I'm using United States-International to still be able to type Umlauts and ß and whatnot. But since the update to Windows 11, this is broken for me. The dead keys (" ' ~ ` etc) behave as if I pressed them twice. Usually with US-International, pressing " followed by a produces an ä. Now, pressing " just results in "". Strangely, this does not seem to be a system-wide problem, in the search bar of the start menu it works as it should. It also works in the Search bar of Windows Explorer BUT not in the address bar or when renaming files. It works properly everywhere in the Files app, including the search bar, address bar and when renaming files. It does not work in browsers and text editors.

US-International keyboard layout is definitely installed and active. Any pointers as to where I could start troubleshooting this?
Hi there
In Languages etc simply add another keyboard and then when typing / editing in that language select that keyboard. Choose US model not the Int'l model. You get same sort of problem if you want UK English and choose Int'l Eng model.

For example when typing in English : UK extended keyboard works perfectly for layout.

Skjámynd 2022-02-28 102642.png

Of course if the keyboard wont accept the relevant key combos then the only solution is to physically add another keyboard or change the one you have. However I have found those Int'l model settings do have those dead keys or you have to press twice so it's worth switching the layout to the "Domestic" English models.

As a German you must have heard of SAP -- I found on SAP systems using their "ABAP" editor those int'l keyboards were irritating in the extremefor using English with the double press and dead keys -- switching to UK Extended keyboard was the best solution as you got dollar, eur and sterling symbols all in the proper place.

cheers
jimbo
 
Last edited:

My Computer

System One

  • OS
    Windows XP,7,10,11 Linux Arch Linux
    Computer type
    PC/Desktop
    CPU
    2 X Intel i7
 

My Computers

System One System Two

  • OS
    Windows 11 Workstation
    Computer type
    PC/Desktop
    Manufacturer/Model
    doofenshmirtz evil incorporated
    CPU
    Ryzen 9 5950X
    Motherboard
    Asus ROG Crosshair VIII Formula
    Memory
    Corsair Vengeance RGB PRO Black 64GB (4x16GB) 3600MHz AMD Ryzen Tuned DDR4
    Graphics Card(s)
    ASUS AMD Radeon RX 6900 XT 16GB ROG Strix LC OC
    Sound Card
    Sound BlasterX Katana
    Monitor(s) Displays
    3 x27" Dell U2724D & 1 x 34" Dell U3415W
    Hard Drives
    Samsung 980 Pro 1TB M.2 2280 PCI-e 4.0 x4 NVMe Solid State
    Drive
    PSU
    ASUS ROG THOR 850W 80 Plus Platinum
    Case
    ASUS ROG Strix Helios Midi-Tower ARGB Gaming Case
    Cooling
    ASUS ROG Strix LC Performance RGB AIO CPU Liquid Cooler - 360mm
    Keyboard
    Logi Ergo
    Mouse
    Logitech MX Master 3
    Internet Speed
    900/100 Mbps
    Browser
    Chrome
    Antivirus
    Windows Defender, Malwarebytes Pro
    Other Info
    HP M281 Printer
    Logitech Brio Stream webcam
    Yeti X mic
  • Operating System
    Windows 10
    Computer type
    Laptop
    Manufacturer/Model
    Surface Laptop
    CPU
    i7
Hi there
that's 100% true of course -- the problem the OP has though (and I've also experienced it too) is that when using the Int'l option for Eng rather than "Domestic versions" you get some dead keys and other ones you have to press they key twice before the symbol appears on the screen. For "One fingured typists" - not a problem but for typical people who type at reasonable rates this can be mega annoying.

Cheers
jimbo
 

My Computer

System One

  • OS
    Windows XP,7,10,11 Linux Arch Linux
    Computer type
    PC/Desktop
    CPU
    2 X Intel i7
You misunderstand, I actually do want the "dead keys" to be dead on a single press because I'm not using a German keyboard but need to type äöü etc regularly. I've been using the US-International to type like this for years.
To type quotation marks, I press " followed by the space bar. My problem is that the dead keys are not dead but behave as if I've pressed them twice even though I only pressed them once.
 
Last edited:

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    Intel i5-10600K
    Memory
    32GB
    Keyboard
    Glorious GMMK-TKL
    Mouse
    Logitech G502 Hero
    Browser
    Firefox
I still think that there is a possibility that the generic keyboard driver is corrupted. Try to uninstall the driver, shut down, unplug the keyboard, start, plug in the keyboard, to get a fresh driver. Good luck (y)
 

My Computer

System One

  • OS
    Windows 10 Pro
I still think that there is a possibility that the generic keyboard driver is corrupted. Try to uninstall the driver, shut down, unplug the keyboard, start, plug in the keyboard, to get a fresh driver. Good luck (y)
Tried that, the issue still persists. There are four HID Keyboard Device entries under Keyboards. Uninstalled them all, unplugged and rebooted and they're back again.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    Intel i5-10600K
    Memory
    32GB
    Keyboard
    Glorious GMMK-TKL
    Mouse
    Logitech G502 Hero
    Browser
    Firefox
I use US Kbd and US-Intl.Kbd. No problems at all after Upgrade W10 -> W11.

syntoh
 

My Computer

System One

  • OS
    W10 pro 21H1
Tried that, the issue still persists. There are four HID Keyboard Device entries under Keyboards. Uninstalled them all, unplugged and rebooted and they're back again.

I fear you have to try a clean install, rebuild your machine from bare metal.
 

My Computer

System One

  • OS
    Windows 10 Pro
I was bedeviled for years by exactly the same problem - a deadkey press generates the equivalent of two key presses instead of proceeding to an accented character. Reinstalling the Windows, in my case Win10, solved the problem, but only temporarily. It worked for about days to months before the computer reverted to showing the same old problem.

I finally solved the problem w/o reinstalling the Windows. The malfunction of US-International (USI) was caused by certain apps that start after computer boot. I found this out by starting the computer in Safe Mode, and the keyboard setting of USI works perfectly.

So I checked the startup app list and disable all but the apps from the well-known reliable sources. To do this,
- Task Manager (right click on Task Bar to get the menu) -> Startup
- disabled all apps except those from usually reliable sources, for example, Microsoft, Intel, Google, ...
- reboot and see if the keyboard works correctly with USI. Works perfectly for me then.
- one by one add i(enable) your favorite startup apps back and reboot, till the problem comes back. You then find the culprit app.
- as a bonus of checking the startup list I discovered and disabled/removed some suspicious apps - executables in the user "Temp" directories, such as C:/Users/..../AppData/.../Temp/...
 

My Computer

System One

  • OS
    Windows 10
    Computer type
    Laptop
    Manufacturer/Model
    Lenovo ThinkPad
Back
Top Bottom