Windows 11 upgrade flashing screen


metaltoby

Member
Local time
9:46 PM
Posts
6
OS
Windows 10
Hi all,
I got the option to upgrade to Windows 11 today so I accepted it.
After the upgrade the screen is flashing on and off non-stop.

I made a video of it here:


Any ideas what I can do to fix it?
I booted into safe mode and reverted back to W10 without any issue.

Spec:
Ryzen 7 3700X
32GB Ram
RX570 Graphic
MSI B450

Thanks!
 
Windows Build/Version
21H1

My Computer

System One

  • OS
    Windows 10
Could be as simple as the Video driver not yet supporting Windows 11, keep your eyes on the manufacturer's update notices, for your card drivers - if you have certified Win 11 drivers check of any specific requirements or setting for your card and resolution etc
 

My Computers

System One System Two

  • OS
    Windows 11 Pro x64 [Latest Release Preview] [Win11 PRO HighEnd MUP-00005 DD]
    Computer type
    PC/Desktop
    Manufacturer/Model
    Scan 3XS to my design
    CPU
    AMD RYZEN 9 7950X OEM
    Motherboard
    *3XS*ASUS TUF B650 PLUS WIFI
    Memory
    64GB [2x32GB Corsair Vengeance 560 AMD DDR5]
    Graphics Card(s)
    3XS* ASUS DUAL RTX 4060 OC 8G
    Sound Card
    On motherboard Feeding SPDiF 5.1 system [plus local sound to each monitor]
    Monitor(s) Displays
    32" UHD 32 Bit HDR Monitor + 43" UHD 4K 32Bit HDR TV
    Screen Resolution
    2 x 3840 x 2160
    Hard Drives
    3XS Samsung 980Pro 2TB M.2 PCIe4 4 x 8TB Data + Various Externals from 1TB to 8TB, 10TB NAS
    PSU
    3XS Corsair RM850x 850w Fully Modular
    Case
    FDesign Define 7 XL BK TGL Case - Black
    Cooling
    3XS iCUE H150i ELITE Liquid Cool, Quiet Case fans
    Keyboard
    Wireless Logitec MX Keys + K830 [Depending on where I'm Sat]
    Mouse
    Wireless Logitec - MX Master 3S +
    Internet Speed
    950 MB Down 55 MB Up
    Browser
    Latest Chrome
    Antivirus
    BitDefender Total Security [Latest]
    Other Info
    Also run...
    Dell XPS 17 Laptop
    HP Laptop 8GB - Windows 10 Pro x64 HP 15.2"
    Nexus 7 Android tablet [x2]
    Samsung 10.2" tablet
    Blackview 10.2 Tablet
    Sony Z3 Android Smartphone
    Samsung S9 Plus Smartphone
    Wacom Pro Medium Pen Pad
    Wacom Pro Small Pen Pad
    Wacom ExpressKey Remote
    Loopdeck+ Graphics Controller
    Shuttle Pro v2 Control Pad
  • Operating System
    Windows 11 Pro x64 [Latest release]
    Computer type
    Laptop
    Manufacturer/Model
    Dell XPS 17 9700
    CPU
    i7 10750H
    Motherboard
    Stock
    Memory
    32 GB
    Graphics card(s)
    Stock Intel + GTX 1650 Ti
    Sound Card
    Stock 4 speaker
    Monitor(s) Displays
    Stock 17" + 32" 4K 3840 x 2160 HDR-10
    Screen Resolution
    3840 x 2400 HDR touchscreen
    Hard Drives
    2TB M2 NVMe
    PSU
    Stock
    Case
    Stock Aluminium / Carbon Fibre
    Cooling
    Stock + 2 fan cooling pad
    Mouse
    Stock Trackpad +Logi Mx Master 3 or MX Ergo Trackball
    Keyboard
    Stock Illuminated + Logi - MX Keys
    Internet Speed
    950 MB Down 55 MB Up
    Browser
    Latest Chrome
    Antivirus
    BitDefender Total Security 2021
    Other Info
    Also use an Adjustable Support for Laptop and Adjustable stand for monitor
Could be as simple as the Video driver not yet supporting Windows 11, keep your eyes on the manufacturer's update notices, for your card drivers - if you have certified Win 11 drivers check of any specific requirements or setting for your card and resolution etc
I checked and there are drivers for 11 available.
1633438679408.png
 

My Computer

System One

  • OS
    Windows 11 Home(Beta) - 23H2 - 22635.3495
    Computer type
    PC/Desktop
    Manufacturer/Model
    Banana Junior 5600- G Series
    CPU
    AMD Ryzen 5 5600G
    Motherboard
    Asus ROG Strix B550-F
    Memory
    G.SKILL Ripjaws V Series 64GB 4x16
    Graphics Card(s)
    NVIDIA GeForce GTX TITAN X
    Monitor(s) Displays
    Viotek 32", 28" ASUS VP28U
    Screen Resolution
    1080p
    Hard Drives
    Primary SAMSUNG 970 EVO Plus
    PSU
    EVGA BQ 700w 80+ Bronze
    Case
    Zalman i3 NEO
    Cooling
    ARCTIC Freezer 7 X
    Keyboard
    Corsair
    Mouse
    Amazon Generic with Cord
    Internet Speed
    Download: 295.11 mbps Upload: 65.35 mbps T-Mobile Internet
    Browser
    Firefox and Edge
    Antivirus
    MS - Defender
    Other Info
    Speakers: Klipsch ProMedia 2.1
The fact that they have bespoke drivers for the two operating systems would suggest to me that there are differences that could be at fault here with the flashing screen
 

My Computers

System One System Two

  • OS
    Windows 11 Pro x64 [Latest Release Preview] [Win11 PRO HighEnd MUP-00005 DD]
    Computer type
    PC/Desktop
    Manufacturer/Model
    Scan 3XS to my design
    CPU
    AMD RYZEN 9 7950X OEM
    Motherboard
    *3XS*ASUS TUF B650 PLUS WIFI
    Memory
    64GB [2x32GB Corsair Vengeance 560 AMD DDR5]
    Graphics Card(s)
    3XS* ASUS DUAL RTX 4060 OC 8G
    Sound Card
    On motherboard Feeding SPDiF 5.1 system [plus local sound to each monitor]
    Monitor(s) Displays
    32" UHD 32 Bit HDR Monitor + 43" UHD 4K 32Bit HDR TV
    Screen Resolution
    2 x 3840 x 2160
    Hard Drives
    3XS Samsung 980Pro 2TB M.2 PCIe4 4 x 8TB Data + Various Externals from 1TB to 8TB, 10TB NAS
    PSU
    3XS Corsair RM850x 850w Fully Modular
    Case
    FDesign Define 7 XL BK TGL Case - Black
    Cooling
    3XS iCUE H150i ELITE Liquid Cool, Quiet Case fans
    Keyboard
    Wireless Logitec MX Keys + K830 [Depending on where I'm Sat]
    Mouse
    Wireless Logitec - MX Master 3S +
    Internet Speed
    950 MB Down 55 MB Up
    Browser
    Latest Chrome
    Antivirus
    BitDefender Total Security [Latest]
    Other Info
    Also run...
    Dell XPS 17 Laptop
    HP Laptop 8GB - Windows 10 Pro x64 HP 15.2"
    Nexus 7 Android tablet [x2]
    Samsung 10.2" tablet
    Blackview 10.2 Tablet
    Sony Z3 Android Smartphone
    Samsung S9 Plus Smartphone
    Wacom Pro Medium Pen Pad
    Wacom Pro Small Pen Pad
    Wacom ExpressKey Remote
    Loopdeck+ Graphics Controller
    Shuttle Pro v2 Control Pad
  • Operating System
    Windows 11 Pro x64 [Latest release]
    Computer type
    Laptop
    Manufacturer/Model
    Dell XPS 17 9700
    CPU
    i7 10750H
    Motherboard
    Stock
    Memory
    32 GB
    Graphics card(s)
    Stock Intel + GTX 1650 Ti
    Sound Card
    Stock 4 speaker
    Monitor(s) Displays
    Stock 17" + 32" 4K 3840 x 2160 HDR-10
    Screen Resolution
    3840 x 2400 HDR touchscreen
    Hard Drives
    2TB M2 NVMe
    PSU
    Stock
    Case
    Stock Aluminium / Carbon Fibre
    Cooling
    Stock + 2 fan cooling pad
    Mouse
    Stock Trackpad +Logi Mx Master 3 or MX Ergo Trackball
    Keyboard
    Stock Illuminated + Logi - MX Keys
    Internet Speed
    950 MB Down 55 MB Up
    Browser
    Latest Chrome
    Antivirus
    BitDefender Total Security 2021
    Other Info
    Also use an Adjustable Support for Laptop and Adjustable stand for monitor
Likely..
 

My Computer

System One

  • OS
    Windows 11 Home(Beta) - 23H2 - 22635.3495
    Computer type
    PC/Desktop
    Manufacturer/Model
    Banana Junior 5600- G Series
    CPU
    AMD Ryzen 5 5600G
    Motherboard
    Asus ROG Strix B550-F
    Memory
    G.SKILL Ripjaws V Series 64GB 4x16
    Graphics Card(s)
    NVIDIA GeForce GTX TITAN X
    Monitor(s) Displays
    Viotek 32", 28" ASUS VP28U
    Screen Resolution
    1080p
    Hard Drives
    Primary SAMSUNG 970 EVO Plus
    PSU
    EVGA BQ 700w 80+ Bronze
    Case
    Zalman i3 NEO
    Cooling
    ARCTIC Freezer 7 X
    Keyboard
    Corsair
    Mouse
    Amazon Generic with Cord
    Internet Speed
    Download: 295.11 mbps Upload: 65.35 mbps T-Mobile Internet
    Browser
    Firefox and Edge
    Antivirus
    MS - Defender
    Other Info
    Speakers: Klipsch ProMedia 2.1
Thanks I saw those as well.
If I do the update again how do I get the drivers to update? When the screen is flashing I can't do anything so I wont be able to run the installer. Can I install the W11 drivers first??
 

My Computer

System One

  • OS
    Windows 10
Thanks I saw those as well.
If I do the update again how do I get the drivers to update? When the screen is flashing I can't do anything so I wont be able to run the installer. Can I install the W11 drivers first??
At AMD's site the Win 11 and Win 10 drivers are the same, in fact the Release Notes both say Windows 11. For that reason, I'd say install the driver for Windows 11 in Win 10 then try upgrading again to Win 11. I'd also though check your display refresh rate while still in Win 10 and make certain you select the highest refresh rate your monitor will do (look up that spec for your monitor if you do not know what it is). It appears to me there may be a problem with the synergy between Win 11, display drivers, and the monitor refresh rate.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Wordsworth 10000
    CPU
    Core i7 10700K 3.8 GHz
    Motherboard
    Asus ROG Strix Z590-A Gaming Wifi
    Memory
    Corsair Vengeance LPX DDR4 64GB 3000MHz
    Graphics Card(s)
    Asus Radeon RX480 Strix 8GB
    Sound Card
    Asus Xonar DSX
    Monitor(s) Displays
    HP 2709m
    Screen Resolution
    1920x1080
    Hard Drives
    Samsung 980 Pro M.2 SSD 500GB; Samsung 980 M.2 SSD 1TB
    PSU
    Thermaltake Toughpower Grand Platinum 850W
    Case
    Fractal Design Meshify 2
    Cooling
    CPU-Noctua NH D15 Chromax, GPU-Stock, Case-Noctua Chromax 3x140
    Keyboard
    Microsoft Natural Ergo 4000
    Mouse
    HP X500
    Internet Speed
    Cable
    Browser
    Vivaldi, MS Edge
    Antivirus
    Malwarebytes 4.4.3, Windows Defender
    Other Info
    Klipsch Promedia 5.1 THX
    Asus External Blu-Ray 16D1X-USB 3.0
  • Operating System
    Windows 11 Pro 23H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Wordsworth 6000
    CPU
    Core i7 6700K 4.0 GHz
    Motherboard
    Asus Z170 Pro
    Memory
    Corsair Vengeance LPX DDR4 32GB 3000MHz
    Graphics card(s)
    Asus GeForce GTX 1050 Ti
    Sound Card
    Asus Xonar SE
    Monitor(s) Displays
    HP X24ih
    Screen Resolution
    1920x1080
    Hard Drives
    Intel 760p M.2 SSD 500GB; Intel 540 SSD 480GB; Intel 335 SSD 240GB
    PSU
    Thermaltake Toughpower GF1 750W
    Case
    Lian Li PC-B70
    Cooling
    CPU- Noctua NH-D15; GPU-Stock; Case-Noctua Chromax 2x140, 2x120
    Mouse
    Microsoft Wireless Comfort 5050
    Keyboard
    Microsoft Wireless Comfort 5050
    Internet Speed
    Cable
    Browser
    Vivaldi, MS Edge
    Antivirus
    Malwarebytes 4.4.3, Windows Defender
    Other Info
    HP bd 340
    HP bd 240
    Denon DRA-800H
    Klipsch RP-600M
    Klipsch R-100SW (2)

    System 3 Specs
    Core i7 10700K 3.8 GHz
    Asus ROG Strix Z590-A Gaming Wifi
    Corsair Vengeance LPX DDR4 32GB 3200MHz
    Asus Radeon RX560 Dual 4GB
    Xonar SE
    Samsung 980 Pro M.2 SSD 1 TB (2)
    Thermaltake Toughpower GF3 850W
    Fractal Design Meshify 2
    CPU-Noctua NH D15 Chromax, GPU-Stock, Case-Noctua Chromax 2x140,1x120
My drivers were out of date so I updated them to the latest versions and ran the upgrade again.... same issue. Screen flashing.

The strange this is that the login page is fine. No flashing at all.
Also, my PC has 2 users so I logged into the other user (my wifes) and everything was fine. New start menu and no flashing. The flashing is only happening when I login with my user.

I did notice that when I logged into my wifes user I got the "Hi, we are setting things up" screens. When I first logged with my user I never got this.

I have a spare SSD so swap it in and try a fresh windows install. Otherwise I'll just wait a few weeks and try again in the hope things improve.
 

My Computer

System One

  • OS
    Windows 10
My drivers were out of date so I updated them to the latest versions and ran the upgrade again.... same issue. Screen flashing.

The strange this is that the login page is fine. No flashing at all.
Also, my PC has 2 users so I logged into the other user (my wifes) and everything was fine. New start menu and no flashing. The flashing is only happening when I login with my user.

I did notice that when I logged into my wifes user I got the "Hi, we are setting things up" screens. When I first logged with my user I never got this.

I have a spare SSD so swap it in and try a fresh windows install. Otherwise I'll just wait a few weeks and try again in the hope things improve.
This could be a rare bug that you may be the first, please report this through Feedback Hub also share link here so that those who have similar can upvote.

Also please use the video file you shared above in your report so they can understand the issue : ) This most likely a bug since early builds of Windows 11, so best to wait for updates or just use another user acount.

Thank you

Shawn
 

My Computer

System One

  • OS
    Windows 10 21H1 19043.1266
    Computer type
    Tablet
    Manufacturer/Model
    Microsoft Surface
    CPU
    Intel® Core™ 7th i5-7300
    Motherboard
    Intel
    Memory
    4GB
    Graphics Card(s)
    Intel® HD Graphics 620
    Sound Card
    Intel
    Monitor(s) Displays
    Surface Pro
    Screen Resolution
    2736 x 1824 (267 PPI)
    Keyboard
    Surface Type Cover
    Browser
    Microsoft Edge: 94.0.992.38
    Antivirus
    Windows Defender
    Other Info
    Windows Live, Microsoft 365, Edge, Bing, Zoom
Quick follow up.... The issue was never resolved. I ended up doing a fresh Win11 installation which worked fine.
 

My Computer

System One

  • OS
    Windows 10
In your case the problem was that Explorer.exe kept crashing and when the screen went dark, an error report was created.

Mostly it is incompatible programs or driver that cause such a crash.


After a clean install, they apparently no longer installed the culprit.
 

My Computer

System One

  • OS
    Win 11
Back
Top Bottom