WSL and Linux Full GUI Desktop on W11

jimbo45

Well-known member
Member
VIP
Local time
9:02 PM
Posts
635
Location
Hafnarfjörður IS
Hi folks
There's an excellent tutorial by @Kari (thanks !!) on the W10 Forums on getting UBUNTU desktop to run on WSL on W10.
Just wondering has anybody had a go with this yet on W11 -- OK we've only got the leaked release so even if it does work we can't guarantee that will continue.

I'm going to try this later -- seems to be an interesting exercise. I'd recommend though anybody doing this to backup their W11 installation first -- especially as some have had a bit of a hassle to install the W11 OS in the first place.

Cheers
jimbo
 

My Computer

System One

  • Operating System
    Windows XP,7,10,11 Linux Arch Linux
    Computer type
    PC/Desktop
    CPU
    2 X Intel i7

z3r010

Administrator
Staff member
Local time
10:02 PM
Posts
1,091
Location
Worsley, Manchester, UK

My Computers

System One System Two

  • Operating System
    Windows 11 Workstation
    Computer type
    PC/Desktop
    Manufacturer/Model
    doofenshmirtz evil incorporated
    CPU
    Ryzen 9 5950X
    Motherboard
    Asus ROG Crosshair VIII Formula
    Memory
    Corsair Vengeance RGB PRO Black 32GB (2x16GB) 3600MHz AMD Ryzen Tuned DDR4
    Graphics Card(s)
    ASUS AMD Radeon RX 6900 XT 16GB ROG Strix LC OC
    Sound Card
    Sound BlasterX Katana
    Monitor(s) Displays
    3 x27" Dell U2714H & 1 x 34" Dell
    Hard Drives
    Samsung 980 Pro 1TB M.2 2280 PCI-e 4.0 x4 NVMe Solid State
    Drive
    PSU
    ASUS ROG THOR 850W 80 Plus Platinum
    Case
    ASUS ROG Strix Helios Midi-Tower ARGB Gaming Case
    Cooling
    ASUS ROG Strix LC Performance RGB AIO CPU Liquid Cooler - 360mm
    Keyboard
    Logi Ergo
    Mouse
    Logitech MX Vertical
    Internet Speed
    900/100 Mbps
    Browser
    Chrome
    Antivirus
    Windows Defender, Malwarebytes Pro
    Other Info
    HP M281 Printer
    Logitech Brio Stream webcam
    Yeti X mic
  • Operating System
    Windows 10
    Computer type
    Laptop
    Manufacturer/Model
    Surface Laptop
    CPU
    i7

jimbo45

Well-known member
Member
VIP
Thread Starter
Local time
9:02 PM
Posts
635
Location
Hafnarfjörður IS
Hi there
Am trying the method Kari suggested in Win 10 Forums tutorial with UBUNTU LTS and XFCE4. OpenSUSE and some later distros use WAYLAND for the display which introduces a whole slew of other factors as well. Currently XORG seems to be the only way to get this stuff working reasonably -- still as always with Linux there's usually a away !!!

First snag after installing / enabling WSL for Linux on W11 reboot just leaves me with nice blank screen. So restore and try another few things. This can't readily be done on a VM BTW unless you allow Nested Virtualisation - and not sure how Windows HOSTS handle that. Making this sort of stuff too complex to start with rather kills the exercise. My motto - just get the base working first --If I can see a Linux GUI login screen first that's a start.

Cheers
jimbo
 

My Computer

System One

  • Operating System
    Windows XP,7,10,11 Linux Arch Linux
    Computer type
    PC/Desktop
    CPU
    2 X Intel i7

swarfega

sʍɐɹɟǝƃɐ
Member
VIP
Local time
10:02 PM
Posts
325
Location
Cambridgeshire, United Kingdom
I only have 11 in a VM atm so haven't been able to test. Will do some testing when the insider is released next week.
 

My Computers

System One System Two

  • Operating System
    Windows 10
    Computer type
    PC/Desktop
    Manufacturer/Model
    Self Built
    CPU
    Ryzen 9 3900x
    Motherboard
    Asus Strix x570-E
    Memory
    Corsair Dominator Platinum 32Gb@3600MHz
    Graphics Card(s)
    Asus Strix 3080 Ti OC
    Monitor(s) Displays
    Samsung Odyssey G7 32" Curved Gaming Monitor, IIYAMA XUB2792QSU-W1 27"
    Screen Resolution
    2560x1440@240Hz, 2560x1440@70Hz
    Hard Drives
    Samsung 980 Pro 1 Tb (OS), Samsung 970 Pro 1 Tb (games), Samsung 860 Evo 1Tb (data), Samsung 860 Evo 4 Tb (games), Crucial MX500 1Tb (photos), WD MyCloud Mirror 6Tb NAS.
    PSU
    Corsair RM850x
    Case
    Corsair Crystal 680x
    Cooling
    Corsair H100i Se Platinum, 8 Corsair QL120/140 fans
    Keyboard
    Corsair K70 RGB Mk 2 SE Rapid Fire
    Mouse
    Corsair M65 Elite
    Internet Speed
    58/12 Mbps
    Browser
    Microsoft Edge
    Antivirus
    Windows Defender + Malwarebytes
    Other Info
    Astro a50 Headset, Samsung Galaxy Tab S3 Tablet.
    Creative T6300 5.1 Speakers. TPM 2.0 Module.
  • Operating System
    Windows 10 Pro Insider 64-bit/Manjaro KDE
    Computer type
    PC/Desktop
    Manufacturer/Model
    Self Built
    CPU
    Ryzen 5600x
    Motherboard
    Asus Strix B550-E
    Memory
    Corsair Vengeance 32Gb@3200MHz
    Graphics card(s)
    Gigabyte RTX2070 Super Gaming OC
    Sound Card
    Creative Soundblaster AE-5
    Monitor(s) Displays
    Asus Strix XG43VQ 43" Ultrawide
    Screen Resolution
    3840x1200 @ 120Mhz
    Hard Drives
    Aorus Gen 4 NVMe 1 Tb (Windows Insider), Samsung 850 Pro 512Gb (data), Samsung 850 Evo 1Tb (files), Samsung 860 Evo 2Tb (Manjaro), Blu-ray player
    PSU
    Corsair RM750i
    Case
    Fractal Define R6
    Cooling
    Scythe Mugen 5 rev B and Corsair QL fans
    Mouse
    Glorious Model D
    Keyboard
    Corsair K70 RGB MK.2 Low Profile Rapidfire
    Internet Speed
    58/12 Mbps
    Browser
    Microsoft Edge
    Antivirus
    Windows Defender + Malwarebytes
    Other Info
    Corsair Virtuoso Headset

jimbo45

Well-known member
Member
VIP
Thread Starter
Local time
9:02 PM
Posts
635
Location
Hafnarfjörður IS
Hi folks

Ubuntu LTS 1804 -- FAIL to install

However MY ERROR - thanks to post by @z3r010

So if you get this

ubuntu.png
simply exit out of wsl and then in elevated command mode type wsl --update.
it will load some updates, restart WSL and then install works properly.

ubuntu1.png

Cheers
jimbo
 

My Computer

System One

  • Operating System
    Windows XP,7,10,11 Linux Arch Linux
    Computer type
    PC/Desktop
    CPU
    2 X Intel i7

swarfega

sʍɐɹɟǝƃɐ
Member
VIP
Local time
10:02 PM
Posts
325
Location
Cambridgeshire, United Kingdom
Did you try 20.04?
 

My Computers

System One System Two

  • Operating System
    Windows 10
    Computer type
    PC/Desktop
    Manufacturer/Model
    Self Built
    CPU
    Ryzen 9 3900x
    Motherboard
    Asus Strix x570-E
    Memory
    Corsair Dominator Platinum 32Gb@3600MHz
    Graphics Card(s)
    Asus Strix 3080 Ti OC
    Monitor(s) Displays
    Samsung Odyssey G7 32" Curved Gaming Monitor, IIYAMA XUB2792QSU-W1 27"
    Screen Resolution
    2560x1440@240Hz, 2560x1440@70Hz
    Hard Drives
    Samsung 980 Pro 1 Tb (OS), Samsung 970 Pro 1 Tb (games), Samsung 860 Evo 1Tb (data), Samsung 860 Evo 4 Tb (games), Crucial MX500 1Tb (photos), WD MyCloud Mirror 6Tb NAS.
    PSU
    Corsair RM850x
    Case
    Corsair Crystal 680x
    Cooling
    Corsair H100i Se Platinum, 8 Corsair QL120/140 fans
    Keyboard
    Corsair K70 RGB Mk 2 SE Rapid Fire
    Mouse
    Corsair M65 Elite
    Internet Speed
    58/12 Mbps
    Browser
    Microsoft Edge
    Antivirus
    Windows Defender + Malwarebytes
    Other Info
    Astro a50 Headset, Samsung Galaxy Tab S3 Tablet.
    Creative T6300 5.1 Speakers. TPM 2.0 Module.
  • Operating System
    Windows 10 Pro Insider 64-bit/Manjaro KDE
    Computer type
    PC/Desktop
    Manufacturer/Model
    Self Built
    CPU
    Ryzen 5600x
    Motherboard
    Asus Strix B550-E
    Memory
    Corsair Vengeance 32Gb@3200MHz
    Graphics card(s)
    Gigabyte RTX2070 Super Gaming OC
    Sound Card
    Creative Soundblaster AE-5
    Monitor(s) Displays
    Asus Strix XG43VQ 43" Ultrawide
    Screen Resolution
    3840x1200 @ 120Mhz
    Hard Drives
    Aorus Gen 4 NVMe 1 Tb (Windows Insider), Samsung 850 Pro 512Gb (data), Samsung 850 Evo 1Tb (files), Samsung 860 Evo 2Tb (Manjaro), Blu-ray player
    PSU
    Corsair RM750i
    Case
    Fractal Define R6
    Cooling
    Scythe Mugen 5 rev B and Corsair QL fans
    Mouse
    Glorious Model D
    Keyboard
    Corsair K70 RGB MK.2 Low Profile Rapidfire
    Internet Speed
    58/12 Mbps
    Browser
    Microsoft Edge
    Antivirus
    Windows Defender + Malwarebytes
    Other Info
    Corsair Virtuoso Headset

jimbo45

Well-known member
Member
VIP
Thread Starter
Local time
9:02 PM
Posts
635
Location
Hafnarfjörður IS
Did you try 20.04?

Hi there

I need the UBUNTU LTS one to try Kari's tutorial on the desktop GUI.

I've modified my previous post -- my error -- in elevated command mode type wsl --update. It updates a kernel then the ubuntu LTS installs OK

screenshots in previous post.

Cheers
jimbo
 

My Computer

System One

  • Operating System
    Windows XP,7,10,11 Linux Arch Linux
    Computer type
    PC/Desktop
    CPU
    2 X Intel i7

swarfega

sʍɐɹɟǝƃɐ
Member
VIP
Local time
10:02 PM
Posts
325
Location
Cambridgeshire, United Kingdom
I know it states LTS, is that the only version that GUi works on atm?
 

My Computers

System One System Two

  • Operating System
    Windows 10
    Computer type
    PC/Desktop
    Manufacturer/Model
    Self Built
    CPU
    Ryzen 9 3900x
    Motherboard
    Asus Strix x570-E
    Memory
    Corsair Dominator Platinum 32Gb@3600MHz
    Graphics Card(s)
    Asus Strix 3080 Ti OC
    Monitor(s) Displays
    Samsung Odyssey G7 32" Curved Gaming Monitor, IIYAMA XUB2792QSU-W1 27"
    Screen Resolution
    2560x1440@240Hz, 2560x1440@70Hz
    Hard Drives
    Samsung 980 Pro 1 Tb (OS), Samsung 970 Pro 1 Tb (games), Samsung 860 Evo 1Tb (data), Samsung 860 Evo 4 Tb (games), Crucial MX500 1Tb (photos), WD MyCloud Mirror 6Tb NAS.
    PSU
    Corsair RM850x
    Case
    Corsair Crystal 680x
    Cooling
    Corsair H100i Se Platinum, 8 Corsair QL120/140 fans
    Keyboard
    Corsair K70 RGB Mk 2 SE Rapid Fire
    Mouse
    Corsair M65 Elite
    Internet Speed
    58/12 Mbps
    Browser
    Microsoft Edge
    Antivirus
    Windows Defender + Malwarebytes
    Other Info
    Astro a50 Headset, Samsung Galaxy Tab S3 Tablet.
    Creative T6300 5.1 Speakers. TPM 2.0 Module.
  • Operating System
    Windows 10 Pro Insider 64-bit/Manjaro KDE
    Computer type
    PC/Desktop
    Manufacturer/Model
    Self Built
    CPU
    Ryzen 5600x
    Motherboard
    Asus Strix B550-E
    Memory
    Corsair Vengeance 32Gb@3200MHz
    Graphics card(s)
    Gigabyte RTX2070 Super Gaming OC
    Sound Card
    Creative Soundblaster AE-5
    Monitor(s) Displays
    Asus Strix XG43VQ 43" Ultrawide
    Screen Resolution
    3840x1200 @ 120Mhz
    Hard Drives
    Aorus Gen 4 NVMe 1 Tb (Windows Insider), Samsung 850 Pro 512Gb (data), Samsung 850 Evo 1Tb (files), Samsung 860 Evo 2Tb (Manjaro), Blu-ray player
    PSU
    Corsair RM750i
    Case
    Fractal Define R6
    Cooling
    Scythe Mugen 5 rev B and Corsair QL fans
    Mouse
    Glorious Model D
    Keyboard
    Corsair K70 RGB MK.2 Low Profile Rapidfire
    Internet Speed
    58/12 Mbps
    Browser
    Microsoft Edge
    Antivirus
    Windows Defender + Malwarebytes
    Other Info
    Corsair Virtuoso Headset

jimbo45

Well-known member
Member
VIP
Thread Starter
Local time
9:02 PM
Posts
635
Location
Hafnarfjörður IS
Hi there
I can't get any desktop to work - just shows blank terminal screen - however some GUI things work such as GPARTED, DOLPHIN (file manager), Solitaire games etc. just type the command in from the console - ignore spurious messages and the window should popup.

E,G spider Solitaire

spy.png
Gparted
gparted.png

GRSYNC

grsync.png

Dolphin

dolph.png

So limited success but I'll wait until I see a full WSL GUI working on W11. !!

Response times pretty impressive - if a decent GUI can be got working this could be a decent alternative to setting up a totally separate VM. I'm only running this stuff on an ageing 8GB RAM laptop as well. There's a lot more traction in this stuff -- depends probably on interest and whether Ms want to continue developing this. I hope so.

Sunday Lunch time now !!!

Cheers
jimbo
 

My Computer

System One

  • Operating System
    Windows XP,7,10,11 Linux Arch Linux
    Computer type
    PC/Desktop
    CPU
    2 X Intel i7

Kari

PhD in Malt Based Liquids
Power User
VIP
Local time
11:02 PM
Posts
573
Location
Expat from Finland in Leipzig Germany
I need the UBUNTU LTS one to try Kari's tutorial on the desktop GUI.
I know it states LTS, is that the only version that GUi works on atm?

At the moment, desktop experience only works in version 18.04, as stated in the tutorial. I am working on to get it to work on version 20.04.

I can't get any desktop to work - just shows blank terminal screen

Works perfectly for me, when done exactly as told in tutorial. Both in W10 and in W11, both physical and virtual machines.

WSL Ubuntu Desktop on W11.jpg

Tutorial on our sister site Ten Forums:

Kari
 

My Computers

System One System Two

  • Operating System
    Windows 11 PRO x64 Dev
    Manufacturer/Model
    Hyper-V Virtual Machine (host in System 2 specs)
    CPU
    Intel Core i7-8550U
    Memory
    6 GB
    Graphics Card(s)
    Microsoft Hyper-V Video
    Monitor(s) Displays
    Laptop display (17.1") & Samsung U28E590 (27.7")
  • Operating System
    Windows 11 PRO x64 Dev Channel
    Computer type
    Laptop
    Manufacturer/Model
    HP HP ProBook 470 G5
    CPU
    Intel Core i7-8550U
    Motherboard
    HP 837F KBC Version 02.3D.00
    Memory
    16 GB
    Graphics card(s)
    Intel(R) UHD Graphics 620 & NVIDIA GeForce 930MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    Laptop display (17.1") & Samsung U28E590 (27.7")
    Hard Drives
    128 GB SSD & 1 TB HDD
    Mouse
    Wireless Logitech MSX mouse
    Keyboard
    Wireless Logitech MK710 keyboard
    Internet Speed
    100 Mbps down, 20 Mbps up
    Browser
    Edge Chromium Dev Channel
    Antivirus
    Windows Defender
    Other Info
    2 * 3 TB USB HDD
    6 TB WD Mirror NAS

Kari

PhD in Malt Based Liquids
Power User
VIP
Local time
11:02 PM
Posts
573
Location
Expat from Finland in Leipzig Germany
A side note: I just installed MS Edge Dev in WSL Ubuntu desktop:

Edge in W11 WSL Ubuntu.jpg

A happy surfer here!

Kari
 

My Computers

System One System Two

  • Operating System
    Windows 11 PRO x64 Dev
    Manufacturer/Model
    Hyper-V Virtual Machine (host in System 2 specs)
    CPU
    Intel Core i7-8550U
    Memory
    6 GB
    Graphics Card(s)
    Microsoft Hyper-V Video
    Monitor(s) Displays
    Laptop display (17.1") & Samsung U28E590 (27.7")
  • Operating System
    Windows 11 PRO x64 Dev Channel
    Computer type
    Laptop
    Manufacturer/Model
    HP HP ProBook 470 G5
    CPU
    Intel Core i7-8550U
    Motherboard
    HP 837F KBC Version 02.3D.00
    Memory
    16 GB
    Graphics card(s)
    Intel(R) UHD Graphics 620 & NVIDIA GeForce 930MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    Laptop display (17.1") & Samsung U28E590 (27.7")
    Hard Drives
    128 GB SSD & 1 TB HDD
    Mouse
    Wireless Logitech MSX mouse
    Keyboard
    Wireless Logitech MK710 keyboard
    Internet Speed
    100 Mbps down, 20 Mbps up
    Browser
    Edge Chromium Dev Channel
    Antivirus
    Windows Defender
    Other Info
    2 * 3 TB USB HDD
    6 TB WD Mirror NAS

jimbo45

Well-known member
Member
VIP
Thread Starter
Local time
9:02 PM
Posts
635
Location
Hafnarfjörður IS
Hi there @Kari
I did 100% from your tutorial -- absolutely step by step from an intital clean Windows 11 install with nothing extra installed from the iso. -- still no joy

Do I need to start any sort of WM like GDDM or whatever -- probably not.

Thanks for taking the time --this stuff I really find interesting so please "Don't Give up" on those who can't get this to work 1st time round. At least a load of GUI apps do work. !! (And I appreciate the help on getting HYPER-V networking to work for me).

Cheers
jimbo
 
Last edited:

My Computer

System One

  • Operating System
    Windows XP,7,10,11 Linux Arch Linux
    Computer type
    PC/Desktop
    CPU
    2 X Intel i7

jimbo45

Well-known member
Member
VIP
Thread Starter
Local time
9:02 PM
Posts
635
Location
Hafnarfjörður IS
Hi there
@Kari

followed to the letter -- still no joy
Re-installed everything including W11 from scratch - on a decent NVMe2 takes about 10 mins so not a big deal.

Now I get the initial Linux login screen with option xorg -- but all it does is nothing !!!

Trying some debugging in the logs - seems to say display fails for display 0 so ????

Also the logs seem to say listening on port 3350 which can't be right !!!!

rdp.png

port.png

Cheers
jimbo
 
Last edited:

My Computer

System One

  • Operating System
    Windows XP,7,10,11 Linux Arch Linux
    Computer type
    PC/Desktop
    CPU
    2 X Intel i7

Kari

PhD in Malt Based Liquids
Power User
VIP
Local time
11:02 PM
Posts
573
Location
Expat from Finland in Leipzig Germany
followed to the letter -- still no joy

I had to test again. Did two tests, one on W11 physical installation, one on W11 Hyper-V VM. On physical, restored a Macrium image, to state before installing WSL and Ubuntu, on Hyper-V VM applied a checkpoint to restore state to just after first boot.

Acted as if I would not know what and how to do. Followed tutorial, step by step, copying each command from tutorial instead of typing them.

Both times, Ubuntu booted to desktop directly. Can't explain, why it does not work for you.

Your screenshots give a hint, though, considering that your XRDP error message tells "login failed". Try to connect WITHOUT adding your Ubuntu username in RDP dialog:

1624813641307.png

It might be as simple as XRDP login not accepting credentials from RDP. Just an idea, worth to try.

Kari
 

My Computers

System One System Two

  • Operating System
    Windows 11 PRO x64 Dev
    Manufacturer/Model
    Hyper-V Virtual Machine (host in System 2 specs)
    CPU
    Intel Core i7-8550U
    Memory
    6 GB
    Graphics Card(s)
    Microsoft Hyper-V Video
    Monitor(s) Displays
    Laptop display (17.1") & Samsung U28E590 (27.7")
  • Operating System
    Windows 11 PRO x64 Dev Channel
    Computer type
    Laptop
    Manufacturer/Model
    HP HP ProBook 470 G5
    CPU
    Intel Core i7-8550U
    Motherboard
    HP 837F KBC Version 02.3D.00
    Memory
    16 GB
    Graphics card(s)
    Intel(R) UHD Graphics 620 & NVIDIA GeForce 930MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    Laptop display (17.1") & Samsung U28E590 (27.7")
    Hard Drives
    128 GB SSD & 1 TB HDD
    Mouse
    Wireless Logitech MSX mouse
    Keyboard
    Wireless Logitech MK710 keyboard
    Internet Speed
    100 Mbps down, 20 Mbps up
    Browser
    Edge Chromium Dev Channel
    Antivirus
    Windows Defender
    Other Info
    2 * 3 TB USB HDD
    6 TB WD Mirror NAS

Kari

PhD in Malt Based Liquids
Power User
VIP
Local time
11:02 PM
Posts
573
Location
Expat from Finland in Leipzig Germany
It might be as simple as XRDP login not accepting credentials from RDP. Just an idea, worth to try.

It's not that. Tested, XRDP had no issues in getting credentials from RDP.

Kari
 

My Computers

System One System Two

  • Operating System
    Windows 11 PRO x64 Dev
    Manufacturer/Model
    Hyper-V Virtual Machine (host in System 2 specs)
    CPU
    Intel Core i7-8550U
    Memory
    6 GB
    Graphics Card(s)
    Microsoft Hyper-V Video
    Monitor(s) Displays
    Laptop display (17.1") & Samsung U28E590 (27.7")
  • Operating System
    Windows 11 PRO x64 Dev Channel
    Computer type
    Laptop
    Manufacturer/Model
    HP HP ProBook 470 G5
    CPU
    Intel Core i7-8550U
    Motherboard
    HP 837F KBC Version 02.3D.00
    Memory
    16 GB
    Graphics card(s)
    Intel(R) UHD Graphics 620 & NVIDIA GeForce 930MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    Laptop display (17.1") & Samsung U28E590 (27.7")
    Hard Drives
    128 GB SSD & 1 TB HDD
    Mouse
    Wireless Logitech MSX mouse
    Keyboard
    Wireless Logitech MK710 keyboard
    Internet Speed
    100 Mbps down, 20 Mbps up
    Browser
    Edge Chromium Dev Channel
    Antivirus
    Windows Defender
    Other Info
    2 * 3 TB USB HDD
    6 TB WD Mirror NAS

ish4d0w

Member
VIP
Local time
11:02 PM
Posts
61
Starting with win10 build 19619 you should have almost full support for this. If the leak is based on this core, or newer than this, it could work. I used an app from the MS store called X410 to provide me with the missing "link". You could try that for GUI.
 

My Computer

System One

Kari

PhD in Malt Based Liquids
Power User
VIP
Local time
11:02 PM
Posts
573
Location
Expat from Finland in Leipzig Germany
I used an app from the MS store called X410 to provide me with the missing "link". You could try that for GUI.

There is no "missing link". Following instructions in the already mentioned tutorial on our sister site Ten Forums, GUI desktop works. No need to download anything from Store.

Kari
 

My Computers

System One System Two

  • Operating System
    Windows 11 PRO x64 Dev
    Manufacturer/Model
    Hyper-V Virtual Machine (host in System 2 specs)
    CPU
    Intel Core i7-8550U
    Memory
    6 GB
    Graphics Card(s)
    Microsoft Hyper-V Video
    Monitor(s) Displays
    Laptop display (17.1") & Samsung U28E590 (27.7")
  • Operating System
    Windows 11 PRO x64 Dev Channel
    Computer type
    Laptop
    Manufacturer/Model
    HP HP ProBook 470 G5
    CPU
    Intel Core i7-8550U
    Motherboard
    HP 837F KBC Version 02.3D.00
    Memory
    16 GB
    Graphics card(s)
    Intel(R) UHD Graphics 620 & NVIDIA GeForce 930MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    Laptop display (17.1") & Samsung U28E590 (27.7")
    Hard Drives
    128 GB SSD & 1 TB HDD
    Mouse
    Wireless Logitech MSX mouse
    Keyboard
    Wireless Logitech MK710 keyboard
    Internet Speed
    100 Mbps down, 20 Mbps up
    Browser
    Edge Chromium Dev Channel
    Antivirus
    Windows Defender
    Other Info
    2 * 3 TB USB HDD
    6 TB WD Mirror NAS

Kari

PhD in Malt Based Liquids
Power User
VIP
Local time
11:02 PM
Posts
573
Location
Expat from Finland in Leipzig Germany
Jimbo, I give up.

I cannot get it to fail, be it Windows 10 or Windows 11, a PC or virtual machine. Works everytime. I simply cannot understand why it does not work for you. Sorry.

Kari
 

My Computers

System One System Two

  • Operating System
    Windows 11 PRO x64 Dev
    Manufacturer/Model
    Hyper-V Virtual Machine (host in System 2 specs)
    CPU
    Intel Core i7-8550U
    Memory
    6 GB
    Graphics Card(s)
    Microsoft Hyper-V Video
    Monitor(s) Displays
    Laptop display (17.1") & Samsung U28E590 (27.7")
  • Operating System
    Windows 11 PRO x64 Dev Channel
    Computer type
    Laptop
    Manufacturer/Model
    HP HP ProBook 470 G5
    CPU
    Intel Core i7-8550U
    Motherboard
    HP 837F KBC Version 02.3D.00
    Memory
    16 GB
    Graphics card(s)
    Intel(R) UHD Graphics 620 & NVIDIA GeForce 930MX
    Sound Card
    Conexant ISST Audio
    Monitor(s) Displays
    Laptop display (17.1") & Samsung U28E590 (27.7")
    Hard Drives
    128 GB SSD & 1 TB HDD
    Mouse
    Wireless Logitech MSX mouse
    Keyboard
    Wireless Logitech MK710 keyboard
    Internet Speed
    100 Mbps down, 20 Mbps up
    Browser
    Edge Chromium Dev Channel
    Antivirus
    Windows Defender
    Other Info
    2 * 3 TB USB HDD
    6 TB WD Mirror NAS

jimbo45

Well-known member
Member
VIP
Thread Starter
Local time
9:02 PM
Posts
635
Location
Hafnarfjörður IS
Hi there

Jimbo, I give up.

I cannot get it to fail, be it Windows 10 or Windows 11, a PC or virtual machine. Works everytime. I simply cannot understand why it does not work for you. Sorry.

Kari

I think the difference was that when I initially tried to install WSL on a W11 host it failed with Linux kernel needed an update -- and I updated it via command wsl --update.

I restored an old W10 system which already had WSL2 installed and everything worked properly !!!!!

Anyway I'll wait until an official W11 comes out before having another go on W11.

Thanks for the time spent and hints.

Just for info -laptop bog standard HP with Intel graphics and Intel i5 processor -- no "unusual graphics etc" -- also tested UBUNTU running native on it and RDP'ing to it from another Windows system -- perfectly OK as well so there's something in my W11 install that doesn't like it !!!!

Cheers
jimbo
 

My Computer

System One

  • Operating System
    Windows XP,7,10,11 Linux Arch Linux
    Computer type
    PC/Desktop
    CPU
    2 X Intel i7

johnlgalt

Antidisestablishmentarianistentarianist
Power User
VIP
Local time
5:02 PM
Posts
1,922
Location
3rd Rock
After reading this topic yesterday, W11 had 2 updates related to WSL pushed to me when I checked for updates later in the afternoon.

WSLg Preview

WSL Update
 

My Computers

System One System Two

  • Operating System
    Windows 10 Pro X64
    Computer type
    PC/Desktop
    Manufacturer/Model
    HomeBrew
    CPU
    AMD Ryzen 9 3950X
    Motherboard
    MSI MEG X570 GODLIKE
    Memory
    4 * Corsair Vengeance 32 GB 3600 MHz
    Graphics Card(s)
    eVGA GeForce GTX 970 SSC ACX 2.0 (04G-P4-3979-KB)
    Sound Card
    Realtek® ALC1220 Codec
    Monitor(s) Displays
    2 * Lenovo LT2323pwA Widescreeen
    Screen Resolution
    2* 1920*1080
    Hard Drives
    3x Sabrent Rocket PCIe Gen4 NVMe M.2 1 TB SSD (SB-ROCKET-NVMe4-1TB)
    SanDisk Ultra SDSSDHII-960G-G25 960 GB SATA III SSD
    Crucial MX100 CT256MX100SSD1 256GB SATA III SSD
    2 * Seagate Barracuda 7200.12 ST31000528AS 1TB 7200 RPM --> RAID1
    PSU
    PC Power & Cooling’s Silencer Series 1050 Watt, 80 Plus Platinum
    Case
    Fractal Design Define 7 XL Dark ATX Full Tower Case
  • Operating System
    Windows 10 x64 Pro build 21H1
    Computer type
    Laptop
    Manufacturer/Model
    Dell Latitude E5470
    CPU
    Intel(R) Core(TM) i5-6300U CPU @ 2.40GHz, 2501 Mhz, 2 Core(s), 4 Logical Processor(s)
    Motherboard
    Dell
    Memory
    16 GB
    Graphics card(s)
    Intel(R) HD Graphics 520
    Sound Card
    Intel(R) HD Graphics 520 + RealTek Audio
    Monitor(s) Displays
    Dell laptop display 15"
    Screen Resolution
    1920 * 1080
    Hard Drives
    Toshiba 128GB M.2 22300 drive
    INTEL Cherryvill 520 Series SSDSC2CW180A 180 GB SATA III SSD
    PSU
    Dell
    Case
    Dell
    Cooling
    Dell
    Mouse
    Logitech MX Master (shared) | Dell TouchPad
    Keyboard
    Dell
    Internet Speed
    AT&T LightSpeed Gigabit Duplex
    Browser
    Edge Chromium | Chrome | Firefox Nightly | Brave
    Antivirus
    Defender + MB4
Top Bottom