General Enable or Disable Search Indexing in Windows 11


  • Staff
Search_Index_Locations_banner.png

This tutorial will show you how to enable or disable search indexing for all users in Windows 10 and Windows 11.

Indexing the content of your PC helps you get faster results when your searching it for files, emails, or other local content.

The search index only includes your selected locations by default. These locations can be filtered for what file types (extensions), file properties, and file contents you want indexed.

You can choose to use Classic or Enhanced search indexing mode for where your PC will search for files.

The index uses the Windows Search service and runs as the Searchindexer.exe process in the background. The index will automatically rebuild and update for changes made to the included locations since the last index rebuild to increase search result accuracy.

By default, the search indexer backoff feature will reduce indexing speed while rebuilding the index when there is user activity, and will automatically continue at full speed when no user activity is detected.

Reference:

If you prefer to search without using the index, then you could completely disable search indexing. If you disable search indexing, searches will take longer to finish, but search results will always be up to date and accurate.

If you do a lot of file content searching, then you may not want to disable search indexing since it will take a lot longer to search file contents without the index.


You must be signed in as an administrator to enable or disable search indexing.



Contents

  • Option One: Enable Search Indexing in Services Console
  • Option Two: Disable Search Indexing in Services Console
  • Option Three: Enable or Disable Search Indexing in Command Prompt


EXAMPLE: Search indexing disabled

Indexing_Settings.png

Windows_Search.jpg
Indexing_Options.png

Libraries.png






OPTION ONE

Enable Search Indexing in Services Console


This is the default setting.


1 Open Services (services.msc).

2 Double click/tap on the Windows Search service to open its properties page. (see screenshot below)

Enable_search_indexing_in_Services-1.png

3 Select Automatic (Delayed Start) in the Startup type drop menu, and click/tap on Apply. (see screenshot below)

Enable_search_indexing_in_Services-2.png

4 Click/tap on Start. (see screenshot below)

Enable_search_indexing_in_Services-3.png

5 When "Servicing status" shows as Running, click/tap on OK. (see screenshot below)

Enable_search_indexing_in_Services-4.png





OPTION TWO

Disable Search Indexing in Services Console


1 Open Services (services.msc).

2 Double click/tap on the Windows Search service to open its properties page. (see screenshot below)

Disable_search_indexing_in_Services-1.png

3 Select Disabled in the Startup type drop menu, and click/tap on Apply. (see screenshot below)

Disable_search_indexing_in_Services-2.png

4 Click/tap on Stop. (see screenshot below)

Disable_search_indexing_in_Services-3.png

5 When "Servicing status" shows as Stopped, click/tap on OK. (see screenshot below)

Disable_search_indexing_in_Services-4.png





OPTION THREE

Enable or Disable Search Indexing in Command Prompt


1 Open Windows Terminal (Admin), and select Command Prompt.

2 Do step 3 (enable) or step 4 (disable) below for what you want.


3 Enable Search Indexing

This is the default setting.


A) Copy and paste the command below into the elevated command prompt, press Enter, and go to step 5 below. (see screenshot below)​

sc config "wsearch" start=delayed-auto && sc start "wsearch"

Enable_search_indexing_command.png


4 Disable Search Indexing

A) Copy and paste the command below into the elevated command prompt, press Enter, and go to step 5 below. (see screenshot below)​

sc stop "wsearch" && sc config "wsearch" start=disabled

Disable_search_indexing_command.png

5 You can now close Windows Terminal (Admin) if you like.


That's it,
Shawn Brink


 

Attachments

  • Search_Index_Locations.png
    Search_Index_Locations.png
    2.6 KB · Views: 4
Last edited:
Great, thanks! This is one of the first things I do after installing Windows (as well as after some updates that insist on restarting all those pesky services that I don't need).
 

My Computer

System One

  • OS
    Windows 10
    Computer type
    PC/Desktop
    CPU
    i5-10600K
    Motherboard
    Asus Rog Strix Z490-A Gaming
    Memory
    16 GB
    Graphics Card(s)
    GeForce GTX 1650
    Monitor(s) Displays
    Samsung U32J59x 32" 4K
    Screen Resolution
    3840x2160
I was always (probably erroneously) under the impression that indexing didn't help all that much if you have SSDs. So, I shut off indexing. Is there much benefit to using indexing with a SSD, or was I misled by a tall tale?

Also, will indexing won't degrade your SSD faster?

EDIT: You can see this page, #5, for why I think indexing will degrade your SSD quicker because of the writing it's doing to it:

EDIT 2: Well, here's an opinion on not disabling indexing:
  • Disable Indexing or the Windows Search Service: Some guides say you should disable search indexing–a feature that makes search work faster. They claim that, with an SSD, search is already fast enough. But this isn’t really true. Indexing builds a list of the files on your drive and looks inside your documents so you can perform instant full-text search. With indexing enabled, you can search and almost instantly find any file on your PC. With indexing disabled, Windows will have to crawl your entire drive and look inside files–that still takes some time and CPU resources. People argue Indexing is bad because Windows writes to the drive when it creates an index, but once again, that isn’t a concern.
 
Last edited:

My Computers

System One System Two

  • OS
    Windows 11 Pro Beta
    Computer type
    PC/Desktop
    Manufacturer/Model
    Home built
    CPU
    Ryzen 9 5900X
    Motherboard
    MSI MPG X570S Edge Max WiFi
    Memory
    Patriot Viper Gaming DDR4 Extreme Performance (2 x32MB)
    Graphics Card(s)
    ZOTAC RTX 3060 Twin Edge OC 12GB GDDR6/ ZOTAC Gaming GeForce GTX 1660 Super 6GB GDDR6 192-bit Gaming Graphics Card
    Sound Card
    Proprietary
    Monitor(s) Displays
    ViewSonic XG2530 25"/Benq XL2411P 24"/ ASUS VA24DQSB) 23.8"
    Screen Resolution
    1920x1080 240Hz/144Hz/60Hz (based on monitor setup above)
    Hard Drives
    SK hynix Gold P31 1TB PCIe NVMe Gen3 M.2 2280 Internal SSD
    ADATA XPG SX8200 Pro 1TB
    Samsung SSD 860 EVO 1TB 2.5 Inch SATA III Internal SSD
    PSU
    Thermaltake Smart 700W 80+ White Certified PSU
    Case
    Rosewill ATX Mid Tower Gaming Computer Case, Gaming Case with Blue LED for Desktop
    Cooling
    Corsair iCUE H60i RGB PRO XT Liquid CPU Cooler
    Keyboard
    Corsair K70
    Mouse
    Logitech MX Master 3
    Internet Speed
    ~950Mb/s upload/ ~700Mb/s download
    Browser
    Edge (Chromium)
    Antivirus
    Norton 360
  • Operating System
    Windows 11 Pro
    Computer type
    PC/Desktop
    Manufacturer/Model
    Home Built
    CPU
    Ryzen 7 3700X
    Motherboard
    MSI B550 Gaming GEN3 Gaming Motherboard
    Memory
    32MB DDR4
    Graphics card(s)
    I forget, but it's old. I can't see the need to upgrade it.
    Sound Card
    Propietary
    Monitor(s) Displays
    ACER LED 24"
    Screen Resolution
    1920X1080
    Hard Drives
    1TB Samsung SSD 3.5"
    Case
    Corsair
    Cooling
    Stock
    Mouse
    Logitech
    Keyboard
    Logitech
    Internet Speed
    ~750Mb/s download / ~750Mb/s upload
    Browser
    Edge
    Antivirus
    Defender and Malware Bytes
@jvickers The key words in the second edit are "instant full-text search". I don't know much about degrading SSDs - I certainly change them faster than they degrade :wink: - but what I know about search is that it's mostly useful for going through text files, just like the old-days grep. While I do have some text files on my computer (LaTeX files are basically plain text, for example), very few of them are *.txt and so I'm not sure search can look into them (not that I need that). On the other hand I have lots of pdfs, various Office files, photos, etc. I don't think Search can look inside Excel files or inside pdfs, definitely not the non-OCRed ones. If I am looking for a photo, how would the search even begin to look for some image of which I have only a vague recollection (try searching for an image of a yellow tree on a riverbank)? All that makes search useless to me, that's why I disable it.
 

My Computer

System One

  • OS
    Windows 10
    Computer type
    PC/Desktop
    CPU
    i5-10600K
    Motherboard
    Asus Rog Strix Z490-A Gaming
    Memory
    16 GB
    Graphics Card(s)
    GeForce GTX 1650
    Monitor(s) Displays
    Samsung U32J59x 32" 4K
    Screen Resolution
    3840x2160
I never disabled it, and it is actually up and running, but for some reason Win 11 23H2 reports in Start search is disabled (???):

1700334322537.png


I tried to delete and re-generate index, but notification didn't go away... ???
"Windows Search" service is enabled and set to delayed automatic start. I restarted it but notification is still there.
I'm on AC, not on battery mode.
As far as I can see Search (and everything else) is working fine, so I have no idea why the notification is stuck there and how to remove it.
 
Last edited:

My Computer

System One

  • OS
    Windows 11 PRO
    Computer type
    Laptop
    Manufacturer/Model
    ASUS GL703GS
    CPU
    Intel Core i7-8750H
    Memory
    32GB DDR4 2666MHz
    Graphics Card(s)
    NVidia GTX 1070 8GB
    Sound Card
    Realtek ALC295
    Monitor(s) Displays
    AUO B173HAN03.2 G-Sync, XiaoMi Mi 34" FreeSync Premium
    Screen Resolution
    1920x1080@144Hz (internal), 3440x1440@144Hz (external)
    Hard Drives
    m.2 Samsung PM961 512MB, Crucial MX300 SSD 1TB
    PSU
    230W
    Mouse
    ROG Strix Carry Wireless-BT mouse
    Other Info
    4K UHD USB Archgon Star Blu-Ray 4K UHD,
    Hori Fighting Stick Mini,
    XBox One Bluetooth controller
I never disabled it, and it is actually up and running, but for some reason Win 11 23H2 reports in Start search is disabled (???):

I tried to delete and re-generate index, but notification didn't go away... ???
"Windows Search" service is enabled and set to delayed automatic start. I restarted it but notification is still there.
I'm on AC, not on battery mode.

The Search Index itself would be unrelated to Windows Search other than it searching from the index (enabled) instead of directly searching (disabled).

You might see if Windows Search on Start may have been disabled using this below instead.

 

My Computers

System One System Two

  • OS
    Windows 11 Pro for Workstations
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom self build
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    64 GB (4x16GB) G.SKILL TridentZ RGB DDR4 3600 MHz (F4-3600C18D-32GTZR)
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING (11GB GDDR5X)
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G75 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 990 PRO M.2,
    4TB Samsung 990 PRO M.2,
    8TB WD MyCloudEX2Ultra NAS
    PSU
    Seasonic Prime Titanium 850W
    Case
    Thermaltake Core P3 wall mounted
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master 3
    Internet Speed
    1 Gbps Download and 35 Mbps Upload
    Browser
    Google Chrome
    Antivirus
    Microsoft Defender and Malwarebytes Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Galaxy S23 Plus phone
  • Operating System
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    HP Spectre x360 2in1 14-eu0098nr (2024)
    CPU
    Intel Core Ultra 7 155H 4.8 GHz
    Memory
    16 GB LPDDR5x-7467 MHz
    Graphics card(s)
    Integrated Intel Arc
    Sound Card
    Poly Studio
    Monitor(s) Displays
    14" 2.8K OLED multitouch
    Screen Resolution
    2880 x 1800
    Hard Drives
    2 TB PCIe NVMe M.2 SSD
    Internet Speed
    Intel Wi-Fi 7 BE200 (2x2) and Bluetooth 5.4
    Browser
    Chrome and Edge
    Antivirus
    Windows Defender and Malwarebytes Premium
Thanks for reply Brink. Windows Search on Start is enabled, as you can see also at the bottom of the pic above... Tried to disable and enable it again but the notification is always there... :think:
 

My Computer

System One

  • OS
    Windows 11 PRO
    Computer type
    Laptop
    Manufacturer/Model
    ASUS GL703GS
    CPU
    Intel Core i7-8750H
    Memory
    32GB DDR4 2666MHz
    Graphics Card(s)
    NVidia GTX 1070 8GB
    Sound Card
    Realtek ALC295
    Monitor(s) Displays
    AUO B173HAN03.2 G-Sync, XiaoMi Mi 34" FreeSync Premium
    Screen Resolution
    1920x1080@144Hz (internal), 3440x1440@144Hz (external)
    Hard Drives
    m.2 Samsung PM961 512MB, Crucial MX300 SSD 1TB
    PSU
    230W
    Mouse
    ROG Strix Carry Wireless-BT mouse
    Other Info
    4K UHD USB Archgon Star Blu-Ray 4K UHD,
    Hori Fighting Stick Mini,
    XBox One Bluetooth controller
Thanks for reply Brink. Windows Search on Start is enabled, as you can see also at the bottom of the pic above... Tried to disable and enable it again but the notification is always there... :think:
In that case, you could see if using option three below to reset and rebuild the search index may refresh it to work in Windows Search on Start.

 

My Computers

System One System Two

  • OS
    Windows 11 Pro for Workstations
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom self build
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    64 GB (4x16GB) G.SKILL TridentZ RGB DDR4 3600 MHz (F4-3600C18D-32GTZR)
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING (11GB GDDR5X)
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G75 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 990 PRO M.2,
    4TB Samsung 990 PRO M.2,
    8TB WD MyCloudEX2Ultra NAS
    PSU
    Seasonic Prime Titanium 850W
    Case
    Thermaltake Core P3 wall mounted
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master 3
    Internet Speed
    1 Gbps Download and 35 Mbps Upload
    Browser
    Google Chrome
    Antivirus
    Microsoft Defender and Malwarebytes Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Galaxy S23 Plus phone
  • Operating System
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    HP Spectre x360 2in1 14-eu0098nr (2024)
    CPU
    Intel Core Ultra 7 155H 4.8 GHz
    Memory
    16 GB LPDDR5x-7467 MHz
    Graphics card(s)
    Integrated Intel Arc
    Sound Card
    Poly Studio
    Monitor(s) Displays
    14" 2.8K OLED multitouch
    Screen Resolution
    2880 x 1800
    Hard Drives
    2 TB PCIe NVMe M.2 SSD
    Internet Speed
    Intel Wi-Fi 7 BE200 (2x2) and Bluetooth 5.4
    Browser
    Chrome and Edge
    Antivirus
    Windows Defender and Malwarebytes Premium
It just got fixed by itself... last action I did was opening this panel and disable/enable this new (?) option for power saving while indexing (above "Find my files"):

1700337618681.png


... or maybe it got fixed because I (re)started the indexing process as I mentioned before.
 

My Computer

System One

  • OS
    Windows 11 PRO
    Computer type
    Laptop
    Manufacturer/Model
    ASUS GL703GS
    CPU
    Intel Core i7-8750H
    Memory
    32GB DDR4 2666MHz
    Graphics Card(s)
    NVidia GTX 1070 8GB
    Sound Card
    Realtek ALC295
    Monitor(s) Displays
    AUO B173HAN03.2 G-Sync, XiaoMi Mi 34" FreeSync Premium
    Screen Resolution
    1920x1080@144Hz (internal), 3440x1440@144Hz (external)
    Hard Drives
    m.2 Samsung PM961 512MB, Crucial MX300 SSD 1TB
    PSU
    230W
    Mouse
    ROG Strix Carry Wireless-BT mouse
    Other Info
    4K UHD USB Archgon Star Blu-Ray 4K UHD,
    Hori Fighting Stick Mini,
    XBox One Bluetooth controller
It just got fixed by itself... last action I did was opening this panel and disable/enable this new (?) option for power saving while indexing (above "Find my files")

... or maybe it got fixed because I (re)started the indexing process as I mentioned before.

Great news. Respect power settings when indexing is turned on by default, so you may have just been in a power saving mode when indexing on Start was disabled.

 

My Computers

System One System Two

  • OS
    Windows 11 Pro for Workstations
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom self build
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    64 GB (4x16GB) G.SKILL TridentZ RGB DDR4 3600 MHz (F4-3600C18D-32GTZR)
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING (11GB GDDR5X)
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G75 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 990 PRO M.2,
    4TB Samsung 990 PRO M.2,
    8TB WD MyCloudEX2Ultra NAS
    PSU
    Seasonic Prime Titanium 850W
    Case
    Thermaltake Core P3 wall mounted
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master 3
    Internet Speed
    1 Gbps Download and 35 Mbps Upload
    Browser
    Google Chrome
    Antivirus
    Microsoft Defender and Malwarebytes Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Galaxy S23 Plus phone
  • Operating System
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    HP Spectre x360 2in1 14-eu0098nr (2024)
    CPU
    Intel Core Ultra 7 155H 4.8 GHz
    Memory
    16 GB LPDDR5x-7467 MHz
    Graphics card(s)
    Integrated Intel Arc
    Sound Card
    Poly Studio
    Monitor(s) Displays
    14" 2.8K OLED multitouch
    Screen Resolution
    2880 x 1800
    Hard Drives
    2 TB PCIe NVMe M.2 SSD
    Internet Speed
    Intel Wi-Fi 7 BE200 (2x2) and Bluetooth 5.4
    Browser
    Chrome and Edge
    Antivirus
    Windows Defender and Malwarebytes Premium
Great news. Respect power settings when indexing is turned on by default, so you may have just been in a power saving mode when indexing on Start was disabled.
Yes maybe Windows was confused because I switched to battery for a while and then back to AC (I expected it to resume normal behaviour). Next time I'll pay more attention to this and see if happens again.

EDIT: today (2 days later) I did the same actions but wasn't able to reproduce it anymore and everything worked as expected this time.
 
Last edited:

My Computer

System One

  • OS
    Windows 11 PRO
    Computer type
    Laptop
    Manufacturer/Model
    ASUS GL703GS
    CPU
    Intel Core i7-8750H
    Memory
    32GB DDR4 2666MHz
    Graphics Card(s)
    NVidia GTX 1070 8GB
    Sound Card
    Realtek ALC295
    Monitor(s) Displays
    AUO B173HAN03.2 G-Sync, XiaoMi Mi 34" FreeSync Premium
    Screen Resolution
    1920x1080@144Hz (internal), 3440x1440@144Hz (external)
    Hard Drives
    m.2 Samsung PM961 512MB, Crucial MX300 SSD 1TB
    PSU
    230W
    Mouse
    ROG Strix Carry Wireless-BT mouse
    Other Info
    4K UHD USB Archgon Star Blu-Ray 4K UHD,
    Hori Fighting Stick Mini,
    XBox One Bluetooth controller

Latest Support Threads

Latest Tutorials

Back
Top Bottom