Entering Credentials for Router Attached Storage


gfd

New member
Local time
10:11 PM
Posts
4
OS
Windows
Greetings,

I have attached an SSD to my router (Asus RT-AX82U with latest Asus firmware-not Merlin). I am using fully patched Windows 11. I am setting up to access the storage from the LAN and remotely.

I originally set up the storage with aiDisk. However I that program setup an FTP host which is no longer supported in the major browsers. I then setup aiCloud and was able to remotely access the storage using HTTPS.

The issue is the LAN. I accessed the storage from the LAN by entering \\192.168.xx.x. I was asked for a user name and password. I entered the credentials and was able to access the drive. I then closed/reopened File Explorer and entered the address for the drive. I was granted access to the drive without having to enter credentials. After restarting Windows, I was required to enter credentials; but after the first prompt, I once again didn't have to. That is not the behaviour I am looking for.

I opened Group Policy and changed cached credentials from 10 to 0 and I enabled requiring password to access network. Neither of those changes worked.

As noted above, I 'want' to be required to enter credentials each time I want to access the drive. Any help in making this so would be most appreciated.

Thanks,
Graham
 

My Computer

System One

  • OS
    Windows

glasskuter

Well-known member
Power User
VIP
Local time
11:11 PM
Posts
1,849
Location
The Lone Star State of Texas
OS
Windows 11 Pro 21H2 22000.778
Look in the settings of your router. My TP Link Archer has an option of 'enable authentication' in the usb storage device settings within its interface. I had to dig into the user manual for the Archer to figure this out.
Sharing using this drive is a little different than sharing the drive when it is attached to your computer. When accessing a drive attached to your router, it uses the sharing options set up within your router, rather than any sharing options set within your computer.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 21H2 22000.778
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900
    Memory
    32 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 m.2 2230-256+1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 21H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    standard
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Antivirus
    Defender+MWB Premium

marodor50

Member
Local time
12:11 AM
Posts
1
OS
Windows 11
Greetings,

I have attached an SSD to my router (Asus RT-AX82U with latest Asus firmware-not Merlin). I am using fully patched Windows 11. I am setting up to access the storage from the LAN and remotely.

I originally set up the storage with aiDisk. However I that program setup an FTP host which is no longer supported in the major browsers. I then setup aiCloud and was able to remotely access the storage using HTTPS.

The issue is the LAN. I accessed the storage from the LAN by entering \\192.168.xx.x. I was asked for a user name and password. I entered the credentials and was able to access the drive. I then closed/reopened File Explorer and entered the address for the drive. I was granted access to the drive without having to enter credentials. After restarting Windows, I was required to enter credentials; but after the first prompt, I once again didn't have to. That is not the behaviour I am looking for.

I opened Group Policy and changed cached credentials from 10 to 0 and I enabled requiring password to access network. Neither of those changes worked.

As noted above, I 'want' to be required to enter credentials each time I want to access the drive. Any help in making this so would be most appreciated.

Thanks,
Graham
I also use Rmerlin firmware on an AC86.
Try this:
Enter the router then go to the section "USB Application ---Network Place (Samba) Share / Cloud Disk -set Allow guest login to On
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    i7-9700K
    Motherboard
    Asus Z390-Gaming pro
    Memory
    32G
    Graphics Card(s)
    GTX2070
  • Like
Reactions: gfd

Archigos

Well-known member
Power User
Local time
12:11 AM
Posts
373
Location
Upstate New York
OS
Windows 11 Pro β
Doesn't turning on Guest Mode do the opposite of what the original post wanted? They want it to demand user/pass EVERY time someone accesses the drive.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro β
    Computer type
    Laptop
    Manufacturer/Model
    HP Pavilion Laptop 15-eg0070wm
    CPU
    Intel® Core™ i7-1165G7
    Memory
    16 GB DDR4-3200 SDRAM
    Graphics Card(s)
    Intel® Iris® Xᵉ Graphics
    Screen Resolution
    1920x1080
    Hard Drives
    512 GB PCIe® NVMe™ M.2 SSD
  • Operating System
    macOS Big Sur
    Computer type
    PC/Desktop
    Manufacturer/Model
    Apple iMac 27" 5K (2017)
    CPU
    3.4 GHz Quad-Core Intel Core i5
    Memory
    40 GB 2400 MHz DDR4
    Graphics card(s)
    Radeon Pro 570 4 GB
    Monitor(s) Displays
    27" 5K, 34" UW
    Screen Resolution
    Mon 1: 5120 × 2880 Mon 2: 2560 x 1080
    Hard Drives
    32GB NVME, 1TB SSD
  • Like
Reactions: gfd

gfd

New member
Thread Starter
Local time
10:11 PM
Posts
4
OS
Windows
Thanks for the replies. Yeah, I am looking to have credentials demanded every time I want to access the drive. Guest access is straight in.
 

My Computer

System One

  • OS
    Windows

glasskuter

Well-known member
Power User
VIP
Local time
11:11 PM
Posts
1,849
Location
The Lone Star State of Texas
OS
Windows 11 Pro 21H2 22000.778
In the documentation for my Archer it states "Note: do not set the sharing username the same as Windows username. Otherwise windows credential mechanism may cause the following problems: Authentication will not work because Windows will automatically use its account information for usb access. If the sharing password is different from the windows password, Windows will not remember your credentials and you will always be required to enter the sharing password for usb access,"
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 21H2 22000.778
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900
    Memory
    32 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 m.2 2230-256+1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 21H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    standard
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Antivirus
    Defender+MWB Premium
  • Like
Reactions: gfd

gfd

New member
Thread Starter
Local time
10:11 PM
Posts
4
OS
Windows
Thanks glass,

Maybe I picked you up wrong, but the username and password for access to the disk are the username and password for the router. With Asus that's automatic. I can setup another account and see what that does. My Windows user and password are different. I use the Microsoft account to log into Windows.

Graham
 

My Computer

System One

  • OS
    Windows

gfd

New member
Thread Starter
Local time
10:11 PM
Posts
4
OS
Windows
Thanks everyone. I came up with an alternate solution. I created 2 batch files. One used 'net use' to map the network share as z: - The second one used 'net use' with an asterisk and y to delete the mapped drive. After deleting the share, I entered \\192.168.xx.x into the address bar of Windows Explorer, and I was asked for credentials. Will keep fingers crossed.
 

My Computer

System One

  • OS
    Windows
Top Bottom