Google Assistant on WSA


mapomme1108

Member
Local time
9:24 AM
Posts
1
OS
Windows 11 Pro
Hello,

I have installed Windows Subsystem for Android with Google Play on Windows 11 Pro.

I want to use Google Assistant and I have installed it but when I run it there is this message

Code:
Update the Google app to use Assistant
Update the Google app on the Play Store to take advantage of the latest improvements to the Google Assistant

I have installed Google app but there is still the same message

What can I do?
 
Windows Build/Version
Windows 11 Pro 21H2 22000.675

My Computer

System One

  • OS
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    Lenovo ThinkPad X1 Yoga G3 (20LD002HFR)
    CPU
    Intel Core i5 8250U
    Memory
    8 Go
    Graphics Card(s)
    Intel UHD Graphics 620
    Sound Card
    Realtek High Definition Audio
    Screen Resolution
    2560x1440
    Hard Drives
    M.2 SSD NVMe 1To
    Mouse
    Logitech G403
    Browser
    Chrome
    Antivirus
    None

satishgr

Member
Local time
1:54 PM
Posts
69
OS
Windows 11
Hello,

I have installed Windows Subsystem for Android with Google Play on Windows 11 Pro.

I want to use Google Assistant and I have installed it but when I run it there is this message

Code:
Update the Google app to use Assistant
Update the Google app on the Play Store to take advantage of the latest improvements to the Google Assistant

I have installed Google app but there is still the same message

What can I do?
Hi @mapomme1108
Could you guide me through or help me in getting google play installed onto my system.

My system strucks at this screen.

1662355828257.png
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop

pokeefe0001

Active member
Local time
12:24 AM
Posts
122
Location
Pacific Northwest USA
OS
Windows 11
Hi @mapomme1108
Could you guide me through or help me in getting google play installed onto my system
Anything I say here is definitely "The blind leading the blind", but I'll going the conversation.
I managed to get Google Play in WSA. It wasn't a matter of installing it; it was building a a modified version of WSA containing Googl Play instead instead of the Amazon store ... and in the end, Google Play didn't work so I also need help.

There are several descriptions of the build process on the web, but the clearest I've found was on GitHub here.
Another technique is here.
I had more luck - success on 2nd try - with the GitHub instructions.
Ignore any instructions that mention MagiskOnWSA. That installed malware and was pulled from GitHub.

I was successful in getting Google Play to start, but the first 2 times I tried bringing it up it hung trying to get a WiFi connection. I have not been able to find a description of network interface(s) presented to the Android VM by WSA, but I assume it includes something that looks to Android like a WiFi interface and Android didn't like what it saw (if it saw anything).

My 3rd attempt was worse. Google Play displayed an error message saying "This device isn't Play Protect certified" and "Google apps and services can't run on this device via Windows Subsystem for Android". As near as I can tell, that's a show-stopper if there's no way to turn off Play Protect. I'm sure there must be some way to get around this since Google Play works fine running on the Android-x86 emulator (eith running on bare metal or running in Windows under Oracle's VirtualBox, but I have no idea how to achieve that in WSA.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Microsoft
    CPU
    Intel Core i5-8400
    Motherboard
    ASUS PRIME H370-PLUS
    Memory
    16GB
    Graphics Card(s)
    Intel UHD Graphics 630
    Sound Card
    On board
    Monitor(s) Displays
    Samsung SyncMaster 2043BWX
    Screen Resolution
    1680 x 1050
    Hard Drives
    Samsung SSD 850 256GB
    WDC 1TB NVMe
    WD 3TB external USB drive
    PSU
    I don't remember
    Case
    Fractal Design R4
    Cooling
    Air CPU + 2 case fans
    Keyboard
    DAS S Pro (Cherry Brown)
    Mouse
    Logitech USB of some sort

satishgr

Member
Local time
1:54 PM
Posts
69
OS
Windows 11
Anything I say here is definitely "The blind leading the blind", but I'll going the conversation.
I managed to get Google Play in WSA. It wasn't a matter of installing it; it was building a a modified version of WSA containing Googl Play instead instead of the Amazon store ... and in the end, Google Play didn't work so I also need help.

There are several descriptions of the build process on the web, but the clearest I've found was on GitHub here.
Another technique is here.
I had more luck - success on 2nd try - with the GitHub instructions.
Ignore any instructions that mention MagiskOnWSA. That installed malware and was pulled from GitHub.

I was successful in getting Google Play to start, but the first 2 times I tried bringing it up it hung trying to get a WiFi connection. I have not been able to find a description of network interface(s) presented to the Android VM by WSA, but I assume it includes something that looks to Android like a WiFi interface and Android didn't like what it saw (if it saw anything).

My 3rd attempt was worse. Google Play displayed an error message saying "This device isn't Play Protect certified" and "Google apps and services can't run on this device via Windows Subsystem for Android". As near as I can tell, that's a show-stopper if there's no way to turn off Play Protect. I'm sure there must be some way to get around this since Google Play works fine running on the Android-x86 emulator (eith running on bare metal or running in Windows under Oracle's VirtualBox, but I have no idea how to achieve that in WSA.
Hello @pokeefe0001

Thank you so much for your reply, infact, I did try all these but no success.

not sure, where am I missing the steps.......
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop

pokeefe0001

Active member
Local time
12:24 AM
Posts
122
Location
Pacific Northwest USA
OS
Windows 11
Just out of curiosity, what was your "no success"? The GitHub instructions never mention how to actually access / communicate with the Android VM. Sometimes I get to it by selecting File in the WSA Settings display; other times not. I didn't see that the GitHub recipe mentions the Android Debugging Bridge. The other techniques seem to imply it's the method of communicating with Android (without saying exactly how to use it.)

When I tried the technique from appuals.com I couldn't get ADB to get a connection with Android - no listening process on the Android side, I think. As near as I can tell, the ADB is just on the Windows side and should communicate with something built into Android, but that's a guess. If so, Android wasn't listening.

Update: I tried bringing up the modified WSA again and this time ADB was available. But I got "failed to authenticate" when I tried using it. Just in case I got out of ADB and executed it from an elevated command prompt. This time the "target" machine activelt=y rejected the connection. I never could get back in. (Maybe the old connection was still active. )

I seem to get different errors every time I try this.

Update #2: Play Store is now in my Windows Start list. I clicked on it and up came Google Play! Unfortunately nothing happens when I click in "Sign in".
 
Last edited:

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Microsoft
    CPU
    Intel Core i5-8400
    Motherboard
    ASUS PRIME H370-PLUS
    Memory
    16GB
    Graphics Card(s)
    Intel UHD Graphics 630
    Sound Card
    On board
    Monitor(s) Displays
    Samsung SyncMaster 2043BWX
    Screen Resolution
    1680 x 1050
    Hard Drives
    Samsung SSD 850 256GB
    WDC 1TB NVMe
    WD 3TB external USB drive
    PSU
    I don't remember
    Case
    Fractal Design R4
    Cooling
    Air CPU + 2 case fans
    Keyboard
    DAS S Pro (Cherry Brown)
    Mouse
    Logitech USB of some sort

satishgr

Member
Local time
1:54 PM
Posts
69
OS
Windows 11
Just out of curiosity, what was your "no success"? The GitHub instructions never mention how to actually access / communicate with the Android VM. Sometimes I get to it by selecting File in the WSA Settings display; other times not. I didn't see that the GitHub recipe mentions the Android Debugging Bridge. The other techniques seem to imply it's the method of communicating with Android (without saying exactly how to use it.)

When I tried the technique from appuals.com I couldn't get ADB to get a connection with Android - no listening process on the Android side, I think. As near as I can tell, the ADB is just on the Windows side and should communicate with something built into Android, but that's a guess. If so, Android wasn't listening.

Update: I tried bringing up the modified WSA again and this time ADB was available. But I got "failed to authenticate" when I tried using it. Just in case I got out of ADB and executed it from an elevated command prompt. This time the "target" machine activelt=y rejected the connection. I never could get back in. (Maybe the old connection was still active. )

I seem to get different errors every time I try this.

Update #2: Play Store is now in my Windows Start list. I clicked on it and up came Google Play! Unfortunately nothing happens when I click in "Sign in".
Hi @pokeefe0001 ,
Thanks for your reply. I intend to say that I did follow all the steps in appuals.com portal that you have referred here. I dont see PlayStore at all and WSA not at all loading.

I did try to connect via ADB and I am not able to connect and getting error like "Cannot connect to 127.0.0.1:58526........"
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop

pokeefe0001

Active member
Local time
12:24 AM
Posts
122
Location
Pacific Northwest USA
OS
Windows 11
Hi @pokeefe0001 ,

I did try to connect via ADB and I am not able to connect and getting error like "Cannot connect to 127.0.0.1:58526........"
This seems to be an intermittent thing for me. Look in the Developer section of the WSA Settings display. When ADB connections are allowed it will show
1663780573505.png
(I hope that image shows in the forum posting.)
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Microsoft
    CPU
    Intel Core i5-8400
    Motherboard
    ASUS PRIME H370-PLUS
    Memory
    16GB
    Graphics Card(s)
    Intel UHD Graphics 630
    Sound Card
    On board
    Monitor(s) Displays
    Samsung SyncMaster 2043BWX
    Screen Resolution
    1680 x 1050
    Hard Drives
    Samsung SSD 850 256GB
    WDC 1TB NVMe
    WD 3TB external USB drive
    PSU
    I don't remember
    Case
    Fractal Design R4
    Cooling
    Air CPU + 2 case fans
    Keyboard
    DAS S Pro (Cherry Brown)
    Mouse
    Logitech USB of some sort

satishgr

Member
Local time
1:54 PM
Posts
69
OS
Windows 11
@pokeefe0001,

I did try connect via ADB but still getting error again "Cannot connect to 127.0.0.1:58526........"

1663895260819.png
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop

pokeefe0001

Active member
Local time
12:24 AM
Posts
122
Location
Pacific Northwest USA
OS
Windows 11
That's what happened to me when I used the appuals.com instructions ... and with those instructions (as I understand them) you need ADB to install Google Play. I hope somebody who actually knows about this chimes in and gives advice.

One thing you might try: Start over but use the GitHub instructions. In it you install Google Play by running some GitHub magic stuff under WSL. That eventually got me farther (but not far enough).

Every set of instructions I've seen have some "black box" steps. Great when everything works right, but they left me completely ignorant and in the dark when things didn't work. And since I'm completely ignorant of Android, Linux, and Hiper-V, I need all the help I can get.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Microsoft
    CPU
    Intel Core i5-8400
    Motherboard
    ASUS PRIME H370-PLUS
    Memory
    16GB
    Graphics Card(s)
    Intel UHD Graphics 630
    Sound Card
    On board
    Monitor(s) Displays
    Samsung SyncMaster 2043BWX
    Screen Resolution
    1680 x 1050
    Hard Drives
    Samsung SSD 850 256GB
    WDC 1TB NVMe
    WD 3TB external USB drive
    PSU
    I don't remember
    Case
    Fractal Design R4
    Cooling
    Air CPU + 2 case fans
    Keyboard
    DAS S Pro (Cherry Brown)
    Mouse
    Logitech USB of some sort

johnlgalt

Antidisestablishmentarianist
Power User
VIP
Local time
3:24 AM
Posts
2,660
Location
3rd Rock
OS
Windows 11 21H2 Current build
I will need to abolish WSA on my system, and probably WSL too, and start all over, to see i I can get it working.

In the meantime, regarding the instructions from Appuals:

In the Section

Set up Google Play Store on Windows Subsystem for Android

And at Step 6

Now, open up the Start Menu and search for Command Prompt. Right-click on the result and choose Run as administrator from the drop-down menu.

Try running command without admin privileges and see if it works. When running adb there is actually no need to run as admin, even if you're going to be working with root on the system that you're modifying. And, FWIW, in the past, I've also run into issues when using adb from my system to modify my devices when the cmd window elevated, too, so that reinforces my theory that it may just be that one little problem.

Also, you can actually download the latest platform-tools from Google (Android developer website) directly. Since I have Android devices, I already have it on my system, and I suspect that I'll be using my own instead of the on in that ADBKit that they want everyone to download.


WSA does need to be running, also - think of it as the device needs to be on in order for you to manipulate it, even via adb - can't mess with files when the device is off.

For me, the instructions at the Git repository seem more than sufficient, but if you can tell me which method you'd prefer for me to follow (I'm betting Appuals?) I'll give that particular method a shot.
 

My Computers

System One System Two

  • OS
    Windows 11 21H2 Current build
    Computer type
    PC/Desktop
    Manufacturer/Model
    HomeBrew
    CPU
    AMD Ryzen 9 3950X
    Motherboard
    MSI MEG X570 GODLIKE
    Memory
    4 * 32 GB - Corsair Vengeance 3600 MHz
    Graphics Card(s)
    EVGA GeForce RTX 3080 Ti XC3 ULTRA GAMING (12G-P5-3955-KR)
    Sound Card
    Realtek® ALC1220 Codec
    Monitor(s) Displays
    Eve Spectrum ES07D03 4K Gaming Monitor (Matte finish) | Eve Spectrum ES07DC9 4K Gaming Monitor (Glossy finish)
    Screen Resolution
    4K x2
    Hard Drives
    3x Samsung 980 Pro NVMe PCIe 4 M.2 2 TB SSD (MZ-V8P2T0B/AM)
    PSU
    PC Power & Cooling’s Silencer Series 1050 Watt, 80 Plus Platinum
    Case
    Fractal Design Define 7 XL Dark ATX Full Tower Case
    Cooling
    ZXT KRAKEN Z73 73.11 CFM Liquid CPU Cooler (3x 120 mm push top) + Air 3x 140mm case fans (pull front) + 1x 120 mm (push back) and 1 x 120 mm (pull bottom)
    Keyboard
    SteelSeries Apex Pro Wired Gaming Keyboard
    Mouse
    Logitech MX Master 3S
    Internet Speed
    AT&T LightSpeed Gigabit Duplex Ftth
    Browser
    Nightly (default) + Firefox (stable),Chrome, Edge/ß/Dev/Canary
    Antivirus
    Defender
  • Operating System
    CHromeOS Flex v108 Dev
    Computer type
    Laptop
    Manufacturer/Model
    Dell Latitude E5470
    CPU
    Intel(R) Core(TM) i5-6300U CPU @ 2.40GHz, 2501 Mhz, 2 Core(s), 4 Logical Processor(s)
    Motherboard
    Dell
    Memory
    16 GB
    Graphics card(s)
    Intel(R) HD Graphics 520
    Sound Card
    Intel(R) HD Graphics 520 + RealTek Audio
    Monitor(s) Displays
    Dell laptop display 15"
    Screen Resolution
    1920 * 1080
    Hard Drives
    Toshiba 128GB M.2 22300 drive
    INTEL Cherryvill 520 Series SSDSC2CW180A 180 GB SATA III SSD
    PSU
    Dell
    Case
    Dell
    Cooling
    Dell
    Mouse
    Logitech MX Master 3S (shared w. Sys 1) | Dell TouchPad
    Keyboard
    Dell
    Internet Speed
    AT&T LightSpeed Gigabit Duplex Ftth

pokeefe0001

Active member
Local time
12:24 AM
Posts
122
Location
Pacific Northwest USA
OS
Windows 11
I gave up on the Appuals technique; I never got the ADB connection. "Netstat /a /b" showed some internal connections but no listener on 58526. I was more successful with the GitHub technique (which doesn't need ADB to install Google Play). I actually got Google Play to run in the GitHub build, but could not get past the Google Play signin. No error indication; it just keeps redisplaying the signin display. I suspect there is no network connection, but I don't know for sure.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Microsoft
    CPU
    Intel Core i5-8400
    Motherboard
    ASUS PRIME H370-PLUS
    Memory
    16GB
    Graphics Card(s)
    Intel UHD Graphics 630
    Sound Card
    On board
    Monitor(s) Displays
    Samsung SyncMaster 2043BWX
    Screen Resolution
    1680 x 1050
    Hard Drives
    Samsung SSD 850 256GB
    WDC 1TB NVMe
    WD 3TB external USB drive
    PSU
    I don't remember
    Case
    Fractal Design R4
    Cooling
    Air CPU + 2 case fans
    Keyboard
    DAS S Pro (Cherry Brown)
    Mouse
    Logitech USB of some sort

amitabhr

Member
Local time
1:54 PM
Posts
12
OS
Win 11 Pro 21H2 / Elementary 6 / macOS Big Sur
Use this to get WSA with GA pre-installed:



You can also use this but its more work. Good to read though just so you know whats being done:

In case of confusion search here, i had written 1-2 paragraphs on what menu items to click etc in some thread where someone was asking
 

My Computer

System One

  • OS
    Win 11 Pro 21H2 / Elementary 6 / macOS Big Sur
    Computer type
    Tablet
    Manufacturer/Model
    Thinkpad Yoga 260
    CPU
    Intel Core i7 6500U
    Memory
    8 GB
    Screen Resolution
    1920x1080 Touch+Stylus
    Hard Drives
    LITEON SSD 512 GB
    Internet Speed
    200 Mbps
    Other Info
    4G+GPS Snapdragon X7 LTE-A Sierra EM7455
    Synaptics Fingerprint Scanner WBDI | Wacom Stylus
    Intel AC-8260 WiFi + Bluetooth BLE | USB 3.1
    Realtek webcam & microSD | Connexant Audio
    TPM 2.0 Intel PTT | Secure Boot | UEFI Bios 1.82

satishgr

Member
Local time
1:54 PM
Posts
69
OS
Windows 11
Use this to get WSA with GA pre-installed:



You can also use this but its more work. Good to read though just so you know whats being done:

In case of confusion search here, i had written 1-2 paragraphs on what menu items to click etc in some thread where someone was asking
Hi @amitabhr
Thank you so much for your reply, could you share the instruction link here to install from github/RahulRST.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop

johnlgalt

Antidisestablishmentarianist
Power User
VIP
Local time
3:24 AM
Posts
2,660
Location
3rd Rock
OS
Windows 11 21H2 Current build
I gave up on the Appuals technique; I never got the ADB connection. "Netstat /a /b" showed some internal connections but no listener on 58526. I was more successful with the GitHub technique (which doesn't need ADB to install Google Play). I actually got Google Play to run in the GitHub build, but could not get past the Google Play signin. No error indication; it just keeps redisplaying the signin display. I suspect there is no network connection, but I don't know for sure.

I've tried a few times now. the WSAScript method got me to a Google Play sign in that I could not get past, clicking the button created a very brief amount of activity and then does nothing.

I then tried Magisk method, using OpenGApps Full + Magisk (daily build), which also failed, then I tried using OpenGApps Full + Magisk (25.2), and I was able to get a login attempt, but because I have Advanced Protection enabled, and WSL for Android does not see my computer's USB ports (so I cannot use my physical keys) I tried to load the temporary code using the g.co/sc URL, using the same account. I tried numerous codes, and they failed every single time.

That is where I am at for now. I may blow this away and try again using the OpenGApps pico instead of full, both with Magisk, and later without, but thus far I've gotten no further than you have.

It's stupidly frustrating that Microsoft would enable Android for WSL but then only put the Amazon store on there, which has sucked for Android apps for almost a decade, and will not put GApps in there natively. Absolutely stupid.
 

My Computers

System One System Two

  • OS
    Windows 11 21H2 Current build
    Computer type
    PC/Desktop
    Manufacturer/Model
    HomeBrew
    CPU
    AMD Ryzen 9 3950X
    Motherboard
    MSI MEG X570 GODLIKE
    Memory
    4 * 32 GB - Corsair Vengeance 3600 MHz
    Graphics Card(s)
    EVGA GeForce RTX 3080 Ti XC3 ULTRA GAMING (12G-P5-3955-KR)
    Sound Card
    Realtek® ALC1220 Codec
    Monitor(s) Displays
    Eve Spectrum ES07D03 4K Gaming Monitor (Matte finish) | Eve Spectrum ES07DC9 4K Gaming Monitor (Glossy finish)
    Screen Resolution
    4K x2
    Hard Drives
    3x Samsung 980 Pro NVMe PCIe 4 M.2 2 TB SSD (MZ-V8P2T0B/AM)
    PSU
    PC Power & Cooling’s Silencer Series 1050 Watt, 80 Plus Platinum
    Case
    Fractal Design Define 7 XL Dark ATX Full Tower Case
    Cooling
    ZXT KRAKEN Z73 73.11 CFM Liquid CPU Cooler (3x 120 mm push top) + Air 3x 140mm case fans (pull front) + 1x 120 mm (push back) and 1 x 120 mm (pull bottom)
    Keyboard
    SteelSeries Apex Pro Wired Gaming Keyboard
    Mouse
    Logitech MX Master 3S
    Internet Speed
    AT&T LightSpeed Gigabit Duplex Ftth
    Browser
    Nightly (default) + Firefox (stable),Chrome, Edge/ß/Dev/Canary
    Antivirus
    Defender
  • Operating System
    CHromeOS Flex v108 Dev
    Computer type
    Laptop
    Manufacturer/Model
    Dell Latitude E5470
    CPU
    Intel(R) Core(TM) i5-6300U CPU @ 2.40GHz, 2501 Mhz, 2 Core(s), 4 Logical Processor(s)
    Motherboard
    Dell
    Memory
    16 GB
    Graphics card(s)
    Intel(R) HD Graphics 520
    Sound Card
    Intel(R) HD Graphics 520 + RealTek Audio
    Monitor(s) Displays
    Dell laptop display 15"
    Screen Resolution
    1920 * 1080
    Hard Drives
    Toshiba 128GB M.2 22300 drive
    INTEL Cherryvill 520 Series SSDSC2CW180A 180 GB SATA III SSD
    PSU
    Dell
    Case
    Dell
    Cooling
    Dell
    Mouse
    Logitech MX Master 3S (shared w. Sys 1) | Dell TouchPad
    Keyboard
    Dell
    Internet Speed
    AT&T LightSpeed Gigabit Duplex Ftth

satishgr

Member
Local time
1:54 PM
Posts
69
OS
Windows 11
I've tried a few times now. the WSAScript method got me to a Google Play sign in that I could not get past, clicking the button created a very brief amount of activity and then does nothing.

I then tried Magisk method, using OpenGApps Full + Magisk (daily build), which also failed, then I tried using OpenGApps Full + Magisk (25.2), and I was able to get a login attempt, but because I have Advanced Protection enabled, and WSL for Android does not see my computer's USB ports (so I cannot use my physical keys) I tried to load the temporary code using the g.co/sc URL, using the same account. I tried numerous codes, and they failed every single time.

That is where I am at for now. I may blow this away and try again using the OpenGApps pico instead of full, both with Magisk, and later without, but thus far I've gotten no further than you have.

It's stupidly frustrating that Microsoft would enable Android for WSL but then only put the Amazon store on there, which has sucked for Android apps for almost a decade, and will not put GApps in there natively. Absolutely stupid.
Hi @johnlgalt ,
Thanks for your post, honestly, we are sailing on the same boat.. I really felt disspointed like trying all the way to have the either amazon appstore or google play installed onto my system. I could not succeed.
Screen strucks as below and no movement at all. And unable to connect via ADB Connect command.

1664929180365.png
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop

satishgr

Member
Local time
1:54 PM
Posts
69
OS
Windows 11
Hi All,

with 22H2 update, my system is now loading the subsystem for android and GooglePlay is working fine. And I am able to install the android apps onto my system.

But few of the apps asking for this options. does anyone knows about it.


1665882751911.png
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop

pokeefe0001

Active member
Local time
12:24 AM
Posts
122
Location
Pacific Northwest USA
OS
Windows 11
Well, it looks like those applications need to have two factor authentication enabled. I Googles Google Play and "new exchange regulations". "Exchange" seems to refer to stock exchange, and everything I found with the phrase "new exchange regulations" pointed to National Stock Exchange of India. 2FA makes sense when using financial transaction sites so the message you saw is understandable in that context. It seems a bit odd if you were not using financial apps under WSA.

Which implementation of WSA were you using and what apps were you trying to install?
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Microsoft
    CPU
    Intel Core i5-8400
    Motherboard
    ASUS PRIME H370-PLUS
    Memory
    16GB
    Graphics Card(s)
    Intel UHD Graphics 630
    Sound Card
    On board
    Monitor(s) Displays
    Samsung SyncMaster 2043BWX
    Screen Resolution
    1680 x 1050
    Hard Drives
    Samsung SSD 850 256GB
    WDC 1TB NVMe
    WD 3TB external USB drive
    PSU
    I don't remember
    Case
    Fractal Design R4
    Cooling
    Air CPU + 2 case fans
    Keyboard
    DAS S Pro (Cherry Brown)
    Mouse
    Logitech USB of some sort

satishgr

Member
Local time
1:54 PM
Posts
69
OS
Windows 11
Well, it looks like those applications need to have two factor authentication enabled. I Googles Google Play and "new exchange regulations". "Exchange" seems to refer to stock exchange, and everything I found with the phrase "new exchange regulations" pointed to National Stock Exchange of India. 2FA makes sense when using financial transaction sites so the message you saw is understandable in that context. It seems a bit odd if you were not using financial apps under WSA.

Which implementation of WSA were you using and what apps were you trying to install?
Hi @pokeefe0001

Thank you so much for your reply.

Yes, it is trading app that I am trying to install (app name "Kite" from Zerodha) and National Stock Exchange India.

I am using 2204.40000.19.0 installed along with google play.

Could you guide me through how to enable 2FA for android App in Windows Subsystem for Android.


1665916682807.png1665916627636.png
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop

pokeefe0001

Active member
Local time
12:24 AM
Posts
122
Location
Pacific Northwest USA
OS
Windows 11
I assume setting up the 2FA would be part of Kite, not a more more general setup for all Android apps. The app should walk you through setting up 2FA. It's possible it would require the Google Authenticator app. I assume you can download and install that from Google Play.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Microsoft
    CPU
    Intel Core i5-8400
    Motherboard
    ASUS PRIME H370-PLUS
    Memory
    16GB
    Graphics Card(s)
    Intel UHD Graphics 630
    Sound Card
    On board
    Monitor(s) Displays
    Samsung SyncMaster 2043BWX
    Screen Resolution
    1680 x 1050
    Hard Drives
    Samsung SSD 850 256GB
    WDC 1TB NVMe
    WD 3TB external USB drive
    PSU
    I don't remember
    Case
    Fractal Design R4
    Cooling
    Air CPU + 2 case fans
    Keyboard
    DAS S Pro (Cherry Brown)
    Mouse
    Logitech USB of some sort

satishgr

Member
Local time
1:54 PM
Posts
69
OS
Windows 11
I assume setting up the 2FA would be part of Kite, not a more more general setup for all Android apps. The app should walk you through setting up 2FA. It's possible it would require the Google Authenticator app. I assume you can download and install that from Google Play.
Hi @pokeefe0001,

Thanks for your message. I did install Google authenticator. However Kite is not getting recognized in google authenticator. On my Android mobile, I need to draw the screen unlock pattern to open Kite app. Do we have screen lock / security options in WSA?

The message on app states
" Your device does not seem to have Security enabled..........Please enable device lock in "System Settings", when I click on System settings its taking me on Windows Settings.


1665968580226.png
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop

Latest Support Threads

Top Bottom