Solved How to whitelist Chrome Remote Desktop in Windows Firewall?

TheMystic

Well-known member
Member
VIP
Local time
12:28 PM
Posts
439
I have set Windows Firewall to block all connections by default. Then I have whitelisted a few programs that need internet to work.

With Chrome Remote Desktop, I have whitelisted under Outbound connections all the .exe and .dll files (total 9 of them) in the following location:

%systemdrive%\Program Files (x86)\Google\Chrome Remote Desktop\CurrentVersion\

20211112_121305.png


It was working fine before. Now it is showing me as offline.

If I change the firewall outbound to Allow (default), then it starts working after sometime. But I didn't have to do this before as it would always work.

In addition, I have also whitelisted chrome_proxy.exe under %systemdrive%\Program Files\Google\Chrome\Application\.

This wasn't required earlier when it used to work fine.


I also see that Remote Desktop Host under C:\Program Files (x86)\Google\Chrome Remote Desktop\96.0.4664.39\remoting_host.exe has automatically whitelisted itself under Inbound connections. I am not sure if this was necessary earlier. But it still isn't working and showing me as Offline.

What else must be whitelisted to make Chrome Remote Desktop work keeping Windows Firewall to block all connections by default?

.
 

Attachments

  • 20211112_121305.png
    20211112_121305.png
    2.8 KB · Views: 0
Last edited:

My Computer

System One

  • Operating System
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    HP Envy dv7
    CPU
    Intel Core i7 3630QM
    Motherboard
    HP
    Memory
    16 GB
    Graphics Card(s)
    Intel HD Graphics 4000 & Nvidia GeForce GT 635M
    Sound Card
    IDT High Definition
    Screen Resolution
    1080p
    Hard Drives
    1 TB Crucial MX500 on bay 1.
    1 TB Seagate HDD on bay 2.
    Antivirus
    Windows Defender

TheMystic

Well-known member
Member
VIP
Thread Starter
Local time
12:28 PM
Posts
439
SOLVED.

I replaced 'Current Version' in the path above with the actual version number as follows:

C:\Program Files (x86)\Google\Chrome Remote Desktop\96.0.4664.39\

I think C: can be replaced with %systemdrive% and that should not have any impact.

I am not sure what will happen when Chrome version changes. I kept this in mind when using 'Current Version' in the program path instead of the actual version number because I don't expect the Firewall rules to automatically update when the version number changes. Although I didn't have to make any changes to the firewall rules earlier, I won't be surprised if I have to do that going forward, if Chrome version changes and Remote Desktop stops working.

Here is how the rules look now:

20211112_125527.png

I also blocked and disabled the ones that do not have a green tick above as well as the Incoming rule that it created automatically. Remote Desktop still works.

.
 

My Computer

System One

  • Operating System
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    HP Envy dv7
    CPU
    Intel Core i7 3630QM
    Motherboard
    HP
    Memory
    16 GB
    Graphics Card(s)
    Intel HD Graphics 4000 & Nvidia GeForce GT 635M
    Sound Card
    IDT High Definition
    Screen Resolution
    1080p
    Hard Drives
    1 TB Crucial MX500 on bay 1.
    1 TB Seagate HDD on bay 2.
    Antivirus
    Windows Defender
Top Bottom