I can't connect to Amazon Appstore or launch Android apps


coukou

Active member
Local time
10:22 PM
Posts
26
OS
Windows 11 23H2 Build 22631.3007
Hello,
I can't connect to Amazon Appstore or launch Android apps

I'm using Windows 11 Pro 22H2 Build 22621.2861
Although I installed the latest WindowsSubsystemForAndroid 2311.40000.3.0, when I launch Amazon Appstore, the window opens and then I click client already? Identify yourself the app is trying to connect me. After several minutes, the “Already a customer?” Log in” is redisplayed (See images bellow)
TNX for yr help
 

Attachments

  • Android subsytem +files.jpg
    Android subsytem +files.jpg
    68.2 KB · Views: 4
  • Connect to Amazon.jpg
    Connect to Amazon.jpg
    48.5 KB · Views: 4
  • Fonctionalites Windows modifies.jpg
    Fonctionalites Windows modifies.jpg
    79 KB · Views: 3

My Computer

System One

  • OS
    Windows 11 23H2 Build 22631.3007
    Computer type
    PC/Desktop
    Manufacturer/Model
    HP Worksatation Z1G9
    CPU
    i7 12700
    Motherboard
    HP
    Memory
    16GB
    Graphics Card(s)
    Nvida
    Hard Drives
    SSD 2T
    Browser
    Firefox
    Antivirus
    SEP (Symantec Endpoint Protction)
Hello folks
No one can help ???
What a pity :tears:
 

My Computer

System One

  • OS
    Windows 11 23H2 Build 22631.3007
    Computer type
    PC/Desktop
    Manufacturer/Model
    HP Worksatation Z1G9
    CPU
    i7 12700
    Motherboard
    HP
    Memory
    16GB
    Graphics Card(s)
    Nvida
    Hard Drives
    SSD 2T
    Browser
    Firefox
    Antivirus
    SEP (Symantec Endpoint Protction)
Hello folks
No one can help ???
What a pity :tears:
This is an Amazon log in issue, not a Windows issue.
You'd be better off contacting Amazon.
I had no problem getting to the France Amazon store thru Windows subsystem for Android.
Please try to create a new user, rather than clicking on 'Je suis déjà client(e)'
Have you logged out from your mobile and logged back in? Does it work there?


Screenshot 2024-01-18 170254.jpg
 
Last edited:

My Computers

System One System Two

  • OS
    Win11 All /Debian/Arch
    Computer type
    Laptop
    Manufacturer/Model
    ASUSTeK COMPUTER INC. TUF Gaming FX705GM
    CPU
    2.20 gigahertz Intel i7-8750H Hyper-threaded 12 cores
    Motherboard
    ASUSTeK COMPUTER INC. FX705GM 1.0
    Memory
    24428 Megabytes
    Graphics Card(s)
    Intel(R) UHD Graphics 630 / NVIDIA GeForce GTX 1060
    Sound Card
    Intel(R) Display Audio / Realtek(R) Audio
    Monitor(s) Displays
    Integrated Monitor (17.3"vis)
    Screen Resolution
    FHD 1920X1080 16:9
    Hard Drives
    2 SSD SATA/NVM Express 1.3
    WDS500G2B0A-00SM50 500.1 GB
    WDCSDAPNUW-1002 256 GB
    PSU
    19V DC 6.32 A 120 W
    Cooling
    Dual Fans
    Mouse
    MS Bluetooth
    Internet Speed
    Fiber 1GB Cox -us & ADSL Bouygues -fr
    Browser
    Edge Canary- Firefox Nightly
    Antivirus
    Windows Defender
    Other Info
    VMs of Windows 11 stable/Beta/Dev/Canary
    VM of XeroLinux- Arch based & Debian 12
  • Operating System
    Windows 11 Insider Canary
    Computer type
    Laptop
    Manufacturer/Model
    ASUS X751BP
    CPU
    AMD Dual Core A6-9220
    Motherboard
    ASUS
    Memory
    8 GB
    Graphics card(s)
    AMD Radeon R5 M420
    Sound Card
    Realtek
    Monitor(s) Displays
    17.3
    Screen Resolution
    1600X900 16:9
    Hard Drives
    1TB 5400RPM
Hi,
TNX for yr reply :wink:
I have already contacted Amazon... they have no solution
What is most curious is that it is impossible for me to connect to Amazon (Already Amazon customer) or to Create new Amazon customer. But when I click on “by signing… Terms of use and agree to enable 1-click" I get France Amazon.

My mobile was not logged in (Amazon), I tested to logged in and logged out with no problem

In the meantime, I made a mistake and uninstalled Amazon and Android subsystem. I let you know after Re-installation.

Regards
 

My Computer

System One

  • OS
    Windows 11 23H2 Build 22631.3007
    Computer type
    PC/Desktop
    Manufacturer/Model
    HP Worksatation Z1G9
    CPU
    i7 12700
    Motherboard
    HP
    Memory
    16GB
    Graphics Card(s)
    Nvida
    Hard Drives
    SSD 2T
    Browser
    Firefox
    Antivirus
    SEP (Symantec Endpoint Protction)
  • Like
Reactions: OAT
Hello,
I reinstalled and configured WSA / Amazon Appstore… same problem: when I click on “Already Amazon customer” or “Create new Amazon customer”, a window opens for connection and closes after a few seconds (here video link - 26sec)…

And yet WSA is well configured with (Advanced networking ON) and Virtual Machine Platform feature enabled

I've been dealing with this problem for 2 days. I really appreciate your help
Kind Regards

26sec video: 20240119_122458_2
 

My Computer

System One

  • OS
    Windows 11 23H2 Build 22631.3007
    Computer type
    PC/Desktop
    Manufacturer/Model
    HP Worksatation Z1G9
    CPU
    i7 12700
    Motherboard
    HP
    Memory
    16GB
    Graphics Card(s)
    Nvida
    Hard Drives
    SSD 2T
    Browser
    Firefox
    Antivirus
    SEP (Symantec Endpoint Protction)
I've been dealing with this problem for 2 days. I really appreciate your help
Kind Regards

26sec video: 20240119_122458_2
If you look at your video and freeze it you will a message stating:
Page Web non disponible.

That means that the connection is being prevented, either by a VPN or a security or privacy setting or by your web virus software.
Disable your firewall or open it for that connection, look for an ICS connection being refused.

Screenshot 2024-01-19 145943.png
 
Last edited:

My Computers

System One System Two

  • OS
    Win11 All /Debian/Arch
    Computer type
    Laptop
    Manufacturer/Model
    ASUSTeK COMPUTER INC. TUF Gaming FX705GM
    CPU
    2.20 gigahertz Intel i7-8750H Hyper-threaded 12 cores
    Motherboard
    ASUSTeK COMPUTER INC. FX705GM 1.0
    Memory
    24428 Megabytes
    Graphics Card(s)
    Intel(R) UHD Graphics 630 / NVIDIA GeForce GTX 1060
    Sound Card
    Intel(R) Display Audio / Realtek(R) Audio
    Monitor(s) Displays
    Integrated Monitor (17.3"vis)
    Screen Resolution
    FHD 1920X1080 16:9
    Hard Drives
    2 SSD SATA/NVM Express 1.3
    WDS500G2B0A-00SM50 500.1 GB
    WDCSDAPNUW-1002 256 GB
    PSU
    19V DC 6.32 A 120 W
    Cooling
    Dual Fans
    Mouse
    MS Bluetooth
    Internet Speed
    Fiber 1GB Cox -us & ADSL Bouygues -fr
    Browser
    Edge Canary- Firefox Nightly
    Antivirus
    Windows Defender
    Other Info
    VMs of Windows 11 stable/Beta/Dev/Canary
    VM of XeroLinux- Arch based & Debian 12
  • Operating System
    Windows 11 Insider Canary
    Computer type
    Laptop
    Manufacturer/Model
    ASUS X751BP
    CPU
    AMD Dual Core A6-9220
    Motherboard
    ASUS
    Memory
    8 GB
    Graphics card(s)
    AMD Radeon R5 M420
    Sound Card
    Realtek
    Monitor(s) Displays
    17.3
    Screen Resolution
    1600X900 16:9
    Hard Drives
    1TB 5400RPM
TNX again OAT :wink:

You must be right...I don't have a connection.
I disabled the VPN and the Firewall... still no connection.
Should I check Ethernet Property/Network Management/Hyper-V Extensible Virtual Listener?

To tell the truth, I'm not a network expert. If you can guide me it would be helpful.

Sorry, I have to go out for the WE
Kind Regards
 

My Computer

System One

  • OS
    Windows 11 23H2 Build 22631.3007
    Computer type
    PC/Desktop
    Manufacturer/Model
    HP Worksatation Z1G9
    CPU
    i7 12700
    Motherboard
    HP
    Memory
    16GB
    Graphics Card(s)
    Nvida
    Hard Drives
    SSD 2T
    Browser
    Firefox
    Antivirus
    SEP (Symantec Endpoint Protction)
To tell the truth, I'm not a network expert. If you can guide me it would be helpful.
Sorry, I have to go out for the WE
By all means, don't let me stop you.
 

My Computers

System One System Two

  • OS
    Win11 All /Debian/Arch
    Computer type
    Laptop
    Manufacturer/Model
    ASUSTeK COMPUTER INC. TUF Gaming FX705GM
    CPU
    2.20 gigahertz Intel i7-8750H Hyper-threaded 12 cores
    Motherboard
    ASUSTeK COMPUTER INC. FX705GM 1.0
    Memory
    24428 Megabytes
    Graphics Card(s)
    Intel(R) UHD Graphics 630 / NVIDIA GeForce GTX 1060
    Sound Card
    Intel(R) Display Audio / Realtek(R) Audio
    Monitor(s) Displays
    Integrated Monitor (17.3"vis)
    Screen Resolution
    FHD 1920X1080 16:9
    Hard Drives
    2 SSD SATA/NVM Express 1.3
    WDS500G2B0A-00SM50 500.1 GB
    WDCSDAPNUW-1002 256 GB
    PSU
    19V DC 6.32 A 120 W
    Cooling
    Dual Fans
    Mouse
    MS Bluetooth
    Internet Speed
    Fiber 1GB Cox -us & ADSL Bouygues -fr
    Browser
    Edge Canary- Firefox Nightly
    Antivirus
    Windows Defender
    Other Info
    VMs of Windows 11 stable/Beta/Dev/Canary
    VM of XeroLinux- Arch based & Debian 12
  • Operating System
    Windows 11 Insider Canary
    Computer type
    Laptop
    Manufacturer/Model
    ASUS X751BP
    CPU
    AMD Dual Core A6-9220
    Motherboard
    ASUS
    Memory
    8 GB
    Graphics card(s)
    AMD Radeon R5 M420
    Sound Card
    Realtek
    Monitor(s) Displays
    17.3
    Screen Resolution
    1600X900 16:9
    Hard Drives
    1TB 5400RPM
Hello,
Sorry for last Friday, I should have left

I re checked all the WSA settings without success
I have gone through and applied all the advice in this article can't log in to the Amazon Appstore without success
Furthermore I tested the installation of Amazon Prime Video from Microsoft Store... I had success ID and Pass OK

I've no idea what goes wrong
 

Attachments

  • WSA Amazon Prime Video 2.jpg
    WSA Amazon Prime Video 2.jpg
    97 KB · Views: 2
Last edited:

My Computer

System One

  • OS
    Windows 11 23H2 Build 22631.3007
    Computer type
    PC/Desktop
    Manufacturer/Model
    HP Worksatation Z1G9
    CPU
    i7 12700
    Motherboard
    HP
    Memory
    16GB
    Graphics Card(s)
    Nvida
    Hard Drives
    SSD 2T
    Browser
    Firefox
    Antivirus
    SEP (Symantec Endpoint Protction)
what kinda connecting are you using? Also Is this at home? Work?

We need more info on the connection your using
 

My Computers

System One System Two

  • OS
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    Dell G15 5525
    CPU
    Ryzen 7 6800H
    Memory
    32 GB DDR5 4800mhz
    Graphics Card(s)
    RTX 3050 4GB Vram
    Screen Resolution
    1920 x 1080
    Hard Drives
    2TB Solidigm™ P41 Plus nvme
    Internet Speed
    800mbps down, 20 up
  • Operating System
    Windows 11
    Computer type
    Tablet
    Manufacturer/Model
    Lenovo ideapad flex 14API 2 in 1
    CPU
    Ryzen 5 3500u
    Motherboard
    LENOVO LNVNB161216 (FP5)
    Memory
    12GB DDR4
    Graphics card(s)
    AMD Radeon Vega 8 Graphics
    Hard Drives
    256 GB Samsung ssd nvme
Hello,
I first make a summary of my France installation: Workstation HP Z1G9 i7-12700, 16 GB, 2T SSD and Windows 11 Pro 22H2 Build 22621.3007.
Regarding the Internet connection, I have both Fiber Ethernet and Wifi. I usually use the Ethernet connection (Customer MS Network).

Here bellow my machine settings:
BIOS's Virtualization enabled
Win11 Optional Features: Virtual Machine Platform enabled
WSA Experimental features option Local Network Access set to ON
SEP (Symantec Endpoint Protection) firewall disabled

So, my machine meets all the requirements, and I have a longstanding Amazon Prime account. Windows Subsystem for Android appears to have been installed correctly, but I can't get past the login screen.

Right now , I enabled Shared connection (see image) without success
I'll appreciate yr help
 

Attachments

  • Share connexion.jpg
    Share connexion.jpg
    36.3 KB · Views: 2
Last edited:

My Computer

System One

  • OS
    Windows 11 23H2 Build 22631.3007
    Computer type
    PC/Desktop
    Manufacturer/Model
    HP Worksatation Z1G9
    CPU
    i7 12700
    Motherboard
    HP
    Memory
    16GB
    Graphics Card(s)
    Nvida
    Hard Drives
    SSD 2T
    Browser
    Firefox
    Antivirus
    SEP (Symantec Endpoint Protction)
Back
Top Bottom