Solved my vs app can't upgrade from vs2008 into vs 2022, vs2022 says innerexception occurred ADODB different version.


sdowney717

Well-known member
Member
VIP
Local time
4:36 AM
Posts
1,015
OS
windows 11
Basically, I don't understand what the solution would be.
What is VS 2022 saying here?
it upgraded succesfully
New item by Scott Downey

New item by Scott Downey

1713783188277.png


It needed a reference for ADODB, I first tried 2.8 but no work, tried 2.7, get same error. I have tried every ADODB reference in the list in vs2022.

An error occurred creating the form. See Exception.InnerException for details. The error is: Could not load file or assembly 'Interop.ADODB, Version=2.7.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded.

When I first tried the program in vs2022, I got tons of various errors, could not load the forms designer for any forms,
so I thought to add .net 3.5. Downloaded and installed, then all the forms were then ok, visible in vs 2022.
Tried to run program, but had no definitions for the adodb. So I thought to add it as a reference.
So that is where I am at for the moment.

AND WHY did vs2022 NOT see the already selected ADODB reference in the vs2008 project, the import into vs2022 simply left it out.
 

My Computer

System One

  • OS
    windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    some kind of old ASUS MB
    CPU
    old AMD B95
    Motherboard
    ASUS
    Memory
    8gb
    Hard Drives
    ssd WD 500 gb

My Computer

System One

  • OS
    windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    some kind of old ASUS MB
    CPU
    old AMD B95
    Motherboard
    ASUS
    Memory
    8gb
    Hard Drives
    ssd WD 500 gb
OK, SOLVED IT!

reading this
You'll either have to upgrade the .NET 2 project to .NET 4, or downgrade the .NET 4 project to .NET 3.5 (or earlier).
How do you upgrade the .net version? I am not sure where to and what to specify. Please help.

Edit: I found the answer myself. Select the project, right click and choose Property Pages. There you can select framework version. or select the project and click Shift+F4
*********************************************************************************************
so to do this, simply right click project name in vs2022 at upper right corner
Change net framework from 3.5 to 4.8

Restart vs2022, load project and it now runs without error!
 

My Computer

System One

  • OS
    windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    some kind of old ASUS MB
    CPU
    old AMD B95
    Motherboard
    ASUS
    Memory
    8gb
    Hard Drives
    ssd WD 500 gb

Latest Support Threads

Back
Top Bottom