Printers and Scanners Stop Working


owensdj

Active member
Local time
8:35 AM
Posts
5
OS
Windows 11
Ever since replacing a Windows 10 machine with a new computer running Windows 11 I've been having problems with the USB printers and scanner. They'll work for a day or so and then the scanner will no longer communicate with the system and the printer shows "Offline." The machine has an HP Laserjet M604 printer, Canon imageformula R50 document scanner, and a Dymo LabelWriter 450. I can usually get them working again by powering down the computer and devices and back on again. Sometimes I have to also unplug the printer from the USB port and back in again.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    i5-9400F
    Motherboard
    ASRock B365 Pro4
    Memory
    16GB(2x8GB)
    Graphics Card(s)
    MSI GeForce GT 1030 2GB GDDR5
    Monitor(s) Displays
    Asus VS278 27"
    Screen Resolution
    1920x1080
    Hard Drives
    Crucial MX500 500GB SSD
    Western Digital Blue 3.0TB HDD
    Western Digital Black 1.5TB HDD
    Case
    Cooler Master HAF 912 Mid-Tower
    Keyboard
    Redragon K582RGB
    Mouse
    Logitech G502 Hero
One question. Since all of these are connected by usb, are you using a usb hub, or are each of then plugged into a separate usb port? If using a hub, is it a powered hub?
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3880
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 nvme+256gb SKHynix m.2 nvme /External +512gb Samsung m.2 sata+1tb Kingston m2.nvme
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
No hub. Each device is plugged into a separate USB port on the back of the computer.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    i5-9400F
    Motherboard
    ASRock B365 Pro4
    Memory
    16GB(2x8GB)
    Graphics Card(s)
    MSI GeForce GT 1030 2GB GDDR5
    Monitor(s) Displays
    Asus VS278 27"
    Screen Resolution
    1920x1080
    Hard Drives
    Crucial MX500 500GB SSD
    Western Digital Blue 3.0TB HDD
    Western Digital Black 1.5TB HDD
    Case
    Cooler Master HAF 912 Mid-Tower
    Keyboard
    Redragon K582RGB
    Mouse
    Logitech G502 Hero
To add, I've seen issue with Win10 and printers, albeit maybe older, where the choice of USB 2 or USB 3 ports was critical in smooth operation. One in particular that got me going in that direction was an older HP plugged into a USB 3 port that would print half of a page, stop then pop up a "lost communication" error, no issue when plugged into a USB 2 port.
 

My Computers

System One System Two

  • OS
    Win11 Pro RTM
    Computer type
    Laptop
    Manufacturer/Model
    Dell Vostro 3400
    CPU
    Intel Core i5 11th Gen. 2.40GHz
    Memory
    12GB
    Hard Drives
    256GB SSD NVMe
  • Operating System
    Windows 11 Pro RTM x64
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Vostro 5890
    CPU
    Intel Core i5 10th Gen. 2.90GHz
    Memory
    16GB
    Graphics card(s)
    Onboard, no VGA, using a DisplayPort-to-VGA adapter
    Monitor(s) Displays
    24" Dell
    Hard Drives
    512GB SSD NVMe, 2TB WDC HDD
    Browser
    Firefox, Edge
    Antivirus
    Windows Defender/Microsoft Security
An offline status indicates the printer can not communicate with the computer. Here are some things to try.

1. I don't believe it is the drivers but check them anyway.Looking at the HP site for the M604 the Windows 11 driver is 7.0.1.24923 10/6/21. I noticed there is also a new firmware update for it dated 2/14/22
Canon R50 scanner driver dated 12/15/21
Dymo 450 has not had a new driver since Windows 8

2. Restart the print spooler- in search box type services-click 'services app' in search results. Within services scroll down to 'print spooler' Make sure startup type is automatic. Restart the service.

3. Low ink cartridges can make a usb printer go offline

4. Check for file corruption. Search for 'cmd' In command prompt app, select run as administrator. In command prompt window
type sfc /scannow

5. Microsoft suggests you remove and reinstall your printers. I suggest you turn off all but one printer and work with them one at a time. In fact, it might be a good idea after you reinstall the first one to leave the others turned off until you determine the trouble does not return on the one.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3880
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 nvme+256gb SKHynix m.2 nvme /External +512gb Samsung m.2 sata+1tb Kingston m2.nvme
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
Once i went to Windows 11 from Windows 10 my Epson All in One Printer was not working at times and sometimes not at all.
Get communication errors and scanner would give same type of communication errors. It would show offline in settings in Windows

Talked to Epson they were not much help, they tried the usual uninstalling and reinstalling printer manually instead of having it detected by Windows.

So i tried everything even the ones mentioned in this post to no solution.

I suspected it was the driver made sense as worked in Windows 10 not 11 but no new drivers on Epsons site.

Turns out last month a new driver came out and ever since printer is working fine, except the scanner part works only when you restart PC so at times it still gets errors. Scanner uses a twain driver again which has not been updated like the printer driver.

So i would say it could most likely be the drivers these are not brand new models you are using and Windows 11 still has bugs to work out also.
Did you try new cables ? One i tried but didn't work either.
 

My Computer

System One

  • OS
    Windows 11 Pro
    Computer type
    PC/Desktop
    Manufacturer/Model
    jds63 /self built
    CPU
    Intel Core i7 10700KF 3.8 MHz
    Motherboard
    ASUS ROG Strix Z490-E Gaming
    Memory
    G.Skill Trident RGB Series 64GB DDR4-3600MHz
    Graphics Card(s)
    ASUS ROG Strix GeForce RTX 3060 Ti OC Edition
    Sound Card
    Creative Sound BlasterX AE-5 Plus
    Monitor(s) Displays
    ASUS VG28UQL1A 28" 144 Mhz 4K Monitor
    Screen Resolution
    3840 X 2160p HDR
    Hard Drives
    Samsung 970 EVO Plus NVMe 500GB M.2 Drive, (2) Samsung 870 EVO 1TB SATA III Internal SSD, (2) Samsung 860 EVO 1TB SATA III Internal SSD & Seagate Barracuda 2TB
    PSU
    ASUS ROG Thor 850 80+ Platinum 850W Fully Modular RGB Power Supply
    Case
    Lian Li Lancool II Mesh Performance
    Cooling
    Noctua NH-U12A CPU Cooler, (5) Noctua NF-A12x15 chromax.black.swap 120mm, (3) Lepa BOL.Quiet PWM LED 120mm
    Keyboard
    Logitech MX Keys
    Mouse
    Logitech MX Ergo Trackball
    Internet Speed
    325Mbps/ 20Mbps
    Browser
    Mozilla Firefox 64-bit, Microsoft Edge
    Antivirus
    Kaspersky Plus 2023
    Other Info
    Pioneer Blu-Ray/DVD Burner 209DBK, Logitech Z906 5.1 Speakers and Epson XP7100 All-in-One Printer
I would like to comment on this thread. I have Epson printers and scanners and have the similar connection issues. They have no problems over my local network (wired or wireless). Just USB. Have not really been able to narrow it down either. A reboot sometimes restores comm but not always. Glad or (sorry) to see others with the issue.
 

My Computer

System One

  • OS
    Win7 Pro Retail Upgrade to Win 10 Pro, to Win11 Pro 23H2 OS Build 22631.3880
    Computer type
    PC/Desktop
    Manufacturer/Model
    Home Build
    CPU
    AMD Ryzen 3 3200G with Radeon Vega Graphics
    Motherboard
    MSI B450 Tomahawk
    Memory
    Corsair DDR4 32g
    Graphics Card(s)
    AMD Radeon Vega 8
    Sound Card
    AMD High Definition Audio Device Realtek High Definition Audio
    Monitor(s) Displays
    2
    Screen Resolution
    1920 x 1080
    Hard Drives
    Samsung SSD 860 EVO 1TB (SATA (SSD))
    931GB Western Digital WDC WD10EZEX-00RKKA0 (SATA )
    Seagate BUP 4TB USB3 (This drive died at one year)
    (3) Seagate BUP Slim 2TB USB3
    Samsung SSD 850 EVO 500G USB3
    PSU
    Corsair TX 750W
    Case
    Cooler Master tower
    Cooling
    3 generic fans
    Keyboard
    Logitech Backlit USB
    Mouse
    Logitech M510
    Internet Speed
    T-Mobile 5G 100+ Mbs
    Browser
    Edge, Firefox
    Antivirus
    Defender and Malwarebytes Prem
    Other Info
    A bunch of legit software
Did you try new cables ?
Same cables, but they work fine with the same printers and scanner using the older Windows 10 machine.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    i5-9400F
    Motherboard
    ASRock B365 Pro4
    Memory
    16GB(2x8GB)
    Graphics Card(s)
    MSI GeForce GT 1030 2GB GDDR5
    Monitor(s) Displays
    Asus VS278 27"
    Screen Resolution
    1920x1080
    Hard Drives
    Crucial MX500 500GB SSD
    Western Digital Blue 3.0TB HDD
    Western Digital Black 1.5TB HDD
    Case
    Cooler Master HAF 912 Mid-Tower
    Keyboard
    Redragon K582RGB
    Mouse
    Logitech G502 Hero
@jds63 In my particular case the Epson devices were added several after I went to Win 11. Before that I had older Brother and Canon devices. Same cables though and no comm issues. I seriously believe mine is Epson driver issues.
 

My Computer

System One

  • OS
    Win7 Pro Retail Upgrade to Win 10 Pro, to Win11 Pro 23H2 OS Build 22631.3880
    Computer type
    PC/Desktop
    Manufacturer/Model
    Home Build
    CPU
    AMD Ryzen 3 3200G with Radeon Vega Graphics
    Motherboard
    MSI B450 Tomahawk
    Memory
    Corsair DDR4 32g
    Graphics Card(s)
    AMD Radeon Vega 8
    Sound Card
    AMD High Definition Audio Device Realtek High Definition Audio
    Monitor(s) Displays
    2
    Screen Resolution
    1920 x 1080
    Hard Drives
    Samsung SSD 860 EVO 1TB (SATA (SSD))
    931GB Western Digital WDC WD10EZEX-00RKKA0 (SATA )
    Seagate BUP 4TB USB3 (This drive died at one year)
    (3) Seagate BUP Slim 2TB USB3
    Samsung SSD 850 EVO 500G USB3
    PSU
    Corsair TX 750W
    Case
    Cooler Master tower
    Cooling
    3 generic fans
    Keyboard
    Logitech Backlit USB
    Mouse
    Logitech M510
    Internet Speed
    T-Mobile 5G 100+ Mbs
    Browser
    Edge, Firefox
    Antivirus
    Defender and Malwarebytes Prem
    Other Info
    A bunch of legit software
Same cables, but they work fine with the same printers and scanner using the older Windows 10 machine.
Maybe worth a try if have any lying around. Thought mine was the cables turned out they were fine after changing to a new one, was a solution to try.
 
Last edited:

My Computer

System One

  • OS
    Windows 11 Pro
    Computer type
    PC/Desktop
    Manufacturer/Model
    jds63 /self built
    CPU
    Intel Core i7 10700KF 3.8 MHz
    Motherboard
    ASUS ROG Strix Z490-E Gaming
    Memory
    G.Skill Trident RGB Series 64GB DDR4-3600MHz
    Graphics Card(s)
    ASUS ROG Strix GeForce RTX 3060 Ti OC Edition
    Sound Card
    Creative Sound BlasterX AE-5 Plus
    Monitor(s) Displays
    ASUS VG28UQL1A 28" 144 Mhz 4K Monitor
    Screen Resolution
    3840 X 2160p HDR
    Hard Drives
    Samsung 970 EVO Plus NVMe 500GB M.2 Drive, (2) Samsung 870 EVO 1TB SATA III Internal SSD, (2) Samsung 860 EVO 1TB SATA III Internal SSD & Seagate Barracuda 2TB
    PSU
    ASUS ROG Thor 850 80+ Platinum 850W Fully Modular RGB Power Supply
    Case
    Lian Li Lancool II Mesh Performance
    Cooling
    Noctua NH-U12A CPU Cooler, (5) Noctua NF-A12x15 chromax.black.swap 120mm, (3) Lepa BOL.Quiet PWM LED 120mm
    Keyboard
    Logitech MX Keys
    Mouse
    Logitech MX Ergo Trackball
    Internet Speed
    325Mbps/ 20Mbps
    Browser
    Mozilla Firefox 64-bit, Microsoft Edge
    Antivirus
    Kaspersky Plus 2023
    Other Info
    Pioneer Blu-Ray/DVD Burner 209DBK, Logitech Z906 5.1 Speakers and Epson XP7100 All-in-One Printer
@jds63 In my particular case the Epson devices were added several after I went to Win 11. Before that I had older Brother and Canon devices. Same cables though and no comm issues. I seriously believe mine is Epson driver issues.
Not sure understanding the statement, do you mean you had several devices showing in Devices and Printers in control panel or in Settings>Bluetooth & Devices>Printers and Scanners ? Because that happened to me when i had to the issue at first was installing two printer devices.
 

My Computer

System One

  • OS
    Windows 11 Pro
    Computer type
    PC/Desktop
    Manufacturer/Model
    jds63 /self built
    CPU
    Intel Core i7 10700KF 3.8 MHz
    Motherboard
    ASUS ROG Strix Z490-E Gaming
    Memory
    G.Skill Trident RGB Series 64GB DDR4-3600MHz
    Graphics Card(s)
    ASUS ROG Strix GeForce RTX 3060 Ti OC Edition
    Sound Card
    Creative Sound BlasterX AE-5 Plus
    Monitor(s) Displays
    ASUS VG28UQL1A 28" 144 Mhz 4K Monitor
    Screen Resolution
    3840 X 2160p HDR
    Hard Drives
    Samsung 970 EVO Plus NVMe 500GB M.2 Drive, (2) Samsung 870 EVO 1TB SATA III Internal SSD, (2) Samsung 860 EVO 1TB SATA III Internal SSD & Seagate Barracuda 2TB
    PSU
    ASUS ROG Thor 850 80+ Platinum 850W Fully Modular RGB Power Supply
    Case
    Lian Li Lancool II Mesh Performance
    Cooling
    Noctua NH-U12A CPU Cooler, (5) Noctua NF-A12x15 chromax.black.swap 120mm, (3) Lepa BOL.Quiet PWM LED 120mm
    Keyboard
    Logitech MX Keys
    Mouse
    Logitech MX Ergo Trackball
    Internet Speed
    325Mbps/ 20Mbps
    Browser
    Mozilla Firefox 64-bit, Microsoft Edge
    Antivirus
    Kaspersky Plus 2023
    Other Info
    Pioneer Blu-Ray/DVD Burner 209DBK, Logitech Z906 5.1 Speakers and Epson XP7100 All-in-One Printer
I would like to comment on this thread. I have Epson printers and scanners and have the similar connection issues. They have no problems over my local network (wired or wireless). Just USB. Have not really been able to narrow it down either. A reboot sometimes restores comm but not always. Glad or (sorry) to see others with the issue.
That's exactly how mine was no issues printing over wireless or even if i tried anything directly from printers menu say like make a copy from scanner, but once i used USB all failed, definitely the driver. Have you checked Epson's site for new drivers yet ? Not the package (with other bundled software) just the printer driver. Check driver dates in Device Manager to compare if have newer one yet. Make sure to select Windows 11 from drop down box after selecting your printer.

Epson Support
 

My Computer

System One

  • OS
    Windows 11 Pro
    Computer type
    PC/Desktop
    Manufacturer/Model
    jds63 /self built
    CPU
    Intel Core i7 10700KF 3.8 MHz
    Motherboard
    ASUS ROG Strix Z490-E Gaming
    Memory
    G.Skill Trident RGB Series 64GB DDR4-3600MHz
    Graphics Card(s)
    ASUS ROG Strix GeForce RTX 3060 Ti OC Edition
    Sound Card
    Creative Sound BlasterX AE-5 Plus
    Monitor(s) Displays
    ASUS VG28UQL1A 28" 144 Mhz 4K Monitor
    Screen Resolution
    3840 X 2160p HDR
    Hard Drives
    Samsung 970 EVO Plus NVMe 500GB M.2 Drive, (2) Samsung 870 EVO 1TB SATA III Internal SSD, (2) Samsung 860 EVO 1TB SATA III Internal SSD & Seagate Barracuda 2TB
    PSU
    ASUS ROG Thor 850 80+ Platinum 850W Fully Modular RGB Power Supply
    Case
    Lian Li Lancool II Mesh Performance
    Cooling
    Noctua NH-U12A CPU Cooler, (5) Noctua NF-A12x15 chromax.black.swap 120mm, (3) Lepa BOL.Quiet PWM LED 120mm
    Keyboard
    Logitech MX Keys
    Mouse
    Logitech MX Ergo Trackball
    Internet Speed
    325Mbps/ 20Mbps
    Browser
    Mozilla Firefox 64-bit, Microsoft Edge
    Antivirus
    Kaspersky Plus 2023
    Other Info
    Pioneer Blu-Ray/DVD Burner 209DBK, Logitech Z906 5.1 Speakers and Epson XP7100 All-in-One Printer
Thanks for your information @jds63. I lost interest in searching for a solution a few weeks ago. Epson devices are very good but their support is not in my opinion. This post is the first I have seen with the same issue. Peaked my interest again. But yes, I did check for up to date drivers, etc. Thanks.
 

My Computer

System One

  • OS
    Win7 Pro Retail Upgrade to Win 10 Pro, to Win11 Pro 23H2 OS Build 22631.3880
    Computer type
    PC/Desktop
    Manufacturer/Model
    Home Build
    CPU
    AMD Ryzen 3 3200G with Radeon Vega Graphics
    Motherboard
    MSI B450 Tomahawk
    Memory
    Corsair DDR4 32g
    Graphics Card(s)
    AMD Radeon Vega 8
    Sound Card
    AMD High Definition Audio Device Realtek High Definition Audio
    Monitor(s) Displays
    2
    Screen Resolution
    1920 x 1080
    Hard Drives
    Samsung SSD 860 EVO 1TB (SATA (SSD))
    931GB Western Digital WDC WD10EZEX-00RKKA0 (SATA )
    Seagate BUP 4TB USB3 (This drive died at one year)
    (3) Seagate BUP Slim 2TB USB3
    Samsung SSD 850 EVO 500G USB3
    PSU
    Corsair TX 750W
    Case
    Cooler Master tower
    Cooling
    3 generic fans
    Keyboard
    Logitech Backlit USB
    Mouse
    Logitech M510
    Internet Speed
    T-Mobile 5G 100+ Mbs
    Browser
    Edge, Firefox
    Antivirus
    Defender and Malwarebytes Prem
    Other Info
    A bunch of legit software

Latest Support Threads

Back
Top Bottom