Samsung Magician switched position of Recovery Partition when I cloned the system from one drive to another


johnpd

Active member
VIP
Local time
7:27 AM
Posts
28
Location
Green Valley, AZ
OS
Windows 10
A little over a month ago I purchased a small mini computer. It came with two drives: an eMMC 256GB system drive and a generic 256GB NVMe SSD data drive. The SSD drive was a little small for what I wanted to do so I purchased a Samsung 980 Pro 2TB drive and cloned the system drive to it using Samsung Magician. Everything is working fine except when a look at the two drives in Disk Management, Samsung Magician switched the positions of the Recovery Partition. On the old drive it was the last partition after the C: partition. On the new drive it now exists at the beginning of the drive. When I run "reagentc", it says that the Recovery Environment is disabled.

So what is the best process to follow:
1. Does it matter if the Recovery Partition is first? If it should be last, how easy is it to switch the Recovery partition to the end?
2. If have not tried enabling the Recovery environment as I was not sure whether I wanted to try switching parttion positions. If the Recovery partition position does not matter, should I just leave the Recovery Partition where it is and enable the Recovery Environment at the first partition if it works ok there?

Also after running HWInfo64, I noticed that "Secure Boot" is not set. How do I fix that?

JohnD
 

My Computer

System One

  • OS
    Windows 10
Hi,
Depends on what size the RE partition is.
 

My Computer

System One

  • OS
    Win-7-10-11Pro's
    Computer type
    PC/Desktop
    Manufacturer/Model
    Acer 17" Nitro 7840sn/ 2x16gb 5600c40/ 4060/ stock 1tb-os/ 4tb sn850x
    CPU
    10900k & 9940x & 5930k
    Motherboard
    z490-Apex & x299-Apex & x99-Sabertooth
    Memory
    Trident-Z Royal 4000c16 2x16gb & Trident-Z 3600c16 4x8gb & 3200c14 4x8gb
    Graphics Card(s)
    Titan Xp & 1080ti FTW3 & evga 980ti gaming
    Sound Card
    Onboard Realtek x3
    Monitor(s) Displays
    1-AOC G2460PG 24"G-Sync 144Hz/ 2nd 1-ASUS VG248QE 24"/ 3rd LG 43" series
    Screen Resolution
    1920-1080 not sure what the t.v is besides 43" class scales from 1920-1080 perfectly
    Hard Drives
    2-WD-sn850x 4tb/ 970evo+500gb/ 980 pro 2tb.
    PSU
    1000p2 & 1200p2 & 850p2
    Case
    D450 x2 & 1 Test bench in cherry Entertainment center
    Cooling
    Custom water loops x3 with 2x mora 360mm rads only 980ti gaming air cooled
    Keyboard
    G710+x3
    Mouse
    Redragon x3
    Internet Speed
    xfinity gigabyte
    Browser
    Firefox
    Antivirus
    mbam pro
Yes that was a Windows 10 issue. The size of the Recovery Partition on this Windows 11 PC is a little over 9GB. I got into BIOS and found that "Secure Boot" is "Enabled" and "Secure Boot Mode" is "Standard", but Secure Boot is not active.

JohnD
 
Last edited:

My Computer

System One

  • OS
    Windows 10
1. I was using Samsung Magician but didn't notice the shift issue.
2. NOT sure your PC maker, Dell or HP? on my HP PCs, when position of Recovery Partition shifted, then Recovery wouldn't work any more.
Indeed, even disk size changed on HP PCs, it wouldn't work any more. I was changing original disk from 1TB to 500GB by clone. restart and working fine. while later it's noticed, the HP PC couldn't run Recovery any more. had to replace the 1TB back. looks HP maps image by disk position in a way (HP is unique)
 

My Computer

System One

  • OS
    Windows 7/11
    Computer type
    PC/Desktop
    Manufacturer/Model
    HP/Lenovo/Asus
    CPU
    Intel
    Hard Drives
    NVMe SSD/SATA SSD
check the recovery partition Type guid is correct on the new disk.

free edition is fine DiskGenius Download Center | Free Download DiskGenius

rt clcik the recovery partition and select "modify partition parameters" to get the window below

dg-ms-recovery.jpg



The size of the Recovery Partition on this Windows 11 PC is a little over 9GB
in diskgenius main window, click the recovery partition and select the Files tab
post a screenie of the contents of your 9gb recovery partition

the way to specify which partition for winre when there is more than one recovery partition:

reagentc /disable

Reagentc /setreimage /path <path_to_selected_recovery on your new disk>

reagentc /enable
 
Last edited:

My Computers

System One System Two

  • OS
    Win7
    Computer type
    PC/Desktop
    CPU
    i5-8400
    Motherboard
    gigabyte b365m ds3h
    Memory
    2x8gb 3200mhz
    Monitor(s) Displays
    benq gw2480
    PSU
    bequiet pure power 11 400CM
    Cooling
    cryorig m9i
  • Operating System
    win7
    Computer type
    PC/Desktop
    CPU
    pentium g5400
    Motherboard
    gigabyte b365m ds3h
    Memory
    1x8gb 2400
    PSU
    xfx pro 450
Here is the image. Don't know what the ReCustomization.xml is?
 

Attachments

  • MeLE_Recovery_Partiion_Disk-0.png
    MeLE_Recovery_Partiion_Disk-0.png
    7.5 KB · Views: 2

My Computer

System One

  • OS
    Windows 10
It is so the option for the oem recovery shows up on the advanced startup menu.

Copy recustomization.xml to your desktop, open it in notepad and post the contents.

something like this

<?xml version="1.0" encoding="utf-8"?>
<!-- AddDiagnosticsToolToBootMenu.xml -->
<BootShell>
<WinRETool locale="en-us">
<Name>some name e.g. oem recovery</Name>
<Description>some description e.g. start oem recovery options</Description>
</WinRETool>
<BootShell>

it is set something like this
Reagentc /setbootshelllink /configfile <path_to_whatever.xml>
 
Last edited:

My Computers

System One System Two

  • OS
    Win7
    Computer type
    PC/Desktop
    CPU
    i5-8400
    Motherboard
    gigabyte b365m ds3h
    Memory
    2x8gb 3200mhz
    Monitor(s) Displays
    benq gw2480
    PSU
    bequiet pure power 11 400CM
    Cooling
    cryorig m9i
  • Operating System
    win7
    Computer type
    PC/Desktop
    CPU
    pentium g5400
    Motherboard
    gigabyte b365m ds3h
    Memory
    1x8gb 2400
    PSU
    xfx pro 450
If you use diskgenius as suggested, you can copy any files out of the recovery partition.

Be interesting to see if the original winre.wim that came with the machine has sources\recovery\tools and some oem program in there
 

My Computers

System One System Two

  • OS
    Win7
    Computer type
    PC/Desktop
    CPU
    i5-8400
    Motherboard
    gigabyte b365m ds3h
    Memory
    2x8gb 3200mhz
    Monitor(s) Displays
    benq gw2480
    PSU
    bequiet pure power 11 400CM
    Cooling
    cryorig m9i
  • Operating System
    win7
    Computer type
    PC/Desktop
    CPU
    pentium g5400
    Motherboard
    gigabyte b365m ds3h
    Memory
    1x8gb 2400
    PSU
    xfx pro 450
Here is the customization .xml.

<?xml version="1.0" encoding="utf-8"?>
<!-- AddDiagnosticsToolToBootMenu.xml -->
<BootShell>
<WinRETool locale="en-us">
<Name>MeLe Fast Recovery Utility</Name>
<Description>Reset your PC and remove everything</Description>
</WinRETool>
<WinRETool locale="fr-fr">
<Name>Utilité de MeLe Fast Recovery</Name>
<Description>Dépannez votre PC de Fabrikam</Description>
</WinRETool>
</BootShell>
 

My Computer

System One

  • OS
    Windows 10
Thought so.

Have alook in winre.wim \sources\recovery\tools

there is probably some program in there with the winreconfig.xml

I have been doing it for years , in win7 the custom tool shows up here

winretools1.jpg


in win10/11 it shows up on a little blue square
 

My Computers

System One System Two

  • OS
    Win7
    Computer type
    PC/Desktop
    CPU
    i5-8400
    Motherboard
    gigabyte b365m ds3h
    Memory
    2x8gb 3200mhz
    Monitor(s) Displays
    benq gw2480
    PSU
    bequiet pure power 11 400CM
    Cooling
    cryorig m9i
  • Operating System
    win7
    Computer type
    PC/Desktop
    CPU
    pentium g5400
    Motherboard
    gigabyte b365m ds3h
    Memory
    1x8gb 2400
    PSU
    xfx pro 450
ReAgent.xml:

<?xml version='1.0' encoding='utf-8'?>

<WindowsRE version="2.0">
<WinreBCD id="{ff3032d8-73d8-11ee-b2b3-b86c49ac007b}"/>
<WinreLocation path="\Recovery\WindowsRE" id="0" offset="240334667776" guid="{e242f45f-1e0e-4722-b176-04426d55ffe1}"/>
<ImageLocation path="\Recovery\windowsre" id="0" offset="240334667776" guid="{e242f45f-1e0e-4722-b176-04426d55ffe1}"/>
<PBRImageLocation path="" id="0" offset="0" guid="{00000000-0000-0000-0000-000000000000}" index="0"/>
<PBRCustomImageLocation path="" id="0" offset="0" guid="{00000000-0000-0000-0000-000000000000}" index="0"/>
<InstallState state="1"/>
<OsInstallAvailable state="0"/>
<CustomImageAvailable state="0"/>
<IsAutoRepairOn state="1"/>
<WinREStaged state="0"/>
<OperationParam path=""/>
<OperationPermanent state="0"/>
<OsBuildVersion path="22621.1.amd64fre.ni_release.220506-1250"/>
<OemTool state="1"/>
<IsServer state="0"/>
<DownlevelWinreLocation path="" id="0" offset="0" guid="{00000000-0000-0000-0000-000000000000}"/>
<IsWimBoot state="0"/>
<NarratorScheduled state="0"/>
<ScheduledOperation state="5"/>
</WindowsRE>
 

My Computer

System One

  • OS
    Windows 10
Yes that was a Windows 10 issue. The size of the Recovery Partition on this Windows 11 PC is a little over 9GB. I got into BIOS and found that "Secure Boot" is "Enabled" and "Secure Boot Mode" is "Standard", but Secure Boot is not active.

JohnD
Hi,
That sounds like an oem manufacture recovery partition not anything microsoft made.
RE is generally max 1gb and more than not 6-800mb
 

My Computer

System One

  • OS
    Win-7-10-11Pro's
    Computer type
    PC/Desktop
    Manufacturer/Model
    Acer 17" Nitro 7840sn/ 2x16gb 5600c40/ 4060/ stock 1tb-os/ 4tb sn850x
    CPU
    10900k & 9940x & 5930k
    Motherboard
    z490-Apex & x299-Apex & x99-Sabertooth
    Memory
    Trident-Z Royal 4000c16 2x16gb & Trident-Z 3600c16 4x8gb & 3200c14 4x8gb
    Graphics Card(s)
    Titan Xp & 1080ti FTW3 & evga 980ti gaming
    Sound Card
    Onboard Realtek x3
    Monitor(s) Displays
    1-AOC G2460PG 24"G-Sync 144Hz/ 2nd 1-ASUS VG248QE 24"/ 3rd LG 43" series
    Screen Resolution
    1920-1080 not sure what the t.v is besides 43" class scales from 1920-1080 perfectly
    Hard Drives
    2-WD-sn850x 4tb/ 970evo+500gb/ 980 pro 2tb.
    PSU
    1000p2 & 1200p2 & 850p2
    Case
    D450 x2 & 1 Test bench in cherry Entertainment center
    Cooling
    Custom water loops x3 with 2x mora 360mm rads only 980ti gaming air cooled
    Keyboard
    G710+x3
    Mouse
    Redragon x3
    Internet Speed
    xfinity gigabyte
    Browser
    Firefox
    Antivirus
    mbam pro
Yes the original drive had the same size partition.
Hi,
That's the real winRE then it should if enabled this is the the partition it should show using
reagentc /info
The larger partition take a combo key to engage it into resetting back to out of box.
 

My Computer

System One

  • OS
    Win-7-10-11Pro's
    Computer type
    PC/Desktop
    Manufacturer/Model
    Acer 17" Nitro 7840sn/ 2x16gb 5600c40/ 4060/ stock 1tb-os/ 4tb sn850x
    CPU
    10900k & 9940x & 5930k
    Motherboard
    z490-Apex & x299-Apex & x99-Sabertooth
    Memory
    Trident-Z Royal 4000c16 2x16gb & Trident-Z 3600c16 4x8gb & 3200c14 4x8gb
    Graphics Card(s)
    Titan Xp & 1080ti FTW3 & evga 980ti gaming
    Sound Card
    Onboard Realtek x3
    Monitor(s) Displays
    1-AOC G2460PG 24"G-Sync 144Hz/ 2nd 1-ASUS VG248QE 24"/ 3rd LG 43" series
    Screen Resolution
    1920-1080 not sure what the t.v is besides 43" class scales from 1920-1080 perfectly
    Hard Drives
    2-WD-sn850x 4tb/ 970evo+500gb/ 980 pro 2tb.
    PSU
    1000p2 & 1200p2 & 850p2
    Case
    D450 x2 & 1 Test bench in cherry Entertainment center
    Cooling
    Custom water loops x3 with 2x mora 360mm rads only 980ti gaming air cooled
    Keyboard
    G710+x3
    Mouse
    Redragon x3
    Internet Speed
    xfinity gigabyte
    Browser
    Firefox
    Antivirus
    mbam pro
Hi,
Think it would be wise to use a different app to clone the disk lol
Disk genus does this.
 

My Computer

System One

  • OS
    Win-7-10-11Pro's
    Computer type
    PC/Desktop
    Manufacturer/Model
    Acer 17" Nitro 7840sn/ 2x16gb 5600c40/ 4060/ stock 1tb-os/ 4tb sn850x
    CPU
    10900k & 9940x & 5930k
    Motherboard
    z490-Apex & x299-Apex & x99-Sabertooth
    Memory
    Trident-Z Royal 4000c16 2x16gb & Trident-Z 3600c16 4x8gb & 3200c14 4x8gb
    Graphics Card(s)
    Titan Xp & 1080ti FTW3 & evga 980ti gaming
    Sound Card
    Onboard Realtek x3
    Monitor(s) Displays
    1-AOC G2460PG 24"G-Sync 144Hz/ 2nd 1-ASUS VG248QE 24"/ 3rd LG 43" series
    Screen Resolution
    1920-1080 not sure what the t.v is besides 43" class scales from 1920-1080 perfectly
    Hard Drives
    2-WD-sn850x 4tb/ 970evo+500gb/ 980 pro 2tb.
    PSU
    1000p2 & 1200p2 & 850p2
    Case
    D450 x2 & 1 Test bench in cherry Entertainment center
    Cooling
    Custom water loops x3 with 2x mora 360mm rads only 980ti gaming air cooled
    Keyboard
    G710+x3
    Mouse
    Redragon x3
    Internet Speed
    xfinity gigabyte
    Browser
    Firefox
    Antivirus
    mbam pro
The reagentc command has an option to "setreimage" where I can point to the one I want to use. What if I tried that and point to Disk 0. I have already assigned a drive letter to that partition.

JohnD
 

My Computer

System One

  • OS
    Windows 10
The reagentc command has an option to "setreimage" where I can point to the one I want to use. What if I tried that and point to Disk 0. I have already assigned a drive letter to that partition.

JohnD
Here's some instructions
 

My Computer

System One

  • OS
    Win-7-10-11Pro's
    Computer type
    PC/Desktop
    Manufacturer/Model
    Acer 17" Nitro 7840sn/ 2x16gb 5600c40/ 4060/ stock 1tb-os/ 4tb sn850x
    CPU
    10900k & 9940x & 5930k
    Motherboard
    z490-Apex & x299-Apex & x99-Sabertooth
    Memory
    Trident-Z Royal 4000c16 2x16gb & Trident-Z 3600c16 4x8gb & 3200c14 4x8gb
    Graphics Card(s)
    Titan Xp & 1080ti FTW3 & evga 980ti gaming
    Sound Card
    Onboard Realtek x3
    Monitor(s) Displays
    1-AOC G2460PG 24"G-Sync 144Hz/ 2nd 1-ASUS VG248QE 24"/ 3rd LG 43" series
    Screen Resolution
    1920-1080 not sure what the t.v is besides 43" class scales from 1920-1080 perfectly
    Hard Drives
    2-WD-sn850x 4tb/ 970evo+500gb/ 980 pro 2tb.
    PSU
    1000p2 & 1200p2 & 850p2
    Case
    D450 x2 & 1 Test bench in cherry Entertainment center
    Cooling
    Custom water loops x3 with 2x mora 360mm rads only 980ti gaming air cooled
    Keyboard
    G710+x3
    Mouse
    Redragon x3
    Internet Speed
    xfinity gigabyte
    Browser
    Firefox
    Antivirus
    mbam pro
Frankly you haven't even shown a screen shot of your disk
Basically you used a crappy migration app and continue to ignore that lol
 

My Computer

System One

  • OS
    Win-7-10-11Pro's
    Computer type
    PC/Desktop
    Manufacturer/Model
    Acer 17" Nitro 7840sn/ 2x16gb 5600c40/ 4060/ stock 1tb-os/ 4tb sn850x
    CPU
    10900k & 9940x & 5930k
    Motherboard
    z490-Apex & x299-Apex & x99-Sabertooth
    Memory
    Trident-Z Royal 4000c16 2x16gb & Trident-Z 3600c16 4x8gb & 3200c14 4x8gb
    Graphics Card(s)
    Titan Xp & 1080ti FTW3 & evga 980ti gaming
    Sound Card
    Onboard Realtek x3
    Monitor(s) Displays
    1-AOC G2460PG 24"G-Sync 144Hz/ 2nd 1-ASUS VG248QE 24"/ 3rd LG 43" series
    Screen Resolution
    1920-1080 not sure what the t.v is besides 43" class scales from 1920-1080 perfectly
    Hard Drives
    2-WD-sn850x 4tb/ 970evo+500gb/ 980 pro 2tb.
    PSU
    1000p2 & 1200p2 & 850p2
    Case
    D450 x2 & 1 Test bench in cherry Entertainment center
    Cooling
    Custom water loops x3 with 2x mora 360mm rads only 980ti gaming air cooled
    Keyboard
    G710+x3
    Mouse
    Redragon x3
    Internet Speed
    xfinity gigabyte
    Browser
    Firefox
    Antivirus
    mbam pro

Latest Support Threads

Back
Top Bottom