System Settings crash when trying to see what Optional Updates there are?


IrvSp

Member
Local time
7:54 PM
Posts
7
OS
Windows 11
I go into Settings Windows Update, Advanced Option, and I see in Optional Updates that 2 are available. I click on this and Settings collapses.

In Event Viewer I see 2 errors seconds apart:

First one:

Log Name: Application
Source: Application Error
Date: 11/12/2021 8:33:01 PM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: IrvXPS8940
Description:
Faulting application name: SystemSettings.exe, version: 10.0.22000.120, time stamp: 0x27a6d211
Faulting module name: SystemSettings.dll, version: 10.0.22000.120, time stamp: 0x9799599e
Exception code: 0xc0000005
Fault offset: 0x0000000000497c4a
Faulting process id: 0x5028
Faulting application start time: 0x01d7d82e5e76989b
Faulting application path: C:\Windows\ImmersiveControlPanel\SystemSettings.exe
Faulting module path: C:\Windows\ImmersiveControlPanel\SystemSettings.dll
Report Id: 14ca71bf-3094-49c3-808f-990c0c177df0
Faulting package full name: windows.immersivecontrolpanel_10.0.6.1000_neutral_neutral_cw5n1h2txyewy
Faulting package-relative application ID: microsoft.windows.immersivecontrolpanel
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>100</Task>
<Opcode>0</Opcode>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2021-11-13T01:33:01.6231557Z" />
<EventRecordID>6298</EventRecordID>
<Correlation />
<Execution ProcessID="24100" ThreadID="0" />
<Channel>Application</Channel>
<Computer>IrvXPS8940</Computer>
<Security />
</System>
<EventData>
<Data>SystemSettings.exe</Data>
<Data>10.0.22000.120</Data>
<Data>27a6d211</Data>
<Data>SystemSettings.dll</Data>
<Data>10.0.22000.120</Data>
<Data>9799599e</Data>
<Data>c0000005</Data>
<Data>0000000000497c4a</Data>
<Data>5028</Data>
<Data>01d7d82e5e76989b</Data>
<Data>C:\Windows\ImmersiveControlPanel\SystemSettings.exe</Data>
<Data>C:\Windows\ImmersiveControlPanel\SystemSettings.dll</Data>
<Data>14ca71bf-3094-49c3-808f-990c0c177df0</Data>
<Data>windows.immersivecontrolpanel_10.0.6.1000_neutral_neutral_cw5n1h2txyewy</Data>
<Data>microsoft.windows.immersivecontrolpanel</Data>
</EventData>
</Event>

2nd one:

Log Name: Application
Source: Application Error
Date: 11/12/2021 8:33:03 PM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: IrvXPS8940
Description:
Faulting application name: SystemSettings.exe, version: 10.0.22000.120, time stamp: 0x27a6d211
Faulting module name: SystemSettings.dll, version: 10.0.22000.120, time stamp: 0x9799599e
Exception code: 0xc000041d
Fault offset: 0x0000000000497c4a
Faulting process id: 0x5028
Faulting application start time: 0x01d7d82e5e76989b
Faulting application path: C:\Windows\ImmersiveControlPanel\SystemSettings.exe
Faulting module path: C:\Windows\ImmersiveControlPanel\SystemSettings.dll
Report Id: ac1e44f4-5500-4ad2-8504-20790a7d1f9f
Faulting package full name: windows.immersivecontrolpanel_10.0.6.1000_neutral_neutral_cw5n1h2txyewy
Faulting package-relative application ID: microsoft.windows.immersivecontrolpanel
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>100</Task>
<Opcode>0</Opcode>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2021-11-13T01:33:03.9524755Z" />
<EventRecordID>6300</EventRecordID>
<Correlation />
<Execution ProcessID="5728" ThreadID="0" />
<Channel>Application</Channel>
<Computer>IrvXPS8940</Computer>
<Security />
</System>
<EventData>
<Data>SystemSettings.exe</Data>
<Data>10.0.22000.120</Data>
<Data>27a6d211</Data>
<Data>SystemSettings.dll</Data>
<Data>10.0.22000.120</Data>
<Data>9799599e</Data>
<Data>c000041d</Data>
<Data>0000000000497c4a</Data>
<Data>5028</Data>
<Data>01d7d82e5e76989b</Data>
<Data>C:\Windows\ImmersiveControlPanel\SystemSettings.exe</Data>
<Data>C:\Windows\ImmersiveControlPanel\SystemSettings.dll</Data>
<Data>ac1e44f4-5500-4ad2-8504-20790a7d1f9f</Data>
<Data>windows.immersivecontrolpanel_10.0.6.1000_neutral_neutral_cw5n1h2txyewy</Data>
<Data>microsoft.windows.immersivecontrolpanel</Data>
</EventData>
</Event>

All other parts of Setting seems to work OK?

I have rebooted, run SFC and DISM with no errors. Still happens.

I am on V 21H2, OS Build 22000.318.

I think it was working fine a few days ago?
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell
    CPU
    i7 11700
    Motherboard
    Dell
    Memory
    16GB
    Graphics Card(s)
    RTX2060
    Sound Card
    Realtek/Nvidia
    Monitor(s) Displays
    Dell S3221QS
    Screen Resolution
    3840x2160
    Hard Drives
    512GB SSD, 1TB HDD
    PSU
    500W
    Case
    Dell
    Cooling
    Passive
    Keyboard
    Logitech MK540
    Mouse
    MK540
    Internet Speed
    400Mbps
    Browser
    Firefox
    Antivirus
    McAfee LiveSafe

FreeBooter

Well-known member
Power User
VIP
Local time
2:54 AM
Posts
914
Location
Adana
OS
Windows 11
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    HP Pavilion
    CPU
    AMD Ryzen 7 5700G
    Motherboard
    Erica6
    Memory
    Micron Technology DDR4-3200 16GB
    Graphics Card(s)
    NVIDIA GeForce RTX 3060
    Sound Card
    Realtek ALC671
    Monitor(s) Displays
    Samsung SyncMaster U28E590
    Screen Resolution
    3840 x 2160
    Hard Drives
    SAMSUNG MZVLQ1T0HALB-000H1

IrvSp

Member
Thread Starter
Local time
7:54 PM
Posts
7
OS
Windows 11
Did "Get-AppxPackage *windows.immersivecontrolpanel* | Reset-AppxPackage" and it didn't fix it.

Took off the RESET-APPXPACKAGE and it shows this:

============================
Name : windows.immersivecontrolpanel
Publisher : CN=Microsoft Windows, O=Microsoft Corporation, L=Redmond, S=Washington, C=US
Architecture : Neutral
ResourceId : neutral
Version : 10.0.6.1000
PackageFullName : windows.immersivecontrolpanel_10.0.6.1000_neutral_neutral_cw5n1h2txyewy
InstallLocation : C:\Windows\ImmersiveControlPanel
IsFramework : False
PackageFamilyName : windows.immersivecontrolpanel_cw5n1h2txyewy
PublisherId : cw5n1h2txyewy
IsResourcePackage : False
IsBundle : False
IsDevelopmentMode : False
NonRemovable : True
Dependencies : {Microsoft.VCLibs.140.00_14.0.30035.0_x64__8wekyb3d8bbwe,
Microsoft.UI.Xaml.CBS_2.62107.16001.0_x64__8wekyb3d8bbwe}
IsPartiallyStaged : False
SignatureKind : System
Status : Ok
===============================

Running the whole command shows a 'blue' screen area above but too quick to see.

Running reset part first and then the first part produces this:

=================
cmdlet Reset-AppxPackage at command pipeline position 1
Supply values for the following parameters:
Package: Get-AppxPackage *windows.immersivecontrolpanel*
reset-AppxPackage : Removal failed. Please contact your software vendor. (Exception from HRESULT: 0x80073CFA)
At line:1 char:1
+ reset-AppxPackage
+ ~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: :)) [Reset-AppxPackage], COMException
+ FullyQualifiedErrorId : System.Runtime.InteropServices.COMException,Microsoft.Windows.Appx.PackageManager.Comman
ds.ResetAppxPackageCommand

==================

This all started yesterday

Oh, in trying to capture the Event Viewer I discovered that the Snipping tool will not 'snip'. I can define the area, but it never shows up?

Capture.JPG

Those before 11/12 as other fails. W11 was upgraded from W10 on 11/6.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell
    CPU
    i7 11700
    Motherboard
    Dell
    Memory
    16GB
    Graphics Card(s)
    RTX2060
    Sound Card
    Realtek/Nvidia
    Monitor(s) Displays
    Dell S3221QS
    Screen Resolution
    3840x2160
    Hard Drives
    512GB SSD, 1TB HDD
    PSU
    500W
    Case
    Dell
    Cooling
    Passive
    Keyboard
    Logitech MK540
    Mouse
    MK540
    Internet Speed
    400Mbps
    Browser
    Firefox
    Antivirus
    McAfee LiveSafe

IrvSp

Member
Thread Starter
Local time
7:54 PM
Posts
7
OS
Windows 11
Fixed the Snipping too, had to uninstall it via PowerShell with this, get-appxpackage *Microsoft.ScreenSketch* | remove-appxpackage, then reboot and then use Get-AppXPackage *Microsoft.ScreenSketch* -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"} to reinstall it. I now works...
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell
    CPU
    i7 11700
    Motherboard
    Dell
    Memory
    16GB
    Graphics Card(s)
    RTX2060
    Sound Card
    Realtek/Nvidia
    Monitor(s) Displays
    Dell S3221QS
    Screen Resolution
    3840x2160
    Hard Drives
    512GB SSD, 1TB HDD
    PSU
    500W
    Case
    Dell
    Cooling
    Passive
    Keyboard
    Logitech MK540
    Mouse
    MK540
    Internet Speed
    400Mbps
    Browser
    Firefox
    Antivirus
    McAfee LiveSafe

IrvSp

Member
Thread Starter
Local time
7:54 PM
Posts
7
OS
Windows 11
I may be in some 'trouble' here.

Looking at my Update D/L's I see this and it is for the Killer Network adapter.

Capture.JPG

It isn't needed, so I removed it...

Could that be the cause?
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell
    CPU
    i7 11700
    Motherboard
    Dell
    Memory
    16GB
    Graphics Card(s)
    RTX2060
    Sound Card
    Realtek/Nvidia
    Monitor(s) Displays
    Dell S3221QS
    Screen Resolution
    3840x2160
    Hard Drives
    512GB SSD, 1TB HDD
    PSU
    500W
    Case
    Dell
    Cooling
    Passive
    Keyboard
    Logitech MK540
    Mouse
    MK540
    Internet Speed
    400Mbps
    Browser
    Firefox
    Antivirus
    McAfee LiveSafe

IrvSp

Member
Thread Starter
Local time
7:54 PM
Posts
7
OS
Windows 11
I do have Acronis True Image that did IMAGE the PC drives early on 11/12.

I just restored the the C: partition. The Snipping tool works fine, but I still can't see the Optional Updates as it still crashes.

Tried the link you posted again, applied it, and it still fails.
 

Attachments

  • Capture1.JPG
    Capture1.JPG
    118.6 KB · Views: 1

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell
    CPU
    i7 11700
    Motherboard
    Dell
    Memory
    16GB
    Graphics Card(s)
    RTX2060
    Sound Card
    Realtek/Nvidia
    Monitor(s) Displays
    Dell S3221QS
    Screen Resolution
    3840x2160
    Hard Drives
    512GB SSD, 1TB HDD
    PSU
    500W
    Case
    Dell
    Cooling
    Passive
    Keyboard
    Logitech MK540
    Mouse
    MK540
    Internet Speed
    400Mbps
    Browser
    Firefox
    Antivirus
    McAfee LiveSafe

rickhd

Member
Local time
7:54 PM
Posts
25
Location
Canada
OS
Windows 11
I have the same issue. Must be a bug that has never been fixed.

Log Name: Application
Source: Application Error
Date: 2021-11-13 10:24:21 AM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: AMD-Desktop
Description:
Faulting application name: SystemSettings.exe, version: 10.0.22000.346, time stamp: 0x27a6d211
Faulting module name: SystemSettings.dll, version: 10.0.22000.346, time stamp: 0xb213d95c
Exception code: 0xc0000005
Fault offset: 0x0000000000497c4a
Faulting process ID: 0x3684
Faulting application start time: 0x01d7d8a283124695
Faulting application path: C:\Windows\ImmersiveControlPanel\SystemSettings.exe
Faulting module path: C:\Windows\ImmersiveControlPanel\SystemSettings.dll
Report ID: 8bde643e-1733-4d7f-bdc3-8b2f923204b2
Faulting package full name: windows.immersivecontrolpanel_10.0.6.1000_neutral_neutral_cw5n1h2txyewy
Faulting package-relative application ID: microsoft.windows.immersivecontrolpanel
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>100</Task>
<Opcode>0</Opcode>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2021-11-13T15:24:21.0593445Z" />
<EventRecordID>7927</EventRecordID>
<Correlation />
<Execution ProcessID="23056" ThreadID="0" />
<Channel>Application</Channel>
<Computer>AMD-Desktop</Computer>
<Security />
</System>
<EventData>
<Data>SystemSettings.exe</Data>
<Data>10.0.22000.346</Data>
<Data>27a6d211</Data>
<Data>SystemSettings.dll</Data>
<Data>10.0.22000.346</Data>
<Data>b213d95c</Data>
<Data>c0000005</Data>
<Data>0000000000497c4a</Data>
<Data>3684</Data>
<Data>01d7d8a283124695</Data>
<Data>C:\Windows\ImmersiveControlPanel\SystemSettings.exe</Data>
<Data>C:\Windows\ImmersiveControlPanel\SystemSettings.dll</Data>
<Data>8bde643e-1733-4d7f-bdc3-8b2f923204b2</Data>
<Data>windows.immersivecontrolpanel_10.0.6.1000_neutral_neutral_cw5n1h2txyewy</Data>
<Data>microsoft.windows.immersivecontrolpanel</Data>
</EventData>
</Event>
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Asus Rog Strix B550-F
    CPU
    Ryzen 7 3700X
    Motherboard
    Asus
    Memory
    16GB
    Graphics Card(s)
    Geforce 1650
    Sound Card
    Realtek
    Monitor(s) Displays
    LG 23MP75
    Screen Resolution
    1920x1080
    Hard Drives
    Samsung 970 Pro
    Case
    Coolmaster
    Keyboard
    Logitech
    Mouse
    Logitech
    Internet Speed
    50
    Browser
    Edge
    Antivirus
    Microsoft

rickhd

Member
Local time
7:54 PM
Posts
25
Location
Canada
OS
Windows 11
If you search for optional updates click on View Optional Updates that link then it works fine.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Asus Rog Strix B550-F
    CPU
    Ryzen 7 3700X
    Motherboard
    Asus
    Memory
    16GB
    Graphics Card(s)
    Geforce 1650
    Sound Card
    Realtek
    Monitor(s) Displays
    LG 23MP75
    Screen Resolution
    1920x1080
    Hard Drives
    Samsung 970 Pro
    Case
    Coolmaster
    Keyboard
    Logitech
    Mouse
    Logitech
    Internet Speed
    50
    Browser
    Edge
    Antivirus
    Microsoft

IrvSp

Member
Thread Starter
Local time
7:54 PM
Posts
7
OS
Windows 11
If you search for optional updates click on View Optional Updates that link then it works fine.
Maybe I'm just beating myself up? Although the error appears to be the same, I can't open Optional Updates?

I used Acronis to restore from a week ago, still had the problem.

One before that, is W10... so I'll install that next. See if it works then? If it should, I'll need to rebuild some stuff I guess?

I couldn't find another instance of this problem with a Google search? Not many people hit by it?
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell
    CPU
    i7 11700
    Motherboard
    Dell
    Memory
    16GB
    Graphics Card(s)
    RTX2060
    Sound Card
    Realtek/Nvidia
    Monitor(s) Displays
    Dell S3221QS
    Screen Resolution
    3840x2160
    Hard Drives
    512GB SSD, 1TB HDD
    PSU
    500W
    Case
    Dell
    Cooling
    Passive
    Keyboard
    Logitech MK540
    Mouse
    MK540
    Internet Speed
    400Mbps
    Browser
    Firefox
    Antivirus
    McAfee LiveSafe

IrvSp

Member
Thread Starter
Local time
7:54 PM
Posts
7
OS
Windows 11

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell
    CPU
    i7 11700
    Motherboard
    Dell
    Memory
    16GB
    Graphics Card(s)
    RTX2060
    Sound Card
    Realtek/Nvidia
    Monitor(s) Displays
    Dell S3221QS
    Screen Resolution
    3840x2160
    Hard Drives
    512GB SSD, 1TB HDD
    PSU
    500W
    Case
    Dell
    Cooling
    Passive
    Keyboard
    Logitech MK540
    Mouse
    MK540
    Internet Speed
    400Mbps
    Browser
    Firefox
    Antivirus
    McAfee LiveSafe

rickhd

Member
Local time
7:54 PM
Posts
25
Location
Canada
OS
Windows 11
Just noticed it works on my laptop but not my desktop. Both had new installations.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Asus Rog Strix B550-F
    CPU
    Ryzen 7 3700X
    Motherboard
    Asus
    Memory
    16GB
    Graphics Card(s)
    Geforce 1650
    Sound Card
    Realtek
    Monitor(s) Displays
    LG 23MP75
    Screen Resolution
    1920x1080
    Hard Drives
    Samsung 970 Pro
    Case
    Coolmaster
    Keyboard
    Logitech
    Mouse
    Logitech
    Internet Speed
    50
    Browser
    Edge
    Antivirus
    Microsoft

Bug locker

Active member
Local time
2:54 AM
Posts
104
Location
Athens
OS
Windows 11 Pro
I go into Settings Windows Update, Advanced Option, and I see in Optional Updates that 2 are available. I click on this and Settings collapses.
The same problem here. I guess is a general bug of Windows 11. I find a temporary solution that only works once: Before you open the "optional updates" or other setting at "Windows update" that does not open, run the Windows update. Then it will work only once. Repeat the same each time to avoid the problem.
 

My Computer

System One

  • OS
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    HP Pavilion 17 cd2205nw
    CPU
    Intel 113700H
    Memory
    16GB
    Graphics Card(s)
    NVIDIA RTX 3050 ti
    Screen Resolution
    1980x1020
    Hard Drives
    Micron 512GB
    Mouse
    Logitech
    Internet Speed
    100Mbs
    Browser
    Vivaldi , Edge
    Antivirus
    Norton 360
Top Bottom