Windows 11 Terrible Font Rendering - External Monitor


Sptz

Member
Local time
2:48 AM
Posts
2
OS
Windows 11
Hi everyone,

So, I've got a Zephyrus G15, the font rendering on the laptop's monitor is impeccable (1440p) but on my external monitor (G34WQC, 3440x1440) it looks absolutely disgusting. I've tried disabling and enabling font smoothing, turn cleartype off and on and it always looks wrong. I can't quite put my finger on it.

This is a fresh install by the way, all updated, latest nvidia drivers, monitor is running correctly on DP1.4 , 8-bit, RGB, etc etc.

Here's a few screenshots to demonstrate the issue.

1656161958828.png
1656162343759.png
1656162367337.png
2.png


3.png

4.png
Notice how the dashes aren't centered.

1656162013301.png

I know it may be hard to see but it just looks jagged and crappy to be honest. Don't really know what to do at this point. I remember it didn't look this bad in Windows 10.
 
Last edited:

My Computer

System One

  • OS
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    ASUS ROG Zephyrus G15 G503QS
    CPU
    AMD Ryzen 5900HS
    Memory
    32GB DDR4
    Graphics Card(s)
    RTX 3080
    Monitor(s) Displays
    Gigabyte G34WQC
    Screen Resolution
    3440x1440

Sptz

Member
Thread Starter
Local time
2:48 AM
Posts
2
OS
Windows 11
Here's laptop's monitor (2560x1440) compared to external (3440x1440)
4_2.png4.png

3_2.png3.png
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    ASUS ROG Zephyrus G15 G503QS
    CPU
    AMD Ryzen 5900HS
    Memory
    32GB DDR4
    Graphics Card(s)
    RTX 3080
    Monitor(s) Displays
    Gigabyte G34WQC
    Screen Resolution
    3440x1440

glasskuter

Well-known member
Pro User
VIP
Local time
8:48 PM
Posts
2,575
Location
The Lone Star State of Texas
OS
Windows 11 Pro 22H2 22621.382
Welcome to the forum.
You might play around with these settings to see if it makes any difference.
Settings-system-about-advanced system settings-change it to 'adjust for best appearance', restart. You might also try 'let windows decide'. If that doesn't make any difference you can also click settings under performance-check 'smooth edges of screen fonts'. Maybe one will show an improvement over the other. I believe you do have to restart for changes to take effect.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 22H2 22621.382
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 m.2 2230-256+1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 21H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
Top Bottom