Windows won't sleep - A file has been opened across the network - VeraCrypt


pokeefe0001

Member
Local time
6:33 AM
Posts
55
Location
Pacific Northwest USA
OS
Windows 11
Win11 Pro 21H2 build 22000.556

I use VeraCrypt and have options set to dismount VeraCrypt mounted drives when Windows enters sleep. This used to work (since early Win10 days), but for the past few months (on both Win10 21H1 and Win11 21H2) having the VeraCrypt container mounted prevents sleep. "Powercfg -requests" shows
Code:
A file has been opened across the network. File name: [\OF-Pub-NAS1\Public\Networked VC Container] Process ID: [4]
Unfortunately, I do not know if this condition was raised back when thos problem did not exist.

BTW, the public share is always mounted whenever anybody is logged on and does not raise this condition.

Is there any way to get Windows to ignore this condition and sleep anyway? I'm having no luck trying to fix it from the VeraCrypt side.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Microsoft
    CPU
    Intel Core i5-8400
    Motherboard
    ASUS PRIME H370-PLUS
    Memory
    16GB
    Graphics Card(s)
    Intel UHD Graphics 630
    Sound Card
    On board
    Monitor(s) Displays
    Samsung SyncMaster 2043BWX
    Screen Resolution
    1680 x 1050
    Hard Drives
    Samsung SSD 850 256GB
    WDC 1TB NVMe
    WD 3TB external USB drive
    PSU
    I don't remember
    Case
    Fractal Design R4
    Cooling
    Air CPU + 2 case fans
    Keyboard
    DAS S Pro (Cherry Brown)
    Mouse
    Logitech USB of some sort

glasskuter

Well-known member
Power User
VIP
Local time
8:33 AM
Posts
1,885
Location
The Lone Star State of Texas
OS
Windows 11 Pro 21H2 22000.778
If you have 11 Pro, I believe you can edit group policy to do what you want.
Open group policy>Computer Configuration >Administrative templates>System>Power Management>Sleep Settings
Edit policy "Allow Auto Sleep With Open Network Files (plugged in)"
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 21H2 22000.778
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900
    Memory
    32 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 m.2 2230-256+1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 21H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    standard
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Antivirus
    Defender+MWB Premium

pokeefe0001

Member
Thread Starter
Local time
6:33 AM
Posts
55
Location
Pacific Northwest USA
OS
Windows 11
If you have 11 Pro, I believe you can edit group policy to do what you want.
Open group policy>Computer Configuration >Administrative templates>System>Power Management>Sleep Settings
Edit policy "Allow Auto Sleep With Open Network Files (plugged in)"
I should have mentioned that that was the first thing I checked. And I did have it set.

I found a VeraCrypt setting that may fix the problem but haven't had time to experiment:
"Mount volumes as removable media".
I don't remember needing that before, but I'm trying it now.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Microsoft
    CPU
    Intel Core i5-8400
    Motherboard
    ASUS PRIME H370-PLUS
    Memory
    16GB
    Graphics Card(s)
    Intel UHD Graphics 630
    Sound Card
    On board
    Monitor(s) Displays
    Samsung SyncMaster 2043BWX
    Screen Resolution
    1680 x 1050
    Hard Drives
    Samsung SSD 850 256GB
    WDC 1TB NVMe
    WD 3TB external USB drive
    PSU
    I don't remember
    Case
    Fractal Design R4
    Cooling
    Air CPU + 2 case fans
    Keyboard
    DAS S Pro (Cherry Brown)
    Mouse
    Logitech USB of some sort
Top Bottom