Edge Address Bar Search


Nzyme

Member
Local time
5:37 PM
Posts
10
OS
Windows 11 Pro (64 bit)
Hello, I recently installed a fresh copy of Windows 11 (23H2) and have installed all the latest updates till date.

I configured the Edge browser settings such that the search results are retrieved from the Google search engine for all the search queries made on the address bar. This is seen in Screenshot 1.

I also have the search suggestions and filters configured as seen in Screenshot 2.

Now coming to my query. When I start typing the first few characters of the name of a movie (say for ex: I start typing "The Equ" to search for the movie "The Equalizer") in Chrome, it shows me the suggestion as seen in the Screenshot 3. As you can see, the search suggestions also show the tiny movie poster, year, etc. in the search suggestions.

When I start typing the same characters ("The Equ") in the address bar in Edge, it does not give me the same kind of suggestions. This is seen in Screenshot 4.

How can I get the same kind of suggestions in Edge?
 
Windows Build/Version
23H2

Attachments

  • Screenshot 1.jpg
    Screenshot 1.jpg
    30 KB · Views: 3
  • Screenshot 2.jpg
    Screenshot 2.jpg
    26.7 KB · Views: 1
  • Screenshot 3.jpg
    Screenshot 3.jpg
    8.9 KB · Views: 2
  • Screenshot 4.jpg
    Screenshot 4.jpg
    22.7 KB · Views: 3

My Computer

System One

  • OS
    Windows 11 Pro (64 bit)
    Computer type
    PC/Desktop
Welcom to the forum. Try this. In Edge Click 3 dots> Settings>Privacy Search & Services>Address bar & search>Search suggestions & filters>toggle on "Show me search suggestions using my typed characters"
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3296
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 +256gb ssd+512 gb usb m.2 sata
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
Welcom to the forum. Try this. In Edge Click 3 dots> Settings>Privacy Search & Services>Address bar & search>Search suggestions & filters>toggle on "Show me search suggestions using my typed characters"
That setting is already on. See my Screenshot 2 in my first post.
 

My Computer

System One

  • OS
    Windows 11 Pro (64 bit)
    Computer type
    PC/Desktop
Things to try:
1. Make sure you have no corrupt system files that is causing this problem. Open a command prompt as administrator and type sfc /scannow
Pay attention to the scan results to see if SFC found anything it could not repair. If it found corruption it could not fix followup with this command (note the spaces)
dism /online /cleanup-image /restorehealth
Restart computer
(Note-you can follow up with another sfc /scannow command to make sure that dism repaired the files)

2. Disable your extensions to see if Edge works correctly.

3. Repair Edge.
  1. Make sure that your browser is closed and that you have administrative rights to your device. If multiple users are logged in your device, make sure Microsoft Edge is closed for all users.
  2. Go to Start > Settings > Apps > Apps & features.
  3. In the apps list, select Microsoft Edge and then select Modify. If the Modify command isn't available, it's likely that your organization installed Microsoft Edge and is managing it for you. For help, contact your system administrator.
  4. When prompted Do you want to allow this app to make changes to your device?, select Yes.
  5. Make sure you're connected to internet and select Repair. Your browser data and settings shouldn't be affected by repair

4. See if Edge works as expected usig another user account.

5. If Edge is messed up in all user accounts, repair install 11. Repair Install Windows 11 with an In-place Upgrade Tutorial
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3296
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 +256gb ssd+512 gb usb m.2 sata
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
That setting is already on. See my Screenshot 2 in my first post.
Edge probably won't let you see enhanced suggestions unless you use Bing as the default! 🤷‍♂️
 

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    ASUS ROG Strix
  • Operating System
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    ASUS VivoBook
Things to try:
1. Make sure you have no corrupt system files that is causing this problem. Open a command prompt as administrator and type sfc /scannow
Pay attention to the scan results to see if SFC found anything it could not repair. If it found corruption it could not fix followup with this command (note the spaces)
dism /online /cleanup-image /restorehealth
Restart computer
(Note-you can follow up with another sfc /scannow command to make sure that dism repaired the files)

2. Disable your extensions to see if Edge works correctly.

3. Repair Edge.
  1. Make sure that your browser is closed and that you have administrative rights to your device. If multiple users are logged in your device, make sure Microsoft Edge is closed for all users.
  2. Go to Start > Settings > Apps > Apps & features.
  3. In the apps list, select Microsoft Edge and then select Modify. If the Modify command isn't available, it's likely that your organization installed Microsoft Edge and is managing it for you. For help, contact your system administrator.
  4. When prompted Do you want to allow this app to make changes to your device?, select Yes.
  5. Make sure you're connected to internet and select Repair. Your browser data and settings shouldn't be affected by repair

4. See if Edge works as expected usig another user account.

5. If Edge is messed up in all user accounts, repair install 11. Repair Install Windows 11 with an In-place Upgrade Tutorial
Does it work for you with Google as the search engine? Can you check?
 

My Computer

System One

  • OS
    Windows 11 Pro (64 bit)
    Computer type
    PC/Desktop
Edge probably won't let you see enhanced suggestions unless you use Bing as the default! 🤷‍♂️
Looks like it. Switched back to Bing and it works.
 

My Computer

System One

  • OS
    Windows 11 Pro (64 bit)
    Computer type
    PC/Desktop
That's crazy. I use Google and it works fine for me. The gremlins at at work again.
 

Attachments

  • Screenshot 2024-01-25 104403.png
    Screenshot 2024-01-25 104403.png
    100.7 KB · Views: 2

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3296
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 +256gb ssd+512 gb usb m.2 sata
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
@Edwin No. No icons at all. I don't use Edge so was not even aware of them.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3296
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 +256gb ssd+512 gb usb m.2 sata
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3296
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 +256gb ssd+512 gb usb m.2 sata
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium

Latest Support Threads

Back
Top Bottom