Storage Spaces assistance


malchior43

Well-known member
Local time
11:08 PM
Posts
19
OS
Win Server 2025 Insiders (currently 26227)
So,

Posted here, even though the OS is Win Server 2025. It's basically W11 for grownups, and the same issue occures on W11 and on WServer2022.

I got the setup below. I cannot get (1) any of the storage spaces to auto-mount on boot; and (2) the NAS-based VHDX to auto-mount on boot. Help will be appreciated!

Setup:

Computer:
Dell T7910 with 2x E5-2699v4 (44 cores, 88+ threads)
192 GB RAM (ECC)
5 NVME SSD (4x2TB, 1x4TB)
15 SAS 3.8TB drives with Microchip (Adaptec) RAID card (not part of the problem)
2 ConnectX-6 cards, each with 2 ports, 1 Realtek 2.5GB NIC (don't laugh :) , for a specific purpose)
Intel ARC display cards, to my sorrow, and
Win Server 2025 v 26227 installed on one of the SSDs, booting (EFI part) from another SSD, with
HyperV Installed (which may well be relevant)

NAS
QNAP TVS-h474
4 x 18TB Drives
2x built in 2.5GB cards
1x USB-adapter card

Network
Riverbed SteelConnect SDI-S24 switch with
24x 1GB Ethernet cable ports
4x 10GB STP+ ports and
JTCom 2.5GB Hub with 2 STP+ ports

Connection: Computer <--> Switch using 2x 10GB Fibers
Switch 10GB <--> JTCom (2.5GB) <--> QNAP using 1GB cables

Setup:
There are two enviornments, both experiencing the same no-automount issue

Env I
3 of the SSDs have 1TB partitions, formated NTFS
On each of these partitions, there is a VHDx file (Hd0,1,2) Which have been added to a Storage Pool ('Pooly')
In Turn
Pooly has two virtual disks, Pool-2 and Pool-3. Both thin.
Pool-2 is a Mirror set and
Pool-3 in a Parity
On each of Pool-2,3 there is one volume, formatted NTFS

Env II
On the QNAP there is a share "\\QNAP\VMs" on top of which there is a VHDx (QNAPHD.vhdx).
The VHDx has one volume.


Normal operation:
The three VHDx files are mounted, the machine sees the drives, the pool, and the volumes. Life is good.
The QNAP VHDx is mounted, the machine sees the volume on top of it. Life is slow, but good.


Problem
Upon reboot, the 3xVHDx local files are not mounted; the machine does not see them, the pool or the volumes.
Similarly, the machine does not see the QNAP vhdx (as it is not mounted) and thus didnt see the volume.


Misc info which may be relevant, is this is windows, after all.
Neither the QNAP share, nor the 3 NVME partitions have a drive letter assigned. They are accessed via a path (D:\Disks\HDname).


Thank you for reading this and trying to help!
 
Windows Build/Version
26227

My Computer

System One

  • OS
    Win Server 2025 Insiders (currently 26227)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell T7910
    CPU
    2x E5-2699v4 (44 cores)
    Motherboard
    Dell
    Memory
    192GB
    Graphics Card(s)
    Arc 580
    Monitor(s) Displays
    3 x Samsung LU something or another, equivalent to Asus VG28UQL1
    Screen Resolution
    3x4k
    Hard Drives
    SSDs: (1) 3x SPCC "SPCCM.2PCIeSSD" (4TB) (2) PNY CS31400 (2TB) (3) Gigabyte-ASM2NE6 (1TB),
    PSU
    2x850W
    Case
    TT Tower 500
    Cooling
    6xIceberg Thermal IceGALE 120mm, 2xIceberg Thermal IceGALE 140MM, ThermalTake 360 CPU Cooler
    Keyboard
    2xMS Sculpt
    Mouse
    2xLogitech MX Master (2 and 3)
    Internet Speed
    1GB
    Browser
    Thorium
    Other Info
    Also 36TB SAN. And additional 15 SAS Drives
I found that pinning a shared folder to quick access solved this issue for me.
 

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Home built
    CPU
    Ryzen 3900x
    Motherboard
    Gigabyte Aorus Master x570 rel 1.0
    Memory
    32GB (2x16) @ 3600 MHz Corsair Vengeance LPX
    Graphics Card(s)
    Gigabyte Windforce RTX 2080
    Sound Card
    No separate sound card.
    Monitor(s) Displays
    Dell U2718Q
    Screen Resolution
    3840x2160
    Hard Drives
    1TB WD-Black SN850; 1TB Samsung Sata 850 Evo; 4 TB WD Blue Sata SA510 2.5''; 4TB Samsung Sata SSD 870 EVO 2.5".
    PSU
    Be Quiet Dark Power Pro 11 750W
    Case
    Lian Li PC-8FIB
    Cooling
    CPU: Noctua NH-U12A; Case: BeQuiet + Lian Li fans.
    Keyboard
    Steelseries Apex 7 brown keys.
    Mouse
    Logitech (wired) G403
    Internet Speed
    940 Mb/s down; 105 Mb/s up
    Browser
    Edge (Chromium)
    Antivirus
    Eset Internet Security
    Other Info
    Pioneer blu-ray optical drive.
  • Operating System
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    Dell Inspiron 7373 2-in-1
    CPU
    Intel Core i7 8th Generation
    Motherboard
    Dell 0HG1FH (U3E1)
    Memory
    8GB DDR4
    Graphics card(s)
    Intel UHD Graphics 620 (Dell)
    Sound Card
    Realtek Audio (on motherboard)
    Monitor(s) Displays
    Touch screen generic monitor
    Screen Resolution
    1920x1080
    Hard Drives
    256GB Micron SATA SSD.
    Internet Speed
    400Mb/s (Wifi)
    Browser
    Edge Chromium
    Antivirus
    Eset Internet Security
    Other Info
    Dell says this system is not Windows 11 capable, but Microsoft seems happy with it.
Interesting @Senecio . Giving that a try.
 

My Computer

System One

  • OS
    Win Server 2025 Insiders (currently 26227)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell T7910
    CPU
    2x E5-2699v4 (44 cores)
    Motherboard
    Dell
    Memory
    192GB
    Graphics Card(s)
    Arc 580
    Monitor(s) Displays
    3 x Samsung LU something or another, equivalent to Asus VG28UQL1
    Screen Resolution
    3x4k
    Hard Drives
    SSDs: (1) 3x SPCC "SPCCM.2PCIeSSD" (4TB) (2) PNY CS31400 (2TB) (3) Gigabyte-ASM2NE6 (1TB),
    PSU
    2x850W
    Case
    TT Tower 500
    Cooling
    6xIceberg Thermal IceGALE 120mm, 2xIceberg Thermal IceGALE 140MM, ThermalTake 360 CPU Cooler
    Keyboard
    2xMS Sculpt
    Mouse
    2xLogitech MX Master (2 and 3)
    Internet Speed
    1GB
    Browser
    Thorium
    Other Info
    Also 36TB SAN. And additional 15 SAS Drives

Latest Support Threads

Back
Top Bottom