TPM and Secure Boot

maarkr

Member
Local time
8:33 AM
Posts
1
Before I try messing around with my BIOS, my Gigabyte Z390 UD mobo does offer secure boot (if I change CSM support from enabled to disabled) and also has PTT (which is the mobo software TPM). Would like to hear if anyone has changed their BIOS settings to these options without incident. Last thing I want is my desktop unable to work.
signed, chicken
 

My Computer

System One

  • Operating System
    10
    Computer type
    PC/Desktop
    CPU
    Intel Core i7-8700k
    Motherboard
    Gigabyte Z390 UD LGA1151
    Memory
    4x8 Corsair Vengeance
    Graphics Card(s)
    NVidia GTX 1050Ti
    Sound Card
    MOTU Ultralite mk4
    Monitor(s) Displays
    2
    Hard Drives
    Samsung 980 SSD NVme 1Tb
    other drives
    PSU
    Corsair 750w

johnlgalt

Antidisestablishmentarianistentarianist
Power User
VIP
Local time
8:33 AM
Posts
1,922
Location
3rd Rock
The good thing about this is that - if it doesn't boot, change them back and you will (well, should) be fine.

But, that being said, they really should not affect the boot process of Windows 10. Several people have done it on a variety of machines using both Intel and AMD CPUs and motherboards from many different OEMs.

If you're worried (and you are right to be, it shows a good amount of insight on your part to ask first), make a full backup of your system, so that, just in case, something stupid DOES happen, you can change the settings back, and if it still doesn't boot, restore your backup for a working system.

Technically, you really should do this whenever you go messing around in the BIOS, anyway, so that's my advice - make the backup, then flip the switches and try it out.
 

My Computers

System One System Two

  • Operating System
    Windows 10 Pro X64
    Computer type
    PC/Desktop
    Manufacturer/Model
    HomeBrew
    CPU
    AMD Ryzen 9 3950X
    Motherboard
    MSI MEG X570 GODLIKE
    Memory
    4 * Corsair Vengeance 32 GB 3600 MHz
    Graphics Card(s)
    eVGA GeForce GTX 970 SSC ACX 2.0 (04G-P4-3979-KB)
    Sound Card
    Realtek® ALC1220 Codec
    Monitor(s) Displays
    2 * Lenovo LT2323pwA Widescreeen
    Screen Resolution
    2* 1920*1080
    Hard Drives
    3x Sabrent Rocket PCIe Gen4 NVMe M.2 1 TB SSD (SB-ROCKET-NVMe4-1TB)
    SanDisk Ultra SDSSDHII-960G-G25 960 GB SATA III SSD
    Crucial MX100 CT256MX100SSD1 256GB SATA III SSD
    2 * Seagate Barracuda 7200.12 ST31000528AS 1TB 7200 RPM --> RAID1
    PSU
    PC Power & Cooling’s Silencer Series 1050 Watt, 80 Plus Platinum
    Case
    Fractal Design Define 7 XL Dark ATX Full Tower Case
  • Operating System
    Windows 10 x64 Pro build 21H1
    Computer type
    Laptop
    Manufacturer/Model
    Dell Latitude E5470
    CPU
    Intel(R) Core(TM) i5-6300U CPU @ 2.40GHz, 2501 Mhz, 2 Core(s), 4 Logical Processor(s)
    Motherboard
    Dell
    Memory
    16 GB
    Graphics card(s)
    Intel(R) HD Graphics 520
    Sound Card
    Intel(R) HD Graphics 520 + RealTek Audio
    Monitor(s) Displays
    Dell laptop display 15"
    Screen Resolution
    1920 * 1080
    Hard Drives
    Toshiba 128GB M.2 22300 drive
    INTEL Cherryvill 520 Series SSDSC2CW180A 180 GB SATA III SSD
    PSU
    Dell
    Case
    Dell
    Cooling
    Dell
    Mouse
    Logitech MX Master (shared) | Dell TouchPad
    Keyboard
    Dell
    Internet Speed
    AT&T LightSpeed Gigabit Duplex
    Browser
    Edge Chromium | Chrome | Firefox Nightly | Brave
    Antivirus
    Defender + MB4

Ghot

Well-known member
Power User
VIP
Local time
8:33 AM
Posts
1,259
Location
PA, USA
Before I try messing around with my BIOS, my Gigabyte Z390 UD mobo does offer secure boot (if I change CSM support from enabled to disabled) and also has PTT (which is the mobo software TPM). Would like to hear if anyone has changed their BIOS settings to these options without incident. Last thing I want is my desktop unable to work.
signed, chicken


As John mentioned... most BIOS settings can just be returned to their previous settings if problems occur.
Most modern BIOS' also have a section where you can save your BIOS settings to a profile, and load them from a previous profile.

Last, but by no means least... use some good backup software like Macrium Reflect.
It won't help if you destroy your BIOS, but it will save the day if you inadvertently corrupt Windows.
Macrium's bootable rescue media, has a "Fix Boot Problems" tool, which fixes a lot of boot problems.

 

My Computers

System One System Two

  • Operating System
    Win 10 Home 10.0.22000.282 (x64)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot® [May 2020]
    CPU
    AMD Ryzen 7 3700X
    Motherboard
    Asus Pro WS X570-ACE
    Memory
    G.Skill (F4-3200C14D-16GTZKW)
    Graphics Card(s)
    EVGA RTX 2070 (08G-P4-2171-KR)
    Sound Card
    (onboard) Realtek ALC1220P / ALC S1220A
    Monitor(s) Displays
    Dell U3011 30"
    Screen Resolution
    2560 x 1600
    Hard Drives
    Samsung 860 EVO 500GB,
    WD 4TB Black FZBX - SATA III,
    WD 8TB Black FZBX - SATA III,
    LG GH22LS30 CD/DVD Burner
    PSU
    PC Power & Cooling 750W Quad EPS12V
    Case
    COOLER MASTER ATCS 840 Full Tower
    Cooling
    CM Hyper 212 EVO (push/pull)
    Keyboard
    Ducky DK9008 Shine II Blue LED
    Mouse
    Logitech Optical M-100
    Internet Speed
    100/100
    Browser
    Firefox (latest)
    Antivirus
    Bitdefender Internet Security 2020
    Other Info
    Speakers: Klipsch Pro Media 2.1
  • Operating System
    Windows XP Pro 32bit w/SP3
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot®
    CPU
    AMD Athlon 64 X2 5000+ (OC'd @ 3.2Ghz)
    Motherboard
    ASUS M2N32-SLI Deluxe Wireless Edition
    Memory
    TWIN2X2048-6400C4DHX (2 x 1GB, DDR2 800)
    Graphics card(s)
    EVGA 256-P2-N758-TR GeForce 8600GT SSC
    Sound Card
    Onboard
    Monitor(s) Displays
    ViewSonic G90FB Black 19" Professional (CRT)
    Screen Resolution
    up to 2048 x 1536
    Hard Drives
    WD 36GB 10,000rpm Raptor SATA
    Seagate 80GB 7200rpm SATA
    Lite-On LTR-52246S CD/RW
    Lite-On LH-18A1P CD/DVD Burner
    PSU
    PC Power & Cooling Silencer 750 Quad EPS12V
    Case
    Generic Beige case, 80mm fans
    Cooling
    ZALMAN 9500A 92mm CPU Cooler
    Mouse
    Logitech Optical M-BT96a
    Keyboard
    Logitech Classic Keybooard 200
    Internet Speed
    100/100
    Browser
    Firefox 3.x ??
    Antivirus
    Symantec (Norton)
    Other Info
    Still assembled, still runs. Haven't turned it on for 13 years?

    http://www.xtremesystems.org/forums/showthread.php?183088-5000-B-E-on-M2N32-SLI-Dlx-Overclocked&p=2891724#post2891724

johnlgalt

Antidisestablishmentarianistentarianist
Power User
VIP
Local time
8:33 AM
Posts
1,922
Location
3rd Rock
but it will save the day if you inadvertently corrupt Windows.

Or, as is more often the case, it corrupts itself.....
 

My Computers

System One System Two

  • Operating System
    Windows 10 Pro X64
    Computer type
    PC/Desktop
    Manufacturer/Model
    HomeBrew
    CPU
    AMD Ryzen 9 3950X
    Motherboard
    MSI MEG X570 GODLIKE
    Memory
    4 * Corsair Vengeance 32 GB 3600 MHz
    Graphics Card(s)
    eVGA GeForce GTX 970 SSC ACX 2.0 (04G-P4-3979-KB)
    Sound Card
    Realtek® ALC1220 Codec
    Monitor(s) Displays
    2 * Lenovo LT2323pwA Widescreeen
    Screen Resolution
    2* 1920*1080
    Hard Drives
    3x Sabrent Rocket PCIe Gen4 NVMe M.2 1 TB SSD (SB-ROCKET-NVMe4-1TB)
    SanDisk Ultra SDSSDHII-960G-G25 960 GB SATA III SSD
    Crucial MX100 CT256MX100SSD1 256GB SATA III SSD
    2 * Seagate Barracuda 7200.12 ST31000528AS 1TB 7200 RPM --> RAID1
    PSU
    PC Power & Cooling’s Silencer Series 1050 Watt, 80 Plus Platinum
    Case
    Fractal Design Define 7 XL Dark ATX Full Tower Case
  • Operating System
    Windows 10 x64 Pro build 21H1
    Computer type
    Laptop
    Manufacturer/Model
    Dell Latitude E5470
    CPU
    Intel(R) Core(TM) i5-6300U CPU @ 2.40GHz, 2501 Mhz, 2 Core(s), 4 Logical Processor(s)
    Motherboard
    Dell
    Memory
    16 GB
    Graphics card(s)
    Intel(R) HD Graphics 520
    Sound Card
    Intel(R) HD Graphics 520 + RealTek Audio
    Monitor(s) Displays
    Dell laptop display 15"
    Screen Resolution
    1920 * 1080
    Hard Drives
    Toshiba 128GB M.2 22300 drive
    INTEL Cherryvill 520 Series SSDSC2CW180A 180 GB SATA III SSD
    PSU
    Dell
    Case
    Dell
    Cooling
    Dell
    Mouse
    Logitech MX Master (shared) | Dell TouchPad
    Keyboard
    Dell
    Internet Speed
    AT&T LightSpeed Gigabit Duplex
    Browser
    Edge Chromium | Chrome | Firefox Nightly | Brave
    Antivirus
    Defender + MB4

RFS

Member
VIP
Local time
1:33 PM
Posts
25
I have a Gigabyte Z370P motherboard which also offers secure boot and PTT for the TPM 2.0 function. Decided to enable it and see what happens. It now passes the Windows 11 test and in device manager I can see that TPM 2.0 is enabled.

But then I found I no longer got the BIOS splash screen when I booed. Concerned about this I tried to enter BIOS by restarting and tapping the delete key. All I got was a blank screen. Rebooting takes it into Windows with no problem but BIOS access is gone.

Thought about it for a while then began to suspect a graphics issue. The MB has built-in graphics but I've installed a Nvidia card. Just a basic card because I had some problems early days and the card's performance is not really much better than the onboard one. It's just a GT 710. So I tried plugging the HDMI cable into this instead whereupon the BIOS splash screen appears and I can now change things again. Phew!

So I've now decided to remove the card as it's not really needed.

Just wondering whether turning on PTT is causing the BIOS firmware to only use the on-board graphics?
 

My Computer

System One

  • Operating System
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Self-build
    CPU
    Intel I3-8100
    Motherboard
    Gigabyte Z370 D3
    Memory
    8 GB
    Graphics Card(s)
    Intel integrated
    Monitor(s) Displays
    Philips 27 inch
    Screen Resolution
    1920x1080
    Hard Drives
    Samsung 960 SSD 256 Gb
    Seagate 2 Tb HDD
    PSU
    ATX 450W
    Keyboard
    Logitech
    Mouse
    Logitech Wireless
    Internet Speed
    150 Mb FTTP
    Browser
    Edge
    Antivirus
    Windows Defender

Ghot

Well-known member
Power User
VIP
Local time
8:33 AM
Posts
1,259
Location
PA, USA
@RFS


Just go into the BIOS on the BIOS tab and disable Fast Boot. Your manual says it's supposed to be disabled by default. That will give you the Splash screen back. I had the same problem. :)


Btw... disabling Fast Boot, didn't slow anything down for me.
And I don't have any onboard graphics (motherboard or CPU)
 

My Computers

System One System Two

  • Operating System
    Win 10 Home 10.0.22000.282 (x64)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot® [May 2020]
    CPU
    AMD Ryzen 7 3700X
    Motherboard
    Asus Pro WS X570-ACE
    Memory
    G.Skill (F4-3200C14D-16GTZKW)
    Graphics Card(s)
    EVGA RTX 2070 (08G-P4-2171-KR)
    Sound Card
    (onboard) Realtek ALC1220P / ALC S1220A
    Monitor(s) Displays
    Dell U3011 30"
    Screen Resolution
    2560 x 1600
    Hard Drives
    Samsung 860 EVO 500GB,
    WD 4TB Black FZBX - SATA III,
    WD 8TB Black FZBX - SATA III,
    LG GH22LS30 CD/DVD Burner
    PSU
    PC Power & Cooling 750W Quad EPS12V
    Case
    COOLER MASTER ATCS 840 Full Tower
    Cooling
    CM Hyper 212 EVO (push/pull)
    Keyboard
    Ducky DK9008 Shine II Blue LED
    Mouse
    Logitech Optical M-100
    Internet Speed
    100/100
    Browser
    Firefox (latest)
    Antivirus
    Bitdefender Internet Security 2020
    Other Info
    Speakers: Klipsch Pro Media 2.1
  • Operating System
    Windows XP Pro 32bit w/SP3
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot®
    CPU
    AMD Athlon 64 X2 5000+ (OC'd @ 3.2Ghz)
    Motherboard
    ASUS M2N32-SLI Deluxe Wireless Edition
    Memory
    TWIN2X2048-6400C4DHX (2 x 1GB, DDR2 800)
    Graphics card(s)
    EVGA 256-P2-N758-TR GeForce 8600GT SSC
    Sound Card
    Onboard
    Monitor(s) Displays
    ViewSonic G90FB Black 19" Professional (CRT)
    Screen Resolution
    up to 2048 x 1536
    Hard Drives
    WD 36GB 10,000rpm Raptor SATA
    Seagate 80GB 7200rpm SATA
    Lite-On LTR-52246S CD/RW
    Lite-On LH-18A1P CD/DVD Burner
    PSU
    PC Power & Cooling Silencer 750 Quad EPS12V
    Case
    Generic Beige case, 80mm fans
    Cooling
    ZALMAN 9500A 92mm CPU Cooler
    Mouse
    Logitech Optical M-BT96a
    Keyboard
    Logitech Classic Keybooard 200
    Internet Speed
    100/100
    Browser
    Firefox 3.x ??
    Antivirus
    Symantec (Norton)
    Other Info
    Still assembled, still runs. Haven't turned it on for 13 years?

    http://www.xtremesystems.org/forums/showthread.php?183088-5000-B-E-on-M2N32-SLI-Dlx-Overclocked&p=2891724#post2891724

RFS

Member
VIP
Local time
1:33 PM
Posts
25
I have Fast Boot is disabled and it's always been like that.
 

My Computer

System One

  • Operating System
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Self-build
    CPU
    Intel I3-8100
    Motherboard
    Gigabyte Z370 D3
    Memory
    8 GB
    Graphics Card(s)
    Intel integrated
    Monitor(s) Displays
    Philips 27 inch
    Screen Resolution
    1920x1080
    Hard Drives
    Samsung 960 SSD 256 Gb
    Seagate 2 Tb HDD
    PSU
    ATX 450W
    Keyboard
    Logitech
    Mouse
    Logitech Wireless
    Internet Speed
    150 Mb FTTP
    Browser
    Edge
    Antivirus
    Windows Defender

Ghot

Well-known member
Power User
VIP
Local time
8:33 AM
Posts
1,259
Location
PA, USA
I have Fast Boot is disabled and it's always been like that.



Then I dunno. When I turned ON my Firmware TPM or Secure Boot... for some reason it Disabled Fast Boot and I lost my Splash Screen. But I'm on an AMD x570 motherboard.


This is what I'm referring to when I say Splash Screen...


IMG_0752.png
 

My Computers

System One System Two

  • Operating System
    Win 10 Home 10.0.22000.282 (x64)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot® [May 2020]
    CPU
    AMD Ryzen 7 3700X
    Motherboard
    Asus Pro WS X570-ACE
    Memory
    G.Skill (F4-3200C14D-16GTZKW)
    Graphics Card(s)
    EVGA RTX 2070 (08G-P4-2171-KR)
    Sound Card
    (onboard) Realtek ALC1220P / ALC S1220A
    Monitor(s) Displays
    Dell U3011 30"
    Screen Resolution
    2560 x 1600
    Hard Drives
    Samsung 860 EVO 500GB,
    WD 4TB Black FZBX - SATA III,
    WD 8TB Black FZBX - SATA III,
    LG GH22LS30 CD/DVD Burner
    PSU
    PC Power & Cooling 750W Quad EPS12V
    Case
    COOLER MASTER ATCS 840 Full Tower
    Cooling
    CM Hyper 212 EVO (push/pull)
    Keyboard
    Ducky DK9008 Shine II Blue LED
    Mouse
    Logitech Optical M-100
    Internet Speed
    100/100
    Browser
    Firefox (latest)
    Antivirus
    Bitdefender Internet Security 2020
    Other Info
    Speakers: Klipsch Pro Media 2.1
  • Operating System
    Windows XP Pro 32bit w/SP3
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot®
    CPU
    AMD Athlon 64 X2 5000+ (OC'd @ 3.2Ghz)
    Motherboard
    ASUS M2N32-SLI Deluxe Wireless Edition
    Memory
    TWIN2X2048-6400C4DHX (2 x 1GB, DDR2 800)
    Graphics card(s)
    EVGA 256-P2-N758-TR GeForce 8600GT SSC
    Sound Card
    Onboard
    Monitor(s) Displays
    ViewSonic G90FB Black 19" Professional (CRT)
    Screen Resolution
    up to 2048 x 1536
    Hard Drives
    WD 36GB 10,000rpm Raptor SATA
    Seagate 80GB 7200rpm SATA
    Lite-On LTR-52246S CD/RW
    Lite-On LH-18A1P CD/DVD Burner
    PSU
    PC Power & Cooling Silencer 750 Quad EPS12V
    Case
    Generic Beige case, 80mm fans
    Cooling
    ZALMAN 9500A 92mm CPU Cooler
    Mouse
    Logitech Optical M-BT96a
    Keyboard
    Logitech Classic Keybooard 200
    Internet Speed
    100/100
    Browser
    Firefox 3.x ??
    Antivirus
    Symantec (Norton)
    Other Info
    Still assembled, still runs. Haven't turned it on for 13 years?

    http://www.xtremesystems.org/forums/showthread.php?183088-5000-B-E-on-M2N32-SLI-Dlx-Overclocked&p=2891724#post2891724

A Guy

Righteous Dude
Power User
VIP
Local time
5:33 AM
Posts
555
Location
No matter where you go, there you are
Do you have multiple monitors attached? Mine shows the Post (and Safe Mode) on my TV which is connected to the IGPU

A Guy
 

My Computers

System One System Two

  • Operating System
    Windows 10 Home x64
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom
    CPU
    INTEL Core i5-11400
    Motherboard
    ASUS PRIME H570-PLUS
    Memory
    KINGSTON HyperX Fury Black DDR4 16GB (2 x 8GB) 3200MHz, CL16
    Graphics Card(s)
    EVGA GeForce GTX 750 Superclocked 1GB 128-Bit GDDR5
    Monitor(s) Displays
    LG 32MA68HY 32" IPS
    Screen Resolution
    1920 x 1080
    Hard Drives
    SAMSUNG 250GB 970 EVO Plus NVMe, M.2 SSD, Crucial 250GB MX500, SEAGATE 500GB Barracuda® 7200.12, SATA 3 Gb/s, 7200 RPM, 16MB cache
    PSU
    CORSAIR RM550x 80 PLUS Gold 550W
    Case
    ANTEC P10 FLUX
    Cooling
    be quiet! Pure Rock 2, 5 x 120 mm Case Fans
    Internet Speed
    480 + Mbps Up/ 12+ Mbps Down
    Browser
    Vivaldi Snapshot
    Antivirus
    Avast
  • Operating System
    Windows 10 Home x64
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom
    CPU
    Intel Core i5-750
    Motherboard
    ASUS P7P55D
    Memory
    Kingston HyperX Fury Black 8GB (2x4GB) DDR3-1600MHz CL8
    Graphics card(s)
    MSI GeForce GT 240 N240GT-MD1G/D5 1 GB DDR5
    Monitor(s) Displays
    LG 32MA68HY 32" IPS
    Screen Resolution
    1980x1040
    Hard Drives
    Samsung Electronics 840 EVO 120GB, SEAGATE 500GB Barracuda® 7200.12, SATA 3 Gb/s, 7200 RPM, 16MB cache
    PSU
    Antec TruePower New TP-550 550W
    Case
    Antec 300
    Cooling
    Cooler Master Hyper 212+, 4 Noctua NF-P12 120mm, 1 Noctua NF-P14 FLX
    Internet Speed
    480+ Mbps Down/12+Mbps Up
    Browser
    Vivaldi Snapshot
    Antivirus
    Avast

RFS

Member
VIP
Local time
1:33 PM
Posts
25
I don't have multiple monitors but both the Nvidia and Intel graphics were enabled and the one screen plugged into the Nvidia. Moving the screen to the Intel graphics port was all I did. Couldn't otherwise have got into the BIOS after enabling PTT.
 

My Computer

System One

  • Operating System
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Self-build
    CPU
    Intel I3-8100
    Motherboard
    Gigabyte Z370 D3
    Memory
    8 GB
    Graphics Card(s)
    Intel integrated
    Monitor(s) Displays
    Philips 27 inch
    Screen Resolution
    1920x1080
    Hard Drives
    Samsung 960 SSD 256 Gb
    Seagate 2 Tb HDD
    PSU
    ATX 450W
    Keyboard
    Logitech
    Mouse
    Logitech Wireless
    Internet Speed
    150 Mb FTTP
    Browser
    Edge
    Antivirus
    Windows Defender

johnlgalt

Antidisestablishmentarianistentarianist
Power User
VIP
Local time
8:33 AM
Posts
1,922
Location
3rd Rock
On my MSI X570 mobo I have the option (that says something along the lines of) enable the external or onboard Graphics card, with auto being a third setting (Last I looked at it was several months ago).

I can try to boot into the UEFI setup and get the exact name, if you actually want to keep the discrete graphics card in there.
 

My Computers

System One System Two

  • Operating System
    Windows 10 Pro X64
    Computer type
    PC/Desktop
    Manufacturer/Model
    HomeBrew
    CPU
    AMD Ryzen 9 3950X
    Motherboard
    MSI MEG X570 GODLIKE
    Memory
    4 * Corsair Vengeance 32 GB 3600 MHz
    Graphics Card(s)
    eVGA GeForce GTX 970 SSC ACX 2.0 (04G-P4-3979-KB)
    Sound Card
    Realtek® ALC1220 Codec
    Monitor(s) Displays
    2 * Lenovo LT2323pwA Widescreeen
    Screen Resolution
    2* 1920*1080
    Hard Drives
    3x Sabrent Rocket PCIe Gen4 NVMe M.2 1 TB SSD (SB-ROCKET-NVMe4-1TB)
    SanDisk Ultra SDSSDHII-960G-G25 960 GB SATA III SSD
    Crucial MX100 CT256MX100SSD1 256GB SATA III SSD
    2 * Seagate Barracuda 7200.12 ST31000528AS 1TB 7200 RPM --> RAID1
    PSU
    PC Power & Cooling’s Silencer Series 1050 Watt, 80 Plus Platinum
    Case
    Fractal Design Define 7 XL Dark ATX Full Tower Case
  • Operating System
    Windows 10 x64 Pro build 21H1
    Computer type
    Laptop
    Manufacturer/Model
    Dell Latitude E5470
    CPU
    Intel(R) Core(TM) i5-6300U CPU @ 2.40GHz, 2501 Mhz, 2 Core(s), 4 Logical Processor(s)
    Motherboard
    Dell
    Memory
    16 GB
    Graphics card(s)
    Intel(R) HD Graphics 520
    Sound Card
    Intel(R) HD Graphics 520 + RealTek Audio
    Monitor(s) Displays
    Dell laptop display 15"
    Screen Resolution
    1920 * 1080
    Hard Drives
    Toshiba 128GB M.2 22300 drive
    INTEL Cherryvill 520 Series SSDSC2CW180A 180 GB SATA III SSD
    PSU
    Dell
    Case
    Dell
    Cooling
    Dell
    Mouse
    Logitech MX Master (shared) | Dell TouchPad
    Keyboard
    Dell
    Internet Speed
    AT&T LightSpeed Gigabit Duplex
    Browser
    Edge Chromium | Chrome | Firefox Nightly | Brave
    Antivirus
    Defender + MB4

SIW2

Active member
Member
VIP
Local time
1:33 PM
Posts
128
I have a Gigabyte Z370P motherboard which also offers secure boot and PTT for the TPM 2.0 function. Decided to enable it and see what happens. It now passes the Windows 11 test and in device manager I can see that TPM 2.0 is enabled.

But then I found I no longer got the BIOS splash screen when I booed. Concerned about this I tried to enter BIOS by restarting and tapping the delete key. All I got was a blank screen. Rebooting takes it into Windows with no problem but BIOS access is gone.

Thought about it for a while then began to suspect a graphics issue. The MB has built-in graphics but I've installed a Nvidia card. Just a basic card because I had some problems early days and the card's performance is not really much better than the onboard one. It's just a GT 710. So I tried plugging the HDMI cable into this instead whereupon the BIOS splash screen appears and I can now change things again. Phew!

So I've now decided to remove the card as it's not really needed.

Just wondering whether turning on PTT is causing the BIOS firmware to only use the on-board graphics?


Is secure boot causing the problem with your graphics card?

It seems the gigabyte z370p has a tpm header on the mobo, yet it also has PTT in the firmare? So what is the point of the tpm header?

Does your mobo also support 9th gen? Looks like it does after a bios update.

 
Last edited:

My Computer

Dru2

Well-known member
Member
VIP
Local time
8:33 AM
Posts
625
Location
Virginia
It seems the gigabyte z370p has a tpm header on the mobo, yet it also has PTT in the firmare? So what is the point of the tpm header?

The header on the board is for a "physical" (hardware) TPM chip. This better explains the difference - Intel Platform Trust Technology (PTT): TPM For The Masses

Basically "hardware" TPM isolates security from the host system but uses more resources than "firmware" TPM. Here's a snippet from the article....
Implementing TPM in dedicated hardware has a key benefit. TPM isolates the security infrastructure from the host system, making it exceedingly difficult to spoof, tamper or defeat. But it adds cost and complexity to system designs, which means that a lot of devices that could benefit from this level of security, simply don’t have it.

For the vast majority, firmware TPM would suffice (certainly does for Microsoft). For those wanting more security at the risk of higher resource use, a physical TPM may be the better choice. I just use firmware TPM. I did have a physical device, but it was based on the Infineon chip which was discovered to have a security flaw as discussed here - RSA Keys Generated by Infineon TPMs are Insecure

Today I just use firmware TPM and all is good. Don't really have a need for anything more (a physical TPM).
 

My Computers

System One System Two

  • Operating System
    Windows 11 Pro (22000.282)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom built
    CPU
    Intel i9-9900K
    Motherboard
    Gigabyte Aorus Z390 Xtreme
    Memory
    32G (4x8) DDR4 Corsair RGB Dominator Platinum (3600Mhz)
    Graphics Card(s)
    Radeon VII
    Sound Card
    Onboard (ESS Sabre HiFi using Realtek drivers)
    Monitor(s) Displays
    NEC PA242w (24 inch)
    Screen Resolution
    1920 x 1200
    Hard Drives
    5 Samsung SSD drives: 2X 970 NVME (512 & 1TB), 3X EVO SATA (2X 2TB, 1X 1TB)
    PSU
    EVGA Super Nova I000 P2 (1000 watt)
    Case
    Cooler Master H500M
    Cooling
    Corsair H115i RGB Platinum
    Keyboard
    Logitech Craft
    Mouse
    Logitech MX Master 2S
    Internet Speed
    100mb
    Browser
    Edge Chromium
    Antivirus
    Windows Security
    Other Info
    System used for gaming and photography.
  • Operating System
    Win 11 Pro Dev build 22454.1000
    Computer type
    Laptop
    Manufacturer/Model
    Lenovo ThinkPad Yoga X1
    CPU
    Intel i7-7600U
    Motherboard
    Intel
    Memory
    16igg
    Graphics card(s)
    Intel HD 620
    Sound Card
    Onboard
    Monitor(s) Displays
    14.0 WQHD OLED Touch
    Screen Resolution
    2560 x 1440
    Hard Drives
    1TB NVMe Drive (OEM)
    PSU
    laptop
    Case
    laptop
    Cooling
    Laptop cooling
    Mouse
    Logitech MX Anywhere 2S
    Keyboard
    Laptop
    Internet Speed
    100MB
    Browser
    Edge Chromium
    Antivirus
    Windows Security

johnlgalt

Antidisestablishmentarianistentarianist
Power User
VIP
Local time
8:33 AM
Posts
1,922
Location
3rd Rock

My Computers

System One System Two

  • Operating System
    Windows 10 Pro X64
    Computer type
    PC/Desktop
    Manufacturer/Model
    HomeBrew
    CPU
    AMD Ryzen 9 3950X
    Motherboard
    MSI MEG X570 GODLIKE
    Memory
    4 * Corsair Vengeance 32 GB 3600 MHz
    Graphics Card(s)
    eVGA GeForce GTX 970 SSC ACX 2.0 (04G-P4-3979-KB)
    Sound Card
    Realtek® ALC1220 Codec
    Monitor(s) Displays
    2 * Lenovo LT2323pwA Widescreeen
    Screen Resolution
    2* 1920*1080
    Hard Drives
    3x Sabrent Rocket PCIe Gen4 NVMe M.2 1 TB SSD (SB-ROCKET-NVMe4-1TB)
    SanDisk Ultra SDSSDHII-960G-G25 960 GB SATA III SSD
    Crucial MX100 CT256MX100SSD1 256GB SATA III SSD
    2 * Seagate Barracuda 7200.12 ST31000528AS 1TB 7200 RPM --> RAID1
    PSU
    PC Power & Cooling’s Silencer Series 1050 Watt, 80 Plus Platinum
    Case
    Fractal Design Define 7 XL Dark ATX Full Tower Case
  • Operating System
    Windows 10 x64 Pro build 21H1
    Computer type
    Laptop
    Manufacturer/Model
    Dell Latitude E5470
    CPU
    Intel(R) Core(TM) i5-6300U CPU @ 2.40GHz, 2501 Mhz, 2 Core(s), 4 Logical Processor(s)
    Motherboard
    Dell
    Memory
    16 GB
    Graphics card(s)
    Intel(R) HD Graphics 520
    Sound Card
    Intel(R) HD Graphics 520 + RealTek Audio
    Monitor(s) Displays
    Dell laptop display 15"
    Screen Resolution
    1920 * 1080
    Hard Drives
    Toshiba 128GB M.2 22300 drive
    INTEL Cherryvill 520 Series SSDSC2CW180A 180 GB SATA III SSD
    PSU
    Dell
    Case
    Dell
    Cooling
    Dell
    Mouse
    Logitech MX Master (shared) | Dell TouchPad
    Keyboard
    Dell
    Internet Speed
    AT&T LightSpeed Gigabit Duplex
    Browser
    Edge Chromium | Chrome | Firefox Nightly | Brave
    Antivirus
    Defender + MB4

AddRAM

This is the way !
Member
VIP
Local time
8:33 AM
Posts
196
Location
Mandalore

 

My Computers

System One System Two

  • Operating System
    Windows 10 Pro x64 Windows 11 Pro x64
    Computer type
    PC/Desktop
    Manufacturer/Model
    Skylake Special X299
    CPU
    Intel Core i9 9900X
    Motherboard
    Asus ROG Strix X299-E Gaming II
    Memory
    GSkill Trident Z RGB 32GB 3600 16-16-16-36 (F4-3600C16Q-32GTZR)
    Graphics Card(s)
    Zotac RTX 2080 Ti AMP Extreme
    Sound Card
    Supreme FX
    Monitor(s) Displays
    Asus PG279Q
    Screen Resolution
    2560 x 1440 165Hz
    Hard Drives
    Samsung 970 Pro 512GB, Samsung 980 Pro 500GB, Seagate Barracuda 4TB x2, Western Digital Black 4TB x1
    PSU
    EVGA 1200 P2, EVGA Black Custom Braided Cables
    Case
    Thermaltake View 31 Tempered Glass Limited Edition
    Cooling
    Corsair H115i, Thermal Grizzly Kryonaut
    Keyboard
    Logitech G910 Orion Spark
    Mouse
    Logitech G700s, Asus ROG GX860 Buzzard
    Internet Speed
    Verizon Fios Quantum Gateway 75/75
    Browser
    Edge
    Antivirus
    Windows Defender, Malwarebytes Free 3.8.3
    Other Info
    Thermaltake Riing Duo 14 x3, Thermaltake Riing Plus 14 x2, Corsair HS70 Pro Wireless Headset
  • Operating System
    Windows 10 Pro x64 21H1
    Computer type
    PC/Desktop
    Manufacturer/Model
    Skylake Special Z170
    CPU
    Intel Core i7 6700K
    Motherboard
    Asus Sabertooth Z170 Mark 1
    Memory
    GSkill Trident Z RGB 16GB 3600 16-16-16-36 (F4-3600C16D-16GTZR)
    Graphics card(s)
    EVGA GTX 980 Ti SC x2
    Sound Card
    Realtek High Definition
    Monitor(s) Displays
    AOC G2460PG
    Screen Resolution
    1920 x 1080 144Hz
    Hard Drives
    Samsung 860 Pro 256GB, Seagate Barracuda 4TB x2
    PSU
    EVGA 1000 P2, EVGA White Custom Braided Cables
    Case
    Corsair Vengeance C70 Gunmetal Black
    Cooling
    Corsair H100i v2, Corsair ML120 x2, Thermal Grizzly Kryonaut
    Mouse
    Logitech G500s
    Keyboard
    Logitech G910 Orion Spectrum
    Internet Speed
    Verizon Fios Quantum Gateway 75/75
    Browser
    Edge
    Antivirus
    Windows Defender, Malwarebytes Free 3.8.3
    Other Info
    Corsair SP120 x4, LG Blu-ray Drive, Durabrand HT-395 100 Watt Dolby Digital Amp

geneo

You've got to pick up every stitch
Power User
VIP
Local time
8:33 AM
Posts
710

^ are you all saying this horse has been beaten to death and trying to change the subject? LOL.
 

My Computers

System One System Two

  • Operating System
    Windows 11 Pro x64
    Computer type
    PC/Desktop
    Manufacturer/Model
    DIY
    CPU
    10900KF, 5.1 GHz delid
    Motherboard
    Asus Maximus Hero XII Wifi
    Memory
    64GB G.skill TridentZ RGB 3200CL14 B-die @ 3600 CL16
    Graphics Card(s)
    Asus ROG Strix 2070 Super A8G
    Sound Card
    Onboard Audio, Vanatoo Transparent One; Klipsch R-12SWi Sub
    Monitor(s) Displays
    Eizo CG2730, ViewSonic VP2768
    Screen Resolution
    2560 x 1440p x 2
    Hard Drives
    Samsung 960 Pro 512 GB (OS), Samsung 980 1TB, Raid 0: 1TB 850 EVO + 1TB 860 EVO. Sabrent USB-C DS-SC5B docking station: 6TB WDC Black, 6TB Ironwolf Pro; 2TB WDC Black
    PSU
    750W Seasonic Prime Ultra Titanium
    Case
    Fractal Design Meshify 2
    Cooling
    EK-AIO 360 D-RGB w/Phanteks 120 T30 fans, 2x Noctua NF-A14 Chromax case
    Keyboard
    Glorious GMMK TKL - Brown mechanical
    Mouse
    Logitech G305 wireless gaming
    Internet Speed
    120 Mb/s down, 12 Mb/s up
    Browser
    Firefox
    Antivirus
    Defender, Macrium Reflect 8 ;-)
    Other Info
    Logitech C920e Webcam
  • Operating System
    Mac OS Big Sur
    Computer type
    Laptop
    Manufacturer/Model
    Apple 13" Macbook Pro 2020 (m1)
    CPU
    M1
    Monitor(s) Displays
    2560x1600

sgage

Active member
Member
VIP
Local time
8:33 AM
Posts
157
Before I try messing around with my BIOS, my Gigabyte Z390 UD mobo does offer secure boot (if I change CSM support from enabled to disabled) and also has PTT (which is the mobo software TPM). Would like to hear if anyone has changed their BIOS settings to these options without incident. Last thing I want is my desktop unable to work.
signed, chicken

I dual boot Win10 and Win11 with SB and TPM enabled. Windows 10 doesn't care. Windows 11 won't log in if I turn TPM off, but works fine once I turn TPM back on. I really wouldn't worry about it.
 

My Computer

System One

  • Operating System
    Windows 11 Pro build 22000.65
    Computer type
    PC/Desktop
    Manufacturer/Model
    HP Pavilion PC 570-p026
    CPU
    Intel Core i5 7400 @ 3 GHz
    Motherboard
    HP Model 82F2 (U3E1)
    Memory
    12 GB
    Graphics Card(s)
    Intel HD Graphics 630
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    Acer V173
    Screen Resolution
    1280x1024
    Hard Drives
    500MB Samsung Evo+ SSD
    1TB Western Digital WDC WD10EZEX-60WN4A0 (SATA) 7200 RPM
    Internet Speed
    300/300 Mbs fiber

MAKO1989

Member
Local time
8:33 PM
Posts
4
I am having issues disabling CSM support in BIOS, for Windows11 compatibility. Gigabyte z390 M motherboard running F9m latest version of bios. Maybe its my RX480 8gb video card issue. I do not know, all I know is that when I disable the CSM support the computer will not boot / display / go back into bios. My only choice is to power down and unplug to reset motherboard bios though connecting two pins on the board carefully. I have just done this literally 10 times, to find the culprit of CSM Support. I am back to using the pc now on this forum with it enabled. Anyone??
 

My Computer

System One

  • Operating System
    Win 10 x64 Pro
    Computer type
    PC/Desktop
    Manufacturer/Model
    self made
    CPU
    i7 -9700K
    Motherboard
    Gigabyte z390
    Memory
    32gb HyperX
    Graphics Card(s)
    RX480 8gb
    Sound Card
    onboard
    Monitor(s) Displays
    Curved 32"
    Screen Resolution
    full hd
    Hard Drives
    6x sata 1-2tb
    Cooling
    AIR
    Keyboard
    mechanical
    Mouse
    Logitech
    Internet Speed
    50mbps

geneo

You've got to pick up every stitch
Power User
VIP
Local time
8:33 AM
Posts
710
Could be video card. Manufacturers have often offered updated GOP enabled BIOS for the video cards. You could check on the Gigabyte support forums. GOP is an embedded EFI driver in the BIOS that is required to boot in EFI mode. But I think your card should already have EFI support.

Does your motherboard/processor support an on-chip Intel graphics? For Z390 the BIOS should support GOP for the on-board Intel graphics. To rule out the video card, you could try booting with that.

Remove any other pci-e cards to rule them out.

Is your disk GPT partitioned or MBR. It needs to be GPT with an EFI system partition.
 

My Computers

System One System Two

  • Operating System
    Windows 11 Pro x64
    Computer type
    PC/Desktop
    Manufacturer/Model
    DIY
    CPU
    10900KF, 5.1 GHz delid
    Motherboard
    Asus Maximus Hero XII Wifi
    Memory
    64GB G.skill TridentZ RGB 3200CL14 B-die @ 3600 CL16
    Graphics Card(s)
    Asus ROG Strix 2070 Super A8G
    Sound Card
    Onboard Audio, Vanatoo Transparent One; Klipsch R-12SWi Sub
    Monitor(s) Displays
    Eizo CG2730, ViewSonic VP2768
    Screen Resolution
    2560 x 1440p x 2
    Hard Drives
    Samsung 960 Pro 512 GB (OS), Samsung 980 1TB, Raid 0: 1TB 850 EVO + 1TB 860 EVO. Sabrent USB-C DS-SC5B docking station: 6TB WDC Black, 6TB Ironwolf Pro; 2TB WDC Black
    PSU
    750W Seasonic Prime Ultra Titanium
    Case
    Fractal Design Meshify 2
    Cooling
    EK-AIO 360 D-RGB w/Phanteks 120 T30 fans, 2x Noctua NF-A14 Chromax case
    Keyboard
    Glorious GMMK TKL - Brown mechanical
    Mouse
    Logitech G305 wireless gaming
    Internet Speed
    120 Mb/s down, 12 Mb/s up
    Browser
    Firefox
    Antivirus
    Defender, Macrium Reflect 8 ;-)
    Other Info
    Logitech C920e Webcam
  • Operating System
    Mac OS Big Sur
    Computer type
    Laptop
    Manufacturer/Model
    Apple 13" Macbook Pro 2020 (m1)
    CPU
    M1
    Monitor(s) Displays
    2560x1600

SIW2

Active member
Member
VIP
Local time
1:33 PM
Posts
128
I am having issues disabling CSM support in BIOS, for Windows11 compatibility. Gigabyte z390 M motherboard running F9m latest version of bios. Maybe its my RX480 8gb video card issue. I do not know, all I know is that when I disable the CSM support the computer will not boot / display / go back into bios. My only choice is to power down and unplug to reset motherboard bios though connecting two pins on the board carefully. I have just done this literally 10 times, to find the culprit of CSM Support. I am back to using the pc now on this forum with it enabled. Anyone??
Why are you trying to disable csm ?
 

My Computer

Top Bottom