Solved Why does my PC self-wake up?


Birk

Well-known member
Member
Local time
11:24 AM
Posts
146
OS
Win11
I recently replaced my system's USB cabled mouse and trackball with a wireless Bluetooth lighted keyboard and wireless trackball. Everything is working OK - except the system wakes up by itself after I put it to sleep. Needless to say it did not do that when the 2 devices were wired ones.

So - what do I have to do to stop the system from waking itself up? Here's my typical scenario that starts with everything powered off

Power on PC
While it is booting I turn on the trackball and keyboard - they both have their own on/off switches
The system runs A-OK until I want to leave it for more than a half hour or so (sometime up to 6 -8 hours)
I use the Sleep command to put the system to sleep
I turn both the trackball and keyboard off
The system sleeps, both monitors show black screens, and I walk away
When I come back my 2 monitors are on and the PC is running

Something is causing it to wake up - but what could it be: I turned "wake on LAN" off years ago, so that should not be it. I've checked the on/off switches on both devices and they seem to work ok.
 

My Computer

System One

  • OS
    Win11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom build
    CPU
    Intel i5-12600K 3700 MHz
    Motherboard
    Asus B660-M
    Memory
    16 GB
    Graphics Card(s)
    none
    Sound Card
    none
    Monitor(s) Displays
    Primary: LG 4K; Secondary: Dell U2412M
    Screen Resolution
    Primary: 3860 x 2160; Secondary: 1200 x 1920
    Hard Drives
    C: Samsung NVme SSD970 256K
    E: 1 TB HDD
    F: 500K HDD
    W: Samsung SSD 840 128K
    Keyboard
    Logitech Lighted
    Mouse
    Kensington ExpertMouse trackball
    Internet Speed
    500/500
    Browser
    Brave
    Antivirus
    Windows Defender
You can disable "allow this device to wake the computer". In device manager, you can expand the mouse section, and then right click on the mouse. now, click on properties and go to the power management section. untick the "allow this device to wake the computer".
image_2024-02-01_064402845.png

Do the same for the keyboard as well.

Now, you can pinpoint the issue, if its actually cause by the mouse and keyboard (probably is) or something else. If it now stops happening, you can leave it this way till you find a solution, and till then, you can wake the computer from the power button.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
You can see what woke your computer last by opening command prompt as administrator and typing powercfg -lastwake

 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3447
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 +256gb ssd+512 gb usb m.2 sata
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
Excellent suggestions - thanks. Now that I see it again I remember the lastwake trick - I had completely forgotten it. Will try not to do that again.
 

My Computer

System One

  • OS
    Win11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom build
    CPU
    Intel i5-12600K 3700 MHz
    Motherboard
    Asus B660-M
    Memory
    16 GB
    Graphics Card(s)
    none
    Sound Card
    none
    Monitor(s) Displays
    Primary: LG 4K; Secondary: Dell U2412M
    Screen Resolution
    Primary: 3860 x 2160; Secondary: 1200 x 1920
    Hard Drives
    C: Samsung NVme SSD970 256K
    E: 1 TB HDD
    F: 500K HDD
    W: Samsung SSD 840 128K
    Keyboard
    Logitech Lighted
    Mouse
    Kensington ExpertMouse trackball
    Internet Speed
    500/500
    Browser
    Brave
    Antivirus
    Windows Defender
The Lastwake trick was the key to fixing this problem. It showed that my Ethernet controller was the cause of the last wake, and I found that the last 2 wake option were enabled. so I switched them to disabled. Problem solved.

1.jpg
 

My Computer

System One

  • OS
    Win11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom build
    CPU
    Intel i5-12600K 3700 MHz
    Motherboard
    Asus B660-M
    Memory
    16 GB
    Graphics Card(s)
    none
    Sound Card
    none
    Monitor(s) Displays
    Primary: LG 4K; Secondary: Dell U2412M
    Screen Resolution
    Primary: 3860 x 2160; Secondary: 1200 x 1920
    Hard Drives
    C: Samsung NVme SSD970 256K
    E: 1 TB HDD
    F: 500K HDD
    W: Samsung SSD 840 128K
    Keyboard
    Logitech Lighted
    Mouse
    Kensington ExpertMouse trackball
    Internet Speed
    500/500
    Browser
    Brave
    Antivirus
    Windows Defender

Latest Support Threads

Back
Top Bottom