Why my windows 11 doesn't have microsoft store

weshantbe

New member
Local time
8:32 PM
Posts
1
I just installed windows 11 and just realized that it doesn't have a microsoft store. How do i fix this??
 
Windows Build/Version
22000.184/21H2

Attachments

  • unknown_2021.09.12-19.56.png
    unknown_2021.09.12-19.56.png
    316.4 KB · Views: 12

My Computer

System One

  • Operating System
    Windows 11

Fabler2

Well-known member
Member
VIP
Local time
4:32 AM
Posts
549

My Computers

System One System Two

  • Operating System
    Win 10 Home
    Computer type
    Laptop
    Manufacturer/Model
    ASUS VivoBook
    CPU
    AMD Ryzen 7 3700U with Radeon Vega Mobile Gfx
    Motherboard
    ASUSTeK COMPUTER INC. X509DA (FP5)
    Memory
    12GB
    Graphics Card(s)
    RX Vega 10 Graphics
    Monitor(s) Displays
    Generic PnP Monitor (1920x1080@60Hz)
    Screen Resolution
    1920x1080@60Hz
    Hard Drives
    INTEL SSD 660p 512GB NVMe
    Internet Speed
    25 Mbps
    Browser
    Edge
    Antivirus
    Defender
  • Operating System
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    ACER
    CPU
    AMD Ryzen 7 5800H / 3.2 GHz
    Motherboard
    CZ Scala_CAS (FP6)
    Memory
    16 GB (2 x 8 GB) DDR4 SDRAM 3200 MHz
    Graphics card(s)
    NVIDIA GeForce RTX 3060 6 GB GDDR6 SDRAM
    Sound Card
    Realtek Audio. NVIDIA High Definition Audio
    Monitor(s) Displays
    15.6" LED backlight 1920 x 1080 (Full HD) 144 Hz
    Screen Resolution
    1920 x 1080 (Full HD)
    Hard Drives
    1.024 TB SSD M.2 2280 - Samsung
    PSU
    180 Watt, 19.5 V
    Mouse
    Logitech
    Internet Speed
    25 Mbps
    Browser
    Edge
    Antivirus
    Defender

Berton

Member
VIP
Local time
9:32 PM
Posts
35
Location
Wyoming
Since Win11 is still in BETA/Test phases I wouldn't bother about the Store until after Oct. 5 when the Released/RTM version of Win11 is available, wait for the writers of programs catch up to what Win11 will finally offer and get any necessary support from Microsoft when problems arise which are inevitable with testing software.
 

My Computers

System One System Two

  • Operating System
    Windows XP Pro, 7 Pro, 8.1 Pro, 10 Pro, 11_IP_Dev, MS-DOS 6/Win3.13
    CPU
    AMD and Intel
  • Operating System
    MS-DOS 6.xx, Windows 3.1
    Computer type
    Laptop
    Manufacturer/Model
    Toshiba

BunnyJ

Python Programmer
Power User
VIP
Local time
11:32 PM
Posts
2,437
Location
Oak Ridge, TN(The Secret City)
Since Win11 is still in BETA/Test phases I wouldn't bother about the Store until after Oct. 5 when the Released/RTM version of Win11 is available, wait for the writers of programs catch up to what Win11 will finally offer and get any necessary support from Microsoft when problems arise which are inevitable with testing software.
I have to agree.. who knows.. with the next update the issue might fix itself.
 

My Computer

System One

  • Operating System
    Windows 11 Home 22000.258
    Computer type
    PC/Desktop
    Manufacturer/Model
    Banna Junior 6K - E Series
    CPU
    AMD Ryze 3 3200G
    Motherboard
    ASUS Prime B350M-E
    Memory
    Crucial Ballistix Sport LT 2666 MHz DDR4 - 16GB
    Graphics Card(s)
    GeForce GTX TITAN X 12GB
    Sound Card
    On motherboard
    Monitor(s) Displays
    Viotek 32" Curved, ViewSonic 27"
    Screen Resolution
    1080P
    Hard Drives
    Primary Samsung 256 SSD
    PSU
    EVGA BQ 700w 80+ Bronze
    Case
    NZXT 510
    Cooling
    Stock AMD cooler
    Keyboard
    Corsair
    Mouse
    Amazon Generic with Cord
    Internet Speed
    Download: 240.78 mbps Upload: 12.02 mbps Ping: 15ms
    Browser
    Firefox and Edge
    Antivirus
    Defender

Bree

Well-known member
Power User
VIP
Local time
4:32 AM
Posts
845
I just installed windows 11 and just realized that it doesn't have a microsoft store. How do i fix this??
Welcome to Eleven Forum weshantbe

I have two PCs with 11 installed and both have the Store, not only that but checking for updates in the Store has recently updated it to the new 'Microsoft Store PREVIEW' version.

I can't say I've ever bothered to look for it in the All Apps list, I've always opened it from Pinned apps. You should see (and be able to use it) there too.

1631459210645.png

However, you prompted me to check on both of my machines. One of them has it in All Apps where you'd expect it to be, the other doesn't.

What it does have is an entry under 'Other' named ms-resource:AppName/Text that when clicked will open the Store. This is not a new bug, the same occasional failure to list a UWP app with its correct name has been seen in Windows 10 for quite a few years. An in-place repair install or a new clean install may fix this.


Store - msresource-appname.png

 

My Computers

System One System Two

  • Operating System
    Windows 11 Home
    Computer type
    Laptop
    Manufacturer/Model
    Acer Aspire 3 A315-23
    CPU
    AMD Athlon Silver 3050U
    Memory
    8GB
    Graphics Card(s)
    Radeon Graphics
    Monitor(s) Displays
    laptop screen
    Screen Resolution
    1366x768 native resolution, up to 2560x1440 with Radeon Virtual Super Resolution
    Hard Drives
    1TB HDD
    Browser
    Edge, Firefox
    Antivirus
    Defender
    Other Info
    fully 'Windows 11 ready' laptop. Windows 10 C: partition migrated from my old unsupported 'main machine' then upgraded to 11. Now 11 has been released it has been re-imaged back to 10 and awaits the upgrade to be offered in Windows Update.


    My SYSTEM THREE is a Dell Latitude 5410, i7-10610U, 32GB RAM, 512GB ssd, Windows 11 Pro.
  • Operating System
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    Dell Lattitude E4310
    CPU
    i5 M 520
    Motherboard
    0T6M8G
    Memory
    4GB
    Screen Resolution
    1366x768
    Hard Drives
    500GB HDD
    Browser
    Firefox, Edge
    Antivirus
    Defender
    Other Info
    unsupported machine: Legacy bios, MBR, TPM 1.2, upgraded from W10 to W11 using W10/W11 hybrid install media workaround.


    My SYSTEM THREE is a Dell Latitude 5410, i7-10610U, 32GB RAM, 512GB ssd, Windows 11 Pro.

Bree

Well-known member
Power User
VIP
Local time
4:32 AM
Posts
845
An in-place repair install or a new clean install may fix this.
How do i fix this??

I have just performed a repair install with an in-place upgrade on my machine where the Store was missing from All apps. As expected it has restored the entry in All apps for the Microsoft Store. What it hasn't done is remove the erroneous ms-resource:AppName/Text entry under Others, so I now have two items that will open the Store. :D
 

My Computers

System One System Two

  • Operating System
    Windows 11 Home
    Computer type
    Laptop
    Manufacturer/Model
    Acer Aspire 3 A315-23
    CPU
    AMD Athlon Silver 3050U
    Memory
    8GB
    Graphics Card(s)
    Radeon Graphics
    Monitor(s) Displays
    laptop screen
    Screen Resolution
    1366x768 native resolution, up to 2560x1440 with Radeon Virtual Super Resolution
    Hard Drives
    1TB HDD
    Browser
    Edge, Firefox
    Antivirus
    Defender
    Other Info
    fully 'Windows 11 ready' laptop. Windows 10 C: partition migrated from my old unsupported 'main machine' then upgraded to 11. Now 11 has been released it has been re-imaged back to 10 and awaits the upgrade to be offered in Windows Update.


    My SYSTEM THREE is a Dell Latitude 5410, i7-10610U, 32GB RAM, 512GB ssd, Windows 11 Pro.
  • Operating System
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    Dell Lattitude E4310
    CPU
    i5 M 520
    Motherboard
    0T6M8G
    Memory
    4GB
    Screen Resolution
    1366x768
    Hard Drives
    500GB HDD
    Browser
    Firefox, Edge
    Antivirus
    Defender
    Other Info
    unsupported machine: Legacy bios, MBR, TPM 1.2, upgraded from W10 to W11 using W10/W11 hybrid install media workaround.


    My SYSTEM THREE is a Dell Latitude 5410, i7-10610U, 32GB RAM, 512GB ssd, Windows 11 Pro.

johnlgalt

Antidisestablishmentarianistentarianist
Power User
VIP
Local time
11:32 PM
Posts
1,873
Location
3rd Rock
Similar thing happened with various items in Windows 10 as well, as reported on 10F. Completely reaching from memory, here, but either it fixed itself within a couple of reboots, or there was a way it was manually removed from shell:AppsFolder.

I'll go looking for that thread in a moment.
 

My Computers

System One System Two

  • Operating System
    Windows 10 Pro X64
    Computer type
    PC/Desktop
    Manufacturer/Model
    HomeBrew
    CPU
    AMD Ryzen 9 3950X
    Motherboard
    MSI MEG X570 GODLIKE
    Memory
    4 * Corsair Vengeance 32 GB 3600 MHz
    Graphics Card(s)
    eVGA GeForce GTX 970 SSC ACX 2.0 (04G-P4-3979-KB)
    Sound Card
    Realtek® ALC1220 Codec
    Monitor(s) Displays
    2 * Lenovo LT2323pwA Widescreeen
    Screen Resolution
    2* 1920*1080
    Hard Drives
    3x Sabrent Rocket PCIe Gen4 NVMe M.2 1 TB SSD (SB-ROCKET-NVMe4-1TB)
    SanDisk Ultra SDSSDHII-960G-G25 960 GB SATA III SSD
    Crucial MX100 CT256MX100SSD1 256GB SATA III SSD
    2 * Seagate Barracuda 7200.12 ST31000528AS 1TB 7200 RPM --> RAID1
    PSU
    PC Power & Cooling’s Silencer Series 1050 Watt, 80 Plus Platinum
    Case
    Fractal Design Define 7 XL Dark ATX Full Tower Case
  • Operating System
    Windows 10 x64 Pro build 21H1
    Computer type
    Laptop
    Manufacturer/Model
    Dell Latitude E5470
    CPU
    Intel(R) Core(TM) i5-6300U CPU @ 2.40GHz, 2501 Mhz, 2 Core(s), 4 Logical Processor(s)
    Motherboard
    Dell
    Memory
    16 GB
    Graphics card(s)
    Intel(R) HD Graphics 520
    Sound Card
    Intel(R) HD Graphics 520 + RealTek Audio
    Monitor(s) Displays
    Dell laptop display 15"
    Screen Resolution
    1920 * 1080
    Hard Drives
    Toshiba 128GB M.2 22300 drive
    INTEL Cherryvill 520 Series SSDSC2CW180A 180 GB SATA III SSD
    PSU
    Dell
    Case
    Dell
    Cooling
    Dell
    Mouse
    Logitech MX Master (shared) | Dell TouchPad
    Keyboard
    Dell
    Internet Speed
    AT&T LightSpeed Gigabit Duplex
    Browser
    Edge Chromium | Chrome | Firefox Nightly | Brave
    Antivirus
    Defender + MB4

johnlgalt

Antidisestablishmentarianistentarianist
Power User
VIP
Local time
11:32 PM
Posts
1,873
Location
3rd Rock
Ahhh, a tutorial on how to fix it - but there are also numerous posts about it disappearing here and there at 10F.

 

My Computers

System One System Two

  • Operating System
    Windows 10 Pro X64
    Computer type
    PC/Desktop
    Manufacturer/Model
    HomeBrew
    CPU
    AMD Ryzen 9 3950X
    Motherboard
    MSI MEG X570 GODLIKE
    Memory
    4 * Corsair Vengeance 32 GB 3600 MHz
    Graphics Card(s)
    eVGA GeForce GTX 970 SSC ACX 2.0 (04G-P4-3979-KB)
    Sound Card
    Realtek® ALC1220 Codec
    Monitor(s) Displays
    2 * Lenovo LT2323pwA Widescreeen
    Screen Resolution
    2* 1920*1080
    Hard Drives
    3x Sabrent Rocket PCIe Gen4 NVMe M.2 1 TB SSD (SB-ROCKET-NVMe4-1TB)
    SanDisk Ultra SDSSDHII-960G-G25 960 GB SATA III SSD
    Crucial MX100 CT256MX100SSD1 256GB SATA III SSD
    2 * Seagate Barracuda 7200.12 ST31000528AS 1TB 7200 RPM --> RAID1
    PSU
    PC Power & Cooling’s Silencer Series 1050 Watt, 80 Plus Platinum
    Case
    Fractal Design Define 7 XL Dark ATX Full Tower Case
  • Operating System
    Windows 10 x64 Pro build 21H1
    Computer type
    Laptop
    Manufacturer/Model
    Dell Latitude E5470
    CPU
    Intel(R) Core(TM) i5-6300U CPU @ 2.40GHz, 2501 Mhz, 2 Core(s), 4 Logical Processor(s)
    Motherboard
    Dell
    Memory
    16 GB
    Graphics card(s)
    Intel(R) HD Graphics 520
    Sound Card
    Intel(R) HD Graphics 520 + RealTek Audio
    Monitor(s) Displays
    Dell laptop display 15"
    Screen Resolution
    1920 * 1080
    Hard Drives
    Toshiba 128GB M.2 22300 drive
    INTEL Cherryvill 520 Series SSDSC2CW180A 180 GB SATA III SSD
    PSU
    Dell
    Case
    Dell
    Cooling
    Dell
    Mouse
    Logitech MX Master (shared) | Dell TouchPad
    Keyboard
    Dell
    Internet Speed
    AT&T LightSpeed Gigabit Duplex
    Browser
    Edge Chromium | Chrome | Firefox Nightly | Brave
    Antivirus
    Defender + MB4

Bree

Well-known member
Power User
VIP
Local time
4:32 AM
Posts
845
....there are also numerous posts about it disappearing here and there at 10F.
there's probably one from me a few years back. I had it on one of my machines, eventually got removed after a CU as I recall.
 

My Computers

System One System Two

  • Operating System
    Windows 11 Home
    Computer type
    Laptop
    Manufacturer/Model
    Acer Aspire 3 A315-23
    CPU
    AMD Athlon Silver 3050U
    Memory
    8GB
    Graphics Card(s)
    Radeon Graphics
    Monitor(s) Displays
    laptop screen
    Screen Resolution
    1366x768 native resolution, up to 2560x1440 with Radeon Virtual Super Resolution
    Hard Drives
    1TB HDD
    Browser
    Edge, Firefox
    Antivirus
    Defender
    Other Info
    fully 'Windows 11 ready' laptop. Windows 10 C: partition migrated from my old unsupported 'main machine' then upgraded to 11. Now 11 has been released it has been re-imaged back to 10 and awaits the upgrade to be offered in Windows Update.


    My SYSTEM THREE is a Dell Latitude 5410, i7-10610U, 32GB RAM, 512GB ssd, Windows 11 Pro.
  • Operating System
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    Dell Lattitude E4310
    CPU
    i5 M 520
    Motherboard
    0T6M8G
    Memory
    4GB
    Screen Resolution
    1366x768
    Hard Drives
    500GB HDD
    Browser
    Firefox, Edge
    Antivirus
    Defender
    Other Info
    unsupported machine: Legacy bios, MBR, TPM 1.2, upgraded from W10 to W11 using W10/W11 hybrid install media workaround.


    My SYSTEM THREE is a Dell Latitude 5410, i7-10610U, 32GB RAM, 512GB ssd, Windows 11 Pro.
Top Bottom