Devices Change Mouse Hover Time in Windows 11


  • Staff
Click_banner.png

This tutorial will show you how to change the mouse hover time for an auto select or open event for your account in Windows 7, Windows 8, Windows 10, and Windows 11.

The mouse hover time is the time in milliseconds that the mouse pointer has to stay hovered over an item before an event happens. For example:
The default mouse hover time is 400 milliseconds, but you can change this time if wanted.


Here's How:

1 Open Registry Editor (regedit.exe).

2 Navigate to the key below in the left pane of Registry Editor. (see screenshot below)

HKEY_CURRENT_USER\Control Panel\Mouse

MouseHoverTime-1.png

3 In the right pane of the Mouse key, double click/tap on the MouseHoverTime string value (REG_SZ) to modify it. (see screenshot above)

4 Type in how many milliseconds you want for the mouse hover time, and click/tap on OK. (see screenshot below)

The default mouse hover time is 400 milliseconds.

1000 milliseconds equals 1 second.


MouseHoverTime-2.png

5 Close Registry Editor.

6 Either Sign out and Sign in or restart the computer to apply.


That's it,
Shawn Brink


 
Last edited:
I noticed on the taskbar when I hover over an Icon it took too long to show anything so thank you for this, cause that was annoying me..lol
 

My Computer

System One

  • OS
    Windows 11 Pro Version 23H2(OS Build 22631.3527)
    Computer type
    PC/Desktop
    Manufacturer/Model
    AMD
    CPU
    12-Core AMD Ryzen 9 5900X, 4950 MHz (49.5 x 100)
    Motherboard
    Gigabyte X570 Aorus Master
    Memory
    4 - G Skill Trident Z Neo F4-3600C16-16GTZNC
    Graphics Card(s)
    PCI Express 4.0 x16: PowerColor RX 6800
    Sound Card
    Realtek ALC1220 @ AMD K19.2 - High Definition Audio Controller
    Monitor(s) Displays
    2 - 27 inch Westinghouse
    Screen Resolution
    1920 x 1080
    Hard Drives
    2 SSD - 2 TB each
    1 SSD - 4TB
    1 HDD - 2TB
    Keyboard
    logitech
    Mouse
    logitech
    Internet Speed
    1 GB
    Browser
    Firefox
    Antivirus
    Eset Endpoint Security
I noticed on the taskbar when I hover over an Icon it took too long to show anything so thank you for this, cause that was annoying me..lol

Glad it could help. :party:
 

My Computers

System One System Two

  • OS
    Windows 11 Pro for Workstations
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom self build
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    64 GB (4x16GB) G.SKILL TridentZ RGB DDR4 3600 MHz (F4-3600C18D-32GTZR)
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING (11GB GDDR5X)
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G75 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 990 PRO M.2,
    4TB Samsung 990 PRO M.2,
    8TB WD MyCloudEX2Ultra NAS
    PSU
    Seasonic Prime Titanium 850W
    Case
    Thermaltake Core P3 wall mounted
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master 3
    Internet Speed
    1 Gbps Download and 35 Mbps Upload
    Browser
    Google Chrome
    Antivirus
    Microsoft Defender and Malwarebytes Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Galaxy S23 Plus phone
  • Operating System
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    HP Spectre x360 2in1 14-eu0098nr (2024)
    CPU
    Intel Core Ultra 7 155H 4.8 GHz
    Memory
    16 GB LPDDR5x-7467 MHz
    Graphics card(s)
    Integrated Intel Arc
    Sound Card
    Poly Studio
    Monitor(s) Displays
    14" 2.8K OLED multitouch
    Screen Resolution
    2880 x 1800
    Hard Drives
    2 TB PCIe NVMe M.2 SSD
    Internet Speed
    Intel Wi-Fi 7 BE200 (2x2) and Bluetooth 5.4
    Browser
    Chrome and Edge
    Antivirus
    Windows Defender and Malwarebytes Premium
Is there any way to disable this altogether? As I recall there was no way in Win10. The closest was to set the hover time to a very large value. I also vaguely recall there was an undocumented maximum value so trial and error was required.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Microsoft
    CPU
    Intel Core i5-8400
    Motherboard
    ASUS PRIME H370-PLUS
    Memory
    16GB
    Graphics Card(s)
    Intel UHD Graphics 630
    Sound Card
    On board
    Monitor(s) Displays
    Samsung SyncMaster 2043BWX
    Screen Resolution
    1680 x 1050
    Hard Drives
    Samsung SSD 850 256GB
    WDC 1TB NVMe
    WD 3TB external USB drive
    PSU
    I don't remember
    Case
    Corsair something-or-other
    Cooling
    Air CPU + 2 case fans
    Keyboard
    DAS S Pro (Cherry Brown)
    Mouse
    Logitech USB of some sort
Is there any way to disable this altogether? As I recall there was no way in Win10. The closest was to set the hover time to a very large value. I also vaguely recall there was an undocumented maximum value so trial and error was required.
I set my settings to 99000 lol
 

My Computers

System One System Two

  • OS
    Windows 11 Pro x64 23H2 v22631.3447
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built Myself in 2013
    CPU
    AMD Ryzen 1800X 8-Core @ 3.60GHz
    Motherboard
    Asus Crosshair VI Hero
    Memory
    16GB G.Skill Trident Z RGB Series
    Graphics Card(s)
    AMD Radeon RX 580 8GB GDDR5
    Sound Card
    On Board
    Monitor(s) Displays
    Samsung 27" , PLANAR 22", eMachine 22"
    Screen Resolution
    1920 X 1080
    Hard Drives
    ~~~~~~~~~~~~~~~~~~~~~~~~~~
    ~ P34A60 512GB NVMe PCIe Gen3x4 M.2
    ~ 3TB WD Red HDD (extra storage)
    ~ SanDisk 250GB SSD
    ~ 2 X 1TB HDD
    ~~~~~~~~~~
    PSU
    Corsair RM850 Fully Modular (850watts)
    Case
    NZXT Phantom 630 CA-PH630-W1
    Cooling
    CORSAIR iCUE H100i RGB PRO XT
    Keyboard
    Logitech K860
    Mouse
    Logitech MX Master
    Internet Speed
    752Mbps (Download) / 537Mbps (Upload)
    Browser
    Firefox
    Antivirus
    Malwarebytes
    Other Info
    *This is my Main Computer That I use*
  • Operating System
    Windows 10 Pro x64
    Computer type
    PC/Desktop
    Manufacturer/Model
    Asus
    CPU
    AMD A10-5700 APU @ 3.40Ghz
    Motherboard
    Asus CM1745
    Memory
    8GB
    Graphics card(s)
    AMD Radeon R7 350x GDDR5 4 GB
    Sound Card
    On Board
    Monitor(s) Displays
    Dual Monitor Setup ONN 22" Monitors
    Screen Resolution
    1920 X 1080
    Hard Drives
    ~~~~~~~~
    250GB SSD

    500GB HDD
    ~~~~~~~~
    PSU
    350Watt PSU
    Cooling
    Air Cooling
    Mouse
    MX Master
    Keyboard
    Microsoft Ergonomic 4000
    Internet Speed
    752Mbps (Download) / 537Mbps (Upload)
    Browser
    Firefox
    Antivirus
    Malwarebytes
    Other Info
    *Computer for Weather Software*
after the latest Cumulative update a few days ago I have Zero issues anymore. Currently my WIn11 is running smooth as butter.
 

My Computer

System One

  • OS
    Windows 11 Pro Version 23H2(OS Build 22631.3527)
    Computer type
    PC/Desktop
    Manufacturer/Model
    AMD
    CPU
    12-Core AMD Ryzen 9 5900X, 4950 MHz (49.5 x 100)
    Motherboard
    Gigabyte X570 Aorus Master
    Memory
    4 - G Skill Trident Z Neo F4-3600C16-16GTZNC
    Graphics Card(s)
    PCI Express 4.0 x16: PowerColor RX 6800
    Sound Card
    Realtek ALC1220 @ AMD K19.2 - High Definition Audio Controller
    Monitor(s) Displays
    2 - 27 inch Westinghouse
    Screen Resolution
    1920 x 1080
    Hard Drives
    2 SSD - 2 TB each
    1 SSD - 4TB
    1 HDD - 2TB
    Keyboard
    logitech
    Mouse
    logitech
    Internet Speed
    1 GB
    Browser
    Firefox
    Antivirus
    Eset Endpoint Security
Back
Top Bottom