Ethernet Connection Lost During PC Sleep


sspohl

Member
Local time
9:26 AM
Posts
18
OS
Windows 11
My PC goes to sleep after 30 minutes of inactivity. When I return, the ethernet connection is lost so I don't have internet access until it re-identifies and re-connects. Connection time is slow, although I haven't actually timed it out. Super annoying at any rate. Is this normal behavior? Should I change the sleep setting? Is it a gateway setting that's doing this? Any pointers of what I should look at are much appreciated!
 
Windows Build/Version
version 21H2 build 22000.795

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Self Built
    CPU
    AMD Ryzen 5 5600 G
    Motherboard
    Asus STRIX B550-F
    Memory
    16 GB Corsair 2x8 D4 3200
    Monitor(s) Displays
    Dell 1905 Flat Panel, ca 2005
    Screen Resolution
    1280 x 1024
    Hard Drives
    1TB Samsung 970 EVO Plus M.2 SSD
    1TB Samsung 850 EVO SATA SSD
    PSU
    Seasonic Focus Plus 650W
    Case
    Fractal Meshify-C
    Cooling
    two case fans
    Keyboard
    Logitech, wired
    Mouse
    Logitech, wired
    Internet Speed
    AT&T fiber Gig speed
    Browser
    Edge, until I get back to Chrome

Catnip

Member
Local time
10:26 AM
Posts
34
OS
Win 11
You didn't mention if your internet connection is WIFI or wired. WIFI will take longer to re-establish in my experience, but it still should not take very long to do so.
 

My Computer

System One

  • OS
    Win 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Self build
    CPU
    Ryzen 5800X
    Motherboard
    Gigabyte x570 Aorus Elite Wifi
    Memory
    32 GB GSkill Trident Neo
    Graphics Card(s)
    ASUS TUF GAMING RTX 3070 Ti
    Sound Card
    On board Realtek
    Monitor(s) Displays
    2 x Samsung 32 inch curved - one 4K, one 1080p
    Screen Resolution
    4K, 1920 x 1080
    Hard Drives
    1 TB Samsung 970 EVO Nvme, 2 x Samsung 970 2TB SATA
    PSU
    EVGA 1000Q
    Case
    Rosewill something or other
    Cooling
    Corsair 100i 240 mm
    Keyboard
    Logitech G815
    Mouse
    Logitech G502 Hero
    Internet Speed
    700 up
    Browser
    Firefox
    Antivirus
    MalwareBytes

sspohl

Member
Thread Starter
Local time
9:26 AM
Posts
18
OS
Windows 11
It's a wired ethernet connection over cat5e wiring
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Self Built
    CPU
    AMD Ryzen 5 5600 G
    Motherboard
    Asus STRIX B550-F
    Memory
    16 GB Corsair 2x8 D4 3200
    Monitor(s) Displays
    Dell 1905 Flat Panel, ca 2005
    Screen Resolution
    1280 x 1024
    Hard Drives
    1TB Samsung 970 EVO Plus M.2 SSD
    1TB Samsung 850 EVO SATA SSD
    PSU
    Seasonic Focus Plus 650W
    Case
    Fractal Meshify-C
    Cooling
    two case fans
    Keyboard
    Logitech, wired
    Mouse
    Logitech, wired
    Internet Speed
    AT&T fiber Gig speed
    Browser
    Edge, until I get back to Chrome

FreeBooter

Well-known member
Power User
VIP
Local time
4:26 PM
Posts
988
Location
Adana
OS
Windows 11
If the current Power Management plan turns off your Wireless adapter while in sleep mode, just change it and your problem will be solved.

Press Windows logo key and X key together and choose Device Manager.

Expand Network Adapters, right-click the adapter, click Properties.

Click the Power Management tab, and then clear the Allow the computer to turn off this device to save power check box.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    HP Pavilion
    CPU
    AMD Ryzen 7 5700G
    Motherboard
    Erica6
    Memory
    Micron Technology DDR4-3200 16GB
    Graphics Card(s)
    NVIDIA GeForce RTX 3060
    Sound Card
    Realtek ALC671
    Monitor(s) Displays
    Samsung SyncMaster U28E590
    Screen Resolution
    3840 x 2160
    Hard Drives
    SAMSUNG MZVLQ1T0HALB-000H1

sspohl

Member
Thread Starter
Local time
9:26 AM
Posts
18
OS
Windows 11
Thank you for that suggestion... Unfortunately, I looked and that box was already unchecked.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Self Built
    CPU
    AMD Ryzen 5 5600 G
    Motherboard
    Asus STRIX B550-F
    Memory
    16 GB Corsair 2x8 D4 3200
    Monitor(s) Displays
    Dell 1905 Flat Panel, ca 2005
    Screen Resolution
    1280 x 1024
    Hard Drives
    1TB Samsung 970 EVO Plus M.2 SSD
    1TB Samsung 850 EVO SATA SSD
    PSU
    Seasonic Focus Plus 650W
    Case
    Fractal Meshify-C
    Cooling
    two case fans
    Keyboard
    Logitech, wired
    Mouse
    Logitech, wired
    Internet Speed
    AT&T fiber Gig speed
    Browser
    Edge, until I get back to Chrome

FreeBooter

Well-known member
Power User
VIP
Local time
4:26 PM
Posts
988
Location
Adana
OS
Windows 11

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    HP Pavilion
    CPU
    AMD Ryzen 7 5700G
    Motherboard
    Erica6
    Memory
    Micron Technology DDR4-3200 16GB
    Graphics Card(s)
    NVIDIA GeForce RTX 3060
    Sound Card
    Realtek ALC671
    Monitor(s) Displays
    Samsung SyncMaster U28E590
    Screen Resolution
    3840 x 2160
    Hard Drives
    SAMSUNG MZVLQ1T0HALB-000H1

sspohl

Member
Thread Starter
Local time
9:26 AM
Posts
18
OS
Windows 11
Thank you for again trying to help me. I'm running Win11 and I don't see anywhere that I can stop the network disconnect from occurring during sleep. I did change from 30 minutes to 4 hours for entering sleep mode, hopefully that will stop the problem for me.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Self Built
    CPU
    AMD Ryzen 5 5600 G
    Motherboard
    Asus STRIX B550-F
    Memory
    16 GB Corsair 2x8 D4 3200
    Monitor(s) Displays
    Dell 1905 Flat Panel, ca 2005
    Screen Resolution
    1280 x 1024
    Hard Drives
    1TB Samsung 970 EVO Plus M.2 SSD
    1TB Samsung 850 EVO SATA SSD
    PSU
    Seasonic Focus Plus 650W
    Case
    Fractal Meshify-C
    Cooling
    two case fans
    Keyboard
    Logitech, wired
    Mouse
    Logitech, wired
    Internet Speed
    AT&T fiber Gig speed
    Browser
    Edge, until I get back to Chrome

jvickers

The lunatics have taken over the asylum
Guru
VIP
Local time
9:26 AM
Posts
6,053
Location
Deep South, USA
OS
Windows 11 Pro
Try this:
  • Navigate to Device Manager > Network adapters.
  • Right-click on your Ethernet connection and click Properties.
  • Click the Advanced tab.
  • Under Property, scroll down and select Wake on magic packet.
  • Set the value to Enabled.
  • Click OK.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro
    Computer type
    PC/Desktop
    Manufacturer/Model
    Home built
    CPU
    Ryzen 9 5900X
    Motherboard
    MSI MPG X570 GAMING EDGE WIFI
    Memory
    Crucial Ballistix Sport LT 3200 MHz DDR4 DRAM Desktop Gaming Memory 32MB
    Graphics Card(s)
    ZOTAC RTX 3060 Twin Edge OC/ ZOTAC Gaming GeForce GTX 1660 Super 6GB GDDR6 192-bit Gaming Graphics Card
    Sound Card
    Proprietary
    Monitor(s) Displays
    ViewSonic XG2530 25"/Benq XL2411P 24"/ Samsung SyncMaster BX2331 23"
    Screen Resolution
    1920x1080 240Hz/144Hz/60Hz (based on monitor setup above)
    Hard Drives
    SK hynix Gold P31 1TB PCIe NVMe Gen3 M.2 2280 Internal SSD
    ADATA XPG SX8200 Pro 1TB
    Samsung SSD 860 EVO 1TB 2.5 Inch SATA III Internal SSD
    PSU
    Thermaltake Smart 700W 80+ White Certified PSU
    Case
    Rosewill ATX Mid Tower Gaming Computer Case, Gaming Case with Blue LED for Desktop
    Cooling
    Corsair iCUE H60i RGB PRO XT Liquid CPU Cooler
    Keyboard
    Corsair K70
    Mouse
    Logitech MX Master 3
    Internet Speed
    120MB/s Download/ 10MB/s Upload
    Browser
    Edge (Chromium)
    Antivirus
    Norton 360
  • Operating System
    Windows 10
    Computer type
    PC/Desktop
    Manufacturer/Model
    Home Built
    CPU
    AMD FX Black Edition
    Motherboard
    Asus M5A97 LE R2.0
    Memory
    16MB DDR
    Graphics card(s)
    I forget, but it's old.
    Sound Card
    Propietary
    Monitor(s) Displays
    ACER LED 24"
    Screen Resolution
    1920X1080
    Hard Drives
    1TB Samsung SSD 3.5"
    Case
    Corsair
    Cooling
    Stock
    Mouse
    Logitech
    Keyboard
    Logitech
    Internet Speed
    120MB/10MB
    Browser
    Chrome
    Antivirus
    Norton 360
    Other Info
    Currently taken down because of a lack of space :-(
    Maybe I'll make room somewhere and connect to the Dev channel if possible.

imanlien2020

EternalSoul
Member
Local time
8:26 AM
Posts
240
Location
USA
OS
Windows 11 Pro Version 21H2(OS Build 22000.795)
It's a wired ethernet connection over cat5e wiring
I have the same connection as you and for the last couple months I had this happen...When I would start or restart my PC my internet symbol in the lower right would be normal id hover on it and it said connected, then it would disconnect and seriously it would reconnect itself but after 5 minutes after restarting. Finally in say the last 2 windows updates I dont have that issue, Also another reason it was happening was AMD Radeon software. If your using it, uninstall it, restart you PC and let the generic AMD drivers install and see if it happens. I bet it doesnt.
 

My Computer

System One

  • OS
    Windows 11 Pro Version 21H2(OS Build 22000.795)
    Computer type
    PC/Desktop
    Manufacturer/Model
    AMD
    CPU
    AMD Ryzen 7 5800X 8 Core
    Motherboard
    Gigabyte X570 Aorus Pro WiFi
    Memory
    32 GB
    Graphics Card(s)
    PCI Express 3.0 x16: PowerColor RX Vega 56 Red Dragon
    Sound Card
    Realtek ALC1220 and AMD Greenland - High Definition Audio Controller
    Monitor(s) Displays
    2 - 27 inch Westinghouse
    Screen Resolution
    1920 x 1080
    Hard Drives
    2 SSD - 2 TB each
    1 HDD - 2 TB
    Keyboard
    logitech
    Mouse
    logitech
    Internet Speed
    1 GB
    Browser
    Microsoft Edge
    Antivirus
    Avast Premium

Winsanity

New member
Local time
6:26 AM
Posts
3
OS
Windows 11
Does your device have any UEFI sleep/power management settings? If your hardware is configured for deep sleep or a similar power management behavior then it will make the Ethernet adapter fully power down during sleep regardless of what's configured in Windows or your Ethernet driver.
 

My Computer

System One

  • OS
    Windows 11

sspohl

Member
Thread Starter
Local time
9:26 AM
Posts
18
OS
Windows 11
Thank you for that helpful suggestion. I checked the UEFI settings and could not find anything related to power management. Hopefully I didn't miss something, that's on an Asus B550-F mobo with American Megatrends 2403 UEFI.

FWIW, the problem has been much less since I changed the sleep settings from 30 minutes inactivity to 4 hours. Now I usually just deal with it in the morning. Is there some setting that would keep the ethernet adapter live even while the computer sleeps?
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Self Built
    CPU
    AMD Ryzen 5 5600 G
    Motherboard
    Asus STRIX B550-F
    Memory
    16 GB Corsair 2x8 D4 3200
    Monitor(s) Displays
    Dell 1905 Flat Panel, ca 2005
    Screen Resolution
    1280 x 1024
    Hard Drives
    1TB Samsung 970 EVO Plus M.2 SSD
    1TB Samsung 850 EVO SATA SSD
    PSU
    Seasonic Focus Plus 650W
    Case
    Fractal Meshify-C
    Cooling
    two case fans
    Keyboard
    Logitech, wired
    Mouse
    Logitech, wired
    Internet Speed
    AT&T fiber Gig speed
    Browser
    Edge, until I get back to Chrome

Latest Tutorials

Top Bottom