Solved Ethernet is slower than Wi-Fi


Subscriber43

Active member
Member
Local time
10:00 PM
Posts
155
OS
Windows 11 Dev
I recently renovated my home office, and moved my desk closer to my router. I decided to try using Ethernet instead of Wi-Fi, for the supposed added speed and stability.

So, I plugged in my patch cable, disabled my Wi-Fi adapter, and restarted my PC.

To my surprise, my Internet speed was cut almost in half.
Wi-Fi gives me around 50 Mbps (megabits per second), while Ethernet averages 30 Mbps.

I tried the following:

Reboot the router
Completely reset the router
Different patch cable
OEM, Microsoft and Realtek drivers
Using my laptop instead of My PC

The only thing that was unchanged through all of this was the router, but I do not have another router to try.
With Wi-Fi, though, I get close to my ISP's stated speed, so it's not the router.
Or maybe the Ethernet ports on the router have a problem? I tried all four, with the same results.

I am trying to avoid calling my ISP Tech as far as possible, since the information desk said I would have to pay for the visit (because my Wi-Fi Internet is working properly).

Wi-Fi adapter: Intel(R) Wireless-AC 9260 160MHz
Ethernet adapter: Realtek PCIe GbE Family Controller
Router: ASUS RT-ACRH13

Edit: corrected adapter OEM
 
Last edited:

My Computer

System One

  • OS
    Windows 11 Dev
    Computer type
    PC/Desktop
    Manufacturer/Model
    Lenovo ThinkCentre M75Q-1
    CPU
    AMD Ryzen 5 Pro 3400GE @3.30 GHz (4.0 GHz Turbo)
    Motherboard
    Lenovo 3151
    Memory
    20 GB DDR4 2666 (1x16GB + 1x4GB)
    Graphics Card(s)
    AMD Radeon Vega 11
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC 2369
    Screen Resolution
    1920 x 1080
    Hard Drives
    WD 512 GB NVME + SPCC 240GB SATA SSD
    PSU
    External 65W
    Case
    Mini (1L)

FrancoDT

Well-known member
Member
VIP
Local time
7:00 PM
Posts
247
Location
Nevada
OS
Windows 11
Is your Ethernet adapter driver up to date?
 

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    Alienware M17 R3
    CPU
    Intel Core i7-10750H (Comet Lake)
    Motherboard
    Alienware
    Memory
    32GB DDR4
    Graphics Card(s)
    NVIDIA GeForce RTX 2060 and Intel UHD Graphics
    Sound Card
    Realtek ALC3281-CG
    Monitor(s) Displays
    17"
    Screen Resolution
    3840x2160
    Hard Drives
    Micron 2300 NVMe 1TB
    PC SN530 NVMe WDC 512GB
    Mouse
    Logitech MX Master 3
    Internet Speed
    50mbps
    Browser
    Vivaldi and Firefox
    Antivirus
    MS Defender and Malwarebytes Free
  • Operating System
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    Microsoft Surface Laptop 3
    CPU
    Intel Core i7-1065G7 (Ice Lake)
    Motherboard
    Microsoft Corp.
    Memory
    16GB DDR4
    Graphics card(s)
    Intel Iris Plus Graphics
    Sound Card
    Omnisonic Speakers with Dolby Audio
    Monitor(s) Displays
    13.5” PixelSense Touchscreen Display
    Screen Resolution
    2256x1504
    Hard Drives
    Toshiba Memory 512GB
    Internet Speed
    50 mbps
    Browser
    Vivaldi and Firefox
    Antivirus
    MS Defender and Malwarebytes Free

Subscriber43

Active member
Member
Thread Starter
Local time
10:00 PM
Posts
155
OS
Windows 11 Dev
Well, I've tried the latest drivers from Lenovo and Windows update. Realtek is a crapshoot.
The Lenovo driver is pretty old (for Windows 10 v2004.
 

My Computer

System One

  • OS
    Windows 11 Dev
    Computer type
    PC/Desktop
    Manufacturer/Model
    Lenovo ThinkCentre M75Q-1
    CPU
    AMD Ryzen 5 Pro 3400GE @3.30 GHz (4.0 GHz Turbo)
    Motherboard
    Lenovo 3151
    Memory
    20 GB DDR4 2666 (1x16GB + 1x4GB)
    Graphics Card(s)
    AMD Radeon Vega 11
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC 2369
    Screen Resolution
    1920 x 1080
    Hard Drives
    WD 512 GB NVME + SPCC 240GB SATA SSD
    PSU
    External 65W
    Case
    Mini (1L)

AndreTen

Well-known member
Power User
VIP
Local time
4:00 AM
Posts
492
Location
Slovenia
OS
Windows 10 Pro, Windows 11 Dev
try to turn on Jumbo Packets. Should be in Router network settings

...and factory reset of router could help too. Surprisingly lot of similar issues with ASUS routers
 

My Computers

System One System Two

  • OS
    Windows 10 Pro, Windows 11 Dev
    Computer type
    PC/Desktop
    Manufacturer/Model
    Homebuilt
    CPU
    Intel I3 10100
    Motherboard
    ASUS B460M
    Memory
    16 GB DDR4 Crucial
    Graphics Card(s)
    Intel on chip
    Sound Card
    Realtek onboard
    Monitor(s) Displays
    ASUS 24, LG 24
    Screen Resolution
    Full HD x 2
    Hard Drives
    kingston A2000 NVMe PCIe 500 GB
    PSU
    LC Power 650W
    Case
    Noname
    Cooling
    Air 2x 120mm
    Keyboard
    Cherry G-81
    Mouse
    Logitech M500
    Internet Speed
    100/20
    Browser
    Firefox, Vivaldi
    Antivirus
    MS Defender
  • Operating System
    Windows 10 Home
    Computer type
    Laptop
    Manufacturer/Model
    ASUS/Vivobook Flip 14
    CPU
    Ryzen 7 4700u
    Memory
    8 GB DDR4
    Graphics card(s)
    AMD Vega
    Sound Card
    Realtek onboard
    Monitor(s) Displays
    14"
    Screen Resolution
    FullHD
    Hard Drives
    512 Samsung NVMe PCIe
    PSU
    -
    Case
    Laptop
    Mouse
    Touchpad, Touchscreen
    Internet Speed
    100/20
    Browser
    Firefox, Vivaldi
    Antivirus
    MS Defender

FrancoDT

Well-known member
Member
VIP
Local time
7:00 PM
Posts
247
Location
Nevada
OS
Windows 11
Well, I've tried the latest drivers from Lenovo and Windows update. Realtek is a crapshoot.
The Lenovo driver is pretty old (for Windows 10 v2004.
Don't suppose you have a second PC you can test the Ethernet connection on do you? Probably the easiest way to see if its your PC's Ethernet adapter or router/ISP related.
 

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    Alienware M17 R3
    CPU
    Intel Core i7-10750H (Comet Lake)
    Motherboard
    Alienware
    Memory
    32GB DDR4
    Graphics Card(s)
    NVIDIA GeForce RTX 2060 and Intel UHD Graphics
    Sound Card
    Realtek ALC3281-CG
    Monitor(s) Displays
    17"
    Screen Resolution
    3840x2160
    Hard Drives
    Micron 2300 NVMe 1TB
    PC SN530 NVMe WDC 512GB
    Mouse
    Logitech MX Master 3
    Internet Speed
    50mbps
    Browser
    Vivaldi and Firefox
    Antivirus
    MS Defender and Malwarebytes Free
  • Operating System
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    Microsoft Surface Laptop 3
    CPU
    Intel Core i7-1065G7 (Ice Lake)
    Motherboard
    Microsoft Corp.
    Memory
    16GB DDR4
    Graphics card(s)
    Intel Iris Plus Graphics
    Sound Card
    Omnisonic Speakers with Dolby Audio
    Monitor(s) Displays
    13.5” PixelSense Touchscreen Display
    Screen Resolution
    2256x1504
    Hard Drives
    Toshiba Memory 512GB
    Internet Speed
    50 mbps
    Browser
    Vivaldi and Firefox
    Antivirus
    MS Defender and Malwarebytes Free

FrancoDT

Well-known member
Member
VIP
Local time
7:00 PM
Posts
247
Location
Nevada
OS
Windows 11
Also try swapping another cable
 

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    Alienware M17 R3
    CPU
    Intel Core i7-10750H (Comet Lake)
    Motherboard
    Alienware
    Memory
    32GB DDR4
    Graphics Card(s)
    NVIDIA GeForce RTX 2060 and Intel UHD Graphics
    Sound Card
    Realtek ALC3281-CG
    Monitor(s) Displays
    17"
    Screen Resolution
    3840x2160
    Hard Drives
    Micron 2300 NVMe 1TB
    PC SN530 NVMe WDC 512GB
    Mouse
    Logitech MX Master 3
    Internet Speed
    50mbps
    Browser
    Vivaldi and Firefox
    Antivirus
    MS Defender and Malwarebytes Free
  • Operating System
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    Microsoft Surface Laptop 3
    CPU
    Intel Core i7-1065G7 (Ice Lake)
    Motherboard
    Microsoft Corp.
    Memory
    16GB DDR4
    Graphics card(s)
    Intel Iris Plus Graphics
    Sound Card
    Omnisonic Speakers with Dolby Audio
    Monitor(s) Displays
    13.5” PixelSense Touchscreen Display
    Screen Resolution
    2256x1504
    Hard Drives
    Toshiba Memory 512GB
    Internet Speed
    50 mbps
    Browser
    Vivaldi and Firefox
    Antivirus
    MS Defender and Malwarebytes Free

wimorrison

Member
Local time
3:00 AM
Posts
48
OS
Win11
Firstly, how are you measuring your speed?

Secondly what speed does your router say you have connected at? Bear in mind that it can often take a period of time for the ISP line to establish the best speed for your DSL connection.
 

My Computer

System One

  • OS
    Win11
    Computer type
    Laptop
    Manufacturer/Model
    Dell Latitude 7490
    CPU
    Intel(R) Core(TM) i5-8350U CPU @ 1.70GHz, 189
    Memory
    8GB

AndreTen

Well-known member
Power User
VIP
Local time
4:00 AM
Posts
492
Location
Slovenia
OS
Windows 10 Pro, Windows 11 Dev
Also check your QoS settings. You may have user defined settings for Ethernet and WiFi

Check your router's manual on page 27-28

1641596570673.png
 

My Computers

System One System Two

  • OS
    Windows 10 Pro, Windows 11 Dev
    Computer type
    PC/Desktop
    Manufacturer/Model
    Homebuilt
    CPU
    Intel I3 10100
    Motherboard
    ASUS B460M
    Memory
    16 GB DDR4 Crucial
    Graphics Card(s)
    Intel on chip
    Sound Card
    Realtek onboard
    Monitor(s) Displays
    ASUS 24, LG 24
    Screen Resolution
    Full HD x 2
    Hard Drives
    kingston A2000 NVMe PCIe 500 GB
    PSU
    LC Power 650W
    Case
    Noname
    Cooling
    Air 2x 120mm
    Keyboard
    Cherry G-81
    Mouse
    Logitech M500
    Internet Speed
    100/20
    Browser
    Firefox, Vivaldi
    Antivirus
    MS Defender
  • Operating System
    Windows 10 Home
    Computer type
    Laptop
    Manufacturer/Model
    ASUS/Vivobook Flip 14
    CPU
    Ryzen 7 4700u
    Memory
    8 GB DDR4
    Graphics card(s)
    AMD Vega
    Sound Card
    Realtek onboard
    Monitor(s) Displays
    14"
    Screen Resolution
    FullHD
    Hard Drives
    512 Samsung NVMe PCIe
    PSU
    -
    Case
    Laptop
    Mouse
    Touchpad, Touchscreen
    Internet Speed
    100/20
    Browser
    Firefox, Vivaldi
    Antivirus
    MS Defender

Slavic

Active member
Member
Local time
5:00 AM
Posts
215
OS
Windows 11 Pro; Windows 8.1 Pro
What is your link speed for both adapters, Ethernet and Wi-Fi?
I don't have Wi-Fi on desktop PC, so can show only Ethernet.

network.png
 

My Computer

System One

  • OS
    Windows 11 Pro; Windows 8.1 Pro
    Computer type
    PC/Desktop
    CPU
    i7-12700K (Alder Lake)
    Motherboard
    Asus PRIME Z690-M Plus D4
    Memory
    16 GB (2x8 Corsair DDR4-2132)
    Graphics Card(s)
    Asus GeForce 1050 Ti, 4 GB
    Monitor(s) Displays
    Philips 235PQ
    Screen Resolution
    1920x1080
    Hard Drives
    Windows 11: Samsung SSD 870 EVO, 500 GB (SATA), MBR
    Windows 8.1: Samsung SSD 980 PRO, 500 GB (M.2), MBR
    PSU
    Platimax D.F. 1050 W (80 Plus Platinum)
    Internet Speed
    Local link 1 Gbps, provider's line 500 Mbps
    Browser
    Google Chrome
    Other Info
    Realtek PCIe GbE Family Controller (for Windows 8.1 compatibility)
    Microsoft Office H&S 2013 x64

Subscriber43

Active member
Member
Thread Starter
Local time
10:00 PM
Posts
155
OS
Windows 11 Dev
try to turn on Jumbo Packets. Should be in Router network settings

...and factory reset of router could help too. Surprisingly lot of similar issues with ASUS routers
I did a factory reset. Nothing.
 

My Computer

System One

  • OS
    Windows 11 Dev
    Computer type
    PC/Desktop
    Manufacturer/Model
    Lenovo ThinkCentre M75Q-1
    CPU
    AMD Ryzen 5 Pro 3400GE @3.30 GHz (4.0 GHz Turbo)
    Motherboard
    Lenovo 3151
    Memory
    20 GB DDR4 2666 (1x16GB + 1x4GB)
    Graphics Card(s)
    AMD Radeon Vega 11
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC 2369
    Screen Resolution
    1920 x 1080
    Hard Drives
    WD 512 GB NVME + SPCC 240GB SATA SSD
    PSU
    External 65W
    Case
    Mini (1L)

Subscriber43

Active member
Member
Thread Starter
Local time
10:00 PM
Posts
155
OS
Windows 11 Dev
Firstly, how are you measuring your speed?

Secondly what speed does your router say you have connected at? Bear in mind that it can often take a period of time for the ISP line to establish the best speed for your DSL connection.
The router is connected at 866 Megabits. I use ookla and Megapath for speed test. both report similar speeds.
 

My Computer

System One

  • OS
    Windows 11 Dev
    Computer type
    PC/Desktop
    Manufacturer/Model
    Lenovo ThinkCentre M75Q-1
    CPU
    AMD Ryzen 5 Pro 3400GE @3.30 GHz (4.0 GHz Turbo)
    Motherboard
    Lenovo 3151
    Memory
    20 GB DDR4 2666 (1x16GB + 1x4GB)
    Graphics Card(s)
    AMD Radeon Vega 11
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC 2369
    Screen Resolution
    1920 x 1080
    Hard Drives
    WD 512 GB NVME + SPCC 240GB SATA SSD
    PSU
    External 65W
    Case
    Mini (1L)

Subscriber43

Active member
Member
Thread Starter
Local time
10:00 PM
Posts
155
OS
Windows 11 Dev

My Computer

System One

  • OS
    Windows 11 Dev
    Computer type
    PC/Desktop
    Manufacturer/Model
    Lenovo ThinkCentre M75Q-1
    CPU
    AMD Ryzen 5 Pro 3400GE @3.30 GHz (4.0 GHz Turbo)
    Motherboard
    Lenovo 3151
    Memory
    20 GB DDR4 2666 (1x16GB + 1x4GB)
    Graphics Card(s)
    AMD Radeon Vega 11
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC 2369
    Screen Resolution
    1920 x 1080
    Hard Drives
    WD 512 GB NVME + SPCC 240GB SATA SSD
    PSU
    External 65W
    Case
    Mini (1L)

Subscriber43

Active member
Member
Thread Starter
Local time
10:00 PM
Posts
155
OS
Windows 11 Dev

My Computer

System One

  • OS
    Windows 11 Dev
    Computer type
    PC/Desktop
    Manufacturer/Model
    Lenovo ThinkCentre M75Q-1
    CPU
    AMD Ryzen 5 Pro 3400GE @3.30 GHz (4.0 GHz Turbo)
    Motherboard
    Lenovo 3151
    Memory
    20 GB DDR4 2666 (1x16GB + 1x4GB)
    Graphics Card(s)
    AMD Radeon Vega 11
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC 2369
    Screen Resolution
    1920 x 1080
    Hard Drives
    WD 512 GB NVME + SPCC 240GB SATA SSD
    PSU
    External 65W
    Case
    Mini (1L)

tomdsr

Fighting Cancer :(
Member
VIP
Local time
7:00 PM
Posts
109
Location
Little Island Near Seattle
OS
Windows 11
Ethernet is connected at 866 Mbps.
You have something wrong then. Ethernet should show as 100 or 1000. never 866 or 482, or some odd number.

Old ethernet = 100mbit
New ethernet = 1000mbit

Note the "100" and "1000"
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Self Built
    CPU
    Ryzen 5 3600
    Motherboard
    ASUS Prime X570-P
    Memory
    32gb DDR4 - 3200Mhz
    Graphics Card(s)
    EVGA 2060 Super KO 6GB PCIE 3.0
    Sound Card
    Realtek S1200A
    Monitor(s) Displays
    1. LG 34UM68-P 34-Inch 21:9 UltraWide IPS 2. ONN 24-Inch LCD
    Screen Resolution
    1. 2560 x 1080 2. 1920 x 1080 (side by side 4480 x 1080)
    Hard Drives
    Samsung 860 EVO 1TB SATA III SSD (OS)
    WD BLUE 2TB SATA III (DATA)
    WD BLUE 2TB SATA III (DATA)
    WD BLUE 1TB SATA III (DATA)
    PSU
    Thermaltake Toughpower PF1 750W
    Case
    Coolermaster HAF XB EVO
    Cooling
    Corsair 240mm AIO + 4x 120mm case fans
    Keyboard
    Standard Logitech
    Mouse
    Logitech M535
    Internet Speed
    Gigabit (Cable)
    Browser
    Firefox, Chrome, Edge
    Antivirus
    Defender

Zardoc

Well-known member
Member
VIP
Local time
10:00 PM
Posts
597
Location
In a van down by the river
OS
Windows 11 Enterprise

My Computer

System One

  • OS
    Windows 11 Enterprise
    Computer type
    PC/Desktop
    CPU
    Intel® Core™ i7-11700 (16M Cache, up to 4.80 GHz)
    Motherboard
    ASUS ROG Strix Z590-A Gaming WiFi 6 Intel® Z590 LGA 1200
    Memory
    G.Skill Ripjaws V Series 32gb (2x16gb) DDR4 3200mhz
    Graphics Card(s)
    Asus Dual Geforce Rtx™ 2070 Oc Edition 8gb Gddr6
    Monitor(s) Displays
    BenQ EW3270U 31.5” 3840x2160 UHD 16:9 HDR LED 4K LG 27UK850-W 27'' 4K UHD IPS LED Monitor with HDR10
    Screen Resolution
    3840x2160
    Hard Drives
    Samsung 980 PRO PCIe 4.0 Gen 4 NVMe® SSD 250GB
    Samsung 970 Evo M.2 2280 2tb Pcie Gen3. X4
    Samsung 960 Pro M.2 512gb Nvme Pcie-Express 3.0
    Crucial MX500 1TB 3D NAND SATA Internal SSD
    PSU
    Corsair AXi Series AX860i Digital 860W 80 PLUS PSU
    Case
    Fractal Design Define R5 ATX Mid Tower Window Case
    Keyboard
    Logi MX Keys
    Mouse
    Logi M705
    Internet Speed
    400 mbs
    Browser
    Firefox
    Antivirus
    Eset NOD32
    Other Info
    Love fast boots

Zardoc

Well-known member
Member
VIP
Local time
10:00 PM
Posts
597
Location
In a van down by the river
OS
Windows 11 Enterprise
I use Merlin firmware with a few tweaks.

1641612792406.png
 

My Computer

System One

  • OS
    Windows 11 Enterprise
    Computer type
    PC/Desktop
    CPU
    Intel® Core™ i7-11700 (16M Cache, up to 4.80 GHz)
    Motherboard
    ASUS ROG Strix Z590-A Gaming WiFi 6 Intel® Z590 LGA 1200
    Memory
    G.Skill Ripjaws V Series 32gb (2x16gb) DDR4 3200mhz
    Graphics Card(s)
    Asus Dual Geforce Rtx™ 2070 Oc Edition 8gb Gddr6
    Monitor(s) Displays
    BenQ EW3270U 31.5” 3840x2160 UHD 16:9 HDR LED 4K LG 27UK850-W 27'' 4K UHD IPS LED Monitor with HDR10
    Screen Resolution
    3840x2160
    Hard Drives
    Samsung 980 PRO PCIe 4.0 Gen 4 NVMe® SSD 250GB
    Samsung 970 Evo M.2 2280 2tb Pcie Gen3. X4
    Samsung 960 Pro M.2 512gb Nvme Pcie-Express 3.0
    Crucial MX500 1TB 3D NAND SATA Internal SSD
    PSU
    Corsair AXi Series AX860i Digital 860W 80 PLUS PSU
    Case
    Fractal Design Define R5 ATX Mid Tower Window Case
    Keyboard
    Logi MX Keys
    Mouse
    Logi M705
    Internet Speed
    400 mbs
    Browser
    Firefox
    Antivirus
    Eset NOD32
    Other Info
    Love fast boots

Subscriber43

Active member
Member
Thread Starter
Local time
10:00 PM
Posts
155
OS
Windows 11 Dev
You have something wrong then. Ethernet should show as 100 or 1000. never 866 or 482, or some odd number.

Old ethernet = 100mbit
New ethernet = 1000mbit

Note the "100" and "1000"
You are right. I re-installed the firmware, reset the router to factory, set up my network, and now I am getting the correct speeds. The connection is now at 1000 Mbps.

Also @AndreTen, I believe it was in fact the QOS settings. It looks different now than what it was before the reset. Too bad I didn't do a screenshot of the previous setting.
I will leave everything at Asus default from now on.

Thanks to all of you guys for the suggestions and help.
I really appreciate it.
 

My Computer

System One

  • OS
    Windows 11 Dev
    Computer type
    PC/Desktop
    Manufacturer/Model
    Lenovo ThinkCentre M75Q-1
    CPU
    AMD Ryzen 5 Pro 3400GE @3.30 GHz (4.0 GHz Turbo)
    Motherboard
    Lenovo 3151
    Memory
    20 GB DDR4 2666 (1x16GB + 1x4GB)
    Graphics Card(s)
    AMD Radeon Vega 11
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC 2369
    Screen Resolution
    1920 x 1080
    Hard Drives
    WD 512 GB NVME + SPCC 240GB SATA SSD
    PSU
    External 65W
    Case
    Mini (1L)

AndreTen

Well-known member
Power User
VIP
Local time
4:00 AM
Posts
492
Location
Slovenia
OS
Windows 10 Pro, Windows 11 Dev
André, is that your router? seems to be showing a firmware update. :wink:
No, it's from the Manual of the ASUS router in question..
 

My Computers

System One System Two

  • OS
    Windows 10 Pro, Windows 11 Dev
    Computer type
    PC/Desktop
    Manufacturer/Model
    Homebuilt
    CPU
    Intel I3 10100
    Motherboard
    ASUS B460M
    Memory
    16 GB DDR4 Crucial
    Graphics Card(s)
    Intel on chip
    Sound Card
    Realtek onboard
    Monitor(s) Displays
    ASUS 24, LG 24
    Screen Resolution
    Full HD x 2
    Hard Drives
    kingston A2000 NVMe PCIe 500 GB
    PSU
    LC Power 650W
    Case
    Noname
    Cooling
    Air 2x 120mm
    Keyboard
    Cherry G-81
    Mouse
    Logitech M500
    Internet Speed
    100/20
    Browser
    Firefox, Vivaldi
    Antivirus
    MS Defender
  • Operating System
    Windows 10 Home
    Computer type
    Laptop
    Manufacturer/Model
    ASUS/Vivobook Flip 14
    CPU
    Ryzen 7 4700u
    Memory
    8 GB DDR4
    Graphics card(s)
    AMD Vega
    Sound Card
    Realtek onboard
    Monitor(s) Displays
    14"
    Screen Resolution
    FullHD
    Hard Drives
    512 Samsung NVMe PCIe
    PSU
    -
    Case
    Laptop
    Mouse
    Touchpad, Touchscreen
    Internet Speed
    100/20
    Browser
    Firefox, Vivaldi
    Antivirus
    MS Defender
Top Bottom