How to remove unknown disk


fart_tonnie

New member
Local time
5:22 AM
Posts
4
Visit site
OS
Windows 11
My PC has one main drive (C) and one storage drive (D). They both show as normal in Windows Explorer. However, when I open disk manager, it shows there is a third disk "Disk 2" besides Disk 0 and Disk 1. This "Disk 2" appears as "unkown device" and everytime I open disk manager, it asks me to initialize it ("GPT" or "MBR"), but whatever I do, it always fail. When I right-click a drive eg Drive (C) and then "Hardware" tab, apart from the two working drives, it shows a third disk called "ST500L0..." - when I look this part number up in google, it shows as a Seagate HDD.

I then remember several years ago I cloned Windows 10 from my old to my new PC, before (free) updating to Win 11. When I moved to the new hardware, I did not install the Seagate HDD and replaced it with a 2.5" SSD instead. Therefore this "unknown disk" may be a ghost from the past well before update to Win 11.

I googled and found a guide using AOMEI Partition assistant to "rebuild MBR", but this "unknown disk" still shows in disk manager. I also rebooted Windows into "Advanced options" and tried "startup repair", but it says it cannot be repaired.

What can I do to remove this phantom "unknown disk"? Thanks.
 

My Computer

System One

  • OS
    Windows 11

Wynona

Well-known member
Power User
VIP
Local time
4:22 AM
Posts
1,825
Location
Arkansas
Visit site
OS
Windows 11 22621.819
My PC has one main drive (C) and one storage drive (D). They both show as normal in Windows Explorer. However, when I open disk manager, it shows there is a third disk "Disk 2" besides Disk 0 and Disk 1. This "Disk 2" appears as "unkown device" and everytime I open disk manager, it asks me to initialize it ("GPT" or "MBR"), but whatever I do, it always fail. When I right-click a drive eg Drive (C) and then "Hardware" tab, it shows a third disk called "ST500L0..." - when I look this part number up in google, it shows as a Seagate HDD.

I then remember several years ago I cloned Windows 10 from my old to my new PC, before (free) updating to Win 11. When I moved to the new hardware, I did not install the Seagate HDD and replaced it with a 2.5" SSD instead. Therefore this "unknown disk" may be a ghost from the past well before update to Win 11.

I googled and found a guide using AOMEI Partition assistant to "rebuild MBR", but this "unknown disk" still shows in disk manager. I also rebooted Windows into "Advanced options" and tried "startup repair", but it says it cannot be repaired.

What can I do to remove this phantom "unknown disk"? Thanks.
The gurus most likely don't have enough info to help you, since you haven't completed your My Computer specs. (Click on My Computer and complete everything.)

They need every little bit of info about your hardware and operating system (current version of Windows 11) in order to help you understand what's going on.

Guessing wildly, it may take a clean install of your OS in order to eliminate the ghost drive.
 

My Computers

System One System Two

  • OS
    Windows 11 22621.819
    Computer type
    PC/Desktop
    Manufacturer/Model
    HP Envy TE01-1xxx
    CPU
    Intel(R) Core(TM) i7-10700 CPU @ 2.90GHz 2.90 GHz
    Motherboard
    16.0GB Dual-Channel Unknown @ 1463MHz (21-21-21-47)
    Memory
    16384 MBytes
    Graphics Card(s)
    Intel UHD Graphics 630
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    Monitor 1 - Acer 27" Monitor 2 - Acer 27"
    Screen Resolution
    1920 x 1080
    Hard Drives
    WDC PC SN530 SDBPNPZ-512G-1006 (SSD)
    Seagate ST1000DM003-1SB102
    Seagate BUP Slim SCSI Disk Device (SSD)
    PSU
    HP
    Case
    HP
    Cooling
    Standard
    Keyboard
    Logitech Wave K350
    Mouse
    Logitech M705
    Internet Speed
    100 mbps
    Browser
    Firefox
    Antivirus
    Windows Defender
    Other Info
    That's all Folks!
  • Operating System
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    HP
    CPU
    Intel Core i7 (10th gen) 10700
    Motherboard
    Intel
    Memory
    16 GB
    Graphics card(s)
    Intel UHD Graphics 630
    Sound Card
    Built-in
    Monitor(s) Displays
    Acer 27" & Samsung 24"
    Screen Resolution
    1920 x
    Hard Drives
    SSD (512 GB)
    HDD (1 TB)
    Seagate
    PSU
    Intel i7 10th Generation
    Case
    HP
    Cooling
    HP/Intel?
    Mouse
    Logitech M705
    Keyboard
    Logitech Wave K350
    Internet Speed
    50 mbps
    Browser
    Firefox 90.2
    Antivirus
    Windows Defender
    Other Info
    Headphone/Microphone Combo
    SuperSpeed USB Type-A (4 on front)
    HP 3-in-One Card Readr
    SuperSpeed USB Type-C
    DVD Writer

SIW2

Well-known member
Power User
VIP
Local time
10:22 AM
Posts
633
Visit site
OS
Win7
does it show in a free 3rd party partition manager?

Have a look in HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices . If you can't identify the culprit, you could delete all the entries except \DosDevices\C: ( or whatever your os letter is )

then restart and it will populate the key with present devices.
 

My Computers

System One System Two

  • OS
    Win7
    Computer type
    PC/Desktop
    CPU
    i5-8400
    Motherboard
    gigabyte b365m ds3h
    Memory
    2x8gb 3200mhz
    Monitor(s) Displays
    benq gw2480
    PSU
    bequiet pure power 11 400CM
    Cooling
    cryorig m9i
  • Operating System
    win7
    Computer type
    PC/Desktop
    CPU
    pentium g5400
    Motherboard
    gigabyte b365m ds3h
    Memory
    1x8gb 2400
    PSU
    xfx pro 450

fart_tonnie

New member
Thread Starter
Local time
5:22 AM
Posts
4
Visit site
OS
Windows 11
Dell Optiplex 3060 (i5-8500T / 16GB / 500GB boot / 500GB storage / Win11 Pro 10.0.22621)

does it show in a free 3rd party partition manager?
Yes it also shows in AOMEI partition assistant.

Have a look in HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices . If you can't identify the culprit, you could delete all the entries except \DosDevices\C: ( or whatever your os letter is )

then restart and it will populate the key with present devices.
Sorry does not work - after following your steps and reboot, <Mounted devices> shows \DosDevices\C and \DosDevices\D only (meaning my storage SSD has been re-populated). Unfortunately, Disk manager still shows unknown disk asking for initialization (which fails of course).
 

My Computer

System One

  • OS
    Windows 11

BobD

Active member
VIP
Local time
9:22 PM
Posts
130
Location
Hastings 3915 Australia
Visit site
OS
Windows 11 Pro 22H2
My PC has one main drive (C) and one storage drive (D). They both show as normal in Windows Explorer. However, when I open disk manager, it shows there is a third disk "Disk 2" besides Disk 0 and Disk 1. This "Disk 2" appears as "unkown device" and everytime I open disk manager, it asks me to initialize it ("GPT" or "MBR"), but whatever I do, it always fail. When I right-click a drive eg Drive (C) and then "Hardware" tab, apart from the two working drives, it shows a third disk called "ST500L0..." - when I look this part number up in google, it shows as a Seagate HDD.

I then remember several years ago I cloned Windows 10 from my old to my new PC, before (free) updating to Win 11. When I moved to the new hardware, I did not install the Seagate HDD and replaced it with a 2.5" SSD instead. Therefore this "unknown disk" may be a ghost from the past well before update to Win 11.

I googled and found a guide using AOMEI Partition assistant to "rebuild MBR", but this "unknown disk" still shows in disk manager. I also rebooted Windows into "Advanced options" and tried "startup repair", but it says it cannot be repaired.

What can I do to remove this phantom "unknown disk"? Thanks.
Methinks you have done too many tricks with upgrading and swapping to new hardware without clean installing windows. You can get away with a lot but I think you have hit the limits. Just clean install Win 11 and see how it goes.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 22H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Bob the Builder
    CPU
    Intel i7-13700KF @ 5.4GHz
    Motherboard
    MSI MPG Z790 Edge WiFi DDR4
    Memory
    G-Skill F4-3200C16-16GVK x 2 (32GB total)
    Graphics Card(s)
    GeForce RTX 3060 Ti Ventus 2X 8G OCV1 LHR
    Sound Card
    Realtek® ALC4080 (mobo chipset)
    Monitor(s) Displays
    Philips 28 inch Display 288E2UAE
    Screen Resolution
    3840 x 2160 (16 x 9)
    Hard Drives
    Samsung 980 Pro NVMe 500GB, Samsung 980 NVMe 500GB, Samsung 2.5" SSD 1TB, Seagate 2.5" ST5000 5TB, Seagate Barracuda NVMe 1TB
    PSU
    Antec HCG850-Gold (850W)
    Case
    Fractal Design Define 7 Compact ATX
    Cooling
    CoolerMaster MA610P
    Keyboard
    HAVIT mechanical keyboard HV-KB390L TKL
    Internet Speed
    100 x 20 megabits / second fibre
    Browser
    Firefox
    Antivirus
    Microsoft
    Other Info
    Intel Ethernet 1226-V 2.5GHz @ 1GHz
    Intel Wi-Fi 6E AX210
    ASUS router RT-AX86U with Wi-Fi 6
    Macrium Reflect 8 for backups etc.
  • Operating System
    Win 11 Pro 22H2
    Computer type
    Laptop
    Manufacturer/Model
    MSI SUMMIT E16 FLIP EVO A11MT-013AU
    CPU
    Intel i7-1195G7
    Memory
    16 GB
    Graphics card(s)
    Iris Xe graphics
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    16" 120Hz Pen Touch panel
    Screen Resolution
    2560 x 1600 (16 x 10)
    Hard Drives
    Samsung NVMe PCIe4 980 500GB
    PSU
    Delta Electronics ADP-65SD B, HP 1HE08AA
    Keyboard
    Full Keyboard
    Internet Speed
    100 x 20 megabits / second fibre
    Browser
    Firefox
    Antivirus
    Microsoft
    Other Info
    Killer Wi-Fi 6E 1675x (210NGW)
    MSI Pen
    Web Cam with Windows Hello Face
    Fingerprint Reader
    ASUS router RT-AX86U with Wi-Fi 6
    Macrium Reflect 8 for backups etc.

glasskuter

Well-known member
Pro User
VIP
Local time
4:22 AM
Posts
3,266
Location
Paris in the Lone Star State of Texas
Visit site
OS
Windows 11 Pro 22H2 22621.1105
I believe @Bree solution in this post will solve your problem. Be very careful in selecting correct disk in diskpart.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 22H2 22621.1105
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 m.2 2230-256+1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 21H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium

fart_tonnie

New member
Thread Starter
Local time
5:22 AM
Posts
4
Visit site
OS
Windows 11
Tried reinstalling Windows keeping all files and apps - no luck removing the ghost disk. Looks like the only way is a fresh clean re-install. Well it doesn't seem to affect the Windows operation until I open disk manager. I guess I'll leave it as is .... for now.

Thanks for everyone's help anyway.
 

My Computer

System One

  • OS
    Windows 11

SIW2

Well-known member
Power User
VIP
Local time
10:22 AM
Posts
633
Visit site
OS
Win7
called "ST500L0..." - when I look this part number up in google, it shows as a Seagate HDD.
Curious. Sometimes things like card readers can appear odd, but as you got the above info it is even stranger.
 

My Computers

System One System Two

  • OS
    Win7
    Computer type
    PC/Desktop
    CPU
    i5-8400
    Motherboard
    gigabyte b365m ds3h
    Memory
    2x8gb 3200mhz
    Monitor(s) Displays
    benq gw2480
    PSU
    bequiet pure power 11 400CM
    Cooling
    cryorig m9i
  • Operating System
    win7
    Computer type
    PC/Desktop
    CPU
    pentium g5400
    Motherboard
    gigabyte b365m ds3h
    Memory
    1x8gb 2400
    PSU
    xfx pro 450

spapakons

Well-known member
Power User
VIP
Local time
12:22 PM
Posts
1,699
Location
Athens
Visit site
OS
Windows 11 Pro 22H2 64-bit (build 22621.1105)
Could you have a third physical disk that has gone bad and cannot be initialized? Go to Device Manager and expand Disks (or similar). If you see three disks, it is what I guessed. Post a screenshot of Device Manager to help you further.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 22H2 64-bit (build 22621.1105)
    Computer type
    Laptop
    Manufacturer/Model
    Acer Extensa 5630EZ
    CPU
    Mobile DualCore Intel Core 2 Duo T7250, 2000 MHz
    Motherboard
    Acer Extensa 5630
    Memory
    4GB
    Graphics Card(s)
    Mobile Intel(R) GMA 4500M (Mobile 4 series)
    Sound Card
    Realtek ALC268 @ Intel 82801IB ICH9 - High Definition Audio Controller
    Monitor(s) Displays
    1
    Screen Resolution
    1280x800
    Hard Drives
    Samsung SSD 850 EVO 250GB SATA Device (250 GB, SATA-III)
    Internet Speed
    VDSL 50 Mbps
    Browser
    MICROSOFT EDGE
    Antivirus
    WINDOWS DEFENDER
    Other Info
    Legacy MBR installation, no TPM, no Secure Boot, no WDDM 2.0 graphics drivers, cannot get more unsupported ;) This is only my test laptop. I had installed Windows 11 here before upgrading my main PC. For my main PC I use everyday see my 2nd system specs.
  • Operating System
    Windows 11 Pro v22H2 (build 22621.1105)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom-built PC
    CPU
    Intel Core-i7 3770 3.40GHz s1155 (3rd generation)
    Motherboard
    Asus P8H61 s1155 ATX
    Memory
    2x Kingston Hyper-X Blu 8GB DDR3-1600
    Graphics card(s)
    Gainward NE5105T018G1-1070F (nVidia GeForce GTX 1050Ti 4GB GDDR5)
    Sound Card
    Realtek HD audio (ALC887)
    Monitor(s) Displays
    Sony Bravia KDL-19L4000 19" LCD TV via VGA
    Screen Resolution
    1440x900 32-bit 60Hz
    Hard Drives
    Patriot Burst Elite 480GB SSD as system disk, Western Digital Caviar Purple 4TB SATA III (WD40PURZ) as second
    PSU
    Thermaltake Litepower RGB 550W Full Wired
    Case
    SUPERCASE MIDI-TOWER
    Cooling
    Stock Intel CPU Fan, 1x 8cm fan at the back
    Mouse
    Sunnyline OptiEye PS/2
    Keyboard
    Mitsumi 101-key PS/2
    Internet Speed
    100Mbps
    Browser
    Microsoft Edge, Mozilla Firefox
    Antivirus
    Microsoft Windows Defender
    Other Info
    Legacy BIOS (MBR) installation, no TPM, no Secure Boot, WDDM 3.0 graphics drivers, WEI score 7.4

spapakons

Well-known member
Power User
VIP
Local time
12:22 PM
Posts
1,699
Location
Athens
Visit site
OS
Windows 11 Pro 22H2 64-bit (build 22621.1105)
If the unknown disk has gone bad it most probably slows down the whole system. I would disconnect it. This way it will also disappear from Disk Management and AOMEI or whatever other disk utility.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 22H2 64-bit (build 22621.1105)
    Computer type
    Laptop
    Manufacturer/Model
    Acer Extensa 5630EZ
    CPU
    Mobile DualCore Intel Core 2 Duo T7250, 2000 MHz
    Motherboard
    Acer Extensa 5630
    Memory
    4GB
    Graphics Card(s)
    Mobile Intel(R) GMA 4500M (Mobile 4 series)
    Sound Card
    Realtek ALC268 @ Intel 82801IB ICH9 - High Definition Audio Controller
    Monitor(s) Displays
    1
    Screen Resolution
    1280x800
    Hard Drives
    Samsung SSD 850 EVO 250GB SATA Device (250 GB, SATA-III)
    Internet Speed
    VDSL 50 Mbps
    Browser
    MICROSOFT EDGE
    Antivirus
    WINDOWS DEFENDER
    Other Info
    Legacy MBR installation, no TPM, no Secure Boot, no WDDM 2.0 graphics drivers, cannot get more unsupported ;) This is only my test laptop. I had installed Windows 11 here before upgrading my main PC. For my main PC I use everyday see my 2nd system specs.
  • Operating System
    Windows 11 Pro v22H2 (build 22621.1105)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom-built PC
    CPU
    Intel Core-i7 3770 3.40GHz s1155 (3rd generation)
    Motherboard
    Asus P8H61 s1155 ATX
    Memory
    2x Kingston Hyper-X Blu 8GB DDR3-1600
    Graphics card(s)
    Gainward NE5105T018G1-1070F (nVidia GeForce GTX 1050Ti 4GB GDDR5)
    Sound Card
    Realtek HD audio (ALC887)
    Monitor(s) Displays
    Sony Bravia KDL-19L4000 19" LCD TV via VGA
    Screen Resolution
    1440x900 32-bit 60Hz
    Hard Drives
    Patriot Burst Elite 480GB SSD as system disk, Western Digital Caviar Purple 4TB SATA III (WD40PURZ) as second
    PSU
    Thermaltake Litepower RGB 550W Full Wired
    Case
    SUPERCASE MIDI-TOWER
    Cooling
    Stock Intel CPU Fan, 1x 8cm fan at the back
    Mouse
    Sunnyline OptiEye PS/2
    Keyboard
    Mitsumi 101-key PS/2
    Internet Speed
    100Mbps
    Browser
    Microsoft Edge, Mozilla Firefox
    Antivirus
    Microsoft Windows Defender
    Other Info
    Legacy BIOS (MBR) installation, no TPM, no Secure Boot, WDDM 3.0 graphics drivers, WEI score 7.4

Winuser

Well-known member
Pro User
VIP
Local time
5:22 AM
Posts
4,427
Visit site
OS
Windows 11
If the unknown disk has gone bad it most probably slows down the whole system. I would disconnect it. This way it will also disappear from Disk Management and AOMEI or whatever other disk utility.
The OP stated the there is only two drives in the computer. I wonder if it has a card reader installed.
 

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    PowerSpec B746
    CPU
    Intel Core i7-10700K
    Motherboard
    ASRock Z490 Phantom Gaming 4/ax
    Memory
    16GB (8GB PC4-19200 DDR4 SDRAM x2)
    Graphics Card(s)
    NVIDIA GeForce GTX 1050 TI
    Sound Card
    Realtek Audio
    Monitor(s) Displays
    Samsung SAM0A87 Samsung SAM0D32
    Screen Resolution
    1920 x 1080
    Hard Drives
    NVMe WDC WDS100T2B0C-00PXH0 1TB
    Samsung SSD 860 EVO 1TB
    PSU
    750 Watts (62.5A)
    Case
    PowerSpec/Lian Li ATX 205
    Keyboard
    Logitech K270
    Mouse
    Logitech M185
    Browser
    Microsoft Edge and Firefox
    Antivirus
    ESET Internet Security
  • Operating System
    Windows 11 Dev
    Computer type
    Laptop
    Manufacturer/Model
    HP Envy x360 15-ds1083cl
    CPU
    AMD Ryzen 7 4700U 2.0GHZ
    Memory
    16 MB DDR 4-2666
    Graphics card(s)
    AMD Radeon
    Monitor(s) Displays
    15.6"
    Screen Resolution
    1920x1080
    Hard Drives
    PCIe NVMe M.2 512GB
    Browser
    Firefox, Edge and Edge Canary
    Antivirus
    ESET Internet Security

spapakons

Well-known member
Power User
VIP
Local time
12:22 PM
Posts
1,699
Location
Athens
Visit site
OS
Windows 11 Pro 22H2 64-bit (build 22621.1105)
He can post a screenshot of Computer Management, Disk Manager to find out.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 22H2 64-bit (build 22621.1105)
    Computer type
    Laptop
    Manufacturer/Model
    Acer Extensa 5630EZ
    CPU
    Mobile DualCore Intel Core 2 Duo T7250, 2000 MHz
    Motherboard
    Acer Extensa 5630
    Memory
    4GB
    Graphics Card(s)
    Mobile Intel(R) GMA 4500M (Mobile 4 series)
    Sound Card
    Realtek ALC268 @ Intel 82801IB ICH9 - High Definition Audio Controller
    Monitor(s) Displays
    1
    Screen Resolution
    1280x800
    Hard Drives
    Samsung SSD 850 EVO 250GB SATA Device (250 GB, SATA-III)
    Internet Speed
    VDSL 50 Mbps
    Browser
    MICROSOFT EDGE
    Antivirus
    WINDOWS DEFENDER
    Other Info
    Legacy MBR installation, no TPM, no Secure Boot, no WDDM 2.0 graphics drivers, cannot get more unsupported ;) This is only my test laptop. I had installed Windows 11 here before upgrading my main PC. For my main PC I use everyday see my 2nd system specs.
  • Operating System
    Windows 11 Pro v22H2 (build 22621.1105)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom-built PC
    CPU
    Intel Core-i7 3770 3.40GHz s1155 (3rd generation)
    Motherboard
    Asus P8H61 s1155 ATX
    Memory
    2x Kingston Hyper-X Blu 8GB DDR3-1600
    Graphics card(s)
    Gainward NE5105T018G1-1070F (nVidia GeForce GTX 1050Ti 4GB GDDR5)
    Sound Card
    Realtek HD audio (ALC887)
    Monitor(s) Displays
    Sony Bravia KDL-19L4000 19" LCD TV via VGA
    Screen Resolution
    1440x900 32-bit 60Hz
    Hard Drives
    Patriot Burst Elite 480GB SSD as system disk, Western Digital Caviar Purple 4TB SATA III (WD40PURZ) as second
    PSU
    Thermaltake Litepower RGB 550W Full Wired
    Case
    SUPERCASE MIDI-TOWER
    Cooling
    Stock Intel CPU Fan, 1x 8cm fan at the back
    Mouse
    Sunnyline OptiEye PS/2
    Keyboard
    Mitsumi 101-key PS/2
    Internet Speed
    100Mbps
    Browser
    Microsoft Edge, Mozilla Firefox
    Antivirus
    Microsoft Windows Defender
    Other Info
    Legacy BIOS (MBR) installation, no TPM, no Secure Boot, WDDM 3.0 graphics drivers, WEI score 7.4

SIW2

Well-known member
Power User
VIP
Local time
10:22 AM
Posts
633
Visit site
OS
Win7
From the OP's first post:


When I right-click a drive eg Drive (C) and then "Hardware" tab...it shows a third disk called "ST500L0..." - when I look this part number up in google, it shows as a Seagate HDD.

Presumably he means Properties>Hardware

like this, except an extra seagate disk is showing

hardware.jpg


Likely one of these , which he says he doesn't have attached:


Perhaps he can get rid of it from device manager.
 
Last edited:

My Computers

System One System Two

  • OS
    Win7
    Computer type
    PC/Desktop
    CPU
    i5-8400
    Motherboard
    gigabyte b365m ds3h
    Memory
    2x8gb 3200mhz
    Monitor(s) Displays
    benq gw2480
    PSU
    bequiet pure power 11 400CM
    Cooling
    cryorig m9i
  • Operating System
    win7
    Computer type
    PC/Desktop
    CPU
    pentium g5400
    Motherboard
    gigabyte b365m ds3h
    Memory
    1x8gb 2400
    PSU
    xfx pro 450

spapakons

Well-known member
Power User
VIP
Local time
12:22 PM
Posts
1,699
Location
Athens
Visit site
OS
Windows 11 Pro 22H2 64-bit (build 22621.1105)
If it was once connected and now isn't, it would show in Device Manager as a semi-transparent icon when you show hidden devices. Just delete any such icon from Disks section and restart. It should also disappear from Disk Management.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 22H2 64-bit (build 22621.1105)
    Computer type
    Laptop
    Manufacturer/Model
    Acer Extensa 5630EZ
    CPU
    Mobile DualCore Intel Core 2 Duo T7250, 2000 MHz
    Motherboard
    Acer Extensa 5630
    Memory
    4GB
    Graphics Card(s)
    Mobile Intel(R) GMA 4500M (Mobile 4 series)
    Sound Card
    Realtek ALC268 @ Intel 82801IB ICH9 - High Definition Audio Controller
    Monitor(s) Displays
    1
    Screen Resolution
    1280x800
    Hard Drives
    Samsung SSD 850 EVO 250GB SATA Device (250 GB, SATA-III)
    Internet Speed
    VDSL 50 Mbps
    Browser
    MICROSOFT EDGE
    Antivirus
    WINDOWS DEFENDER
    Other Info
    Legacy MBR installation, no TPM, no Secure Boot, no WDDM 2.0 graphics drivers, cannot get more unsupported ;) This is only my test laptop. I had installed Windows 11 here before upgrading my main PC. For my main PC I use everyday see my 2nd system specs.
  • Operating System
    Windows 11 Pro v22H2 (build 22621.1105)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom-built PC
    CPU
    Intel Core-i7 3770 3.40GHz s1155 (3rd generation)
    Motherboard
    Asus P8H61 s1155 ATX
    Memory
    2x Kingston Hyper-X Blu 8GB DDR3-1600
    Graphics card(s)
    Gainward NE5105T018G1-1070F (nVidia GeForce GTX 1050Ti 4GB GDDR5)
    Sound Card
    Realtek HD audio (ALC887)
    Monitor(s) Displays
    Sony Bravia KDL-19L4000 19" LCD TV via VGA
    Screen Resolution
    1440x900 32-bit 60Hz
    Hard Drives
    Patriot Burst Elite 480GB SSD as system disk, Western Digital Caviar Purple 4TB SATA III (WD40PURZ) as second
    PSU
    Thermaltake Litepower RGB 550W Full Wired
    Case
    SUPERCASE MIDI-TOWER
    Cooling
    Stock Intel CPU Fan, 1x 8cm fan at the back
    Mouse
    Sunnyline OptiEye PS/2
    Keyboard
    Mitsumi 101-key PS/2
    Internet Speed
    100Mbps
    Browser
    Microsoft Edge, Mozilla Firefox
    Antivirus
    Microsoft Windows Defender
    Other Info
    Legacy BIOS (MBR) installation, no TPM, no Secure Boot, WDDM 3.0 graphics drivers, WEI score 7.4

fart_tonnie

New member
Thread Starter
Local time
5:22 AM
Posts
4
Visit site
OS
Windows 11
Sorry I didnt realize my post was moved to another forum.

Thank you for reminding me of Device Manager - this should be the first place I looked, stupid me!

Yes I do see the phantom drive (ST500LT0) in device manager under "disk drives". I am sure it is not a card reader because the Dell Optiplex 3060 (a microPC) does not have card reader. All peripherals are connected by external ports eg USB, HDMI, and I have never used a USB card reader.

In Device manager, right-clicking "ST500LT0 ..." shows the following options:

1) update driver (not relevant and nothing to update by automatic search anyway)
2) uninstall device - I tried this option and the disk disappears from the list. Unfortunately it reappears after rebooting Windows
3) scan for hardware changes - phantom drive is still there
4) disable device - this works (ie it disappears from disk manager), but the name remains on the list of disk drives in device manager

I am not going to do fresh clean Windows reinstall just to get rid of this device name, because it does not affect the operation of Windows, and disk manager is now also free of this unknown device (even if it persists there, it does not affect the PC operation).

Thank you for reminding me of "Device Manager" - I cannot believe I overlooked this most basic step! Consider the problem "solved"!
 

My Computer

System One

  • OS
    Windows 11

spapakons

Well-known member
Power User
VIP
Local time
12:22 PM
Posts
1,699
Location
Athens
Visit site
OS
Windows 11 Pro 22H2 64-bit (build 22621.1105)
You can also try fixing any Registry errors with CCleaner.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 22H2 64-bit (build 22621.1105)
    Computer type
    Laptop
    Manufacturer/Model
    Acer Extensa 5630EZ
    CPU
    Mobile DualCore Intel Core 2 Duo T7250, 2000 MHz
    Motherboard
    Acer Extensa 5630
    Memory
    4GB
    Graphics Card(s)
    Mobile Intel(R) GMA 4500M (Mobile 4 series)
    Sound Card
    Realtek ALC268 @ Intel 82801IB ICH9 - High Definition Audio Controller
    Monitor(s) Displays
    1
    Screen Resolution
    1280x800
    Hard Drives
    Samsung SSD 850 EVO 250GB SATA Device (250 GB, SATA-III)
    Internet Speed
    VDSL 50 Mbps
    Browser
    MICROSOFT EDGE
    Antivirus
    WINDOWS DEFENDER
    Other Info
    Legacy MBR installation, no TPM, no Secure Boot, no WDDM 2.0 graphics drivers, cannot get more unsupported ;) This is only my test laptop. I had installed Windows 11 here before upgrading my main PC. For my main PC I use everyday see my 2nd system specs.
  • Operating System
    Windows 11 Pro v22H2 (build 22621.1105)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom-built PC
    CPU
    Intel Core-i7 3770 3.40GHz s1155 (3rd generation)
    Motherboard
    Asus P8H61 s1155 ATX
    Memory
    2x Kingston Hyper-X Blu 8GB DDR3-1600
    Graphics card(s)
    Gainward NE5105T018G1-1070F (nVidia GeForce GTX 1050Ti 4GB GDDR5)
    Sound Card
    Realtek HD audio (ALC887)
    Monitor(s) Displays
    Sony Bravia KDL-19L4000 19" LCD TV via VGA
    Screen Resolution
    1440x900 32-bit 60Hz
    Hard Drives
    Patriot Burst Elite 480GB SSD as system disk, Western Digital Caviar Purple 4TB SATA III (WD40PURZ) as second
    PSU
    Thermaltake Litepower RGB 550W Full Wired
    Case
    SUPERCASE MIDI-TOWER
    Cooling
    Stock Intel CPU Fan, 1x 8cm fan at the back
    Mouse
    Sunnyline OptiEye PS/2
    Keyboard
    Mitsumi 101-key PS/2
    Internet Speed
    100Mbps
    Browser
    Microsoft Edge, Mozilla Firefox
    Antivirus
    Microsoft Windows Defender
    Other Info
    Legacy BIOS (MBR) installation, no TPM, no Secure Boot, WDDM 3.0 graphics drivers, WEI score 7.4

torchwood

Member
VIP
Local time
10:22 AM
Posts
68
Visit site
OS
w7/10/11ip
I'm wondering if its in your BIOS boot-up preferences, which is then passing it to W11
if it is remove it from there
 

My Computer

System One

  • OS
    w7/10/11ip
    Computer type
    Laptop
    Manufacturer/Model
    hp probook 450 g8
    CPU
    i5 11th gen

johnlgalt

Antidisestablishmentarianist
Power User
VIP
Local time
5:22 AM
Posts
2,945
Location
3rd Rock
about.me
OS
Windows 11 21H2 Current build
I'm wondering if its in your BIOS boot-up preferences, which is then passing it to W11
if it is remove it from there

This is a good possibility, in that uninstalling the device in Device Manager was ineffective, as it was 'reinstalled" from somewhere, meaning that the OS thinks the device is still there physically. If you're sure you only have the 2 drives, then it might be something set in the BIOS / UEFI firmware that is forcing Windows to load this device.
 

My Computers

System One System Two

  • OS
    Windows 11 21H2 Current build
    Computer type
    PC/Desktop
    Manufacturer/Model
    HomeBrew
    CPU
    AMD Ryzen 9 3950X
    Motherboard
    MSI MEG X570 GODLIKE
    Memory
    4 * 32 GB - Corsair Vengeance 3600 MHz
    Graphics Card(s)
    EVGA GeForce RTX 3080 Ti XC3 ULTRA GAMING (12G-P5-3955-KR)
    Sound Card
    Realtek® ALC1220 Codec
    Monitor(s) Displays
    Eve Spectrum ES07D03 4K Gaming Monitor (Matte finish) | Eve Spectrum ES07DC9 4K Gaming Monitor (Glossy finish)
    Screen Resolution
    4K x2
    Hard Drives
    3x Samsung 980 Pro NVMe PCIe 4 M.2 2 TB SSD (MZ-V8P2T0B/AM)
    PSU
    PC Power & Cooling’s Silencer Series 1050 Watt, 80 Plus Platinum
    Case
    Fractal Design Define 7 XL Dark ATX Full Tower Case
    Cooling
    ZXT KRAKEN Z73 73.11 CFM Liquid CPU Cooler (3x 120 mm push top) + Air 3x 140mm case fans (pull front) + 1x 120 mm (push back) and 1 x 120 mm (pull bottom)
    Keyboard
    SteelSeries Apex Pro Wired Gaming Keyboard
    Mouse
    Logitech MX Master 3S
    Internet Speed
    AT&T LightSpeed Gigabit Duplex Ftth
    Browser
    Nightly (default) + Firefox (stable),Chrome, Edge/ß/Dev/Canary
    Antivirus
    Defender
  • Operating System
    CHromeOS Flex v108 Dev
    Computer type
    Laptop
    Manufacturer/Model
    Dell Latitude E5470
    CPU
    Intel(R) Core(TM) i5-6300U CPU @ 2.40GHz, 2501 Mhz, 2 Core(s), 4 Logical Processor(s)
    Motherboard
    Dell
    Memory
    16 GB
    Graphics card(s)
    Intel(R) HD Graphics 520
    Sound Card
    Intel(R) HD Graphics 520 + RealTek Audio
    Monitor(s) Displays
    Dell laptop display 15"
    Screen Resolution
    1920 * 1080
    Hard Drives
    Toshiba 128GB M.2 22300 drive
    INTEL Cherryvill 520 Series SSDSC2CW180A 180 GB SATA III SSD
    PSU
    Dell
    Case
    Dell
    Cooling
    Dell
    Mouse
    Logitech MX Master 3S (shared w. Sys 1) | Dell TouchPad
    Keyboard
    Dell
    Internet Speed
    AT&T LightSpeed Gigabit Duplex Ftth

spapakons

Well-known member
Power User
VIP
Local time
12:22 PM
Posts
1,699
Location
Athens
Visit site
OS
Windows 11 Pro 22H2 64-bit (build 22621.1105)
Sounds weird. I once had installed Mac OS X 10.10 on my desktop (2nd system specs) and created an UEFI boot entry "Mac OS X" which I cannot get rid of, but this never caused any issue in Windows 10/11 such as phantom disk in Disk Manager or Device Manager.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 22H2 64-bit (build 22621.1105)
    Computer type
    Laptop
    Manufacturer/Model
    Acer Extensa 5630EZ
    CPU
    Mobile DualCore Intel Core 2 Duo T7250, 2000 MHz
    Motherboard
    Acer Extensa 5630
    Memory
    4GB
    Graphics Card(s)
    Mobile Intel(R) GMA 4500M (Mobile 4 series)
    Sound Card
    Realtek ALC268 @ Intel 82801IB ICH9 - High Definition Audio Controller
    Monitor(s) Displays
    1
    Screen Resolution
    1280x800
    Hard Drives
    Samsung SSD 850 EVO 250GB SATA Device (250 GB, SATA-III)
    Internet Speed
    VDSL 50 Mbps
    Browser
    MICROSOFT EDGE
    Antivirus
    WINDOWS DEFENDER
    Other Info
    Legacy MBR installation, no TPM, no Secure Boot, no WDDM 2.0 graphics drivers, cannot get more unsupported ;) This is only my test laptop. I had installed Windows 11 here before upgrading my main PC. For my main PC I use everyday see my 2nd system specs.
  • Operating System
    Windows 11 Pro v22H2 (build 22621.1105)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom-built PC
    CPU
    Intel Core-i7 3770 3.40GHz s1155 (3rd generation)
    Motherboard
    Asus P8H61 s1155 ATX
    Memory
    2x Kingston Hyper-X Blu 8GB DDR3-1600
    Graphics card(s)
    Gainward NE5105T018G1-1070F (nVidia GeForce GTX 1050Ti 4GB GDDR5)
    Sound Card
    Realtek HD audio (ALC887)
    Monitor(s) Displays
    Sony Bravia KDL-19L4000 19" LCD TV via VGA
    Screen Resolution
    1440x900 32-bit 60Hz
    Hard Drives
    Patriot Burst Elite 480GB SSD as system disk, Western Digital Caviar Purple 4TB SATA III (WD40PURZ) as second
    PSU
    Thermaltake Litepower RGB 550W Full Wired
    Case
    SUPERCASE MIDI-TOWER
    Cooling
    Stock Intel CPU Fan, 1x 8cm fan at the back
    Mouse
    Sunnyline OptiEye PS/2
    Keyboard
    Mitsumi 101-key PS/2
    Internet Speed
    100Mbps
    Browser
    Microsoft Edge, Mozilla Firefox
    Antivirus
    Microsoft Windows Defender
    Other Info
    Legacy BIOS (MBR) installation, no TPM, no Secure Boot, WDDM 3.0 graphics drivers, WEI score 7.4

Winuser

Well-known member
Pro User
VIP
Local time
5:22 AM
Posts
4,427
Visit site
OS
Windows 11
Do you still have the drive? I'm thinking that temporarily installing the drive and then uninstalling it in Device Manger might work.
 

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    PowerSpec B746
    CPU
    Intel Core i7-10700K
    Motherboard
    ASRock Z490 Phantom Gaming 4/ax
    Memory
    16GB (8GB PC4-19200 DDR4 SDRAM x2)
    Graphics Card(s)
    NVIDIA GeForce GTX 1050 TI
    Sound Card
    Realtek Audio
    Monitor(s) Displays
    Samsung SAM0A87 Samsung SAM0D32
    Screen Resolution
    1920 x 1080
    Hard Drives
    NVMe WDC WDS100T2B0C-00PXH0 1TB
    Samsung SSD 860 EVO 1TB
    PSU
    750 Watts (62.5A)
    Case
    PowerSpec/Lian Li ATX 205
    Keyboard
    Logitech K270
    Mouse
    Logitech M185
    Browser
    Microsoft Edge and Firefox
    Antivirus
    ESET Internet Security
  • Operating System
    Windows 11 Dev
    Computer type
    Laptop
    Manufacturer/Model
    HP Envy x360 15-ds1083cl
    CPU
    AMD Ryzen 7 4700U 2.0GHZ
    Memory
    16 MB DDR 4-2666
    Graphics card(s)
    AMD Radeon
    Monitor(s) Displays
    15.6"
    Screen Resolution
    1920x1080
    Hard Drives
    PCIe NVMe M.2 512GB
    Browser
    Firefox, Edge and Edge Canary
    Antivirus
    ESET Internet Security

Latest Support Threads

Top Bottom