Long standing File Explorer irritation.


Subscriber43

Active member
Member
Local time
12:44 AM
Posts
207
OS
Windows 11 Dev
When I want to change my desktop background, I open my "wallpapers" folder in file explorer. I have about 250 jpegs in this folder, set to view a "Extra Large Icons". Whenever I scroll past a pageful (the ones visible without scrolling) and right-click a picture to set as the desktop background, Explorer instantly jumps back to the top, so that the first jpeg is again visible. So, to select another picture, I have to scroll again and look for it.

This happens no matter what view I set for the folder (large icons list etc.) It has happened as far back as I can remember, even in Windows 8, I think.
I am seriously so fed up with this behaviour that I now use a third party file viewer to manage my desktop background, which I change very often.

Is there a workaround for this autoscroll back to top? I have Googled extensively, but most of the responses are to deal with other wallpaper issues. Maybe I am using the wrong search terms, I don;t know.
 

My Computer

System One

  • OS
    Windows 11 Dev
    Computer type
    PC/Desktop
    Manufacturer/Model
    Lenovo ThinkCentre M75Q-1
    CPU
    AMD Ryzen 5 Pro 3400GE @3.30 GHz (4.0 GHz Turbo)
    Motherboard
    Lenovo 3151
    Memory
    20 GB DDR4 2666 (1x16GB + 1x4GB)
    Graphics Card(s)
    AMD Radeon Vega 11
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC 2369
    Screen Resolution
    1920 x 1080
    Hard Drives
    WD 512 GB NVME + SPCC 240GB SATA SSD
    PSU
    External 65W
    Case
    Mini (1L)

Berton

Well-known member
Power User
VIP
Local time
10:44 PM
Posts
808
Location
Wyoming
OS
Win11 Pro RTM x64
Do you see the same thing in other folders, other types of files? Might check if the Indexing of a drive is causing an issue. I've seen such an issue with Photos loading the first time after restart/reboot.
 

My Computers

System One System Two

  • OS
    Win11 Pro RTM x64
    Computer type
    Laptop
    Manufacturer/Model
    Dell Vostro 3400
    CPU
    Intel Core i5
    Memory
    8GB
    Hard Drives
    256GB SSD NVMe
  • Operating System
    Windows 11 Pro RTM x64
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Vostro 5890
    CPU
    Intel Core i5
    Memory
    16GB
    Graphics card(s)
    Onboard, no VGA using DisplayPort-to-VGA adapter
    Monitor(s) Displays
    21"
    Hard Drives
    512GB SSD NVMe, 2TB WDC HDD
    Browser
    Firefox, Edge
    Antivirus
    Windows Defender/Microsoft Security

Subscriber43

Active member
Member
Thread Starter
Local time
12:44 AM
Posts
207
OS
Windows 11 Dev
No, only when setting a wallpaper.

Edit: Indexing is turned off on all drives.
 

My Computer

System One

  • OS
    Windows 11 Dev
    Computer type
    PC/Desktop
    Manufacturer/Model
    Lenovo ThinkCentre M75Q-1
    CPU
    AMD Ryzen 5 Pro 3400GE @3.30 GHz (4.0 GHz Turbo)
    Motherboard
    Lenovo 3151
    Memory
    20 GB DDR4 2666 (1x16GB + 1x4GB)
    Graphics Card(s)
    AMD Radeon Vega 11
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC 2369
    Screen Resolution
    1920 x 1080
    Hard Drives
    WD 512 GB NVME + SPCC 240GB SATA SSD
    PSU
    External 65W
    Case
    Mini (1L)

hsehestedt

Well-known member
Power User
VIP
Local time
11:44 PM
Posts
811
Location
Texas, USA
OS
Windows 11 21H2
This doesn't seem to be the default behavior. I just tried it on 4 different systems and none of them show that behavior.

Try seeing if it behaves that way in Safe Mode. If not, do the usual process of elimination of services, apps that start automatically, etc.
 

My Computers

System One System Two

  • OS
    Windows 11 21H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Home Built
    CPU
    Intel i7-11700K
    Motherboard
    ASUS Prime Z590-A
    Memory
    128GB Crucial Ballistix 3200MHz DRAM
    Graphics Card(s)
    No GPU - CPU graphics only (for now)
    Sound Card
    Realtek (on motherboard)
    Monitor(s) Displays
    HP Envy 32
    Screen Resolution
    2560 x 1440
    Hard Drives
    1 x 1TB NVMe Gen 4 x 4 SSD
    1 x 2TB NVMe Gen 3 x 4 SSD
    2 x 512GB 2.5" SSDs
    2 x 8TB HD
    PSU
    Corsair HX850i
    Case
    Corsair iCue 5000X RGB
    Cooling
    Noctua NH-D15 chromax.black cooler + 10 case fans
    Keyboard
    CODE backlit mechanical keyboard
    Mouse
    Logitech MX Master 3
    Internet Speed
    300Mb down / 20Mb up
    Browser
    Chromium Edge
    Antivirus
    Windows Defender
    Other Info
    Additional options installed:
    WiFi 6E PCIe adapter
    ASUS ThunderboltEX 4 PCIe adapter
  • Operating System
    Windows 11 21H2
    Computer type
    Laptop
    Manufacturer/Model
    HP Spectre x360 15-BL012DX
    CPU
    Intel i7-7500U
    Memory
    32GB
    Graphics card(s)
    Dual Intel HD 620 and Nvidia GeForce 940MX
    Sound Card
    Built-in Realtek HD Audio
    Monitor(s) Displays
    4k 15-inch
    Screen Resolution
    4k (3840 x 2160)
    Hard Drives
    1TB Seagate FireCuda 510 NVMe SSD
    Internet Speed
    300Mb down / 20Mb up
    Browser
    Chromium Edge
    Antivirus
    Windows Defender
    Other Info
    RAM Upgraded from 16GB to 32GB WiFi Upgraded from WiFi 5 to WiFi 6 SSD upgraded from 512GB NVMe SSD to 1TB Seagate FireCuda 510 NVMe SSD

Subscriber43

Active member
Member
Thread Starter
Local time
12:44 AM
Posts
207
OS
Windows 11 Dev
Okay, will try safe mode first. Same behaviour in my laptop, though.
 

My Computer

System One

  • OS
    Windows 11 Dev
    Computer type
    PC/Desktop
    Manufacturer/Model
    Lenovo ThinkCentre M75Q-1
    CPU
    AMD Ryzen 5 Pro 3400GE @3.30 GHz (4.0 GHz Turbo)
    Motherboard
    Lenovo 3151
    Memory
    20 GB DDR4 2666 (1x16GB + 1x4GB)
    Graphics Card(s)
    AMD Radeon Vega 11
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC 2369
    Screen Resolution
    1920 x 1080
    Hard Drives
    WD 512 GB NVME + SPCC 240GB SATA SSD
    PSU
    External 65W
    Case
    Mini (1L)

Bree

Well-known member
Guru
VIP
Local time
5:44 AM
Posts
4,133
Location
S/E England, UK
OS
Windows 11 Home
When I want to change my desktop background, I open my "wallpapers" folder in file explorer. I have about 250 jpegs in this folder, set to view a "Extra Large Icons". Whenever I scroll past a pageful (the ones visible without scrolling) and right-click a picture to set as the desktop background, Explorer instantly jumps back to the top, so that the first jpeg is again visible. So, to select another picture, I have to scroll again and look for it.
This doesn't seem to be the default behavior. I just tried it on 4 different systems and none of them show that behavior
I can confirm this behaviour. To reproduce this there must be sufficient files that you had to scroll down to see the image you have selected (so try selecting the last file). Setting the View to Icons (Extra large, large, medium, or small) is not necessary, but the larger the icon the more likely it is that you have to scroll down to find a file.

And no, I don't know how to stop this behaviour - but I can offer a workaround.

Just because Explorer has scrolled back to the top doesn't mean the file concerned is no longer selected. It is still selected, and if you use the arrow keys on the keyboard you can step the selection to the previous (or next) image. Explorer will then scroll to your selected file, allowing you to carry on from where you had left off.

EDIT: and I can confirm that the behaviour is exactly the same in Windows 10.
 
Last edited:

My Computers

System One System Two

  • OS
    Windows 11 Home
    Computer type
    Laptop
    Manufacturer/Model
    Acer Aspire 3 A315-23
    CPU
    AMD Athlon Silver 3050U
    Memory
    8GB
    Graphics Card(s)
    Radeon Graphics
    Monitor(s) Displays
    laptop screen
    Screen Resolution
    1366x768 native resolution, up to 2560x1440 with Radeon Virtual Super Resolution
    Hard Drives
    1TB HDD
    Browser
    Edge, Firefox
    Antivirus
    Defender
    Other Info
    fully 'Windows 11 ready' laptop. Windows 10 C: partition migrated from my old unsupported 'main machine' then upgraded to 11. A test migration ran Insider builds for 2 months. When 11 was released on 5th October it was re-imaged back to 10 and was offered the upgrade in Windows Update on 20th October.


    My SYSTEM THREE is a Dell Latitude 5410, i7-10610U, 32GB RAM, 512GB ssd, Windows 11 Pro.
  • Operating System
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    Dell Lattitude E4310
    CPU
    i5 M 520
    Motherboard
    0T6M8G
    Memory
    4GB
    Screen Resolution
    1366x768
    Hard Drives
    500GB HDD
    Browser
    Firefox, Edge
    Antivirus
    Defender
    Other Info
    unsupported machine: Legacy bios, MBR, TPM 1.2, upgraded from W10 to W11 using W10/W11 hybrid install media workaround.


    My SYSTEM THREE is a Dell Latitude 5410, i7-10610U, 32GB RAM, 512GB ssd, Windows 11 Pro.

Subscriber43

Active member
Member
Thread Starter
Local time
12:44 AM
Posts
207
OS
Windows 11 Dev
Thank you @Bree!
This is exactly what I was trying to say, and your workaround does the trick.
I still don't understand why Explorer has this behaviour, though. Gonna continue to live with it.
 

My Computer

System One

  • OS
    Windows 11 Dev
    Computer type
    PC/Desktop
    Manufacturer/Model
    Lenovo ThinkCentre M75Q-1
    CPU
    AMD Ryzen 5 Pro 3400GE @3.30 GHz (4.0 GHz Turbo)
    Motherboard
    Lenovo 3151
    Memory
    20 GB DDR4 2666 (1x16GB + 1x4GB)
    Graphics Card(s)
    AMD Radeon Vega 11
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC 2369
    Screen Resolution
    1920 x 1080
    Hard Drives
    WD 512 GB NVME + SPCC 240GB SATA SSD
    PSU
    External 65W
    Case
    Mini (1L)

hsehestedt

Well-known member
Power User
VIP
Local time
11:44 PM
Posts
811
Location
Texas, USA
OS
Windows 11 21H2
Strange that I cannot duplicate this. There must be some setting that alters this behavior. Just tried it on two more systems (6 in total now) and not a single way behaves as described.
 

My Computers

System One System Two

  • OS
    Windows 11 21H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Home Built
    CPU
    Intel i7-11700K
    Motherboard
    ASUS Prime Z590-A
    Memory
    128GB Crucial Ballistix 3200MHz DRAM
    Graphics Card(s)
    No GPU - CPU graphics only (for now)
    Sound Card
    Realtek (on motherboard)
    Monitor(s) Displays
    HP Envy 32
    Screen Resolution
    2560 x 1440
    Hard Drives
    1 x 1TB NVMe Gen 4 x 4 SSD
    1 x 2TB NVMe Gen 3 x 4 SSD
    2 x 512GB 2.5" SSDs
    2 x 8TB HD
    PSU
    Corsair HX850i
    Case
    Corsair iCue 5000X RGB
    Cooling
    Noctua NH-D15 chromax.black cooler + 10 case fans
    Keyboard
    CODE backlit mechanical keyboard
    Mouse
    Logitech MX Master 3
    Internet Speed
    300Mb down / 20Mb up
    Browser
    Chromium Edge
    Antivirus
    Windows Defender
    Other Info
    Additional options installed:
    WiFi 6E PCIe adapter
    ASUS ThunderboltEX 4 PCIe adapter
  • Operating System
    Windows 11 21H2
    Computer type
    Laptop
    Manufacturer/Model
    HP Spectre x360 15-BL012DX
    CPU
    Intel i7-7500U
    Memory
    32GB
    Graphics card(s)
    Dual Intel HD 620 and Nvidia GeForce 940MX
    Sound Card
    Built-in Realtek HD Audio
    Monitor(s) Displays
    4k 15-inch
    Screen Resolution
    4k (3840 x 2160)
    Hard Drives
    1TB Seagate FireCuda 510 NVMe SSD
    Internet Speed
    300Mb down / 20Mb up
    Browser
    Chromium Edge
    Antivirus
    Windows Defender
    Other Info
    RAM Upgraded from 16GB to 32GB WiFi Upgraded from WiFi 5 to WiFi 6 SSD upgraded from 512GB NVMe SSD to 1TB Seagate FireCuda 510 NVMe SSD

Bree

Well-known member
Guru
VIP
Local time
5:44 AM
Posts
4,133
Location
S/E England, UK
OS
Windows 11 Home
Strange that I cannot duplicate this.
Yes, very strange. Read my post #6 again. In addition to what I posted there, it appears that the pictures folder you choose a background from must be a local drive, it doesn't appear to happen with a network drive. The folder I used for this test has 95 files in it.

I can reproduce this on almost all my machines. It happens in Windows 8.1, 10 and 11. The only machine that I cannot reproduce this on is running Windows 7.
 

My Computers

System One System Two

  • OS
    Windows 11 Home
    Computer type
    Laptop
    Manufacturer/Model
    Acer Aspire 3 A315-23
    CPU
    AMD Athlon Silver 3050U
    Memory
    8GB
    Graphics Card(s)
    Radeon Graphics
    Monitor(s) Displays
    laptop screen
    Screen Resolution
    1366x768 native resolution, up to 2560x1440 with Radeon Virtual Super Resolution
    Hard Drives
    1TB HDD
    Browser
    Edge, Firefox
    Antivirus
    Defender
    Other Info
    fully 'Windows 11 ready' laptop. Windows 10 C: partition migrated from my old unsupported 'main machine' then upgraded to 11. A test migration ran Insider builds for 2 months. When 11 was released on 5th October it was re-imaged back to 10 and was offered the upgrade in Windows Update on 20th October.


    My SYSTEM THREE is a Dell Latitude 5410, i7-10610U, 32GB RAM, 512GB ssd, Windows 11 Pro.
  • Operating System
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    Dell Lattitude E4310
    CPU
    i5 M 520
    Motherboard
    0T6M8G
    Memory
    4GB
    Screen Resolution
    1366x768
    Hard Drives
    500GB HDD
    Browser
    Firefox, Edge
    Antivirus
    Defender
    Other Info
    unsupported machine: Legacy bios, MBR, TPM 1.2, upgraded from W10 to W11 using W10/W11 hybrid install media workaround.


    My SYSTEM THREE is a Dell Latitude 5410, i7-10610U, 32GB RAM, 512GB ssd, Windows 11 Pro.

FrancoDT

Well-known member
Member
VIP
Local time
9:44 PM
Posts
280
Location
Nevada
OS
Windows 11
I can vouch mine have always done this on Win 10 and 11 using thumbnails. My workaround was double clicking to open the images in the Photo app and setting it as desktop background from there to keep my place in explorer but Bree's workaround is quicker. After trying it the arrow down always selects the image directly below my last set image.
 

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    Alienware M17 R3
    CPU
    Intel Core i7-10750H (Comet Lake)
    Motherboard
    Alienware
    Memory
    32GB DDR4
    Graphics Card(s)
    NVIDIA GeForce RTX 2060 and Intel UHD Graphics
    Sound Card
    Realtek ALC3281-CG
    Monitor(s) Displays
    17"
    Screen Resolution
    3840x2160
    Hard Drives
    Micron 2300 NVMe 1TB
    PC SN530 NVMe WDC 512GB
    Mouse
    Logitech MX Master 3
    Internet Speed
    50mbps
    Browser
    Vivaldi and Firefox
    Antivirus
    MS Defender and Malwarebytes Free
  • Operating System
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    Microsoft Surface Laptop 3
    CPU
    Intel Core i7-1065G7 (Ice Lake)
    Motherboard
    Microsoft Corp.
    Memory
    16GB DDR4
    Graphics card(s)
    Intel Iris Plus Graphics
    Sound Card
    Omnisonic Speakers with Dolby Audio
    Monitor(s) Displays
    13.5” PixelSense Touchscreen Display
    Screen Resolution
    2256x1504
    Hard Drives
    Toshiba Memory 512GB
    Internet Speed
    50 mbps
    Browser
    Vivaldi and Firefox
    Antivirus
    MS Defender and Malwarebytes Free

hsehestedt

Well-known member
Power User
VIP
Local time
11:44 PM
Posts
811
Location
Texas, USA
OS
Windows 11 21H2
Maybe I'm doing something wrong. Here's a demo video. See if you spot me doing anything wrong. I simply scroll down through my thumbnails and right click on a couple of thumbnails. The only thing that happens is that the context menu is displayed.

NOTE: All my systems are clean installs of Windows 11. Is it possible that this happens only on upgrades?
 

Attachments

  • Demo Video.zip
    620.6 KB · Views: 2

My Computers

System One System Two

  • OS
    Windows 11 21H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Home Built
    CPU
    Intel i7-11700K
    Motherboard
    ASUS Prime Z590-A
    Memory
    128GB Crucial Ballistix 3200MHz DRAM
    Graphics Card(s)
    No GPU - CPU graphics only (for now)
    Sound Card
    Realtek (on motherboard)
    Monitor(s) Displays
    HP Envy 32
    Screen Resolution
    2560 x 1440
    Hard Drives
    1 x 1TB NVMe Gen 4 x 4 SSD
    1 x 2TB NVMe Gen 3 x 4 SSD
    2 x 512GB 2.5" SSDs
    2 x 8TB HD
    PSU
    Corsair HX850i
    Case
    Corsair iCue 5000X RGB
    Cooling
    Noctua NH-D15 chromax.black cooler + 10 case fans
    Keyboard
    CODE backlit mechanical keyboard
    Mouse
    Logitech MX Master 3
    Internet Speed
    300Mb down / 20Mb up
    Browser
    Chromium Edge
    Antivirus
    Windows Defender
    Other Info
    Additional options installed:
    WiFi 6E PCIe adapter
    ASUS ThunderboltEX 4 PCIe adapter
  • Operating System
    Windows 11 21H2
    Computer type
    Laptop
    Manufacturer/Model
    HP Spectre x360 15-BL012DX
    CPU
    Intel i7-7500U
    Memory
    32GB
    Graphics card(s)
    Dual Intel HD 620 and Nvidia GeForce 940MX
    Sound Card
    Built-in Realtek HD Audio
    Monitor(s) Displays
    4k 15-inch
    Screen Resolution
    4k (3840 x 2160)
    Hard Drives
    1TB Seagate FireCuda 510 NVMe SSD
    Internet Speed
    300Mb down / 20Mb up
    Browser
    Chromium Edge
    Antivirus
    Windows Defender
    Other Info
    RAM Upgraded from 16GB to 32GB WiFi Upgraded from WiFi 5 to WiFi 6 SSD upgraded from 512GB NVMe SSD to 1TB Seagate FireCuda 510 NVMe SSD

Bree

Well-known member
Guru
VIP
Local time
5:44 AM
Posts
4,133
Location
S/E England, UK
OS
Windows 11 Home
Here's a demo video. See if you spot me doing anything wrong....
Ah, I see what's 'wrong'. It's what you're not doing. After scrolling down and right-clicking on an image file near the bottom of the list, you have to select 'Set as desktop background'. It's only then that the Explorer view resets to show the top of the files list.
 

My Computers

System One System Two

  • OS
    Windows 11 Home
    Computer type
    Laptop
    Manufacturer/Model
    Acer Aspire 3 A315-23
    CPU
    AMD Athlon Silver 3050U
    Memory
    8GB
    Graphics Card(s)
    Radeon Graphics
    Monitor(s) Displays
    laptop screen
    Screen Resolution
    1366x768 native resolution, up to 2560x1440 with Radeon Virtual Super Resolution
    Hard Drives
    1TB HDD
    Browser
    Edge, Firefox
    Antivirus
    Defender
    Other Info
    fully 'Windows 11 ready' laptop. Windows 10 C: partition migrated from my old unsupported 'main machine' then upgraded to 11. A test migration ran Insider builds for 2 months. When 11 was released on 5th October it was re-imaged back to 10 and was offered the upgrade in Windows Update on 20th October.


    My SYSTEM THREE is a Dell Latitude 5410, i7-10610U, 32GB RAM, 512GB ssd, Windows 11 Pro.
  • Operating System
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    Dell Lattitude E4310
    CPU
    i5 M 520
    Motherboard
    0T6M8G
    Memory
    4GB
    Screen Resolution
    1366x768
    Hard Drives
    500GB HDD
    Browser
    Firefox, Edge
    Antivirus
    Defender
    Other Info
    unsupported machine: Legacy bios, MBR, TPM 1.2, upgraded from W10 to W11 using W10/W11 hybrid install media workaround.


    My SYSTEM THREE is a Dell Latitude 5410, i7-10610U, 32GB RAM, 512GB ssd, Windows 11 Pro.

hsehestedt

Well-known member
Power User
VIP
Local time
11:44 PM
Posts
811
Location
Texas, USA
OS
Windows 11 21H2
Ahhh, okay. See, I knew I had to be doing something wrong :)
 

My Computers

System One System Two

  • OS
    Windows 11 21H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Home Built
    CPU
    Intel i7-11700K
    Motherboard
    ASUS Prime Z590-A
    Memory
    128GB Crucial Ballistix 3200MHz DRAM
    Graphics Card(s)
    No GPU - CPU graphics only (for now)
    Sound Card
    Realtek (on motherboard)
    Monitor(s) Displays
    HP Envy 32
    Screen Resolution
    2560 x 1440
    Hard Drives
    1 x 1TB NVMe Gen 4 x 4 SSD
    1 x 2TB NVMe Gen 3 x 4 SSD
    2 x 512GB 2.5" SSDs
    2 x 8TB HD
    PSU
    Corsair HX850i
    Case
    Corsair iCue 5000X RGB
    Cooling
    Noctua NH-D15 chromax.black cooler + 10 case fans
    Keyboard
    CODE backlit mechanical keyboard
    Mouse
    Logitech MX Master 3
    Internet Speed
    300Mb down / 20Mb up
    Browser
    Chromium Edge
    Antivirus
    Windows Defender
    Other Info
    Additional options installed:
    WiFi 6E PCIe adapter
    ASUS ThunderboltEX 4 PCIe adapter
  • Operating System
    Windows 11 21H2
    Computer type
    Laptop
    Manufacturer/Model
    HP Spectre x360 15-BL012DX
    CPU
    Intel i7-7500U
    Memory
    32GB
    Graphics card(s)
    Dual Intel HD 620 and Nvidia GeForce 940MX
    Sound Card
    Built-in Realtek HD Audio
    Monitor(s) Displays
    4k 15-inch
    Screen Resolution
    4k (3840 x 2160)
    Hard Drives
    1TB Seagate FireCuda 510 NVMe SSD
    Internet Speed
    300Mb down / 20Mb up
    Browser
    Chromium Edge
    Antivirus
    Windows Defender
    Other Info
    RAM Upgraded from 16GB to 32GB WiFi Upgraded from WiFi 5 to WiFi 6 SSD upgraded from 512GB NVMe SSD to 1TB Seagate FireCuda 510 NVMe SSD

Subscriber43

Active member
Member
Thread Starter
Local time
12:44 AM
Posts
207
OS
Windows 11 Dev
Personally, I would like to understand why this only happens in Windows since (as @Bree said) 8.1 and up. Other file managers I've tried work as expected.
 

My Computer

System One

  • OS
    Windows 11 Dev
    Computer type
    PC/Desktop
    Manufacturer/Model
    Lenovo ThinkCentre M75Q-1
    CPU
    AMD Ryzen 5 Pro 3400GE @3.30 GHz (4.0 GHz Turbo)
    Motherboard
    Lenovo 3151
    Memory
    20 GB DDR4 2666 (1x16GB + 1x4GB)
    Graphics Card(s)
    AMD Radeon Vega 11
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC 2369
    Screen Resolution
    1920 x 1080
    Hard Drives
    WD 512 GB NVME + SPCC 240GB SATA SSD
    PSU
    External 65W
    Case
    Mini (1L)
Top Bottom