Microsoft Wireless Display Adapter Bug


JimmyWork

Member
Local time
2:36 AM
Posts
3
OS
Windows 11
On Windows 11 not tested on Windows 10. There is an issue with Microsoft Wireless Display Adapters.

- First time you connect to w new Display Adapter it works without any issue. (This adds the Display adapter in the Bluetooth device list on your device)

- Second time you try to connect (
you have the display adapter in your Bluetooth device list) it will fail, you then have to hit re-connect and it will connect again.

If you remove the Display adapter from the Bluetooth device list it will instantly connect again, then the issue repeats itself.
Tested on fresh clean Win 23H2 install, issue been present for a long time.
 
Windows Build/Version
23H2

My Computer

System One

  • OS
    Windows 11
I can’t remember seeing others complain about this to a noticable degree, so I assume it is a problem you are personally having at the moment.

DISM commands:

You can run the SFC /scannow command from any console, including the command prompt, PowerShell, or Windows Terminal. Open one of these as Admin and type or past that command and press enter, then wait for it to finish, then run restorehealth

-—>

Open search on your PC, type CMD. Right click on the Icon and “Open as admin”

Type (or copy and paste) the following command”

Code:
SFC /scannow

Press enter.

When completed, type (or copy and paste) the following command:

Code:
DISM /online /cleanup-image /restorehealth

Press enter and be patient.

Reboot your PC

<—-

The above failing: You could also try rolling back the driver, the latest isn’t always the greatest.

Failing that working, completely uninstall your Wireless/Bluetooth driver, reboot Windows and let Windows take care of it, or, check the “Optional Updates” under the Advanced button in Windows Update.
 
Last edited:

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 Build: 22631.3593
    Computer type
    PC/Desktop
    Manufacturer/Model
    Sin-built
    CPU
    Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz (4th Gen?)
    Motherboard
    ASUS ROG Maximus VI Formula
    Memory
    32.0 GB of I forget and the box is in storage.
    Graphics Card(s)
    Gigabyte nVidia GeForce GTX 1660 Super OC 6GB
    Sound Card
    Onboard
    Monitor(s) Displays
    4 x LG 23MP75 1 x 24" LG M38H 1 x 32" LF6300 TV Monitor 1 x Wacom Pro 22" Tablet
    Screen Resolution
    All over the place
    Hard Drives
    2 x WD something Something 8TB HDD's / 2 x WD something Something 4TB HDD's / 1 x EVO 1TB SSD / 2 x QVO 1TB SSD's / 1 x EVO 250 GB SSD / 2 x QVO 1TB (External Hub) / 1 x EVO 1TB (Portable Backup Case)
    PSU
    Silverstone 1500
    Case
    NZXT Phantom 820 Full-Tower Case
    Cooling
    Noctua NH-D15 Elite Class Dual Tower CPU Cooler / 6 x EziDIY 120mm / 2 x Corsair 140mm somethings / 1 x 140mm Thermaltake something / 2 x 200mm Corsair.
    Keyboard
    Corsair K95 / Logitech diNovo Edge Wireless
    Mouse
    Logitech G402 / G502 / Mx Masters / MX Air Cordless
    Internet Speed
    100/40Mbps
    Browser
    All sorts
    Antivirus
    Kaspersky Premium
    Other Info
    I’m on a horse.
  • Operating System
    Windows 11 Pro 22621.2215
    Computer type
    Laptop
    Manufacturer/Model
    LENOVO Yoga 7i EVO OLED 14" Touchscreen i5 12 Core 16GB/512GB
    CPU
    Intel Core 12th Gen i5-1240P Processor (1.7 - 4.4GHz)
    Memory
    16GB LPDDR5 RAM
    Graphics card(s)
    Graphics processor is an Intel Iris Xe
    Sound Card
    optimized with Dolby Atmos®
    Screen Resolution
    QHD 2880 x 1800 OLED
    Hard Drives
    M.2 512GB
    Other Info
    …still on a horse.
I have this issue too. Probably something with the wireless drivers or settings. Once you reinstall the wireless drivers it works only to fail next time. Even if it does work the image has some lag and artifacts. I gave up and connected my laptop directly to the TV with an HDMI cable.

PS: Don't bother with sfc and dism instructions, it won't make any difference since it is not a Windows issue.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 64-bit (build 22631.3672)
    Computer type
    Laptop
    Manufacturer/Model
    Acer Extensa 5630EZ
    CPU
    Mobile DualCore Intel Core 2 Duo T7250, 2000 MHz
    Motherboard
    Acer Extensa 5630
    Memory
    4GB
    Graphics Card(s)
    Mobile Intel(R) GMA 4500M (Mobile 4 series)
    Sound Card
    Realtek ALC268 @ Intel 82801IB ICH9 - High Definition Audio Controller
    Monitor(s) Displays
    1
    Screen Resolution
    1280x800
    Hard Drives
    Samsung SSD 850 EVO 250GB SATA Device (250 GB, SATA-III)
    Internet Speed
    VDSL 50 Mbps
    Browser
    MICROSOFT EDGE
    Antivirus
    WINDOWS DEFENDER
    Other Info
    Legacy MBR installation, no TPM, no Secure Boot, no WDDM 2.0 graphics drivers, cannot get more unsupported ;) This is only my test laptop. I had installed Windows 11 here before upgrading my main PC. For my main PC I use everyday see my 2nd system specs.
  • Operating System
    Windows 11 Pro v23H2 (build 22631.3672)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom-built PC
    CPU
    Intel Core-i7 3770 3.40GHz s1155 (3rd generation)
    Motherboard
    Asus P8H61 s1155 ATX
    Memory
    2x Kingston Hyper-X Blu 8GB DDR3-1600
    Graphics card(s)
    Gainward NE5105T018G1-1070F (nVidia GeForce GTX 1050Ti 4GB GDDR5)
    Sound Card
    Realtek HD audio (ALC887)
    Monitor(s) Displays
    Sony Bravia KDL-19L4000 19" LCD TV via VGA
    Screen Resolution
    1440x900 32-bit 60Hz
    Hard Drives
    Patriot Burst Elite 480GB SSD as system disk, Western Digital Caviar Purple 4TB SATA III (WD40PURZ) as second
    PSU
    Thermaltake Litepower RGB 550W Full Wired
    Case
    SUPERCASE MIDI-TOWER
    Cooling
    Stock Intel CPU Fan, 1x 8cm fan at the back
    Mouse
    Sunnyline OptiEye PS/2
    Keyboard
    Mitsumi 101-key PS/2
    Internet Speed
    100Mbps
    Browser
    Microsoft Edge, Mozilla Firefox
    Antivirus
    Microsoft Windows Defender
    Other Info
    Legacy BIOS (MBR) installation, no TPM, no Secure Boot, WDDM 3.0 graphics drivers, WEI score 7.4

Latest Support Threads

Back
Top Bottom