Network Discovery, File and Printer Sharing turns ON by itself


wackopath

Member
Local time
6:08 AM
Posts
4
OS
Windows 11
Hi everyone!
I'm new here so please be patient.
I keep seeing in my 2 PCs the same behaviour;
Network Discovery + File and Printer Sharing turns ON by itself on both Private and Public Networks, I keep checking
and trying to understand what it is that changes this setting everytime without luck.
I always turn it OFF, I want it OFF, but keeps turning ON byt itself.
This happens on my Windows 10 and Windows 11 PCs (this one).
Afaik this shouldn't behave like this or am I wrong?

I'm running Windows 11 Enterprise 22621.232

Any tips are welcome!
Thanks!
 
Windows Build/Version
Windows 11 Enterprise 22621.232

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom
    CPU
    AMD Ryzen 9 5950X
    Motherboard
    Asus ROG Crosshair VIII Dark Hero
    Memory
    Team Group T-Force Xtreem ARGB DDR4 3600MHz 2x16GB
    Graphics Card(s)
    Asus GeForce GTX 1060 Dual OC 2xHDMI 2xDP 6GB (I know, old rubbish enough for me.)
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC
    Hard Drives
    Server

wiganken

Active member
Member
VIP
Local time
5:08 AM
Posts
104
Location
UK
OS
Windows 11 Pro

My Computers

System One System Two

  • OS
    Windows 11 Pro
    Computer type
    PC/Desktop
    Manufacturer/Model
    HP EliteDesk 705 G5
    CPU
    AMD Ryzen 5 Pro 3400GE
    Memory
    8GB DDR4 SDRAM
    Graphics Card(s)
    Integrated AMD Radeon Vega 11
    Hard Drives
    256 GB PCIe NVMe M.2 SSD
  • Operating System
    Windows 11 Home
    Computer type
    Laptop
    Manufacturer/Model
    DELL Inspiron 15-3576
    CPU
    Intel Core i5-8250U
    Memory
    8 GB DDR4 - 2400 SODIMM
    Graphics card(s)
    Intel UHD Graphics 620
    Hard Drives
    256GB SK Hynix SC311 SATA SSD

wackopath

Member
Thread Starter
Local time
6:08 AM
Posts
4
OS
Windows 11
hey! thanx for replying :)

Yes i have tried that, unfortunately still the same issue.

What i don't understand is that while i change to my preference; No file and printer sharing (all networks), it changes to ON inconsistently,
sometimes after a few minutes after reboot or hours later. Very strange behaviour.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom
    CPU
    AMD Ryzen 9 5950X
    Motherboard
    Asus ROG Crosshair VIII Dark Hero
    Memory
    Team Group T-Force Xtreem ARGB DDR4 3600MHz 2x16GB
    Graphics Card(s)
    Asus GeForce GTX 1060 Dual OC 2xHDMI 2xDP 6GB (I know, old rubbish enough for me.)
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC
    Hard Drives
    Server

wiganken

Active member
Member
VIP
Local time
5:08 AM
Posts
104
Location
UK
OS
Windows 11 Pro
This might be a silly question but are you clicking on 'Save Changes' after turning off the settings? See bottom of photo.

I'll try it out on my PC to see if my PC has the same problem and report back tomorrow.Save Changes.jpg
 

My Computers

System One System Two

  • OS
    Windows 11 Pro
    Computer type
    PC/Desktop
    Manufacturer/Model
    HP EliteDesk 705 G5
    CPU
    AMD Ryzen 5 Pro 3400GE
    Memory
    8GB DDR4 SDRAM
    Graphics Card(s)
    Integrated AMD Radeon Vega 11
    Hard Drives
    256 GB PCIe NVMe M.2 SSD
  • Operating System
    Windows 11 Home
    Computer type
    Laptop
    Manufacturer/Model
    DELL Inspiron 15-3576
    CPU
    Intel Core i5-8250U
    Memory
    8 GB DDR4 - 2400 SODIMM
    Graphics card(s)
    Intel UHD Graphics 620
    Hard Drives
    256GB SK Hynix SC311 SATA SSD

wackopath

Member
Thread Starter
Local time
6:08 AM
Posts
4
OS
Windows 11
Yes i have saved :)
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom
    CPU
    AMD Ryzen 9 5950X
    Motherboard
    Asus ROG Crosshair VIII Dark Hero
    Memory
    Team Group T-Force Xtreem ARGB DDR4 3600MHz 2x16GB
    Graphics Card(s)
    Asus GeForce GTX 1060 Dual OC 2xHDMI 2xDP 6GB (I know, old rubbish enough for me.)
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC
    Hard Drives
    Server

wiganken

Active member
Member
VIP
Local time
5:08 AM
Posts
104
Location
UK
OS
Windows 11 Pro
Update as promised: On my PC the settings are still 'Off' after 24 hours.

I wonder if it is something to do with the 'Enterprise' edition of Windows that you are running? This version is intended for companies which need file sharing so maybe the default is for this to be 'On' and a bug is switching it back to 'On' even after you switched it 'Off'. Just a thought. I am not an expert. See: -

As long as there are only your own two computers on your network then it doesn't matter. And if the two computers are not networked then it doesn't matter at all since there is nothing to 'Discover' anyway. I know you state that you want the setting to be 'Off' but I wouldn't get concerned if it is 'On'. I know it is frustrating but I suggest you let it drop and move on.

Best wishes.
 
Last edited:

My Computers

System One System Two

  • OS
    Windows 11 Pro
    Computer type
    PC/Desktop
    Manufacturer/Model
    HP EliteDesk 705 G5
    CPU
    AMD Ryzen 5 Pro 3400GE
    Memory
    8GB DDR4 SDRAM
    Graphics Card(s)
    Integrated AMD Radeon Vega 11
    Hard Drives
    256 GB PCIe NVMe M.2 SSD
  • Operating System
    Windows 11 Home
    Computer type
    Laptop
    Manufacturer/Model
    DELL Inspiron 15-3576
    CPU
    Intel Core i5-8250U
    Memory
    8 GB DDR4 - 2400 SODIMM
    Graphics card(s)
    Intel UHD Graphics 620
    Hard Drives
    256GB SK Hynix SC311 SATA SSD

Berton

Well-known member
Power User
VIP
Local time
10:08 PM
Posts
1,388
Location
Buffalo, Wyoming
OS
Win11 Pro RTM
Could use a 'sledgehammer' on the problem, in Device Manager right-click the Network adapter/s and Disable. Just have to remember to Enable when wanting to use them.
 

My Computers

System One System Two

  • OS
    Win11 Pro RTM
    Computer type
    Laptop
    Manufacturer/Model
    Dell Vostro 3400
    CPU
    Intel Core i5
    Memory
    8GB
    Hard Drives
    256GB SSD NVMe
  • Operating System
    Windows 11 Pro RTM x64
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Vostro 5890
    CPU
    Intel Core i5
    Memory
    16GB
    Graphics card(s)
    Onboard, no VGA, using a DisplayPort-to-VGA adapter
    Monitor(s) Displays
    21"
    Hard Drives
    512GB SSD NVMe, 2TB WDC HDD
    Browser
    Firefox, Edge
    Antivirus
    Windows Defender/Microsoft Security

wackopath

Member
Thread Starter
Local time
6:08 AM
Posts
4
OS
Windows 11
Hi everyone, thanks for the replies.
I've reinstalled my Win 11 PC and so far settings have not changed back to ON, which i still don't understand why it happen in the first place. So for now it works as expected. I'll uppdate this thread soon again just say if the problem is solved.
Thanks again :)
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom
    CPU
    AMD Ryzen 9 5950X
    Motherboard
    Asus ROG Crosshair VIII Dark Hero
    Memory
    Team Group T-Force Xtreem ARGB DDR4 3600MHz 2x16GB
    Graphics Card(s)
    Asus GeForce GTX 1060 Dual OC 2xHDMI 2xDP 6GB (I know, old rubbish enough for me.)
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC
    Hard Drives
    Server

Latest Support Threads

Top Bottom