Problem with OneDrive


ordnance1

New member
Local time
6:41 PM
Posts
13
OS
Windows 11
I have a folder that has been shared with me. I have edit rights. I go to Shared and Shared with me, select the folder then click on Add Shortcut to My Files. Instead of adding the folder to my Windows File Explorer it adds it to my OneDrive My Files. This is on a MS Surface running Windows 11.

Any thought on what the issue might be?
 

My Computer

System One

  • OS
    Windows 11

glasskuter

Well-known member
Pro User
VIP
Local time
8:41 PM
Posts
2,575
Location
The Lone Star State of Texas
OS
Windows 11 Pro 22H2 22621.382
Yes, it is an irksome thing that Windows 11 now sets the location of user folders to Onedrive by default instead of locating these user folders on your local hard drive.
You can prove this is so by going to file explorer, right click on one of your personal folders (ex:documents or desktop), select properties. Observe the location.
To get this folders to be saved on your computer takes a little work.

1. Unlink PC from Onedrive In task tray, click Onedrive icon. Click gear icon to get into Onedrive Settings. Under Account tab, select "Unlink this PC"

NOTE 1: If you do not want to use Onedrive at all and do not want to be nagged with popups about setting up onedrive also under Settings tab - Uncheck start Onedrive automatically.
ATTENTION Note 2: If after you get your folders moved back to you hard drive
you can go back into onedrive settings, check this box again, go to the sync tab and choose what folders you want to sync to onedrive.

You first need to decide if you want your user files saved in their default location on C: drive OR if you want them saved to another location such as a second storage drive in your computer. If you choose the default location use the following steps. (If you choose to move your personal files to another location see instruction at end of this post.)

TO CHANGE LOCATION OF PERSONAL FOLDERS BACK TO DEFAULT LOCATION ON C: DRIVE

2. Browse to your user account C:\users\yourusername. Make sure there are folders there named

Desktop

Documents

Downloads

Music

Pictures

Videos

If these folders do not exist, you will need to create them.

Then use the following tutorials to move your files to their default location on your C: drive. In each of these tutorials I suggest you use Brink's Option 3 (.bat file method) to accomplish the task.







---------------------------------------------------------------------------------------------------------------------------------------------

-------------------------------------------------------------------------------------------------------------------------------------------------

HOW TO CHANGE LOCATION OF PERSONAL FOLDER TO A NEW STORAGE LOCATION SUCH AS A SECONDARY DRIVE
  1. Open File Explorer.
  2. Click on This PC from the left pane.
  3. Navigate to your storage drive
  4. Create new folders named Documents, Desktop, Downloads, Music, Pictures, Videos
Browse back to your user folder C:\users\yourusername

Right-click the folder you want to move and select the Properties options.

Click the Location tab.

Click the Move button and select the newly created folder under the target drive.

Click the Select Folder button. In the explorer window that pops up, browse to the drive where you created the folders and select the newly created equivalent folder to the folder you are moving. Click Select Folder, Click Move. OK or Apply and you'll see a prompt asking whether you want to move files from the existing folder to the new location. In general, you should say yes

Repeat this process for any other folders you want to move to your secondary drive.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 22H2 22621.382
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 m.2 2230-256+1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 21H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium

Try3

Well-known member
Power User
VIP
Local time
2:41 AM
Posts
840
Location
The proper part of London
OS
Windows 11 Home x64 Version 21H2 Build 22000.978
I agree with everything glasskuter has written but would like to add:-

Then double-check by running RegEdit [C:\Windows\regedit.exe] & making sure that no references to OneDrive remain in any of the folder paths shown in these Keys
{You can just paste these Key addresses into RegEdit's address bar to get straight to them.
First - HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
Then - HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders


All the best,
Denis
 
Last edited:

My Computer

System One

  • OS
    Windows 11 Home x64 Version 21H2 Build 22000.978

Dragon Drop

New member
Local time
9:41 PM
Posts
7
OS
Windows 11
I have a related but slightly different OneDrive issue. On setting up my new computer (last week) I copied all my data files (hundreds of them!) to the new computer using a USB flashdrive which was the old computer's backup. I did not put them in OneDrive; I put them on the C: drive, and that's where they are. (I don't want to use OneDrive, because I don't trust "the cloud".) But one folder that I copied consists of shortcuts to all my files, and Windows 11 has changed all the shortcuts so they now point to my OneDrive, which is empty. So now the shortcuts don't work!
 

My Computer

System One

  • OS
    Windows 11

glasskuter

Well-known member
Pro User
VIP
Local time
8:41 PM
Posts
2,575
Location
The Lone Star State of Texas
OS
Windows 11 Pro 22H2 22621.382
@Dragon Drop Maybe someone else knows of a way to do it in bulk, but the only way I would know how to fix that would be to manually change the target path of each shortcut OR delete the bad shortcuts and create a new ones. To manually change the path right click on shortcut, select properties, alter the target, OK
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 22H2 22621.382
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 m.2 2230-256+1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 21H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium

TraderGary

Stock Market Wizard
Power User
VIP
Local time
9:41 PM
Posts
567
Location
Atlanta, GA, USA
OS
Windows 11 Pro
Yes, it is an irksome thing that Windows 11 now sets the location of user folders to Onedrive by default instead of locating these user folders on your local hard drive.
You can prove this is so by going to file explorer, right click on one of your personal folders (ex:documents or desktop), select properties. Observe the location.
And of course, if you are a OneDrive user as I am, this isn't irksome at all. Quite the opposite, it's exactly the behavior you want! :wink:
 

My Computer

System One

  • OS
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    Dell XPS 15 9510 OLED
    CPU
    11th Gen i9 -11900H
    Memory
    32 GB 3200 MHz DDR4
    Graphics Card(s)
    NVIDIA® GeForce® RTX 3050Ti
    Monitor(s) Displays
    15.6" OLED Infinity Edge Touch
    Screen Resolution
    16:10 Aspect Ratio (3456 x 2160)
    Hard Drives
    1 Terabyte M.2 PCIe NVMe SSD
    2 Thunderbolt™ 4 (USB Type-C™)
    1 USB 3.2 Gen 2 (USB Type-C™)
    SD Card Reader (SD, SDHC, SDXC)
    Internet Speed
    700 Mbps, 24 Mbps
    Browser
    Microsoft Edge (Chromium) + Bing
    Antivirus
    Microsoft Windows Security (Defender)
    Other Info
    Microsoft 365 subscription (Office)
    Microsoft OneDrive 1TB Cloud
    Microsoft File History
    Microsoft Outlook
    Microsoft OneNote

    Interactive Brokers Trader Workstation
    Lightroom/Photoshop subscription
    DaVinci Resolve Studio
Top Bottom