Resolving dead internet connection on laptop with screen off


Binky12

Member
Local time
6:17 PM
Posts
1
OS
Windows 11
Hello, I've got an odd problem that I have been unable to resolve for months. I have my laptop connected to an external monitor if that makes any difference. I've noticed that if I leave my laptop on but idle for a number of hours with the screen off, that the internet connection is dead until I move the mouse or press a button on my keyboard. This happens even if I have a CMD window open downloading a video stream using something like FFMPEG. It also happens even if I have script running on Ubuntu via WSL2. Annoyingly, it does not always occur which makes it harder to pinpoint.

I have checked to see if networking is enabled with Modern Standby, which it is. I've tried disabling all power saving features that I know of on my ethernet adapter, which hasn't helped. I have noticed that at times, it almost seems like my ethernet adapter has turned itself off when this issue happens? I don't know how accurate the "duration" time is in Advanced Network Settings, but typically when this issue occurs, the time will reset itself to 0.

I've gone through event viewer and noted the exact time when the issue happened today. It is at the same time as a bunch of "Entering Modern Standby" entries. At this point I'm pretty lost and would love some ideas. It is frustrating knowing that it could always happen when I've gone to work or gone to bed. Sleep is set to Never whilst turn display off is set to 5 minutes. My laptop is connected to AC power at all times.
 
Windows Build/Version
Windows 11 Home 23H2 22631.3593

My Computer

System One

  • OS
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    Acer Aspire A515-47
    CPU
    AMD Ryzen 5 5625U
    Memory
    32GB
    Graphics Card(s)
    Intergrated
    Monitor(s) Displays
    External - 165hz 1440p Display
    Screen Resolution
    Laptop - 1080p
    Internet Speed
    1000Mbps
    Browser
    Edge, Chrome, FireFox
Welcome to the forum. Is this what you did?.... open device manager. Expand 'Network adapters', right click on your wireless adapter (or ethernet adapter if you use wired internet) Select properties, select power management tab, uncheck "allow computer to turn off
this device to save power." OK
Also look in bios to make sure there is no setting relating to network that is turning off its power.

If that doesn't work, try hibernate instead of S0.

By the way, make sure you are using the latest UEFI bios version. Also check for graphics driver update.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3880
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 nvme+256gb SKHynix m.2 nvme /External +512gb Samsung m.2 sata+1tb Kingston m2.nvme
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium

Latest Tutorials

Back
Top Bottom