Solved Screen saver not working / display does not turn off automatically


Kreeep

Member
Local time
11:17 AM
Posts
6
OS
Windows 11 Enterprise 64-bit
I have only started having an issue with this in the past couple of months. Previously, my display would turn off after the selected time as it should. Same with the screen saver. Now, neither function at all. I've tried various solutions online and no luck. I bought a Valve Index VR headset a couple months ago, and suspect that it might be interfering in some way. Perhaps keeping the PC active even when idle in some way to prevent it from displaying the screen saver or turning off the display? Do you guys have any ideas? Thanks.
 
Windows Build/Version
Version 21H2 (OS Build 22000.918)

My Computer

System One

  • OS
    Windows 11 Enterprise 64-bit
    Computer type
    PC/Desktop
    CPU
    AMD Ryzen 9 5900X 12-Core Processor 3.70 GHz
    Motherboard
    ASUSTeK COMPUTER INC. ROG STRIX X470-F GAMING (AM4)
    Memory
    G.SKILL TRIDENT Z RGB 32GB (4X8GB) DDR4 3200MHZ CL16
    Graphics Card(s)
    4095MB NVIDIA GeForce RTX 2080 SUPER (ASUStek Computer Inc)
    Sound Card
    Onboard
    Monitor(s) Displays
    Dell AW3423DW
    Screen Resolution
    3440x1440@175Hz
    Hard Drives
    Samsung 980 Pro 2TB PCIe 4.0 NVMe M.2 SSD
    PSU
    Seasonic Platinum-760 760W 80Plus Platinum Full Modular ATX
    Case
    Aerocool XPredator X3
    Cooling
    Hydro Series H100i RGB PLATINUM
    Keyboard
    K95 RGB PLATINUM
    Mouse
    Razer Basilisk V3
    Internet Speed
    100 Mbps
    Browser
    Mozilla Firefox
    Antivirus
    Malwarebytes Premium

glasskuter

Well-known member
Pro User
VIP
Local time
8:17 PM
Posts
2,574
Location
The Lone Star State of Texas
OS
Windows 11 Pro 22H2 22621.382
I bought a Valve Index VR headset a couple months ago, and suspect that it might be interfering in some way.
It's easy enough to prove. Try turning the headset off. If that doesn't work try disconnecting the headset from graphics card and usb port to see if display turns off and screensaver comes on when it is supposed to.
Once you definitely prove it's the source of the problem, you can troubleshoot accordingly. A web search showed a number of complaints from people that using this and other VR headsets affected sleep and monitor settings. Many found that Steam was keeping their monitor on. One interesting thread in the Steam community found that disabling Nvidia High Definition Audio device in the device manager solved the problem. Steam preventing sleep (not store page videos) :: Help and Tips
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 22H2 22621.382
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 m.2 2230-256+1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 21H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium

Kreeep

Member
Thread Starter
Local time
11:17 AM
Posts
6
OS
Windows 11 Enterprise 64-bit
Thanks for the help and advice. Through your link, I found another link with people having this issue who are using Alienware monitors. Steam being open with or without Nvidia High Definition Audio device enabled made no difference for me. Ending any Alienware related task in Task Manager fixed the issue, so I've uninstalled the drivers and everything is working now. I think it has something to do with Windows attempting to install its own Alienware driver over the top of Alienware's.
 

My Computer

System One

  • OS
    Windows 11 Enterprise 64-bit
    Computer type
    PC/Desktop
    CPU
    AMD Ryzen 9 5900X 12-Core Processor 3.70 GHz
    Motherboard
    ASUSTeK COMPUTER INC. ROG STRIX X470-F GAMING (AM4)
    Memory
    G.SKILL TRIDENT Z RGB 32GB (4X8GB) DDR4 3200MHZ CL16
    Graphics Card(s)
    4095MB NVIDIA GeForce RTX 2080 SUPER (ASUStek Computer Inc)
    Sound Card
    Onboard
    Monitor(s) Displays
    Dell AW3423DW
    Screen Resolution
    3440x1440@175Hz
    Hard Drives
    Samsung 980 Pro 2TB PCIe 4.0 NVMe M.2 SSD
    PSU
    Seasonic Platinum-760 760W 80Plus Platinum Full Modular ATX
    Case
    Aerocool XPredator X3
    Cooling
    Hydro Series H100i RGB PLATINUM
    Keyboard
    K95 RGB PLATINUM
    Mouse
    Razer Basilisk V3
    Internet Speed
    100 Mbps
    Browser
    Mozilla Firefox
    Antivirus
    Malwarebytes Premium

glasskuter

Well-known member
Pro User
VIP
Local time
8:17 PM
Posts
2,574
Location
The Lone Star State of Texas
OS
Windows 11 Pro 22H2 22621.382
Good to hear you found the problem. Thanks for posting what fixed it. It would be helpful if you would mark your thread as solved. (there's a box right under the title)
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 22H2 22621.382
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 m.2 2230-256+1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 21H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium

hsehestedt

Well-known member
Power User
VIP
Local time
8:17 PM
Posts
986
Location
Texas, USA
OS
Windows 11 21H2
FYI, in case you are interested because you are working with a screensaver:

You may have noticed that you can't get the screensaver to display on the lock screen. This is because the lock screen is only displayed for one minute before the screen is turned off. By default, there is no way to alter that in the GUI. To resolve this, follow these steps:

1) Open an elevated command prompt and run this command:

REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\8EC4B3A5-6868-48c2-BE75-4F3044BE88A7" /v "attributes" /t REG_DWORD /d 0x00000002 /f

This will expose a new option in the Windows GUI that was not there previously.

2) Next, do either one of the following:

A) Open Control Panel > Power Options > Change plan settings > Change advanced power settings

or

B) From your command prompt run control powercfg.cpl,,1,

Either of those two options will take you to the same place in Control Panel.

3) You should be looking at the Power options Advanced settings window. Navigate to Display and expand it. You will find that a new option, previously unavailable, is now there: Console lock display off timeout. So long as the timeout you set here is less than the time for the screensaver to kick in, you will now be able to see the screensaver on the lock screen.

Let's take an example:

Let's suppose that you set this to 60 minutes, and you set the screensaver to turn on after 30 minutes. Now, lock the screen. After 30 minutes the screensaver will kick in and it will be visible up to the 60 minute mark at which time the screen will be shut off.

Hope that this is helpful!
 

My Computers

System One System Two

  • OS
    Windows 11 21H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Home Built
    CPU
    Intel i7-11700K
    Motherboard
    ASUS Prime Z590-A
    Memory
    128GB Crucial Ballistix 3200MHz DRAM
    Graphics Card(s)
    No GPU - CPU graphics only (for now)
    Sound Card
    Realtek (on motherboard)
    Monitor(s) Displays
    HP Envy 32
    Screen Resolution
    2560 x 1440
    Hard Drives
    1 x 1TB NVMe Gen 4 x 4 SSD
    1 x 2TB NVMe Gen 3 x 4 SSD
    2 x 512GB 2.5" SSDs
    2 x 8TB HD
    PSU
    Corsair HX850i
    Case
    Corsair iCue 5000X RGB
    Cooling
    Noctua NH-D15 chromax.black cooler + 10 case fans
    Keyboard
    CODE backlit mechanical keyboard
    Mouse
    Logitech MX Master 3
    Internet Speed
    300Mb down / 20Mb up
    Browser
    Chromium Edge
    Antivirus
    Windows Defender
    Other Info
    Additional options installed:
    WiFi 6E PCIe adapter
    ASUS ThunderboltEX 4 PCIe adapter
  • Operating System
    Windows 11 21H2
    Computer type
    Laptop
    Manufacturer/Model
    HP Spectre x360 15-BL012DX
    CPU
    Intel i7-7500U
    Memory
    32GB
    Graphics card(s)
    Dual Intel HD 620 and Nvidia GeForce 940MX
    Sound Card
    Built-in Realtek HD Audio
    Monitor(s) Displays
    4k 15-inch
    Screen Resolution
    4k (3840 x 2160)
    Hard Drives
    1TB Seagate FireCuda 510 NVMe SSD
    Internet Speed
    300Mb down / 20Mb up
    Browser
    Chromium Edge
    Antivirus
    Windows Defender
    Other Info
    RAM Upgraded from 16GB to 32GB WiFi Upgraded from WiFi 5 to WiFi 6 SSD upgraded from 512GB NVMe SSD to 1TB Seagate FireCuda 510 NVMe SSD

Kreeep

Member
Thread Starter
Local time
11:17 AM
Posts
6
OS
Windows 11 Enterprise 64-bit
Oh cool. Thanks for all of that. I don't use a lock screen though, but if I do decide to I'll keep it in mind.

Good to hear you found the problem. Thanks for posting what fixed it. It would be helpful if you would mark your thread as solved. (there's a box right under the title)
I mean, uninstalling the Alienware software is a solution I suppose, but it just creates a new problem. No Alienware software :p But yeah. It's solved enough. If I need fancy lighting in a modern game, then I'll put the Alienware software back on temporarily.
 

My Computer

System One

  • OS
    Windows 11 Enterprise 64-bit
    Computer type
    PC/Desktop
    CPU
    AMD Ryzen 9 5900X 12-Core Processor 3.70 GHz
    Motherboard
    ASUSTeK COMPUTER INC. ROG STRIX X470-F GAMING (AM4)
    Memory
    G.SKILL TRIDENT Z RGB 32GB (4X8GB) DDR4 3200MHZ CL16
    Graphics Card(s)
    4095MB NVIDIA GeForce RTX 2080 SUPER (ASUStek Computer Inc)
    Sound Card
    Onboard
    Monitor(s) Displays
    Dell AW3423DW
    Screen Resolution
    3440x1440@175Hz
    Hard Drives
    Samsung 980 Pro 2TB PCIe 4.0 NVMe M.2 SSD
    PSU
    Seasonic Platinum-760 760W 80Plus Platinum Full Modular ATX
    Case
    Aerocool XPredator X3
    Cooling
    Hydro Series H100i RGB PLATINUM
    Keyboard
    K95 RGB PLATINUM
    Mouse
    Razer Basilisk V3
    Internet Speed
    100 Mbps
    Browser
    Mozilla Firefox
    Antivirus
    Malwarebytes Premium
Top Bottom