Accessibility Turn On or Off Animation Effects in Windows 11


  • Staff
Animation_effects_banner.png

Windows 11 uses animation effects for controls and elements by default.

This tutorial will show you how to turn on or off animation effects for your account in Windows 11.


Your animation effects settings are saved to the UserPreferencesMask DWORD value in the registry key below. This DWORD value also includes other visual effects settings.

HKEY_CURRENT_USER\Control Panel\Desktop



Contents

  • Option One: Turn On or Off Animation Effects in Settings
  • Option Two: Turn On or Off Animation Effects in Control Panel
  • Option Three: Turn On or Off Animation Effects in Performance Options


EXAMPLE: Animations in Windows 11 Motion Design





Option One

Turn On or Off Animation Effects in Settings


1 Open Settings (Win+I).

2 Click/tap on Accessibility on the left side, and click/tap on Visual effects on the right side. (see screenshot below)

Open Visual effects Settings

Animation_effects_Settings-1.png

3 Turn On (default) or Off Animation effects for what you want on the right side. (see screenshot below)

Animation_effects_Settings-2.png

4 You can now close Settings if you like.




Option Two

Turn On or Off Animation Effects in Control Panel


1 Open the Control Panel (icons view), and click/tap on the Ease of Access Center icon.

2 Click/tap on either Use the computer without a display, Make the computer easier to see, or Make it easier to focus on tasks. (see screenshot below)

Animation_effects_Control_Panel-1.png

3 Check (off) or uncheck (on - default) Turn off all unnecessary animations (when posssible) for what you want, and click/tap on OK. (see screenshot below)

Animation_effects_Control_Panel-2.png

4 You can now close the Control Panel if you like.




Option Three

Turn On or Off Animation Effects in Performance Options


1 Open Performance Options (SystemPropertiesPerformance.exe).

2 In the Visual Effects tab, check (on - default) or uncheck (off) Animate controls and elements inside windows, Animate windows when minimizing and maximizing, and Animations in the taskbar for what you want. (see screenshot below)

3 Click/tap on OK.

Visual_Effects.png



That's it,
Shawn Brink


 

Attachments

  • Animation_effects.png
    Animation_effects.png
    11.5 KB · Views: 63
Last edited:
  • Like
Reactions: CB

atinfo

Active member
Member
VIP
Local time
12:39 PM
Posts
244
OS
Win 11 Enterprise
Hi @Brink,

Is it possible to disable only "Menu" sliding? By uncheck "Fade or slide menu into view" nothing happens! When uncheck "Animate controls and elements inside windows", sliding menus become inactive (disable) but it disables "Taskbar" animations too. I like all Win animations but "Menu slide" one. Is there a way to just disable that one. As I realized those are tied together.
 

My Computer

System One

  • OS
    Win 11 Enterprise
    Computer type
    Laptop
    CPU
    i7
    Hard Drives
    SSD

Brink

Administrator
Staff member
MVP
Thread Starter
Local time
3:09 AM
Posts
4,799
OS
Windows 11 Pro for Workstations
Hi @Brink,

Is it possible to disable only "Menu" sliding? By uncheck "Fade or slide menu into view" nothing happens! When uncheck "Animate controls and elements inside windows", sliding menus become inactive (disable) but it disables "Taskbar" animations too. I like all Win animations but "Menu slide" one. Is there a way to just disable that one. As I realized those are tied together.
Hello, :-)

I'm not aware of a separate setting for menus, but you might see of setting the MenuShowDelay time below to 0 may help.

 

My Computers

System One System Two

  • OS
    Windows 11 Pro for Workstations
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom self build
    CPU
    Intel i7-8700K 5 GHz
    Motherboard
    ASUS ROG Maximus XI Formula Z390
    Memory
    16 GB (8GBx2) G.SKILL TridentZ DDR4 3200 MHz
    Graphics Card(s)
    ASUS ROG-STRIX-GTX1080TI-O11G-GAMING
    Sound Card
    Integrated Digital Audio (S/PDIF)
    Monitor(s) Displays
    2 x Samsung Odyssey G75 27"
    Screen Resolution
    2560x1440
    Hard Drives
    1TB Samsung 980 PRO M.2,
    1TB Samsung 970 EVO Plus M.2,
    6TB WD Black WD6001FZWX
    8TB WD MyCloudEX2Ultra NAS
    PSU
    Seasonic Prime Titanium 850W
    Case
    Thermaltake Core P3 wall mounted
    Cooling
    Corsair Hydro H115i
    Keyboard
    Logitech wireless K800
    Mouse
    Logitech MX Master 3
    Internet Speed
    1 Gbps Download and 35 Mbps Upload
    Browser
    Google Chrome
    Antivirus
    Microsoft Defender and Malwarebytes Premium
    Other Info
    Logitech Z625 speaker system,
    Logitech BRIO 4K Pro webcam,
    HP Color LaserJet Pro MFP M477fdn,
    Linksys EA9500 router,
    Motorola MB8611 cable modem,
    APC SMART-UPS RT 1000 XL - SURT1000XLI,
    Galaxy S20 Ultra 5G phone
  • Operating System
    Windows 11 Pro for Workstations
    Computer type
    Laptop
    Manufacturer/Model
    HP Spectre x360 2in1
    CPU
    i7-1065G7 3.9 GHz
    Memory
    16 GB LPDDR4-3200
    Graphics card(s)
    Intel Iris Plus
    Sound Card
    Intel SST
    Monitor(s) Displays
    13.3" 4K UWVA AMOLED multitouch
    Screen Resolution
    3840 x 2160
    Hard Drives
    512 GB PCIe NVMe M.2 SSD
    Browser
    Google Chrome
    Antivirus
    Windows Defender and Malwarebytes Premium

atinfo

Active member
Member
VIP
Local time
12:39 PM
Posts
244
OS
Win 11 Enterprise
I have already changed it to "50" (had changed it to "0" before that) but when you decrease sliding time another problem arises! Sometimes by hovering mouse on an item (menu item) to select it, if one of those items have submenu, it would open before you select your desire item from the menu and take whole space of the menu and you can't see items (!) and you have to use "Esc" key. I thought it is a trick to disable slide animation, but I realized it just decrease sliding speed, as you know better than me it does not disable slide animation fully (just change slide speed).
 

My Computer

System One

  • OS
    Win 11 Enterprise
    Computer type
    Laptop
    CPU
    i7
    Hard Drives
    SSD
Top Bottom