Solved Windows 11 Pro - Quick Assist doesn't work anymore


crancat

New member
Local time
4:39 PM
Posts
5
OS
Windows 11
I have an issue with Quick Assist and Windows 11 Version 10.0.22000.675, OS is joined to a domain

Quick Assist has been correctly updated through Windows Store, but as soon it starts suddenly disappears

checking event viewer I see that application crash, see below details
I can also state:
Microsoft EDGE is updated
tried to reinstall WebViewer2 but it says that is already installed
uninstall and reinstall quick assist won't solve the issue

all repairing modes tried doesn't work, scan SFC or health image, along workaround with PowerShell re-instate
e.g.
Get-AppXPackage | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

it looks like that its related to EmbeddedBrowserWebView.dll but is totally out of blue to me

is anyone able to help ?
thanks a lot
Marco (crancat)

event issue:
Error 08/06/2022 05:36:13 Application Error 1000 (100)
Faulting application name: QuickAssist.exe, version: 10.0.25054.1000, time stamp: 0x13c637fc
Faulting module name: EmbeddedBrowserWebView.dll, version: 90.0.818.66, time stamp: 0x60a5b127
Exception code: 0xc0000005
Fault offset: 0x00000000000b8f1b
Faulting process id: 0x3428
Faulting application start time: 0x01d87ae8e55c862c
Faulting application path: C:\Program Files\WindowsApps\MicrosoftCorporationII.QuickAssist_2.0.6.0_x64__8wekyb3d8bbwe\QuickAssist.exe
Faulting module path: C:\Program Files (x86)\Microsoft\EdgeWebView\Application\90.0.818.66\EBWebView\x64\EmbeddedBrowserWebView.dll
Report Id: fb23038c-ce5e-4b38-ab5c-48c0267c3674
Faulting package full name: MicrosoftCorporationII.QuickAssist_2.0.6.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: App
 

My Computer

System One

  • OS
    Windows 11

garyb0125

New member
Local time
10:39 AM
Posts
6
OS
Windows 10 Pro
Hmmm....my Quick Assist version from the Store is 2.0.6.0. Did you uninstall the old Quick Assist (Settings/Apps&features/optional features) first?
 

My Computer

System One

  • OS
    Windows 10 Pro

crancat

New member
Thread Starter
Local time
4:39 PM
Posts
5
OS
Windows 11
Hmmm....my Quick Assist version from the Store is 2.0.6.0. Did you uninstall the old Quick Assist (Settings/Apps&features/optional features) first?
yes is in my checklist of tests also event-log confirms is the store version, tried everything though...

1654689980444.png
 

My Computer

System One

  • OS
    Windows 11

crancat

New member
Thread Starter
Local time
4:39 PM
Posts
5
OS
Windows 11
got solved this issue

first of all, is totally related to WebViewer2 runtime which is part of Microsoft EDGE
in-fact embeddedbrowserwebview.dll is the application that fails, due it is called/used by quickassist.exe

1) I had to remove and reinstall afterwards .NET 2.0, 3.0 and .NET 4.8 Advanced Services
2) I had to uninstall WebViewer2 runtime with Bulk Crap help, using disable protection feature, it is a Microsoft app with no uninstall feature
3) whilst I was usning Bulk Crap, I also uninstalled Quick Assist along its leftovers within same tool
4) restarts as well included though

5) I had to manually re-install WebView runtime

6) Installed as last piece Quick Assist from Windows Store and finally worked
however, I'm not convinced that this check-list upon is the correct fixing, I'm still convinced that root cause of this is (was) a "pending update" status, I have to remark that this machine is joined to a domain with also updates under GPO control, even though a manual update is also enabled whenever it needs

I do not have another machine on where I could reproduce the same issue, but I'm pretty confident that instead of this checklist, a forcing windows update would have been solved the issue

any thoughts from your side ?
 

My Computer

System One

  • OS
    Windows 11
Top Bottom