Epson Printer XP-15000 prints a weird page "automatically"...

Mistergom

Member
Local time
9:58 AM
Posts
17
Hello!
First of all, thanks a lot for all the great job on the forums! So useful and helpful!

I moved on W11 recently. And for the very first time (no troubles with W10), my printer prints 1 weird page automatically. EVERYTIME I want to print a document for the first time, after turning on the printer (everything seems OK for the next documents IF I don't turn off the printer).
Also, weird over again, the printed weird page is "blocked" (standby) in the printer during the process.
And I have to shut down and relaunch the print spooler (via Epson Printer Connection Checker or via Fix Print Spooler v1.2). Then the printer ejects the weird page, and then I can continue to print documents safely.
Until I turn off the printer and try to print something again.

I also noticed that I can see the printer two times in the list of peripherals.
I'm using the very last Epson drivers and I have already tried to install/reinstall the printer several times.
And if I try to remove one, it removes the other.
The printer is linked via USB port.

Screenshot_001310.jpg

And the weird page is almost blank, with this text on top:

Screenshot_001312.jpg

Fortunately, I have found a "solution" by rebooting the print spooler and/or keeping ON the printer all day(s) long. But a bit tired of handling and trashing papers...

Any thoughts? Thanks!
Best.
 
Windows Build/Version
Win 11 21H2 22000.282
Last edited:

My Computer

System One

  • Operating System
    Win 11 21H2 22000.282
    Computer type
    PC/Desktop
    CPU
    ntel Core i9-10900K CPU @ 3.70GHz
    Motherboard
    TUF GAMING Z590-PLUS WIFI (LGA1200)
    Memory
    64,0 Go
    Graphics Card(s)
    NVIDIA GeForce GTX 1060 6GB
    Monitor(s) Displays
    DELL U2717D + DELL U2715H
    Screen Resolution
    2560x1440
    Hard Drives
    3726GB Western Digital WDC WD40EZRZ-00GXCB0 (SATA )
    232GB Samsung SSD 850 EVO 250GB (SATA (SSD))
    1863GB Samsung SSD 860 QVO 2TB (SATA (SSD))
    465GB Samsung SSD 860 EVO 500GB (SATA (SSD))
    238GB Samsung SSD 850 PRO 256GB (SATA (SSD))
    1863GB Samsung SSD 860 QVO 2TB (SATA (SSD))
    1863GB Samsung SSD 870 QVO 2TB (SATA (SSD))
    PSU
    BeQuiet Straight Power 11 Platinum 750W
    Case
    BeQuiet Silent Base 802
    Cooling
    BeQuiet
    Keyboard
    Logitech Craft
    Mouse
    Razer Viper Ultimate
    Internet Speed
    1GB
    Browser
    Firefox
    Antivirus
    Eset Nod32

Dru2

Well-known member
Power User
VIP
Local time
7:58 PM
Posts
891
Location
Virginia
You sure there's nothing wrong with the printer itself?

All I can say at this point is I have an Epson XP-960 under Windows 11 and all is good. We're also running the same OS, and build.
 

My Computers

System One System Two

  • Operating System
    Windows 11 Pro 21H2 (22000.318)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom built
    CPU
    Intel i9-9900K
    Motherboard
    Gigabyte Aorus Z390 Xtreme
    Memory
    32G (4x8) DDR4 Corsair RGB Dominator Platinum (3600Mhz)
    Graphics Card(s)
    Radeon VII
    Sound Card
    Onboard (ESS Sabre HiFi using Realtek drivers)
    Monitor(s) Displays
    NEC PA242w (24 inch)
    Screen Resolution
    1920 x 1200
    Hard Drives
    5 Samsung SSD drives: 2X 970 NVME (512 & 1TB), 3X EVO SATA (2X 2TB, 1X 1TB)
    PSU
    EVGA Super Nova I000 P2 (1000 watt)
    Case
    Cooler Master H500M
    Cooling
    Corsair H115i RGB Platinum
    Keyboard
    Logitech Craft
    Mouse
    Logitech MX Master 2S
    Internet Speed
    100mb
    Browser
    Edge Chromium
    Antivirus
    Windows Security
    Other Info
    System used for gaming, photography, audiophile media center, work.
  • Operating System
    Win 11 Pro Dev build 22454.1000
    Computer type
    Laptop
    Manufacturer/Model
    Lenovo ThinkPad Yoga X1
    CPU
    Intel i7-7600U
    Motherboard
    Intel
    Memory
    16igg
    Graphics card(s)
    Intel HD 620
    Sound Card
    Onboard
    Monitor(s) Displays
    14.0 WQHD OLED Touch
    Screen Resolution
    2560 x 1440
    Hard Drives
    1TB NVMe Drive (OEM)
    PSU
    laptop
    Case
    laptop
    Cooling
    Laptop cooling
    Mouse
    Logitech MX Anywhere 2S
    Keyboard
    Laptop
    Internet Speed
    100MB
    Browser
    Edge Chromium
    Antivirus
    Windows Security

Mistergom

Member
Thread Starter
Local time
9:58 AM
Posts
17
Hmmm, I have already checked the printer several times and I don't see anything wrong. And the timing seems very linked with Win11 upgrade, as I have never seen this issue before.

Looking at Epson support, sounds possible that several things are not up to date with drivers and firmwares:
 
Last edited:

My Computer

System One

  • Operating System
    Win 11 21H2 22000.282
    Computer type
    PC/Desktop
    CPU
    ntel Core i9-10900K CPU @ 3.70GHz
    Motherboard
    TUF GAMING Z590-PLUS WIFI (LGA1200)
    Memory
    64,0 Go
    Graphics Card(s)
    NVIDIA GeForce GTX 1060 6GB
    Monitor(s) Displays
    DELL U2717D + DELL U2715H
    Screen Resolution
    2560x1440
    Hard Drives
    3726GB Western Digital WDC WD40EZRZ-00GXCB0 (SATA )
    232GB Samsung SSD 850 EVO 250GB (SATA (SSD))
    1863GB Samsung SSD 860 QVO 2TB (SATA (SSD))
    465GB Samsung SSD 860 EVO 500GB (SATA (SSD))
    238GB Samsung SSD 850 PRO 256GB (SATA (SSD))
    1863GB Samsung SSD 860 QVO 2TB (SATA (SSD))
    1863GB Samsung SSD 870 QVO 2TB (SATA (SSD))
    PSU
    BeQuiet Straight Power 11 Platinum 750W
    Case
    BeQuiet Silent Base 802
    Cooling
    BeQuiet
    Keyboard
    Logitech Craft
    Mouse
    Razer Viper Ultimate
    Internet Speed
    1GB
    Browser
    Firefox
    Antivirus
    Eset Nod32

Mistergom

Member
Thread Starter
Local time
9:58 AM
Posts
17
Ah! One more info, I shared my printer via Wifi with other local PC. They are all on Win10 and no troubles while printing from distance...
 

My Computer

System One

  • Operating System
    Win 11 21H2 22000.282
    Computer type
    PC/Desktop
    CPU
    ntel Core i9-10900K CPU @ 3.70GHz
    Motherboard
    TUF GAMING Z590-PLUS WIFI (LGA1200)
    Memory
    64,0 Go
    Graphics Card(s)
    NVIDIA GeForce GTX 1060 6GB
    Monitor(s) Displays
    DELL U2717D + DELL U2715H
    Screen Resolution
    2560x1440
    Hard Drives
    3726GB Western Digital WDC WD40EZRZ-00GXCB0 (SATA )
    232GB Samsung SSD 850 EVO 250GB (SATA (SSD))
    1863GB Samsung SSD 860 QVO 2TB (SATA (SSD))
    465GB Samsung SSD 860 EVO 500GB (SATA (SSD))
    238GB Samsung SSD 850 PRO 256GB (SATA (SSD))
    1863GB Samsung SSD 860 QVO 2TB (SATA (SSD))
    1863GB Samsung SSD 870 QVO 2TB (SATA (SSD))
    PSU
    BeQuiet Straight Power 11 Platinum 750W
    Case
    BeQuiet Silent Base 802
    Cooling
    BeQuiet
    Keyboard
    Logitech Craft
    Mouse
    Razer Viper Ultimate
    Internet Speed
    1GB
    Browser
    Firefox
    Antivirus
    Eset Nod32

Dru2

Well-known member
Power User
VIP
Local time
7:58 PM
Posts
891
Location
Virginia
Again, don't have an answer for your issue other than to say I have two Epson printers - Epson 3880 Pro, and Epson XP-960 and both are working with drivers supplied from Epson

That though there is a "Window 11" dropdown option the drivers are really Windows 10 drivers and they work just fine for me.


Again, though there is a Windows 11 dropdown option, the drivers are really Windows 10 drivers. I place that on the version numbers as well as the date of the drivers.

Here's your Epson XP-15000 drivers (XP-15000_Lite_NA.exe; dated 04/30/21).

All that said, as an Epson fan, I can say I've never run into issues where their printer stop working from one OS to the next. I still have an old (2001) Epson 2200 printer that I've used from Windows XP to Windows 10 and it still works (Epson's drivers still work).

Oh, and I'm also sharing printers between Windows 10 and Windows 11 PC's - laptop/desktops.

Again, no answer for your issue so good luck in finding what's going on.
 

My Computers

System One System Two

  • Operating System
    Windows 11 Pro 21H2 (22000.318)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom built
    CPU
    Intel i9-9900K
    Motherboard
    Gigabyte Aorus Z390 Xtreme
    Memory
    32G (4x8) DDR4 Corsair RGB Dominator Platinum (3600Mhz)
    Graphics Card(s)
    Radeon VII
    Sound Card
    Onboard (ESS Sabre HiFi using Realtek drivers)
    Monitor(s) Displays
    NEC PA242w (24 inch)
    Screen Resolution
    1920 x 1200
    Hard Drives
    5 Samsung SSD drives: 2X 970 NVME (512 & 1TB), 3X EVO SATA (2X 2TB, 1X 1TB)
    PSU
    EVGA Super Nova I000 P2 (1000 watt)
    Case
    Cooler Master H500M
    Cooling
    Corsair H115i RGB Platinum
    Keyboard
    Logitech Craft
    Mouse
    Logitech MX Master 2S
    Internet Speed
    100mb
    Browser
    Edge Chromium
    Antivirus
    Windows Security
    Other Info
    System used for gaming, photography, audiophile media center, work.
  • Operating System
    Win 11 Pro Dev build 22454.1000
    Computer type
    Laptop
    Manufacturer/Model
    Lenovo ThinkPad Yoga X1
    CPU
    Intel i7-7600U
    Motherboard
    Intel
    Memory
    16igg
    Graphics card(s)
    Intel HD 620
    Sound Card
    Onboard
    Monitor(s) Displays
    14.0 WQHD OLED Touch
    Screen Resolution
    2560 x 1440
    Hard Drives
    1TB NVMe Drive (OEM)
    PSU
    laptop
    Case
    laptop
    Cooling
    Laptop cooling
    Mouse
    Logitech MX Anywhere 2S
    Keyboard
    Laptop
    Internet Speed
    100MB
    Browser
    Edge Chromium
    Antivirus
    Windows Security

Dru2

Well-known member
Power User
VIP
Local time
7:58 PM
Posts
891
Location
Virginia
Forgot to address this...
I also noticed that I can see the printer two times in the list of peripherals.

The reason you see two printers in Devices and Printers is the printer is multifunctional (All-In-One), so one represents the Printer, the other the Scanner.

You can right click on "Properties" and look at the "General" tab - one will say "Printer. Scanner", the other will say "Multi Function Printer"

Hope this helps :)
 

My Computers

System One System Two

  • Operating System
    Windows 11 Pro 21H2 (22000.318)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom built
    CPU
    Intel i9-9900K
    Motherboard
    Gigabyte Aorus Z390 Xtreme
    Memory
    32G (4x8) DDR4 Corsair RGB Dominator Platinum (3600Mhz)
    Graphics Card(s)
    Radeon VII
    Sound Card
    Onboard (ESS Sabre HiFi using Realtek drivers)
    Monitor(s) Displays
    NEC PA242w (24 inch)
    Screen Resolution
    1920 x 1200
    Hard Drives
    5 Samsung SSD drives: 2X 970 NVME (512 & 1TB), 3X EVO SATA (2X 2TB, 1X 1TB)
    PSU
    EVGA Super Nova I000 P2 (1000 watt)
    Case
    Cooler Master H500M
    Cooling
    Corsair H115i RGB Platinum
    Keyboard
    Logitech Craft
    Mouse
    Logitech MX Master 2S
    Internet Speed
    100mb
    Browser
    Edge Chromium
    Antivirus
    Windows Security
    Other Info
    System used for gaming, photography, audiophile media center, work.
  • Operating System
    Win 11 Pro Dev build 22454.1000
    Computer type
    Laptop
    Manufacturer/Model
    Lenovo ThinkPad Yoga X1
    CPU
    Intel i7-7600U
    Motherboard
    Intel
    Memory
    16igg
    Graphics card(s)
    Intel HD 620
    Sound Card
    Onboard
    Monitor(s) Displays
    14.0 WQHD OLED Touch
    Screen Resolution
    2560 x 1440
    Hard Drives
    1TB NVMe Drive (OEM)
    PSU
    laptop
    Case
    laptop
    Cooling
    Laptop cooling
    Mouse
    Logitech MX Anywhere 2S
    Keyboard
    Laptop
    Internet Speed
    100MB
    Browser
    Edge Chromium
    Antivirus
    Windows Security

Mistergom

Member
Thread Starter
Local time
9:58 AM
Posts
17
Thanks for your help and attentions. I'm also a big fan of Epson products, and I've never run into issues before, moving quietly between Windows new versions... And I'm quite surprised.

Even with Windows 11 dropdown option, Epson have troubles with some specific products, scanners too, with Win11. For example, buttons of Epson Scan software are - sometimes - missing. Epson suggested to first push "ALT" to make them reappear, while waiting for an update. It is really weird that now, with Win11, some very simple things are broken or odd.
Another issue here with Epson scanners and scan > Windows services and scanner issue

Screenshot_001316.jpg Screenshot_001317.jpg

And my printer is not multifunctional. Printer only. There should be only 1 device, not two. That's why it is easy to guess some troubles with drivers and/or firmware.
And this morning, I have seen only one device... Sometimes 1, sometimes 2...
About Win11, Epson informed that "Epson will release a fix for some products in early November of 2021. Several solutions will be available. Some legacy products will not receive an update."
 

My Computer

System One

  • Operating System
    Win 11 21H2 22000.282
    Computer type
    PC/Desktop
    CPU
    ntel Core i9-10900K CPU @ 3.70GHz
    Motherboard
    TUF GAMING Z590-PLUS WIFI (LGA1200)
    Memory
    64,0 Go
    Graphics Card(s)
    NVIDIA GeForce GTX 1060 6GB
    Monitor(s) Displays
    DELL U2717D + DELL U2715H
    Screen Resolution
    2560x1440
    Hard Drives
    3726GB Western Digital WDC WD40EZRZ-00GXCB0 (SATA )
    232GB Samsung SSD 850 EVO 250GB (SATA (SSD))
    1863GB Samsung SSD 860 QVO 2TB (SATA (SSD))
    465GB Samsung SSD 860 EVO 500GB (SATA (SSD))
    238GB Samsung SSD 850 PRO 256GB (SATA (SSD))
    1863GB Samsung SSD 860 QVO 2TB (SATA (SSD))
    1863GB Samsung SSD 870 QVO 2TB (SATA (SSD))
    PSU
    BeQuiet Straight Power 11 Platinum 750W
    Case
    BeQuiet Silent Base 802
    Cooling
    BeQuiet
    Keyboard
    Logitech Craft
    Mouse
    Razer Viper Ultimate
    Internet Speed
    1GB
    Browser
    Firefox
    Antivirus
    Eset Nod32

cammac49

Member
Local time
7:58 PM
Posts
66
I have an XP-410. Have used Epson printers for a long time. There are 2 devices I think because one of them is for a physical connection to your computer, and one is for wireless. At least that is what mine does. When I purchased the printer, directions advised using the setup disk and FOR FIRST TIME USE, it advised to use a physical connection. And I think the setup disk installs both wireless and non-wireless connection. Since then though, I just go to Epson website and download the setup file for XP-410 and when I run that file, I chose to only set it up by wireless. So there is only 1 device. That setup file was for Win 10. It still works the same under W11 for me. Hope this helps.
 

My Computer

System One

  • Operating System
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    HP
    CPU
    Intel Core i3-8130UCPU @2.20GHz
    Memory
    4 GB + 16 GB Optane
    Graphics Card(s)
    Intel UHD Graphics 620
    Hard Drives
    932 GB HDD
    Internet Speed
    Spectrum Cable
    Browser
    Chrome
    Antivirus
    Windows Secuirity

spapakons

Well-known member
Member
Local time
2:58 AM
Posts
318
I would uninstall the driver from Programs and Features. Then go to Device Manager, show hidden devices, and delete any entry refering to the printer in printers, print queue and Image devices. Disconnect the printer USB cable and restart. This time I would run the setup with right-click Run as Administrator and select to connect via USB. Connect the cable when prompted and wait for setup to finish. After I made sure it works as expected, I would optionally connect it wireless, but if it is next to the computer, I would prefer USB as it provides the most features.
 

My Computers

System One System Two

  • Operating System
    Windows 11 Pro 21H2 64-bit (build 22000.282)
    Computer type
    Laptop
    Manufacturer/Model
    Acer Extensa 5630EZ
    CPU
    Mobile DualCore Intel Core 2 Duo T7250, 2000 MHz
    Motherboard
    Acer Extensa 5630
    Memory
    4GB
    Graphics Card(s)
    Mobile Intel(R) GMA 4500M (Mobile 4 series)
    Sound Card
    Realtek ALC268 @ Intel 82801IB ICH9 - High Definition Audio Controller
    Monitor(s) Displays
    1
    Screen Resolution
    1280x800
    Hard Drives
    Samsung SSD 850 EVO 250GB SATA Device (250 GB, SATA-III)
    Internet Speed
    VDSL 50 Mbps
    Browser
    MICROSOFT EDGE
    Antivirus
    WINDOWS DEFENDER
  • Operating System
    Windows 11 Pro v21H2 (build 22000.348)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom-built PC
    CPU
    Intel Core-i7 3770 3.40GHz s1155 (3rd generation)
    Motherboard
    Asus P8H61 s1155 ATX
    Memory
    2x Kingston Hyper-X Blu 8GB DDR3-1600
    Graphics card(s)
    Asus GT620-1GD3 (nVidia GeForce GT 620 1GB DDR3)
    Sound Card
    Realtek HD audio (ALC887)
    Monitor(s) Displays
    Sony Bravia KDL-19L4000 19" LCD TV via VGA
    Screen Resolution
    1440x900 32-bit 60Hz
    Hard Drives
    Patriot Burst Elite 480GB SSD as system disk, Western Digital Caviar Purple 4TB SATA III (WD40PURZ) as second
    PSU
    Thermaltake Litepower RGB 550W Full Wired
    Case
    SUPERCASE MIDI-TOWER
    Cooling
    Stock Intel CPU Fan, 1x 8cm fan at the back
    Mouse
    Sunnyline OptiEye PS/2
    Keyboard
    Mitsumi 101-key PS/2
    Internet Speed
    100Mbps
    Browser
    Microsoft Edge, Mozilla Firefox
    Antivirus
    Microsoft Windows Defender
    Other Info
    Legacy BIOS (MBR) installation, no TPM, no Secure Boot, WDDM 2.3 graphics drivers, WEI score 4.7

Mistergom

Member
Thread Starter
Local time
9:58 AM
Posts
17
Thanks, my printer is always connected via USB (and it is shared wireless "by itself", not from my PC).

I think that I have already tried these steps, I will try again and keep in touch!
 

My Computer

System One

  • Operating System
    Win 11 21H2 22000.282
    Computer type
    PC/Desktop
    CPU
    ntel Core i9-10900K CPU @ 3.70GHz
    Motherboard
    TUF GAMING Z590-PLUS WIFI (LGA1200)
    Memory
    64,0 Go
    Graphics Card(s)
    NVIDIA GeForce GTX 1060 6GB
    Monitor(s) Displays
    DELL U2717D + DELL U2715H
    Screen Resolution
    2560x1440
    Hard Drives
    3726GB Western Digital WDC WD40EZRZ-00GXCB0 (SATA )
    232GB Samsung SSD 850 EVO 250GB (SATA (SSD))
    1863GB Samsung SSD 860 QVO 2TB (SATA (SSD))
    465GB Samsung SSD 860 EVO 500GB (SATA (SSD))
    238GB Samsung SSD 850 PRO 256GB (SATA (SSD))
    1863GB Samsung SSD 860 QVO 2TB (SATA (SSD))
    1863GB Samsung SSD 870 QVO 2TB (SATA (SSD))
    PSU
    BeQuiet Straight Power 11 Platinum 750W
    Case
    BeQuiet Silent Base 802
    Cooling
    BeQuiet
    Keyboard
    Logitech Craft
    Mouse
    Razer Viper Ultimate
    Internet Speed
    1GB
    Browser
    Firefox
    Antivirus
    Eset Nod32

Mistergom

Member
Thread Starter
Local time
9:58 AM
Posts
17
I did the steps one by one and still same issue, the printer prints a weird page on my first print try. Then everything is OK.
I also still have 2 "similar" printers in the devices and I have just noticed that they don't have the same name!

Screenshot_001337.jpg

I will simply keep my printer turned ON every day ^^, while waiting for a fix from Epson or Microsoft ;)
 

My Computer

System One

  • Operating System
    Win 11 21H2 22000.282
    Computer type
    PC/Desktop
    CPU
    ntel Core i9-10900K CPU @ 3.70GHz
    Motherboard
    TUF GAMING Z590-PLUS WIFI (LGA1200)
    Memory
    64,0 Go
    Graphics Card(s)
    NVIDIA GeForce GTX 1060 6GB
    Monitor(s) Displays
    DELL U2717D + DELL U2715H
    Screen Resolution
    2560x1440
    Hard Drives
    3726GB Western Digital WDC WD40EZRZ-00GXCB0 (SATA )
    232GB Samsung SSD 850 EVO 250GB (SATA (SSD))
    1863GB Samsung SSD 860 QVO 2TB (SATA (SSD))
    465GB Samsung SSD 860 EVO 500GB (SATA (SSD))
    238GB Samsung SSD 850 PRO 256GB (SATA (SSD))
    1863GB Samsung SSD 860 QVO 2TB (SATA (SSD))
    1863GB Samsung SSD 870 QVO 2TB (SATA (SSD))
    PSU
    BeQuiet Straight Power 11 Platinum 750W
    Case
    BeQuiet Silent Base 802
    Cooling
    BeQuiet
    Keyboard
    Logitech Craft
    Mouse
    Razer Viper Ultimate
    Internet Speed
    1GB
    Browser
    Firefox
    Antivirus
    Eset Nod32

Dru2

Well-known member
Power User
VIP
Local time
7:58 PM
Posts
891
Location
Virginia
Even with Windows 11 dropdown option, Epson have troubles with some specific products, scanners too, with Win11. For example, buttons of Epson Scan software are - sometimes - missing. Epson suggested to first push "ALT" to make them reappear, while waiting for an update. It is really weird that now, with Win11, some very simple things are broken or odd.
Another issue here with Epson scanners and scan > Windows services and scanner issue

I'll have to check XP-960 to see if the scanner function is working without issue. Will post back sometime tomorrow. That said, as I said earlier, I have no "printing" issues under Windows 11.

Another issue here with Epson scanners and scan > Windows services and scanner issue

View attachment 13176 View attachment 13177

And my printer is not multifunctional. Printer only. There should be only 1 device, not two. That's why it is easy to guess some troubles with drivers and/or firmware.
And this morning, I have seen only one device... Sometimes 1, sometimes 2...
About Win11, Epson informed that "Epson will release a fix for some products in early November of 2021. Several solutions will be available. Some legacy products will not receive an update."

I stand corrected... assuming this actually is your printer - "Epson Expression Photo HD XP-15000" ???

With that your post is now confusing since you also are showing and talking about Epson Scan software. What's that about? Are you also running an Epson Scanner?

Sorry, but I'm now confused as to what your actual issue is? Scanner software? Printer? Scanner? What printer?

Thanks.
 
Last edited:

My Computers

System One System Two

  • Operating System
    Windows 11 Pro 21H2 (22000.318)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom built
    CPU
    Intel i9-9900K
    Motherboard
    Gigabyte Aorus Z390 Xtreme
    Memory
    32G (4x8) DDR4 Corsair RGB Dominator Platinum (3600Mhz)
    Graphics Card(s)
    Radeon VII
    Sound Card
    Onboard (ESS Sabre HiFi using Realtek drivers)
    Monitor(s) Displays
    NEC PA242w (24 inch)
    Screen Resolution
    1920 x 1200
    Hard Drives
    5 Samsung SSD drives: 2X 970 NVME (512 & 1TB), 3X EVO SATA (2X 2TB, 1X 1TB)
    PSU
    EVGA Super Nova I000 P2 (1000 watt)
    Case
    Cooler Master H500M
    Cooling
    Corsair H115i RGB Platinum
    Keyboard
    Logitech Craft
    Mouse
    Logitech MX Master 2S
    Internet Speed
    100mb
    Browser
    Edge Chromium
    Antivirus
    Windows Security
    Other Info
    System used for gaming, photography, audiophile media center, work.
  • Operating System
    Win 11 Pro Dev build 22454.1000
    Computer type
    Laptop
    Manufacturer/Model
    Lenovo ThinkPad Yoga X1
    CPU
    Intel i7-7600U
    Motherboard
    Intel
    Memory
    16igg
    Graphics card(s)
    Intel HD 620
    Sound Card
    Onboard
    Monitor(s) Displays
    14.0 WQHD OLED Touch
    Screen Resolution
    2560 x 1440
    Hard Drives
    1TB NVMe Drive (OEM)
    PSU
    laptop
    Case
    laptop
    Cooling
    Laptop cooling
    Mouse
    Logitech MX Anywhere 2S
    Keyboard
    Laptop
    Internet Speed
    100MB
    Browser
    Edge Chromium
    Antivirus
    Windows Security

Mistergom

Member
Thread Starter
Local time
9:58 AM
Posts
17
Yes my printer is HD XP-15000 and it is not multifunctional. And I have issue while printing, weird page, etc... as described.

I also have a scanner GT-20000 and another issue.

Link between the two devices is EPSON.
And I simply linked the scanner issue thread to show that there are several troubles with Win11 + Epson products. Even Epson have "Windows 11 dropdown option" for drivers and softwares.

I'm disappointed that Epson point some "Windows 11 options" that are out of date or simply broken, with known issues.
So, now, because I can confirm that it is not a device trouble in my PC or an issue in my PC, I will wait for Epson fixes and updates (and I'm also quite surprised that that kind of issues suddenly appear with Windows 11...).
 

My Computer

System One

  • Operating System
    Win 11 21H2 22000.282
    Computer type
    PC/Desktop
    CPU
    ntel Core i9-10900K CPU @ 3.70GHz
    Motherboard
    TUF GAMING Z590-PLUS WIFI (LGA1200)
    Memory
    64,0 Go
    Graphics Card(s)
    NVIDIA GeForce GTX 1060 6GB
    Monitor(s) Displays
    DELL U2717D + DELL U2715H
    Screen Resolution
    2560x1440
    Hard Drives
    3726GB Western Digital WDC WD40EZRZ-00GXCB0 (SATA )
    232GB Samsung SSD 850 EVO 250GB (SATA (SSD))
    1863GB Samsung SSD 860 QVO 2TB (SATA (SSD))
    465GB Samsung SSD 860 EVO 500GB (SATA (SSD))
    238GB Samsung SSD 850 PRO 256GB (SATA (SSD))
    1863GB Samsung SSD 860 QVO 2TB (SATA (SSD))
    1863GB Samsung SSD 870 QVO 2TB (SATA (SSD))
    PSU
    BeQuiet Straight Power 11 Platinum 750W
    Case
    BeQuiet Silent Base 802
    Cooling
    BeQuiet
    Keyboard
    Logitech Craft
    Mouse
    Razer Viper Ultimate
    Internet Speed
    1GB
    Browser
    Firefox
    Antivirus
    Eset Nod32

Dru2

Well-known member
Power User
VIP
Local time
7:58 PM
Posts
891
Location
Virginia
Well for me, I have no "Epson" issues with Windows 11 on either of my printers - Epson XP-960, Epson 3880 photo printer. And the Epson Scan software for my XP-960 works as well.

That said, the only weird issue I have with the Epson scan software is the "Scan" box is greyed out; however, I can still click the box to scan a document. It's just the box is greyed out; but it still works... In fact, I just scanned a document.

Epson Scan box grayed out.jpg Epson Scan_1.jpg

Outside that minor issue, everything else is good. No weird print pages or missing Epson scan options or properties.

Here's my Epson printers...

Printers under Windows 11.jpg

And yes, because my XP-960 is multifunctional, there are two "XP-960 Series" printers shown. The XP-960 Series (Network) is the actual printer. The XP-960 Series is the scanner portion of the printer. You also might notice my Epson Stylus Pro 3880 as well. BTW, the reason it's greyed out is because the printer is powered off.

No issues here.

BTW, do you have the Epson Software Updater (mine came with and only work with the XP-960). If so, you might run it to check for driver/software update...

Epson Software Updater.jpg
 

My Computers

System One System Two

  • Operating System
    Windows 11 Pro 21H2 (22000.318)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom built
    CPU
    Intel i9-9900K
    Motherboard
    Gigabyte Aorus Z390 Xtreme
    Memory
    32G (4x8) DDR4 Corsair RGB Dominator Platinum (3600Mhz)
    Graphics Card(s)
    Radeon VII
    Sound Card
    Onboard (ESS Sabre HiFi using Realtek drivers)
    Monitor(s) Displays
    NEC PA242w (24 inch)
    Screen Resolution
    1920 x 1200
    Hard Drives
    5 Samsung SSD drives: 2X 970 NVME (512 & 1TB), 3X EVO SATA (2X 2TB, 1X 1TB)
    PSU
    EVGA Super Nova I000 P2 (1000 watt)
    Case
    Cooler Master H500M
    Cooling
    Corsair H115i RGB Platinum
    Keyboard
    Logitech Craft
    Mouse
    Logitech MX Master 2S
    Internet Speed
    100mb
    Browser
    Edge Chromium
    Antivirus
    Windows Security
    Other Info
    System used for gaming, photography, audiophile media center, work.
  • Operating System
    Win 11 Pro Dev build 22454.1000
    Computer type
    Laptop
    Manufacturer/Model
    Lenovo ThinkPad Yoga X1
    CPU
    Intel i7-7600U
    Motherboard
    Intel
    Memory
    16igg
    Graphics card(s)
    Intel HD 620
    Sound Card
    Onboard
    Monitor(s) Displays
    14.0 WQHD OLED Touch
    Screen Resolution
    2560 x 1440
    Hard Drives
    1TB NVMe Drive (OEM)
    PSU
    laptop
    Case
    laptop
    Cooling
    Laptop cooling
    Mouse
    Logitech MX Anywhere 2S
    Keyboard
    Laptop
    Internet Speed
    100MB
    Browser
    Edge Chromium
    Antivirus
    Windows Security

Mistergom

Member
Thread Starter
Local time
9:58 AM
Posts
17
I'm happy for you and I would love to be in the same situation.
But I think that it is not relevant to compare the devices. Because, for example, your Epson scan was updated "recently".
Epson Scan for your device is 4.0.2.0 (2015) and for my for GT-20000, Epson Scan is 3.49 (2009!).
Did you try Epson Scan with "Professional Mode"?

I have another PC at home (for my kids), with Win10, and if I use the printer or the scanner there, everything is fine...
 

My Computer

System One

  • Operating System
    Win 11 21H2 22000.282
    Computer type
    PC/Desktop
    CPU
    ntel Core i9-10900K CPU @ 3.70GHz
    Motherboard
    TUF GAMING Z590-PLUS WIFI (LGA1200)
    Memory
    64,0 Go
    Graphics Card(s)
    NVIDIA GeForce GTX 1060 6GB
    Monitor(s) Displays
    DELL U2717D + DELL U2715H
    Screen Resolution
    2560x1440
    Hard Drives
    3726GB Western Digital WDC WD40EZRZ-00GXCB0 (SATA )
    232GB Samsung SSD 850 EVO 250GB (SATA (SSD))
    1863GB Samsung SSD 860 QVO 2TB (SATA (SSD))
    465GB Samsung SSD 860 EVO 500GB (SATA (SSD))
    238GB Samsung SSD 850 PRO 256GB (SATA (SSD))
    1863GB Samsung SSD 860 QVO 2TB (SATA (SSD))
    1863GB Samsung SSD 870 QVO 2TB (SATA (SSD))
    PSU
    BeQuiet Straight Power 11 Platinum 750W
    Case
    BeQuiet Silent Base 802
    Cooling
    BeQuiet
    Keyboard
    Logitech Craft
    Mouse
    Razer Viper Ultimate
    Internet Speed
    1GB
    Browser
    Firefox
    Antivirus
    Eset Nod32

Dru2

Well-known member
Power User
VIP
Local time
7:58 PM
Posts
891
Location
Virginia
Well, I don't have any other answers for you other than what I posted - no Epson/Windows 11 issues here.

Good luck.
 

My Computers

System One System Two

  • Operating System
    Windows 11 Pro 21H2 (22000.318)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom built
    CPU
    Intel i9-9900K
    Motherboard
    Gigabyte Aorus Z390 Xtreme
    Memory
    32G (4x8) DDR4 Corsair RGB Dominator Platinum (3600Mhz)
    Graphics Card(s)
    Radeon VII
    Sound Card
    Onboard (ESS Sabre HiFi using Realtek drivers)
    Monitor(s) Displays
    NEC PA242w (24 inch)
    Screen Resolution
    1920 x 1200
    Hard Drives
    5 Samsung SSD drives: 2X 970 NVME (512 & 1TB), 3X EVO SATA (2X 2TB, 1X 1TB)
    PSU
    EVGA Super Nova I000 P2 (1000 watt)
    Case
    Cooler Master H500M
    Cooling
    Corsair H115i RGB Platinum
    Keyboard
    Logitech Craft
    Mouse
    Logitech MX Master 2S
    Internet Speed
    100mb
    Browser
    Edge Chromium
    Antivirus
    Windows Security
    Other Info
    System used for gaming, photography, audiophile media center, work.
  • Operating System
    Win 11 Pro Dev build 22454.1000
    Computer type
    Laptop
    Manufacturer/Model
    Lenovo ThinkPad Yoga X1
    CPU
    Intel i7-7600U
    Motherboard
    Intel
    Memory
    16igg
    Graphics card(s)
    Intel HD 620
    Sound Card
    Onboard
    Monitor(s) Displays
    14.0 WQHD OLED Touch
    Screen Resolution
    2560 x 1440
    Hard Drives
    1TB NVMe Drive (OEM)
    PSU
    laptop
    Case
    laptop
    Cooling
    Laptop cooling
    Mouse
    Logitech MX Anywhere 2S
    Keyboard
    Laptop
    Internet Speed
    100MB
    Browser
    Edge Chromium
    Antivirus
    Windows Security
Top Bottom