Solved Multiple Audio drivers ??


S0C9

Member
Local time
11:44 PM
Posts
26
OS
Win11 Pro 23H2 Build 22631.3447
While doing some audio playback, I heard some glitching/artifacts so I started digging.
I discovered I had TWO ACTIVE audio drivers - sO I disabled the NVIDIA version - but the problem persists.
Not even sure how the NVIDIA one installed or whether it came with the build and the Realtek was installed as part of my restoration of my old PC using Laplinks PC Mover app. Thoughts?

1708639704712.png
 

My Computer

System One

  • OS
    Win11 Pro 23H2 Build 22631.3447
    Computer type
    PC/Desktop
    Manufacturer/Model
    Powerspec
    CPU
    Intel(R) Core(TM) i9-14900KF 3.20 GHz
    Motherboard
    MSI PRO Z690-A WIFI (MS-7D25)
    Memory
    G.Skill DDR5-5600 / PC5-44800 DDR5 SDRAM UDIMM
    Graphics Card(s)
    GIGABYTE GeForce RTX 4070 Ti WINDFORCE OC 12G (GV-N407TWF3OC-12GD)
    Sound Card
    OnBoard
    Monitor(s) Displays
    Dell - various (3)
    Screen Resolution
    1920x1080
    Hard Drives
    SSD/HDD/NVME
    PSU
    850 Watt 80+ Gold Modular
    Case
    PowerSpec/Lian Li ATX 205 Mesh
    Cooling
    Coolermaster MASTERLIQUID ML240L V2 RGB
    Keyboard
    Logi MX Keys S
    Mouse
    MX Master 3S
    Internet Speed
    600 mbps
    Browser
    various (Opera, Vivaldi, Edge, Brave, Chrome)
    Antivirus
    anitmalwarebytes; superantispyware; defender
I had to google PCmover. Whenever I see a company claim things like this;

Microsoft® no longer offers Windows Easy Transfer (WET) for moving your data to Windows 10 or Windows 11. Instead, Microsoft®, Intel®, and all major PC manufacturers recommend PCmover when moving to a new computer.

I run for my life.

Here’s a thread from Reddit re having both drivers installed. I doubt your glitching has anything to do with either driver but that’s just my opinion. Are you sure it isn't the hardware?

 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 Build: 22631.3593
    Computer type
    PC/Desktop
    Manufacturer/Model
    Sin-built
    CPU
    Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz (4th Gen?)
    Motherboard
    ASUS ROG Maximus VI Formula
    Memory
    32.0 GB of I forget and the box is in storage.
    Graphics Card(s)
    Gigabyte nVidia GeForce GTX 1660 Super OC 6GB
    Sound Card
    Onboard
    Monitor(s) Displays
    4 x LG 23MP75 1 x 24" LG M38H 1 x 32" LF6300 TV Monitor 1 x Wacom Pro 22" Tablet
    Screen Resolution
    All over the place
    Hard Drives
    2 x WD something Something 8TB HDD's / 2 x WD something Something 4TB HDD's / 1 x EVO 1TB SSD / 2 x QVO 1TB SSD's / 1 x EVO 250 GB SSD / 2 x QVO 1TB (External Hub) / 1 x EVO 1TB (Portable Backup Case)
    PSU
    Silverstone 1500
    Case
    NZXT Phantom 820 Full-Tower Case
    Cooling
    Noctua NH-D15 Elite Class Dual Tower CPU Cooler / 6 x EziDIY 120mm / 2 x Corsair 140mm somethings / 1 x 140mm Thermaltake something / 2 x 200mm Corsair.
    Keyboard
    Corsair K95 / Logitech diNovo Edge Wireless
    Mouse
    Logitech G402 / G502 / Mx Masters / MX Air Cordless
    Internet Speed
    100/40Mbps
    Browser
    All sorts
    Antivirus
    Kaspersky Premium
    Other Info
    I’m on a horse.
  • Operating System
    Windows 11 Pro 22621.2215
    Computer type
    Laptop
    Manufacturer/Model
    LENOVO Yoga 7i EVO OLED 14" Touchscreen i5 12 Core 16GB/512GB
    CPU
    Intel Core 12th Gen i5-1240P Processor (1.7 - 4.4GHz)
    Memory
    16GB LPDDR5 RAM
    Graphics card(s)
    Graphics processor is an Intel Iris Xe
    Sound Card
    optimized with Dolby Atmos®
    Screen Resolution
    QHD 2880 x 1800 OLED
    Hard Drives
    M.2 512GB
    Other Info
    …still on a horse.
The glitching is caused by a controversial topic called "DPC latency". One of your other drivers is hurting the audio driver's performance.
The PC's CPU speed and specs have nothing to do with it, some drivers just don't play well with each other.
 

My Computer

System One

  • OS
    Windows 7
The glitching is caused by a controversial topic called "DPC latency". One of your other drivers is hurting the audio driver's performance.
The PC's CPU speed and specs have nothing to do with it, some drivers just don't play well with each other.
I’m guesssing this is random? I have multiple audio drivers installed and don’t have a problem. I’d imagine millions of people who use windows have both realtek and nvidia audio drivers installed? Yet this is the first topic asking about it that I have seen, which could just mean I don’t take notice. I googled it. Trying to make sense of it.

Also, came across this article;

 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 Build: 22631.3593
    Computer type
    PC/Desktop
    Manufacturer/Model
    Sin-built
    CPU
    Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz (4th Gen?)
    Motherboard
    ASUS ROG Maximus VI Formula
    Memory
    32.0 GB of I forget and the box is in storage.
    Graphics Card(s)
    Gigabyte nVidia GeForce GTX 1660 Super OC 6GB
    Sound Card
    Onboard
    Monitor(s) Displays
    4 x LG 23MP75 1 x 24" LG M38H 1 x 32" LF6300 TV Monitor 1 x Wacom Pro 22" Tablet
    Screen Resolution
    All over the place
    Hard Drives
    2 x WD something Something 8TB HDD's / 2 x WD something Something 4TB HDD's / 1 x EVO 1TB SSD / 2 x QVO 1TB SSD's / 1 x EVO 250 GB SSD / 2 x QVO 1TB (External Hub) / 1 x EVO 1TB (Portable Backup Case)
    PSU
    Silverstone 1500
    Case
    NZXT Phantom 820 Full-Tower Case
    Cooling
    Noctua NH-D15 Elite Class Dual Tower CPU Cooler / 6 x EziDIY 120mm / 2 x Corsair 140mm somethings / 1 x 140mm Thermaltake something / 2 x 200mm Corsair.
    Keyboard
    Corsair K95 / Logitech diNovo Edge Wireless
    Mouse
    Logitech G402 / G502 / Mx Masters / MX Air Cordless
    Internet Speed
    100/40Mbps
    Browser
    All sorts
    Antivirus
    Kaspersky Premium
    Other Info
    I’m on a horse.
  • Operating System
    Windows 11 Pro 22621.2215
    Computer type
    Laptop
    Manufacturer/Model
    LENOVO Yoga 7i EVO OLED 14" Touchscreen i5 12 Core 16GB/512GB
    CPU
    Intel Core 12th Gen i5-1240P Processor (1.7 - 4.4GHz)
    Memory
    16GB LPDDR5 RAM
    Graphics card(s)
    Graphics processor is an Intel Iris Xe
    Sound Card
    optimized with Dolby Atmos®
    Screen Resolution
    QHD 2880 x 1800 OLED
    Hard Drives
    M.2 512GB
    Other Info
    …still on a horse.
It's random because there's too many combinations of graphics, networking and audio drivers, and their releases.

Some drivers play together better than others. It's a crap shoot, and if you discover a stable combination that minimizes audio dropouts -- then don't bother updating your driver set unless it's absolutely necessary. The sad thing is so many users buy expensive "elite PC's" expecting not to see these issues. And it still gets broken by bad drivers. You just keep trying different driver versions until it stops (or becomes less worse).
 

My Computer

System One

  • OS
    Windows 7
Here’s a thread from Reddit re having both drivers installed. I doubt your glitching has anything to do with either driver but that’s just my opinion. Are you sure it isn't the hardware?[/MEDIA]
It's onboard audio from an MSI PRO Z690-A mobo - so it's new-ish and I cannot find anything on their forums about there being a h/ware issue.
I'm reading the reddit sub on it..
It might be the software I am using for playback.. cuz audio from utube vids don't seem to be impacted.
I'll dig some more into that piece of software.... and yes, it's infrequent/intermittent.. might be the audio itself..

Thanks to all for the replies.. I'm NOT using HDMI audio, just audio out from the Z690 to external speakers (w/ sub).
 

My Computer

System One

  • OS
    Win11 Pro 23H2 Build 22631.3447
    Computer type
    PC/Desktop
    Manufacturer/Model
    Powerspec
    CPU
    Intel(R) Core(TM) i9-14900KF 3.20 GHz
    Motherboard
    MSI PRO Z690-A WIFI (MS-7D25)
    Memory
    G.Skill DDR5-5600 / PC5-44800 DDR5 SDRAM UDIMM
    Graphics Card(s)
    GIGABYTE GeForce RTX 4070 Ti WINDFORCE OC 12G (GV-N407TWF3OC-12GD)
    Sound Card
    OnBoard
    Monitor(s) Displays
    Dell - various (3)
    Screen Resolution
    1920x1080
    Hard Drives
    SSD/HDD/NVME
    PSU
    850 Watt 80+ Gold Modular
    Case
    PowerSpec/Lian Li ATX 205 Mesh
    Cooling
    Coolermaster MASTERLIQUID ML240L V2 RGB
    Keyboard
    Logi MX Keys S
    Mouse
    MX Master 3S
    Internet Speed
    600 mbps
    Browser
    various (Opera, Vivaldi, Edge, Brave, Chrome)
    Antivirus
    anitmalwarebytes; superantispyware; defender
It's onboard audio from an MSI PRO Z690-A mobo - so it's new-ish and I cannot find anything on their forums about there being a h/ware issue.
I'm reading the reddit sub on it..

Thanks to all for the replies.. I'm NOT using HDMI audio, just audio out from the Z690 to external speakers (w/ sub).
Let us know what you discover.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 Build: 22631.3593
    Computer type
    PC/Desktop
    Manufacturer/Model
    Sin-built
    CPU
    Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz (4th Gen?)
    Motherboard
    ASUS ROG Maximus VI Formula
    Memory
    32.0 GB of I forget and the box is in storage.
    Graphics Card(s)
    Gigabyte nVidia GeForce GTX 1660 Super OC 6GB
    Sound Card
    Onboard
    Monitor(s) Displays
    4 x LG 23MP75 1 x 24" LG M38H 1 x 32" LF6300 TV Monitor 1 x Wacom Pro 22" Tablet
    Screen Resolution
    All over the place
    Hard Drives
    2 x WD something Something 8TB HDD's / 2 x WD something Something 4TB HDD's / 1 x EVO 1TB SSD / 2 x QVO 1TB SSD's / 1 x EVO 250 GB SSD / 2 x QVO 1TB (External Hub) / 1 x EVO 1TB (Portable Backup Case)
    PSU
    Silverstone 1500
    Case
    NZXT Phantom 820 Full-Tower Case
    Cooling
    Noctua NH-D15 Elite Class Dual Tower CPU Cooler / 6 x EziDIY 120mm / 2 x Corsair 140mm somethings / 1 x 140mm Thermaltake something / 2 x 200mm Corsair.
    Keyboard
    Corsair K95 / Logitech diNovo Edge Wireless
    Mouse
    Logitech G402 / G502 / Mx Masters / MX Air Cordless
    Internet Speed
    100/40Mbps
    Browser
    All sorts
    Antivirus
    Kaspersky Premium
    Other Info
    I’m on a horse.
  • Operating System
    Windows 11 Pro 22621.2215
    Computer type
    Laptop
    Manufacturer/Model
    LENOVO Yoga 7i EVO OLED 14" Touchscreen i5 12 Core 16GB/512GB
    CPU
    Intel Core 12th Gen i5-1240P Processor (1.7 - 4.4GHz)
    Memory
    16GB LPDDR5 RAM
    Graphics card(s)
    Graphics processor is an Intel Iris Xe
    Sound Card
    optimized with Dolby Atmos®
    Screen Resolution
    QHD 2880 x 1800 OLED
    Hard Drives
    M.2 512GB
    Other Info
    …still on a horse.
The simple way to check is change your GPU to run in low-power mode, while you're using audio apps. If that helps, you know where the problem lies.
 

My Computer

System One

  • OS
    Windows 7
The Nvidia audio driver controls the audio carried from graphics card by HDMI or DisplayPort (uses speakers built into monitor). Realtek is audio driver that controls sound from internal audio and the line out jack. In this day and time it is normal to have 2 sound drivers if a system is equipped with a DP or HDMI port.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3737
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 nvme+256gb SKHynix m.2 nvme /External +512gb Samsung m.2 sata+1tb Kingston m2.nvme
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
While doing some audio playback, I heard some glitching/artifacts so I started digging.
I discovered I had TWO ACTIVE audio drivers - sO I disabled the NVIDIA version - but the problem persists.
Not even sure how the NVIDIA one installed or whether it came with the build and the Realtek was installed as part of my restoration of my old PC using Laplinks PC Mover app. Thoughts?

View attachment 88023
I've got more than that. Zero issue. That just shows how many audio devices installed. Interestingly enough I don't see my AMD audio listed, but I've zero worries as I don't use it, and my GPU is running fine. No issues here...

2024-02-22_19-02-43.jpg

Oh, and only one should show active as seen from Sound under Control Panel. Here my Teac DAC ASIO drivers are in use as I'm playing music through my DAC at the moment...

2024-02-22_19-09-56.jpg

Check Sound under Control panel and see what it's saying.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 (Build 22631.3296)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom built
    CPU
    Intel i9-9900K
    Motherboard
    Gigabyte Aorus Z390 Xtreme
    Memory
    32G (4x8) DDR4 Corsair RGB Dominator Platinum (3600Mhz)
    Graphics Card(s)
    Radeon VII
    Sound Card
    Onboard (ESS Sabre HiFi using Realtek drivers)
    Monitor(s) Displays
    NEC PA242w (24 inch)
    Screen Resolution
    1920 x 1200
    Hard Drives
    5 Samsung SSD drives: 2X 970 NVME (512 & 1TB), 3X EVO SATA (2X 2TB, 1X 1TB)
    PSU
    EVGA Super Nova I000 G2 (1000 watt)
    Case
    Cooler Master H500M
    Cooling
    Corsair H115i RGB Platinum
    Keyboard
    Logitech Craft
    Mouse
    Logitech MX Master 3
    Internet Speed
    500mb Download. 11mb Upload
    Browser
    Microsoft Edge Chromium
    Antivirus
    Windows Security
    Other Info
    System used for gaming, photography, music, school.
  • Operating System
    Win 10 Pro 22H2 (build 19045.2130)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custom Built
    CPU
    Intel i7-7700K
    Motherboard
    Gigabyte GA-Z270X-GAMING 8
    Memory
    32G (4x8) DDR4 Corsair Dominator Platinum (3333Mhz)
    Graphics card(s)
    AMD Radeon R9 Fury
    Sound Card
    Onboard (Creative Sound Blaster certified ZxRi)
    Monitor(s) Displays
    Dell U2415 (24 inch)
    Screen Resolution
    1920 x 1200
    Hard Drives
    3 Samsung SSD drives: 1x 512gig 950 NVMe drive (OS drive), 1 x 512gig 850 Pro, 1x 256gig 840 Pro.
    PSU
    EVGA Super Nova 1000 P2 (1000 watt)
    Case
    Phantek Enthoo Luxe
    Cooling
    Corsair H100i
    Mouse
    Logitech MX Master
    Keyboard
    Logitech MK 710
    Internet Speed
    100MB
    Browser
    Edge Chromium
    Antivirus
    Windows Security
    Other Info
    This is my backup system.
Each driver is for different audio functionality.

The Nvidia ones come with Nvidia Graphics drivers, possibly also from Geforce Experience App.

There is 5 on mine
1. Realtek Audio.
2. Nvidia HDA (HDMI/DisplayPort audio).
3. Nvidia broadcast (streaming).
4. Nahimic mirroring device.
5. Nahimic easy surround device.

currently using 1 and 4.
2,3,5 are not used.

No problems with audio.
 

My Computer

System One

  • OS
    Windows 11
you can customize NVidia driver install and choose not to install their audio drivers
 

My Computer

System One

  • OS
    windows 11 pro
    Computer type
    PC/Desktop
    Manufacturer/Model
    selfbuild
    CPU
    Intel Core i9-9900K
    Motherboard
    Asus ROG STRIX Z390-H
    Memory
    Corsair Vengeance LPX 32gb ddr4
    Graphics Card(s)
    ASUS ROG-STRIX-RTX3080-O10G-WHITE 10GB
    Sound Card
    onboard
    Monitor(s) Displays
    ROG Strix XG349C
    Screen Resolution
    3440*1440
    Hard Drives
    windows 11 64 bit => Samsung 970 EVO Plus 500GB m2 drive
    Steam: Client on drive I (1tb Samsung m2-ssd 960 pro 1tb M2 SSD)

    steamlibrary 01 on drive G (500gb samsung 850 EVO 500gb SataSSD)
    steamlibrary 02 on drive J (3tb western digital wd30ezrx-00azb0 Sata)
    steamlibrary 03 on drive H (2tb samsung 850 EVO SataSSD)
    steamlibrary 04 on drive F (2tb samsung 850 EVO SataSSD)
    steamlibrary 05 on drive E (1tb samsung 860 EVO MSataSSD)
    PSU
    Seasonic Prime Ultra 1000 Titanium
    Case
    Cooler Master MasterCase H500M
    Cooling
    NZXT Kraken X72 RGB
    Keyboard
    corsair k95 rgb platinum
    Mouse
    roccat burst core
    Browser
    edge chromium
    Antivirus
    microsoft

Latest Support Threads

Back
Top Bottom