Windows Defender High CPU Usage


Subscriber43

Well-known member
Member
VIP
Local time
8:34 AM
Posts
318
OS
Windows 11 RP
Sorry if this has been asked and answered.
Windows Defender, specifically msmpeng.exe, is using on average 20% CPU. This spikes to 50% briefly. This is even when the system has been completely idle for a while.

My system started lagging, especially when launching programs, and especially slowing down file copy operations.
A web search gives me the same set of solutions from various sites, but none, except disabling real-time protection helps. Even this is temporary, since it apparently re-enables itself after a while.

Windows 11 Dev 25163.1010, Ryzen CPU.
 

My Computer

System One

  • OS
    Windows 11 RP
    Computer type
    PC/Desktop
    Manufacturer/Model
    Lenovo ThinkCentre M75Q-1
    CPU
    AMD Ryzen 5 Pro 3400GE @3.30 GHz (4.0 GHz Turbo)
    Motherboard
    Lenovo 3151
    Memory
    20 GB DDR4 2666 (1x16GB + 1x4GB)
    Graphics Card(s)
    AMD Radeon Vega 11
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC 2369
    Screen Resolution
    1920 x 1080
    Hard Drives
    WD 512 GB NVME + SPCC 240GB SATA SSD
    PSU
    External 65W
    Case
    Mini (1L)
It’s a known problem with build 25163. Some of my apps take 1-2 min to start when normally they initialize in seconds
 

My Computer

System One

  • OS
    Windows 10 , Windows 11
    Computer type
    PC/Desktop
    CPU
    i7-9700
    Motherboard
    Asus ROG Strix Z-390e
    Memory
    32gb
    Graphics Card(s)
    RTX2060S
Some discussion here:
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    CPU
    I8700k
    Motherboard
    MSI Z370A Pro
    Memory
    32 gb
    Graphics Card(s)
    1070ti
    Sound Card
    On-board realtech
It’s a known problem with build 25163. Some of my apps take 1-2 min to start when normally they initialize in seconds
Thanks for the heads up.
 

My Computer

System One

  • OS
    Windows 11 RP
    Computer type
    PC/Desktop
    Manufacturer/Model
    Lenovo ThinkCentre M75Q-1
    CPU
    AMD Ryzen 5 Pro 3400GE @3.30 GHz (4.0 GHz Turbo)
    Motherboard
    Lenovo 3151
    Memory
    20 GB DDR4 2666 (1x16GB + 1x4GB)
    Graphics Card(s)
    AMD Radeon Vega 11
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC 2369
    Screen Resolution
    1920 x 1080
    Hard Drives
    WD 512 GB NVME + SPCC 240GB SATA SSD
    PSU
    External 65W
    Case
    Mini (1L)
Some discussion here:
My CPU is Ryzen, but the article was enlightening. Thanks for this.
 

My Computer

System One

  • OS
    Windows 11 RP
    Computer type
    PC/Desktop
    Manufacturer/Model
    Lenovo ThinkCentre M75Q-1
    CPU
    AMD Ryzen 5 Pro 3400GE @3.30 GHz (4.0 GHz Turbo)
    Motherboard
    Lenovo 3151
    Memory
    20 GB DDR4 2666 (1x16GB + 1x4GB)
    Graphics Card(s)
    AMD Radeon Vega 11
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC 2369
    Screen Resolution
    1920 x 1080
    Hard Drives
    WD 512 GB NVME + SPCC 240GB SATA SSD
    PSU
    External 65W
    Case
    Mini (1L)
I believe this is an old problem that has reared its head off and on since the windows 7 days. Defender tries to scan itself for some crazy reason. Try putting an exception in Windows Defender.
Open settings-privacy and security-click open windows security-virus and threat protection-under virus and threat protection click manage settings-scroll down to exclusions-add an exclusion-file-browse to C:\Program Files\Windows Defender\MsMpEng.exe
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3880
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 nvme+256gb SKHynix m.2 nvme /External +512gb Samsung m.2 sata+1tb Kingston m2.nvme
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
I believe this is an old problem that has reared its head off and on since the windows 7 days. Defender tries to scan itself for some crazy reason. Try putting an exception in Windows Defender.
Open settings-privacy and security-click open windows security-virus and threat protection-under virus and threat protection click manage settings-scroll down to exclusions-add an exclusion-file-browse to C:\Program Files\Windows Defender\MsMpEng.exe
Okay, tried this. Doesn't seem to make a difference. If I sort Task Manager processes by CPU, Antimalware service executable is always at the top. Doesn't move from there.
For now, then, I'll continue to disable real-time protection, the only thing that seems to make a difference.

In this heat, my CPU fans need all the help they can get.
 

My Computer

System One

  • OS
    Windows 11 RP
    Computer type
    PC/Desktop
    Manufacturer/Model
    Lenovo ThinkCentre M75Q-1
    CPU
    AMD Ryzen 5 Pro 3400GE @3.30 GHz (4.0 GHz Turbo)
    Motherboard
    Lenovo 3151
    Memory
    20 GB DDR4 2666 (1x16GB + 1x4GB)
    Graphics Card(s)
    AMD Radeon Vega 11
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC 2369
    Screen Resolution
    1920 x 1080
    Hard Drives
    WD 512 GB NVME + SPCC 240GB SATA SSD
    PSU
    External 65W
    Case
    Mini (1L)
Check details in task manager to see how many instances of MsMpEng you have. I have two, MsMpEng.exe and MsMpEngCP.exe.

Might be worth downloading free Malwarebytes and cancel the free 14 day trial then updating and run a manual scan. Turn on 'scan for rootkits' under Security tab first. Worth checking out.

1658781066182.png


At least then, if nothing found, you'll know it's probably a Defender issue.
 

My Computers

System One System Two

  • OS
    Win 11 Home & 🐥.
    Computer type
    Laptop
    Manufacturer/Model
    ACER Nitro AN16-41
    CPU
    AMD Ryzen™ 7 7735HS Processor 3.2Ghz
    Motherboard
    RB Sierra_PEH (FP7)
    Memory
    32 GB DDR5 4800MHz
    Graphics Card(s)
    NVIDIA GeForce RTX 4060 8GB GDDR6
    Monitor(s) Displays
    16" QHD+ 165Hz 16:10 IPS Technology
    Screen Resolution
    1920 X 1200
    Hard Drives
    Samsung 990 PRO 2TB
    PSU
    330 Watts
    Mouse
    Lenovo Bluetooth.
    Internet Speed
    500 Mbps
    Browser
    Edge
    Antivirus
    Defender
  • Operating System
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    ACER NITRO
    CPU
    AMD Ryzen 7 5800H / 3.2 GHz
    Motherboard
    CZ Scala_CAS (FP6)
    Memory
    32 GB DDR4 SDRAM 3200 MHz
    Graphics card(s)
    NVIDIA GeForce RTX 3060 6 GB GDDR6 SDRAM
    Sound Card
    Realtek Audio. NVIDIA High Definition Audio
    Monitor(s) Displays
    15.6" LED backlight 1920 x 1080 (Full HD) 144 Hz
    Screen Resolution
    1920 x 1080 (Full HD)
    Hard Drives
    Samsung 970 Evo Plus 2TB NVMe M.2
    PSU
    180 Watt, 19.5 V
    Mouse
    Lenovo Bluetooth
    Internet Speed
    500 Mbps
    Browser
    Edge
    Antivirus
    Defender
Check details in task manager to see how many instances of MsMpEng you have. I have two, MsMpEng.exe and MsMpEngCP.exe.

Might be worth downloading free Malwarebytes and cancel the free 14 day trial then updating and run a manual scan. Turn on 'scan for rootkits' under Security tab first. Worth checking out.

View attachment 34973


At least then, if nothing found, you'll know it's probably a Defender issue.
Malwarebytes came up clean, so, as you said, it's probably a defender issue.
 

My Computer

System One

  • OS
    Windows 11 RP
    Computer type
    PC/Desktop
    Manufacturer/Model
    Lenovo ThinkCentre M75Q-1
    CPU
    AMD Ryzen 5 Pro 3400GE @3.30 GHz (4.0 GHz Turbo)
    Motherboard
    Lenovo 3151
    Memory
    20 GB DDR4 2666 (1x16GB + 1x4GB)
    Graphics Card(s)
    AMD Radeon Vega 11
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC 2369
    Screen Resolution
    1920 x 1080
    Hard Drives
    WD 512 GB NVME + SPCC 240GB SATA SSD
    PSU
    External 65W
    Case
    Mini (1L)
I followed the registry method in this site, and the high usage disappeared.
However, this is not a solution, merely a band-aid. Problem is still there.
 

My Computer

System One

  • OS
    Windows 11 RP
    Computer type
    PC/Desktop
    Manufacturer/Model
    Lenovo ThinkCentre M75Q-1
    CPU
    AMD Ryzen 5 Pro 3400GE @3.30 GHz (4.0 GHz Turbo)
    Motherboard
    Lenovo 3151
    Memory
    20 GB DDR4 2666 (1x16GB + 1x4GB)
    Graphics Card(s)
    AMD Radeon Vega 11
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC 2369
    Screen Resolution
    1920 x 1080
    Hard Drives
    WD 512 GB NVME + SPCC 240GB SATA SSD
    PSU
    External 65W
    Case
    Mini (1L)
Some discussion here:
This has nothing to do with OPs issue.
 

My Computer

System One

  • OS
    Windows 10 Pro + others in VHDs
    Computer type
    Laptop
    Manufacturer/Model
    ASUS Vivobook 14
    CPU
    I7
    Motherboard
    Yep, Laptop has one.
    Memory
    16 GB
    Graphics Card(s)
    Integrated Intel Iris XE
    Sound Card
    Realtek built in
    Monitor(s) Displays
    N/A
    Screen Resolution
    1920x1080
    Hard Drives
    1 TB Optane NVME SSD, 1 TB NVME SSD
    PSU
    Yep, got one
    Case
    Yep, got one
    Cooling
    Stella Artois
    Keyboard
    Built in
    Mouse
    Bluetooth , wired
    Internet Speed
    72 Mb/s :-(
    Browser
    Edge mostly
    Antivirus
    Defender
    Other Info
    TPM 2.0

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3880
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 nvme+256gb SKHynix m.2 nvme /External +512gb Samsung m.2 sata+1tb Kingston m2.nvme
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
According to that article:
"The Windows 11 installation media (ISO or USB) must be the same edition, same version, and same or higher build as the currently installed Windows 11."

The latest ISO from Microsoft is 25158. I am on 25163.
I know I can get 25163 from UUPDump, but lately, I have always had problems with Windows 11 after using their ISOs.

I downloaded the 25158 ISO from Microsoft, and am now going to do a clean install.
 

My Computer

System One

  • OS
    Windows 11 RP
    Computer type
    PC/Desktop
    Manufacturer/Model
    Lenovo ThinkCentre M75Q-1
    CPU
    AMD Ryzen 5 Pro 3400GE @3.30 GHz (4.0 GHz Turbo)
    Motherboard
    Lenovo 3151
    Memory
    20 GB DDR4 2666 (1x16GB + 1x4GB)
    Graphics Card(s)
    AMD Radeon Vega 11
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC 2369
    Screen Resolution
    1920 x 1080
    Hard Drives
    WD 512 GB NVME + SPCC 240GB SATA SSD
    PSU
    External 65W
    Case
    Mini (1L)
So, I did a clean install of Dev 25158. Did not install anything else (hid ALL updates using wushowhide2).
Used the PC for an hour. No issues. Msmpeng did not even show up in Task Manager. System ran a little cooler.
Then, installed office 365, Vmware Player, Firefox and a couple apps from the Microsoft Store.
Used it for another hour. No sign of CPU spikes or other overusage like before.
Updated to 25163. Typing this on the PC right now, humming along with no problems. All of my software re-installed and working properly.
PC seems snappier than before.
I have not install a single driver update offered in Windows update except for the Radeon GPU driver (WDDM 3.1).

Ergo, I suspect the culprit was one of those many Intel or Realtek drivers. Not about to find out which one, though. System is working nicely as is.

Edit: Still no msmpeng.exe in Task Manager.
 

My Computer

System One

  • OS
    Windows 11 RP
    Computer type
    PC/Desktop
    Manufacturer/Model
    Lenovo ThinkCentre M75Q-1
    CPU
    AMD Ryzen 5 Pro 3400GE @3.30 GHz (4.0 GHz Turbo)
    Motherboard
    Lenovo 3151
    Memory
    20 GB DDR4 2666 (1x16GB + 1x4GB)
    Graphics Card(s)
    AMD Radeon Vega 11
    Sound Card
    Integrated
    Monitor(s) Displays
    AOC 2369
    Screen Resolution
    1920 x 1080
    Hard Drives
    WD 512 GB NVME + SPCC 240GB SATA SSD
    PSU
    External 65W
    Case
    Mini (1L)

Latest Support Threads

Back
Top Bottom