HOW (?) to block an App from updating in the store ?


pietcorus2

Well-known member
Member
VIP
Thread Starter
Local time
11:31 AM
Posts
369
Location
Netherlands
OS
Windows11 Pro
Im on my "error-free" PC ( with good working latest Media Player ) .
Just checked the two files which gave me the errors , during the " splashscreens " on my other machine.

noticed ; twinapi.appcore.dll is just the same file on both machines .
the other file , which gave erors in the eventlog is ; basecom.dll.............this file IS NOT PRESENT on the good working PC , it is present on the other PC ( gave me the errors pointing to twinapi.appcore.dll and basecom.dll )

Will try to remove this basecom.dll and see if it helps............

OK , tried really everything , even updated my nVidia-drivers , sfc /scannow , uninstalled completely , etc.
This latest Media Player keeps opening in a flash , have to click twice with mp3 , movie , etc.
I will stop and keep my good working previous version !

Maybe next update will work fine...............?
 
Last edited:

My Computer

System One

  • OS
    Windows11 Pro
    Computer type
    PC/Desktop
    Manufacturer/Model
    Asus
    CPU
    i7
    Motherboard
    z97k
    Memory
    32GB
    Graphics Card(s)
    nVidia
    Sound Card
    Realtek
    Hard Drives
    3
    Cooling
    air

Edwin

♦ ♦
Guru
VIP
Local time
5:31 AM
Posts
5,822
OS
Windows 10/11
but after updating with the store I get the problem
Disable Automatic Updates, then update apps individually...,
DO NOT click on Update all or Get updates!

0001206.png
 

My Computers

System One System Two

  • OS
    Windows 10/11
    Computer type
    PC/Desktop
    Manufacturer/Model
    ASUS ROG Strix
  • Operating System
    Windows 11
    Computer type
    Laptop
    Manufacturer/Model
    ASUS VivoBook

pietcorus2

Well-known member
Member
VIP
Thread Starter
Local time
11:31 AM
Posts
369
Location
Netherlands
OS
Windows11 Pro
Yes, I dont update MediaPlayer anymore ( untill better version appears ) .
No updates so far , only this "splashscreen-version " , tried really everything , costed me a whole day , I stop trying , till better solution appears.........HardCopy0001.png
 

My Computer

System One

  • OS
    Windows11 Pro
    Computer type
    PC/Desktop
    Manufacturer/Model
    Asus
    CPU
    i7
    Motherboard
    z97k
    Memory
    32GB
    Graphics Card(s)
    nVidia
    Sound Card
    Realtek
    Hard Drives
    3
    Cooling
    air

atinfo

Well-known member
Member
VIP
Local time
2:01 PM
Posts
547
OS
Win 11 Enterprise
One of the first things I do (disable Store apps auto-update) after a clean install. You can disable Store app automatic update with GPEdit or WinaeroTweaker.

GPEdit: Computer Configuration>Administrative Templates>Windows Components>Store
Turn off Automatic Download and Install of updates (=Enabled)


WinaeroTweaker: Enable "Disable auto-update of Store apps".

ss.png
 

My Computer

System One

  • OS
    Win 11 Enterprise
    Computer type
    Laptop
    CPU
    i7
    Hard Drives
    SSD

Latest Support Threads

Top Bottom