Accent color not showing on some title bars


pokeefe0001

Well-known member
Member
VIP
Local time
10:33 PM
Posts
219
Location
Pacific Northwest USA
OS
Windows 11
Win11 21H2 build 22000.556

I have set the option to show accent color on title bars. This does not work for some Windows applications - notably Notepad and File Explorer. (It does work for WordPad.) Interestingly, the File Explorer colored title bar is used if the "Classic File Explorer" registry hack
Code:
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Shell Extensions\Blocked]
"{e2bf9676-5f8f-435c-97eb-11607a5bedf7}"=""
is in place.

I assume this means there is a whole class of Windows applications that use some new formatting scheme that ignores the accent color setting. Is there some other setting or registry hack that will let (force) them to use the accent color?
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Microsoft
    CPU
    Intel Core i5-8400
    Motherboard
    ASUS PRIME H370-PLUS
    Memory
    16GB
    Graphics Card(s)
    Intel UHD Graphics 630
    Sound Card
    On board
    Monitor(s) Displays
    Samsung SyncMaster 2043BWX
    Screen Resolution
    1680 x 1050
    Hard Drives
    Samsung SSD 850 256GB
    WDC 1TB NVMe
    WD 3TB external USB drive
    PSU
    I don't remember
    Case
    Corsair something-or-other
    Cooling
    Air CPU + 2 case fans
    Keyboard
    DAS S Pro (Cherry Brown)
    Mouse
    Logitech USB of some sort
Yes, it's that way for me as well. I think there's so much under the hood of this new GUI that affects it, that, in places the tweaks we make work against the actual settings in windows in some places. I gave up trying to figure it out.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3737
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 nvme+256gb SKHynix m.2 nvme /External +512gb Samsung m.2 sata+1tb Kingston m2.nvme
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
... I think there's so much under the hood of this new GUI that affects it, that, in places the tweaks we make work against the actual settings in windows in some places. ...
Hmm. Or perhaps a bug in the new GUI that works against a user-customizable setting. If Microsoft hasn't provided some other new option to make this color setting work with the new GUI I'm tempted to call this a bug.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Microsoft
    CPU
    Intel Core i5-8400
    Motherboard
    ASUS PRIME H370-PLUS
    Memory
    16GB
    Graphics Card(s)
    Intel UHD Graphics 630
    Sound Card
    On board
    Monitor(s) Displays
    Samsung SyncMaster 2043BWX
    Screen Resolution
    1680 x 1050
    Hard Drives
    Samsung SSD 850 256GB
    WDC 1TB NVMe
    WD 3TB external USB drive
    PSU
    I don't remember
    Case
    Corsair something-or-other
    Cooling
    Air CPU + 2 case fans
    Keyboard
    DAS S Pro (Cherry Brown)
    Mouse
    Logitech USB of some sort
I've been replicating it several times even after 3 resets and an .iso recovery. As I take screen shots, I found that it involves the active and inactive title bars for the web browser from the Start Menu or Google Search - active and the Start Menu/title bars are grey, inactive it is accent colour - weird! As for the File Manager, the title bars are grey at startup, not the accent colour UNTIL I start to run sfc/ scannow. I don't even have to wait for the scan to complete. I select File Explorer from the Taskbar seconds after I start sfc and the title bar is the accent colour. It will be this way until I shutdown and restart (or just put machine to sleep) This is the only thing I do tio make thew totle bars in File Explorer the accent colour.
 

Attachments

  • File Explorer title bars and accent colour from the Taskbar_need to start sfc scannow at every...png
    File Explorer title bars and accent colour from the Taskbar_need to start sfc scannow at every...png
    57.3 KB · Views: 7
  • Start Menu search_Google search inactive_active title bars and accent colour.png
    Start Menu search_Google search inactive_active title bars and accent colour.png
    92 KB · Views: 7

My Computer

System One

  • OS
    Win11 22623.891
    Computer type
    Laptop
    Manufacturer/Model
    HP
    CPU
    11th Gen Intel R Core TM i7 - 1165G7 @ 2.80GHz
    Memory
    16gb
    Graphics Card(s)
    Intel R Iris R Xe Graphics
    Sound Card
    Realtek R Audio, Intel Smart Sound
    Hard Drives
    C
    Browser
    Google
    Antivirus
    Windows Security/Microsoft Defender
    Other Info
    Downloaded MSEdgeRedirect
It's just the way it works. You can accomplish a lot with colors using Classic Color Panel from Wintools but it still will NOT change explorer colors. It will however change the border of explorer to whatever color you choose as your border colors whether it is active or inactive.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3737
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 nvme+256gb SKHynix m.2 nvme /External +512gb Samsung m.2 sata+1tb Kingston m2.nvme
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
It's just the way it works. You can accomplish a lot with colors using Classic Color Panel from Wintools but it still will NOT change explorer colors. It will however change the border of explorer to whatever color you choose as your border colors whether it is active or inactive.
I understand it is just the way it is, but I find it odd I can get what I want, I can configure the accent colour for Explorer title bar, but I have to run the command everyday or after every restart. Can I create a task or command to run sfc /scannow at startup automatically in the background and not manually?
 

My Computer

System One

  • OS
    Win11 22623.891
    Computer type
    Laptop
    Manufacturer/Model
    HP
    CPU
    11th Gen Intel R Core TM i7 - 1165G7 @ 2.80GHz
    Memory
    16gb
    Graphics Card(s)
    Intel R Iris R Xe Graphics
    Sound Card
    Realtek R Audio, Intel Smart Sound
    Hard Drives
    C
    Browser
    Google
    Antivirus
    Windows Security/Microsoft Defender
    Other Info
    Downloaded MSEdgeRedirect
I can not replicate it. I've run SFC 3 times and opened explorer during and after. Also opened Edge and it changes nothing. The only thing that changes is the border color whether explorer is the active or inactive window. The command window does have the title bar color all the time, but not explorer. I even changed my edge theme to an odd color but it didn't make any difference in explorer. I use light mode as you do. I found the following answer in the Microsoft forum.
"Keep in mind that some applications like File Explorer, word, etc., use custom title bars. As such, you will not see a colored title bar even after enabling the appropriate option. The title bar color depends on the developer or the application-specific settings for those kinds of applications."

I did find that Explorer Patcher is supposed to accomplish what you want if you want to use a third party app. https://www.askvg.com/tip-enable-colored-titlebar-in-windows-11-file-explorer/
I have not personally used Explorer Patcher myself but others on this forum use it.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3737
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 nvme+256gb SKHynix m.2 nvme /External +512gb Samsung m.2 sata+1tb Kingston m2.nvme
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
I started talking about this problem in this thread and post here.
It only seems to happen to Windows 11 system apps. But tray icons can also be affected.
If you scroll through the posts, you'll see that I also had the Notepad problem, plus others until I tweaked it.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro
    Computer type
    PC/Desktop
    Manufacturer/Model
    Stigg's Build
    CPU
    Intel Core i9-10900X
    Motherboard
    GIGABYTE X299X DESIGNARE 10G
    Memory
    Corsair 64 GB (4 x 16 GB) CMW64GX4M4C3000C15 Vengeance RGB Pro 3000Mhz DDR4
    Graphics Card(s)
    GIGABYTE GeForce GTX 1660 Super Mini ITX 6 GB OC
    Sound Card
    Realtek ALC1220
    Monitor(s) Displays
    Samsung 27" FHD LED FreeSync Gaming Monitor (LS27F350FHEXXY)
    Screen Resolution
    1920 x 1080
    Hard Drives
    Samsung 970 Pro Series 1TB M.2 2280 NVMe SSD
    Western Digital Red Pro WD8003FFBX-68B9AN0 8 TB, 7200 RPM, SATA-III
    Western Digital Red Pro WD8003FFBX-68B9AN0 8 TB, 7200 RPM, SATA-III
    PSU
    Corsair HX1200 1200W 80 Plus Platinum
    Case
    Fractal Design Define 7 Black Solid Case
    Cooling
    Noctua NH-D15 Chromax Black
    Keyboard
    Razer Ornata V2
    Mouse
    Razer DeathAdder Essential
    Internet Speed
    FTTN 100Mbps / 40Mbps
    Browser
    Mozilla Firefox
    Antivirus
    N/A
    Other Info
    Logitech BRIO 4k Ultra HD USB-C Webcam
  • Operating System
    Windows 10 Pro
    Computer type
    Laptop
    Manufacturer/Model
    ASUS ROG Zephyrus M GM501GS
    CPU
    Core i7-8750H
    Motherboard
    Zephyrus M GM501GS
    Memory
    SK Hynix 32 GB (2 x 16 GB) HMA82GS6CJR8N-VK 16 GB DDR4-2666 DDR4 SDRAM
    Graphics card(s)
    NVIDIA GeForce GTX 1070
    Sound Card
    Realtek ALC294
    Monitor(s) Displays
    AU Optronics B156HAN07.1 [15.6" LCD]
    Screen Resolution
    1920 x 1080
    Hard Drives
    Samsung MZVKW512HMJP-00000 512 GB, PCI-E 3.0 x4
    Samsung SSD 860 QVO 4TB 4 TB, SATA-III
    PSU
    N/A
    Case
    N/A
    Cooling
    N/A
    Mouse
    Razer DeathAdder Essential
    Keyboard
    PC/AT Enhanced PS2 Keyboard (101/102-Key)
    Internet Speed
    FTTN 100Mbps / 40Mbps
    Browser
    Mozilla Firefox
    Antivirus
    N/A
    Other Info
    USB2.0 HD UVC Webcam
I started talking about this problem in this thread and post here.
It only seems to happen to Windows 11 system apps. But tray icons can also be affected.
If you scroll through the posts, you'll see that I also had the Notepad problem, plus others until I tweaked it.
I have had no issue seeing the accent colour in Note, Paint, Browser., Taskbar, Start Menu. It is the accent colour as chosen. It is only the accent colour in File Explorer. I can make it happen, but I can't make it stray.
 

My Computer

System One

  • OS
    Win11 22623.891
    Computer type
    Laptop
    Manufacturer/Model
    HP
    CPU
    11th Gen Intel R Core TM i7 - 1165G7 @ 2.80GHz
    Memory
    16gb
    Graphics Card(s)
    Intel R Iris R Xe Graphics
    Sound Card
    Realtek R Audio, Intel Smart Sound
    Hard Drives
    C
    Browser
    Google
    Antivirus
    Windows Security/Microsoft Defender
    Other Info
    Downloaded MSEdgeRedirect
For the notepad, the best is to restore the old one.
 

My Computer

System One

  • OS
    Windows 10 21H2
    Computer type
    Laptop
    Manufacturer/Model
    Acer
    Memory
    8 GB
    Screen Resolution
    1920 X 1080
Strangely today I turned on the laptop and the accent color is on the File Explorer title bar BUT I didn't make any changes when I booted this morning. Usually I run sfc /scannow after reboot as the color reverts to grey at startup. Today it is just there!
 

My Computer

System One

  • OS
    Win11 22623.891
    Computer type
    Laptop
    Manufacturer/Model
    HP
    CPU
    11th Gen Intel R Core TM i7 - 1165G7 @ 2.80GHz
    Memory
    16gb
    Graphics Card(s)
    Intel R Iris R Xe Graphics
    Sound Card
    Realtek R Audio, Intel Smart Sound
    Hard Drives
    C
    Browser
    Google
    Antivirus
    Windows Security/Microsoft Defender
    Other Info
    Downloaded MSEdgeRedirect
It would certainly help us understand your situation better if you would complete your computer specs in this forum. We do not know what version and build of Windows you are using nor do we know if your machine is Windows 11 compatible. We also need to know any tweaks you have made to the GUI and if you are using any 3rd party apps to make those tweaks. We cannot know the full picture otherwise.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 22631.3737
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 7080
    CPU
    i9-10900 10 core 20 threads
    Motherboard
    DELL 0J37VM
    Memory
    32 gb
    Graphics Card(s)
    none-Intel UHD Graphics 630
    Sound Card
    Integrated Realtek
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    1tb Solidigm m.2 nvme+256gb SKHynix m.2 nvme /External +512gb Samsung m.2 sata+1tb Kingston m2.nvme
    PSU
    500w
    Case
    MT
    Cooling
    Dell Premium
    Keyboard
    Logitech wired
    Mouse
    Logitech wireless
    Internet Speed
    so slow I'm too embarrassed to tell
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
  • Operating System
    Windows 10 Pro 22H2 19045.3930
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell Optiplex 9020
    CPU
    i7-4770
    Memory
    24 gb
    Monitor(s) Displays
    Benq 27
    Screen Resolution
    2560x1440
    Hard Drives
    256 gb Toshiba BG4 M.2 NVE SSB and 1 tb hdd
    PSU
    500w
    Case
    MT
    Cooling
    Dell factory
    Mouse
    Logitech wireless
    Keyboard
    Logitech wired
    Internet Speed
    still not telling
    Browser
    Firefox
    Antivirus
    Defender+MWB Premium
Strangely today I turned on the laptop and the accent color is on the File Explorer title bar BUT I didn't make any changes when I booted this morning. Usually I run sfc /scannow after reboot as the color reverts to grey at startup. Today it is just there!
*Update* Restarted and File Explorer title bar accent color grey again. Ugh. I'm on the latest Win11 build. Ran the update 2 weeks ago. Only thing I did different today was download MS Redirect and I had a popup to install BT driver update from Intel Driver Support. Will just forget about it and leave it as is. The accent color applies everywhere else it should was just curious why not in File Explorer. Already tried suggested fixes, resets and in-place reinstalls without outcome I was expecting. Thanks everyone! 👍😊
 

My Computer

System One

  • OS
    Win11 22623.891
    Computer type
    Laptop
    Manufacturer/Model
    HP
    CPU
    11th Gen Intel R Core TM i7 - 1165G7 @ 2.80GHz
    Memory
    16gb
    Graphics Card(s)
    Intel R Iris R Xe Graphics
    Sound Card
    Realtek R Audio, Intel Smart Sound
    Hard Drives
    C
    Browser
    Google
    Antivirus
    Windows Security/Microsoft Defender
    Other Info
    Downloaded MSEdgeRedirect
I can not replicate it. I've run SFC 3 times and opened explorer during and after. Also opened Edge and it changes nothing. The only thing that changes is the border color whether explorer is the active or inactive window. The command window does have the title bar color all the time, but not explorer. I even changed my edge theme to an odd color but it didn't make any difference in explorer. I use light mode as you do. I found the following answer in the Microsoft forum.
"Keep in mind that some applications like File Explorer, word, etc., use custom title bars. As such, you will not see a colored title bar even after enabling the appropriate option. The title bar color depends on the developer or the application-specific settings for those kinds of applications."

I did find that Explorer Patcher is supposed to accomplish what you want if you want to use a third party app. https://www.askvg.com/tip-enable-colored-titlebar-in-windows-11-file-explorer/
I have not personally used Explorer Patcher myself but others on this forum use it.
Thanks. I will just let it be. There are no resolves to keep the setting permanent. I don't want to run sfc /scannow at every restart. Maybe others will have the same issue and a resolve will be found.
 

My Computer

System One

  • OS
    Win11 22623.891
    Computer type
    Laptop
    Manufacturer/Model
    HP
    CPU
    11th Gen Intel R Core TM i7 - 1165G7 @ 2.80GHz
    Memory
    16gb
    Graphics Card(s)
    Intel R Iris R Xe Graphics
    Sound Card
    Realtek R Audio, Intel Smart Sound
    Hard Drives
    C
    Browser
    Google
    Antivirus
    Windows Security/Microsoft Defender
    Other Info
    Downloaded MSEdgeRedirect
Thanks. I will just let it be. There are no resolves to keep the setting permanent. I don't want to run sfc /scannow at every restart. Maybe others will have the same issue and a resolve will be found.
Ok so I know I'm beating a dead horse with this, but it is so bizarre. Yesterday, even after in-place reinstall of WIN11 using .iso (previously did 3 resets) and running dism restore health and sfc scannow (usually running sfc results in accent color title bar until shutdown), the File Explorer title bar was grey. I rebooted it and it was still grey. This morning I booted it up and it's grey. I hit the file explorer icon a few times throughout the day, and it is still grey. Suddenly after hours of working opening websites and files I see the title bar is the paler shade of the accent color. Yet, I made no changes to any settings. It has been so intermittent the last couple weeks. Just suddenly appears later in the day but reverts to grey at startup. It's like it's on a timer to come on at a certain time but reverts to grey when shutdown!
 

Attachments

  • Screenshot 2022-11-24 151933.png
    Screenshot 2022-11-24 151933.png
    3.8 KB · Views: 4

My Computer

System One

  • OS
    Win11 22623.891
    Computer type
    Laptop
    Manufacturer/Model
    HP
    CPU
    11th Gen Intel R Core TM i7 - 1165G7 @ 2.80GHz
    Memory
    16gb
    Graphics Card(s)
    Intel R Iris R Xe Graphics
    Sound Card
    Realtek R Audio, Intel Smart Sound
    Hard Drives
    C
    Browser
    Google
    Antivirus
    Windows Security/Microsoft Defender
    Other Info
    Downloaded MSEdgeRedirect
I don't want to run sfc /scannow at every restart.
That was a red herring.
It distracted you from events of significance.

All the best,
Denis
 

My Computer

System One

  • OS
    Windows 11 Home x64 Version 23H2 Build 22631.3447
I customized a theme, background and accent color as my chosen color, saved as a custom theme, and I select SLEEP each night to retain the settings. No other choice. I will reconfigure again when I need to shutdown or restart.

Attachments​

  • Screenshot 2023-02-18 131211.jpg
    Screenshot 2023-02-18 131211.jpg
    44.8 KB · Views: 1
 

My Computer

System One

  • OS
    Win11 22623.891
    Computer type
    Laptop
    Manufacturer/Model
    HP
    CPU
    11th Gen Intel R Core TM i7 - 1165G7 @ 2.80GHz
    Memory
    16gb
    Graphics Card(s)
    Intel R Iris R Xe Graphics
    Sound Card
    Realtek R Audio, Intel Smart Sound
    Hard Drives
    C
    Browser
    Google
    Antivirus
    Windows Security/Microsoft Defender
    Other Info
    Downloaded MSEdgeRedirect
Back
Top Bottom