Fonts copied from Windows 10 don't work?


NormAtHome

Member
Local time
4:16 PM
Posts
20
OS
Windows 11
This year I built myself a new computer because I was dissatisfied with the old one which I built in 2020, Intel i9-13900K; 32gb Corsair Ram, Samsung 2tb 990 Pro ssd, Zotac 3090TI graphics, Asus Creator motherboard and it's currently running Windows 11 Pro 23H2 build 22631.2861. The old computer used an AMD cpu but was Windows 11 compatible and after upgrading to Windows 11 all the fonts that worked in Windows 10 worked in Windows 11 on the old computer. However on my new Windows 11 Pro Intel build when I copied the fonts (all ttf fonts btw) to a flash drive and plugged that into my new computer and used Personalization \ Fonts \ Browse and install fonts to install the new fonts from the flash drive, after multiple reboots and I've checked that the fonts are not installed on the new computer in C:\Windows\Fonts but they are located in C:\Users\<user name>\AppData\Local\Microsoft\Windows\Fonts however no application such as Word etc can see them and they don't appear in the list of fonts in the install fonts applet. What is the problem with these fonts not being available and how do I fix this?
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built Myself
    CPU
    Intel 13-900K
    Motherboard
    Asus ProArt Z790 Creator Wifi
    Memory
    32gb Corsair Dominator Platinum DDR5
    Graphics Card(s)
    Zotac 3090TI AMP Extreme Holo
    Sound Card
    Realtek S1220A 7.1 Surround Sound High Definition Audio CODEC
    Monitor(s) Displays
    Asus 4K 29inch and LG Ultra Wide
    Screen Resolution
    Asus 3840z2160 LG 3440x1440
Download AMP Font Viewer and use it to browse through all of the installed fonts on your system. You can download the portable version in a zip file which does not need installation, just unzip the files and run the FontViewer.exe file.

Click on the Installed fonts tab then if you do not see your fonts listed there, then they have not been installed. Chances are that they have been installed though.

Click on the Not installed fonts tab, navigate to the fonts you wish to install and then you can install them using AMP Font Viewer by clicking on Install selected font, hopefully that will solve your issue or at least help verify they are installed or not.

Make sure you backup all of your Windows 11 fonts, before you start uninstalling/reinstalling any fonts though, otherwise you may have to copy them from another Windows 11 machine.

As to why the fonts are not showing up in your programs, I have no idea at this point.
 

My Computer

System One

  • OS
    Windows 11 Pro
    Computer type
    PC/Desktop
    CPU
    Ryzen 9 3900X
    Motherboard
    ASUS ROG Strix X570-E Gaming
    Memory
    G-Skill RipjawsV F4-3600C18 (16GB x 2)
    Graphics Card(s)
    Gigabyte RX 5700 XT Gaming OC
    Sound Card
    Realtek ALC1220P
    Monitor(s) Displays
    ASUS VE278 (x 2)
    Screen Resolution
    1920x1080
    Hard Drives
    Samsung 850 Pro 256GB
    Samsung 970 Pro NVMe 512GB (x 2)
    ST10000VN0004 10TB (x 2)
    ST10000VN0008 10TB (x 2)
    ST4000VN000 4TB (x 2)
    PSU
    Corsair HX1000
    Case
    Corsair Carbide 400R
    Cooling
    AMD Wraith Prism (Stock)
    Keyboard
    Logitech G213
    Mouse
    Logitech G502
    Internet Speed
    100Mbps down / 40Mbps up
    Browser
    Firefox - Chrome - Edge
    Antivirus
    Windows Defender - Clamwin
Ok I downloaded AMP Font Viewer and despite the font file of the fonts I installed being in C:\Users\<user name>\AppData\Local\Microsoft\Windows\Fonts I can't see them in either the Windows Font App nor AMP Font Viewer. Clicking on Not Installed Fonts didn't show me anything, I had to to browse to the flash drive where I had them copied from the other computer and them I could see them and I tried installing the ones I use most often and that worked and my applications were then able to see them when installed with AMP Font Viewer. But I have like 40 fonts to install and Font Viewer does not allow multiple selection on fonts and the process is like click on a font / click Install selected font / click Yes on the dialog then click on the next font; it's going to take a lot of effort to get these installed, is there an easier way?
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built Myself
    CPU
    Intel 13-900K
    Motherboard
    Asus ProArt Z790 Creator Wifi
    Memory
    32gb Corsair Dominator Platinum DDR5
    Graphics Card(s)
    Zotac 3090TI AMP Extreme Holo
    Sound Card
    Realtek S1220A 7.1 Surround Sound High Definition Audio CODEC
    Monitor(s) Displays
    Asus 4K 29inch and LG Ultra Wide
    Screen Resolution
    Asus 3840z2160 LG 3440x1440
@NormAtHome

I just tested.... I put all my fonts in a folder on my desktop.
I click-drag-highlighted all of them, then I right clicked and chose: Install for all users.
They ALL installed.

It works. And, they show up in Settings > Personalization > Fonts
I also tested and they show up in Paint Shop Pro as well.



Note: Be careful though. A very large number of fonts will slow your boot time. ^^
 
Last edited:

My Computers

System One System Two

  • OS
    Win 11 Home ♦♦♦22631.3447 ♦♦♦♦♦♦♦23H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot® [May 2020]
    CPU
    AMD Ryzen 7 3700X
    Motherboard
    Asus Pro WS X570-ACE (BIOS 4702)
    Memory
    G.Skill (F4-3200C14D-16GTZKW)
    Graphics Card(s)
    EVGA RTX 2070 (08G-P4-2171-KR)
    Sound Card
    Realtek ALC1220P / ALC S1220A
    Monitor(s) Displays
    Dell U3011 30"
    Screen Resolution
    2560 x 1600
    Hard Drives
    2x Samsung 860 EVO 500GB,
    WD 4TB Black FZBX - SATA III,
    WD 8TB Black FZBX - SATA III,
    DRW-24B1ST CD/DVD Burner
    PSU
    PC Power & Cooling 750W Quad EPS12V
    Case
    Cooler Master ATCS 840 Tower
    Cooling
    CM Hyper 212 EVO (push/pull)
    Keyboard
    Ducky DK9008 Shine II Blue LED
    Mouse
    Logitech Optical M-100
    Internet Speed
    300/300
    Browser
    Firefox (latest)
    Antivirus
    Bitdefender Internet Security
    Other Info
    Speakers: Klipsch Pro Media 2.1
  • Operating System
    Windows XP Pro 32bit w/SP3
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot® (not in use)
    CPU
    AMD Athlon 64 X2 5000+ (OC'd @ 3.2Ghz)
    Motherboard
    ASUS M2N32-SLI Deluxe Wireless Edition
    Memory
    TWIN2X2048-6400C4DHX (2 x 1GB, DDR2 800)
    Graphics card(s)
    EVGA 256-P2-N758-TR GeForce 8600GT SSC
    Sound Card
    Onboard
    Monitor(s) Displays
    ViewSonic G90FB Black 19" Professional (CRT)
    Screen Resolution
    up to 2048 x 1536
    Hard Drives
    WD 36GB 10,000rpm Raptor SATA
    Seagate 80GB 7200rpm SATA
    Lite-On LTR-52246S CD/RW
    Lite-On LH-18A1P CD/DVD Burner
    PSU
    PC Power & Cooling Silencer 750 Quad EPS12V
    Case
    Generic Beige case, 80mm fans
    Cooling
    ZALMAN 9500A 92mm CPU Cooler
    Mouse
    Logitech Optical M-BT96a
    Keyboard
    Logitech Classic Keybooard 200
    Internet Speed
    300/300
    Browser
    Firefox 3.x ??
    Antivirus
    Symantec (Norton)
    Other Info
    Still assembled, still runs. Haven't turned it on for 13 years?
Put the fonts you regularly install into a separate folder. Then on the Not installed fonts tab, click on View folder / Install list of fonts and navigate to the folder you created with your regularly used fonts.

That should install all of them at once.
 

My Computer

System One

  • OS
    Windows 11 Pro
    Computer type
    PC/Desktop
    CPU
    Ryzen 9 3900X
    Motherboard
    ASUS ROG Strix X570-E Gaming
    Memory
    G-Skill RipjawsV F4-3600C18 (16GB x 2)
    Graphics Card(s)
    Gigabyte RX 5700 XT Gaming OC
    Sound Card
    Realtek ALC1220P
    Monitor(s) Displays
    ASUS VE278 (x 2)
    Screen Resolution
    1920x1080
    Hard Drives
    Samsung 850 Pro 256GB
    Samsung 970 Pro NVMe 512GB (x 2)
    ST10000VN0004 10TB (x 2)
    ST10000VN0008 10TB (x 2)
    ST4000VN000 4TB (x 2)
    PSU
    Corsair HX1000
    Case
    Corsair Carbide 400R
    Cooling
    AMD Wraith Prism (Stock)
    Keyboard
    Logitech G213
    Mouse
    Logitech G502
    Internet Speed
    100Mbps down / 40Mbps up
    Browser
    Firefox - Chrome - Edge
    Antivirus
    Windows Defender - Clamwin
Hold on a second! The directory that those fonts got loaded into, your <user>\AppData\Local... is usually an "invisible" directory. Have you tried running those font utilities with Admin privileges?
 

My Computer

System One

  • OS
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    MSI Raider GE76 12UE
    CPU
    Intel(R) Core(TM) i9-12900H 2.90 GHz
    Memory
    64 GB
    Graphics Card(s)
    NVIDIA RTX 3060
    Screen Resolution
    1920 x 1080
    Hard Drives
    Kingston OM8PDP31024B-AI1, 953MB (I think it's spinning disk.)
    Mouse
    USB Wireless Logitech
    Internet Speed
    Ethernet cable, Rx/Tx speed 1000Mbps (from Router), Speedtest (Ookla) 57Mbps down, 63 up
    Browser
    Firefox Nightly
    Antivirus
    Avast
Hold on a second! The directory that those fonts got loaded into, your <user>\AppData\Local... is usually an "invisible" directory. Have you tried running those font utilities with Admin privileges?
First looking at the directory C:\Users\<user name>\AppData\Local\Microsoft\Windows\Font I could see all the default fonts as well as the fonts I tried to install, they existed in that directory. Second, the Windows Font app Personalization / Fonts showed everything except the fonts I installed and whose files existed in C:\Users\<user name>\AppData\Local\Microsoft\Windows\Font; just for clarity this is how I originally installed them:
20231222_Fonts App.jpg
Using the "Browse and install fonts" button from this applet; however despite seeming to install them and copying the files to the correct directory they did not appear in the list of available fonts; could not be found using the search for available fonts. In order to actually get them installed I had to either use the AMP Font Viewer whose install font function seemed to work or as the user Got had suggested using file explorer to navigate to the fonts location and selecting then all and right clicking and selecting "Install" worked. It's my theory that there's some kind of bug in the Fonts applet that "Browse and install fonts" doesn't work properly.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built Myself
    CPU
    Intel 13-900K
    Motherboard
    Asus ProArt Z790 Creator Wifi
    Memory
    32gb Corsair Dominator Platinum DDR5
    Graphics Card(s)
    Zotac 3090TI AMP Extreme Holo
    Sound Card
    Realtek S1220A 7.1 Surround Sound High Definition Audio CODEC
    Monitor(s) Displays
    Asus 4K 29inch and LG Ultra Wide
    Screen Resolution
    Asus 3840z2160 LG 3440x1440
@NormAtHome

I just tested.... I put all my fonts in a folder on my desktop.
I click-drag-highlighted all of them, then I right clicked and chose: Install for all users.
They ALL installed.

It works. And, they show up in Settings > Personalization > Fonts
I also tested and they show up in Paint Shop Pro as well.



Note: Be careful though. A very large number of fonts will slow your boot time. ^^
Your method worked (see my other reply) thanks!; re: "Note: Be careful though. A very large number of fonts will slow your boot time. ^^" I've been using this same set of fonts since Windows XP and my current computer boots from a Samsung 990 Pro and I don't really care if it takes and extra 5 seconds to boot.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built Myself
    CPU
    Intel 13-900K
    Motherboard
    Asus ProArt Z790 Creator Wifi
    Memory
    32gb Corsair Dominator Platinum DDR5
    Graphics Card(s)
    Zotac 3090TI AMP Extreme Holo
    Sound Card
    Realtek S1220A 7.1 Surround Sound High Definition Audio CODEC
    Monitor(s) Displays
    Asus 4K 29inch and LG Ultra Wide
    Screen Resolution
    Asus 3840z2160 LG 3440x1440
I've been using this same set of fonts since Windows XP and my current computer boots from a Samsung 990 Pro and I don't really care if it takes and extra 5 seconds to boot.


I always mention it just in case. :-)
 

My Computers

System One System Two

  • OS
    Win 11 Home ♦♦♦22631.3447 ♦♦♦♦♦♦♦23H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot® [May 2020]
    CPU
    AMD Ryzen 7 3700X
    Motherboard
    Asus Pro WS X570-ACE (BIOS 4702)
    Memory
    G.Skill (F4-3200C14D-16GTZKW)
    Graphics Card(s)
    EVGA RTX 2070 (08G-P4-2171-KR)
    Sound Card
    Realtek ALC1220P / ALC S1220A
    Monitor(s) Displays
    Dell U3011 30"
    Screen Resolution
    2560 x 1600
    Hard Drives
    2x Samsung 860 EVO 500GB,
    WD 4TB Black FZBX - SATA III,
    WD 8TB Black FZBX - SATA III,
    DRW-24B1ST CD/DVD Burner
    PSU
    PC Power & Cooling 750W Quad EPS12V
    Case
    Cooler Master ATCS 840 Tower
    Cooling
    CM Hyper 212 EVO (push/pull)
    Keyboard
    Ducky DK9008 Shine II Blue LED
    Mouse
    Logitech Optical M-100
    Internet Speed
    300/300
    Browser
    Firefox (latest)
    Antivirus
    Bitdefender Internet Security
    Other Info
    Speakers: Klipsch Pro Media 2.1
  • Operating System
    Windows XP Pro 32bit w/SP3
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot® (not in use)
    CPU
    AMD Athlon 64 X2 5000+ (OC'd @ 3.2Ghz)
    Motherboard
    ASUS M2N32-SLI Deluxe Wireless Edition
    Memory
    TWIN2X2048-6400C4DHX (2 x 1GB, DDR2 800)
    Graphics card(s)
    EVGA 256-P2-N758-TR GeForce 8600GT SSC
    Sound Card
    Onboard
    Monitor(s) Displays
    ViewSonic G90FB Black 19" Professional (CRT)
    Screen Resolution
    up to 2048 x 1536
    Hard Drives
    WD 36GB 10,000rpm Raptor SATA
    Seagate 80GB 7200rpm SATA
    Lite-On LTR-52246S CD/RW
    Lite-On LH-18A1P CD/DVD Burner
    PSU
    PC Power & Cooling Silencer 750 Quad EPS12V
    Case
    Generic Beige case, 80mm fans
    Cooling
    ZALMAN 9500A 92mm CPU Cooler
    Mouse
    Logitech Optical M-BT96a
    Keyboard
    Logitech Classic Keybooard 200
    Internet Speed
    300/300
    Browser
    Firefox 3.x ??
    Antivirus
    Symantec (Norton)
    Other Info
    Still assembled, still runs. Haven't turned it on for 13 years?
Back
Top Bottom