Edge hardware acceleration black screen flash and weird bugs


biyakuga

Member
Member
Local time
4:39 AM
Posts
43
OS
Windows 11 Pro Version 23H2 (OS Build 22631. 3374)
I have Nivida RTX 3080TI founder addition with latest driver and windows 11/edge latest stable release version.

I have no idea why but when I enable Edge hardware acceleration feature when I surf the web or play video in YouTube/Netflix there are some weird glitches bug on my screen such as half or full black flashes, video refresh, UI of the website or even Edge looks like 16bit colors etc.

If I disable the hardware acceleration feature everything is back to normal, but I would like to know why and how I can fix it because I want to use this hardware acceleration feature for gaming.
 

My Computer

System One

  • OS
    Windows 11 Pro Version 23H2 (OS Build 22631. 3374)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custome Built
    CPU
    intel i7 13th 13700k
    Motherboard
    ROG STRIX Z790-F GAMING WIFI
    Memory
    VENGEANCE® 64GB (2x32GB) DDR5 DRAM 5600MT/s CL40 Memory Kit
    Graphics Card(s)
    NVidia founders edition 3080 ti
    Monitor(s) Displays
    27" Odyssey QHD 165Hz 1ms HDR10 Gaming Monitor
    Screen Resolution
    2k
    Keyboard
    Logitech G512
    Mouse
    Logitech G502 Hero
    Internet Speed
    1GB Fibers
    Browser
    Edge
    Antivirus
    ESET Samrt Security
Most browsers have a hardware acceleration toggle. So does Windows 11.
You need to play around with them and see what works best for you.

You have four possibilities... [HA = Hardware Acceleration]

1. Windows HA ON... Browser HA OFF
2. Windows HA ON... Browser HA ON
3. Windows HA OFF... Browser HA OFF
4. Windows HA OFF... Browser HA ON
 

My Computers

System One System Two

  • OS
    Win 11 Home ♦♦♦22631.3880 ♦♦♦♦♦♦♦23H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot® [May 2020]
    CPU
    AMD Ryzen 7 3700X
    Motherboard
    Asus Pro WS X570-ACE (BIOS 4702)
    Memory
    G.Skill (F4-3200C14D-16GTZKW)
    Graphics Card(s)
    EVGA RTX 2070 (08G-P4-2171-KR)
    Sound Card
    Realtek ALC1220P / ALC S1220A
    Monitor(s) Displays
    Dell U3011 30"
    Screen Resolution
    2560 x 1600
    Hard Drives
    2x Samsung 860 EVO 500GB,
    WD 4TB Black FZBX - SATA III,
    WD 8TB Black FZBX - SATA III,
    DRW-24B1ST CD/DVD Burner
    PSU
    PC Power & Cooling 750W Quad EPS12V
    Case
    Cooler Master ATCS 840 Tower
    Cooling
    CM Hyper 212 EVO (push/pull)
    Keyboard
    Ducky DK9008 Shine II Blue LED
    Mouse
    Logitech Optical M-100
    Internet Speed
    300/300
    Browser
    Firefox (latest)
    Antivirus
    Bitdefender Internet Security
    Other Info
    Speakers: Klipsch Pro Media 2.1
  • Operating System
    Windows XP Pro 32bit w/SP3
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot® (not in use)
    CPU
    AMD Athlon 64 X2 5000+ (OC'd @ 3.2Ghz)
    Motherboard
    ASUS M2N32-SLI Deluxe Wireless Edition
    Memory
    TWIN2X2048-6400C4DHX (2 x 1GB, DDR2 800)
    Graphics card(s)
    EVGA 256-P2-N758-TR GeForce 8600GT SSC
    Sound Card
    Onboard
    Monitor(s) Displays
    ViewSonic G90FB Black 19" Professional (CRT)
    Screen Resolution
    up to 2048 x 1536
    Hard Drives
    WD 36GB 10,000rpm Raptor SATA
    Seagate 80GB 7200rpm SATA
    Lite-On LTR-52246S CD/RW
    Lite-On LH-18A1P CD/DVD Burner
    PSU
    PC Power & Cooling Silencer 750 Quad EPS12V
    Case
    Generic Beige case, 80mm fans
    Cooling
    ZALMAN 9500A 92mm CPU Cooler
    Mouse
    Logitech Optical M-BT96a
    Keyboard
    Logitech Classic Keybooard 200
    Internet Speed
    300/300
    Browser
    Firefox 3.x ??
    Antivirus
    Symantec (Norton)
    Other Info
    Still assembled, still runs. Haven't turned it on for 13 years?

My Computer

System One

  • OS
    Windows 11 Pro 23H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    MSI / MS-7B29
    CPU
    Intel i3 8100 @3.6Ghz
    Motherboard
    H310M PRO-VDH (MS-7B29)
    Memory
    1 x 16GB DDR4 @2400 MHz
    Graphics Card(s)
    Nvidia GeForce GT 1030 2GB SDDR4
    Sound Card
    Realtek VEN_10EC&DEV_0887 / NVIDIA VEN_10DE&DEV_0081
    Monitor(s) Displays
    Acer V226HQL
    Screen Resolution
    1920 x 1080
    Hard Drives
    SSD 500 GB Crucial MX500 / HDD 1 TB TOSHIBA DT01ACA100
    PSU
    ATX, details unknown
    Case
    Everest 551B
    Cooling
    details unknown
    Keyboard
    Mechanical Gaming Hydra R7 - Rampage
    Mouse
    Logitech G703
    Internet Speed
    Down: 28Mbps / Up: 19Mbps
    Browser
    Microsoft Edge
    Antivirus
    Microsoft Defender Antivirus
    Other Info
    Bluetooth: TP Link 5.0 Nano USB adapter UB500
    WLAN: D-Link 150 Pico USB adapter, N standard
    Web camera: Logitech C270 HD 720p @30fps
    Microphone: Trust MICO, model 23790
Is there HA option in Windows?? where?


Buried... as usual... :/

I believe you have to have a discreet vid card for it to show up.
My CPU has no IGP (Integrated Graphics processor), so I can't test that.

Settings > System > Display > Graphics > Change default graphics settings


Image1.png





Keep in mind that Hardware Acceleration doesn't really make games run faster.
It offloads graphics tasks to the GPU, for smoother graphics.
It will do the same for Sound cards if you have one.




@biyakuga
I can't see what hardware you have (in your specs), but if you want "faster" game play (frame rates), get a better vid card.



Here's a "wordy" but pretty good description of Hardware Acceleration...

 
Last edited:

My Computers

System One System Two

  • OS
    Win 11 Home ♦♦♦22631.3880 ♦♦♦♦♦♦♦23H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot® [May 2020]
    CPU
    AMD Ryzen 7 3700X
    Motherboard
    Asus Pro WS X570-ACE (BIOS 4702)
    Memory
    G.Skill (F4-3200C14D-16GTZKW)
    Graphics Card(s)
    EVGA RTX 2070 (08G-P4-2171-KR)
    Sound Card
    Realtek ALC1220P / ALC S1220A
    Monitor(s) Displays
    Dell U3011 30"
    Screen Resolution
    2560 x 1600
    Hard Drives
    2x Samsung 860 EVO 500GB,
    WD 4TB Black FZBX - SATA III,
    WD 8TB Black FZBX - SATA III,
    DRW-24B1ST CD/DVD Burner
    PSU
    PC Power & Cooling 750W Quad EPS12V
    Case
    Cooler Master ATCS 840 Tower
    Cooling
    CM Hyper 212 EVO (push/pull)
    Keyboard
    Ducky DK9008 Shine II Blue LED
    Mouse
    Logitech Optical M-100
    Internet Speed
    300/300
    Browser
    Firefox (latest)
    Antivirus
    Bitdefender Internet Security
    Other Info
    Speakers: Klipsch Pro Media 2.1
  • Operating System
    Windows XP Pro 32bit w/SP3
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot® (not in use)
    CPU
    AMD Athlon 64 X2 5000+ (OC'd @ 3.2Ghz)
    Motherboard
    ASUS M2N32-SLI Deluxe Wireless Edition
    Memory
    TWIN2X2048-6400C4DHX (2 x 1GB, DDR2 800)
    Graphics card(s)
    EVGA 256-P2-N758-TR GeForce 8600GT SSC
    Sound Card
    Onboard
    Monitor(s) Displays
    ViewSonic G90FB Black 19" Professional (CRT)
    Screen Resolution
    up to 2048 x 1536
    Hard Drives
    WD 36GB 10,000rpm Raptor SATA
    Seagate 80GB 7200rpm SATA
    Lite-On LTR-52246S CD/RW
    Lite-On LH-18A1P CD/DVD Burner
    PSU
    PC Power & Cooling Silencer 750 Quad EPS12V
    Case
    Generic Beige case, 80mm fans
    Cooling
    ZALMAN 9500A 92mm CPU Cooler
    Mouse
    Logitech Optical M-BT96a
    Keyboard
    Logitech Classic Keybooard 200
    Internet Speed
    300/300
    Browser
    Firefox 3.x ??
    Antivirus
    Symantec (Norton)
    Other Info
    Still assembled, still runs. Haven't turned it on for 13 years?
Buried... as usual... :/

I believe you have to have a discreet vid card for it to show up.
My CPU has no IGP (Integrated Graphics processor), so I can't test that.

Settings > System > Display > Graphics > Change default graphics settings


View attachment 82525





Keep in mind that Hardware Acceleration doesn't really make games run faster.
It offloads graphics tasks to the GPU, for smoother graphics.
It will do the same for Sound cards if you have one.




@biyakuga
I can't see what hardware you have (in your specs), but if you want "faster" game play (frame rates), get a better vid card.



Here's a "wordy" but pretty good description of Hardware Acceleration...


I have 3080TI GPU and I713700K CPU

Which combination of HA do you recommended?

Right now, I have:
1. Windows HA ON... Browser HA OFF
 

My Computer

System One

  • OS
    Windows 11 Pro Version 23H2 (OS Build 22631. 3374)
    Computer type
    PC/Desktop
    Manufacturer/Model
    Custome Built
    CPU
    intel i7 13th 13700k
    Motherboard
    ROG STRIX Z790-F GAMING WIFI
    Memory
    VENGEANCE® 64GB (2x32GB) DDR5 DRAM 5600MT/s CL40 Memory Kit
    Graphics Card(s)
    NVidia founders edition 3080 ti
    Monitor(s) Displays
    27" Odyssey QHD 165Hz 1ms HDR10 Gaming Monitor
    Screen Resolution
    2k
    Keyboard
    Logitech G512
    Mouse
    Logitech G502 Hero
    Internet Speed
    1GB Fibers
    Browser
    Edge
    Antivirus
    ESET Samrt Security
I have 3080TI GPU and I713700K CPU

Which combination of HA do you recommended?

Right now, I have:
1. Windows HA ON... Browser HA OFF


You just have to play with them, till you get the results you want.
With your hardware... it doesn't really matter.

Just set them to remove the weird glitches.

Mine is set with Win HA turned ON and Firefox HA turned OFF
 

My Computers

System One System Two

  • OS
    Win 11 Home ♦♦♦22631.3880 ♦♦♦♦♦♦♦23H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot® [May 2020]
    CPU
    AMD Ryzen 7 3700X
    Motherboard
    Asus Pro WS X570-ACE (BIOS 4702)
    Memory
    G.Skill (F4-3200C14D-16GTZKW)
    Graphics Card(s)
    EVGA RTX 2070 (08G-P4-2171-KR)
    Sound Card
    Realtek ALC1220P / ALC S1220A
    Monitor(s) Displays
    Dell U3011 30"
    Screen Resolution
    2560 x 1600
    Hard Drives
    2x Samsung 860 EVO 500GB,
    WD 4TB Black FZBX - SATA III,
    WD 8TB Black FZBX - SATA III,
    DRW-24B1ST CD/DVD Burner
    PSU
    PC Power & Cooling 750W Quad EPS12V
    Case
    Cooler Master ATCS 840 Tower
    Cooling
    CM Hyper 212 EVO (push/pull)
    Keyboard
    Ducky DK9008 Shine II Blue LED
    Mouse
    Logitech Optical M-100
    Internet Speed
    300/300
    Browser
    Firefox (latest)
    Antivirus
    Bitdefender Internet Security
    Other Info
    Speakers: Klipsch Pro Media 2.1
  • Operating System
    Windows XP Pro 32bit w/SP3
    Computer type
    PC/Desktop
    Manufacturer/Model
    Built by Ghot® (not in use)
    CPU
    AMD Athlon 64 X2 5000+ (OC'd @ 3.2Ghz)
    Motherboard
    ASUS M2N32-SLI Deluxe Wireless Edition
    Memory
    TWIN2X2048-6400C4DHX (2 x 1GB, DDR2 800)
    Graphics card(s)
    EVGA 256-P2-N758-TR GeForce 8600GT SSC
    Sound Card
    Onboard
    Monitor(s) Displays
    ViewSonic G90FB Black 19" Professional (CRT)
    Screen Resolution
    up to 2048 x 1536
    Hard Drives
    WD 36GB 10,000rpm Raptor SATA
    Seagate 80GB 7200rpm SATA
    Lite-On LTR-52246S CD/RW
    Lite-On LH-18A1P CD/DVD Burner
    PSU
    PC Power & Cooling Silencer 750 Quad EPS12V
    Case
    Generic Beige case, 80mm fans
    Cooling
    ZALMAN 9500A 92mm CPU Cooler
    Mouse
    Logitech Optical M-BT96a
    Keyboard
    Logitech Classic Keybooard 200
    Internet Speed
    300/300
    Browser
    Firefox 3.x ??
    Antivirus
    Symantec (Norton)
    Other Info
    Still assembled, still runs. Haven't turned it on for 13 years?
I had a similar problem and solved it by not using Edge. I have no issues with FireFox and I have HA turned on for both Windows and FF.
 

My Computer

System One

  • OS
    Win 11 Pro 23H2
    Computer type
    PC/Desktop
    Manufacturer/Model
    Self build
    CPU
    Ryzen 5800X
    Motherboard
    Gigabyte x570 Aorus Elite Wifi
    Memory
    32 GB GSkill Trident Neo with pretty LED lights
    Graphics Card(s)
    ASUS TUF GAMING RTX 3070 Ti
    Sound Card
    On board Realtek
    Monitor(s) Displays
    2 x Samsung 32 inch curved - one 4K, one 1080p
    Screen Resolution
    4K, 1920 x 1080
    Hard Drives
    1 TB Samsung 980 Pro Nvme, 1 TB Samsung 970 EVO Nvme, 2 x Samsung 970 2TB SSD SATA
    PSU
    EVGA 1000Q
    Case
    Rosewill something or other
    Cooling
    Noctua NH-D15. A whole schwak of Noctua case fans. $$$
    Keyboard
    Logitech G815
    Mouse
    Logitech G502 Hero
    Internet Speed
    700 up, 600 down
    Browser
    Firefox
    Antivirus
    MalwareBytes
I have Nivida RTX 3080TI founder addition with latest driver and windows 11/edge latest stable release version.

I have no idea why but when I enable Edge hardware acceleration feature when I surf the web or play video in YouTube/Netflix there are some weird glitches bug on my screen such as half or full black flashes, video refresh, UI of the website or even Edge looks like 16bit colors etc.

If I disable the hardware acceleration feature everything is back to normal, but I would like to know why and how I can fix it because I want to use this hardware acceleration feature for gaming.

I am having similar issues ( 4070 Ti). I can't watch any streaming videos with hardware acceleration on in Edge - the video is black screen. If I disable acceleration it is fine.

What version of nvidia drivers are you using?

investigating...
 

My Computers

System One System Two

  • OS
    Windows 11 Pro x64
    Computer type
    PC/Desktop
    Manufacturer/Model
    DIY Photoshop/Game/tinker build
    CPU
    Intel i9 13900KS P/E cores 5.9/4.4 GHz, cache 5.0 GHz
    Motherboard
    Asus ROG Maximus Z790 Dark Hero
    Memory
    64GB (2x32) G.skill Trident Z5 RGB 6400 MT/s
    Graphics Card(s)
    Asus ROG Strix 4070 Ti OC
    Sound Card
    Onboard Audio, Vanatoo Transparent One; Klipsch R-12SWi Sub; Creative Pebble Pro Minimilist
    Monitor(s) Displays
    Eizo CG2730 ColorEdge, ViewSonic VP2768
    Screen Resolution
    2560 x 1440p x 2
    Hard Drives
    WDC SN850 1TB nvme, SK-Hynix 2 TB P41 nvme, Raid 0: 1TB 850 EVO + 1TB 860 EVO SSD. Sabrent USB-C DS-SC5B 5-bay docking station: 6TB WDC Black, 6TB Ironwolf Pro; 2x 2TB WDC Black
    PSU
    850W Seasonic Vertex PX-850 ATX 3.0/PCI-E 5.0
    Case
    Fractal Design North XL Mesh, Black Walnut
    Cooling
    EKWB 360 Nucleus Dark AIO w/Phanteks T30-120 fans, 1 Noctua NF-A14 Chromax case fan, 1 T30-120 fan cooling memory
    Keyboard
    Keychron Q3 Max TKL with custom GMK Redsuns Red Samuri keycaps, TX Stabs
    Mouse
    Logitech G305 wireless gaming
    Internet Speed
    380 Mb/s down, 12 Mb/s up
    Browser
    Firefox
    Antivirus
    Defender, Macrium Reflect 8 ;-)
    Other Info
    Runs hot. LOL. SP: P116/E93/M93
    Phangkey Amaterasu V2 Desk Mat
  • Computer type
    Laptop
    Manufacturer/Model
    Apple 13" Macbook Pro 2020 (m1)
    CPU
    Apple M1
    Screen Resolution
    2560x1600
    Browser
    Firefox
I am having similar issues ( 4070 Ti). I can't watch any streaming videos with hardware acceleration on in Edge - the video is black screen. If I disable acceleration it is fine.

What version of nvidia drivers are you using?

investigating...

Found my issue. In Edge:flags (experimental settings) I had Vulkan enabled which enabled Vulkan as the graphics back-end. Apparently that does not work anymore (or never did - I use edge as my back-up browser). Set it to disabled (or Default) and stream video is working again).
 

My Computers

System One System Two

  • OS
    Windows 11 Pro x64
    Computer type
    PC/Desktop
    Manufacturer/Model
    DIY Photoshop/Game/tinker build
    CPU
    Intel i9 13900KS P/E cores 5.9/4.4 GHz, cache 5.0 GHz
    Motherboard
    Asus ROG Maximus Z790 Dark Hero
    Memory
    64GB (2x32) G.skill Trident Z5 RGB 6400 MT/s
    Graphics Card(s)
    Asus ROG Strix 4070 Ti OC
    Sound Card
    Onboard Audio, Vanatoo Transparent One; Klipsch R-12SWi Sub; Creative Pebble Pro Minimilist
    Monitor(s) Displays
    Eizo CG2730 ColorEdge, ViewSonic VP2768
    Screen Resolution
    2560 x 1440p x 2
    Hard Drives
    WDC SN850 1TB nvme, SK-Hynix 2 TB P41 nvme, Raid 0: 1TB 850 EVO + 1TB 860 EVO SSD. Sabrent USB-C DS-SC5B 5-bay docking station: 6TB WDC Black, 6TB Ironwolf Pro; 2x 2TB WDC Black
    PSU
    850W Seasonic Vertex PX-850 ATX 3.0/PCI-E 5.0
    Case
    Fractal Design North XL Mesh, Black Walnut
    Cooling
    EKWB 360 Nucleus Dark AIO w/Phanteks T30-120 fans, 1 Noctua NF-A14 Chromax case fan, 1 T30-120 fan cooling memory
    Keyboard
    Keychron Q3 Max TKL with custom GMK Redsuns Red Samuri keycaps, TX Stabs
    Mouse
    Logitech G305 wireless gaming
    Internet Speed
    380 Mb/s down, 12 Mb/s up
    Browser
    Firefox
    Antivirus
    Defender, Macrium Reflect 8 ;-)
    Other Info
    Runs hot. LOL. SP: P116/E93/M93
    Phangkey Amaterasu V2 Desk Mat
  • Computer type
    Laptop
    Manufacturer/Model
    Apple 13" Macbook Pro 2020 (m1)
    CPU
    Apple M1
    Screen Resolution
    2560x1600
    Browser
    Firefox

Latest Support Threads

Latest Tutorials

Back
Top Bottom