Generic icons showing on taskbar


mldardy

Member
Local time
9:33 AM
Posts
3
OS
Windows 11
I'm not sure how this happened but most of my icons in the taskbar are showing up generic like this. I have googled and searched for solutions but none have worked so far.

Tried these command prompt steps:
ie4uinit.exe -show
taskkill /IM explorer.exe /F
DEL /A /Q "%localappdata%\IconCache.db" says this is not found when I run it.
DEL /A /F /Q "%localappdata%\Microsoft\Windows\Explorer\iconcache*"
explorer.exe

and

these steps
From the File menu of Task Manager, select New Task (Run…)

Type CMD.EXE, and click OK

In the Command Prompt window, type the following commands one by one and press ENTER after each command:

CD /d %userprofile%\AppData\Local

DEL IconCache.db /a

EXIT

In Task Manager, Restart file explorer.




genericicons.png
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell
    CPU
    12th Gen Intel(R) Core(TM) i7-1255U 1.70 GHz
    Memory
    16.0 GB
Hi mldardy, welcome to the Eleven Forums

There is a tutorial in here, Option one and Option Two
But you seem to get snagged at IconCache.db


There is also a MS thread here that was at the top of my search results, you may of seen it.

Windows 11 taskbar icons are genetic for some apps

Note the post and script by Claudio Tropeano who replied on September 17, 2023
It’s on page 4 when I look at the thread. It seems to of helped at least one person so…
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 Build: 22631.3374
    Computer type
    PC/Desktop
    Manufacturer/Model
    Sin-built
    CPU
    Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz (4th Gen?)
    Motherboard
    ASUS ROG Maximus VI Formula
    Memory
    32.0 GB of I forget and the box is in storage.
    Graphics Card(s)
    Gigabyte nVidia GeForce GTX 1660 Super OC 6GB
    Sound Card
    Onboard
    Monitor(s) Displays
    4 x LG 23MP75 1 x 24" LG M38H 1 x 32" LF6300 TV Monitor 1 x Wacom Pro 22" Tablet
    Screen Resolution
    All over the place
    Hard Drives
    2 x WD something Something 8TB HDD's / 2 x WD something Something 4TB HDD's / 1 x EVO 1TB SSD / 2 x QVO 1TB SSD's / 1 x EVO 250 GB SSD / 2 x QVO 1TB (External Hub) / 1 x EVO 1TB (Portable Backup Case)
    PSU
    Silverstone 1500
    Case
    NZXT Phantom 820 Full-Tower Case
    Cooling
    Noctua NH-D15 Elite Class Dual Tower CPU Cooler / 6 x EziDIY 120mm / 2 x Corsair 140mm somethings / 1 x 140mm Thermaltake something / 2 x 200mm Corsair.
    Keyboard
    Corsair K95 / Logitech diNovo Edge Wireless
    Mouse
    Logitech G402 / G502 / Mx Masters / MX Air Cordless
    Internet Speed
    100/40Mbps
    Browser
    All sorts
    Antivirus
    Kaspersky Premium
    Other Info
    I’m on a horse.
  • Operating System
    Windows 11 Pro 22621.2215
    Computer type
    Laptop
    Manufacturer/Model
    LENOVO Yoga 7i EVO OLED 14" Touchscreen i5 12 Core 16GB/512GB
    CPU
    Intel Core 12th Gen i5-1240P Processor (1.7 - 4.4GHz)
    Memory
    16GB LPDDR5 RAM
    Graphics card(s)
    Graphics processor is an Intel Iris Xe
    Sound Card
    optimized with Dolby Atmos®
    Screen Resolution
    QHD 2880 x 1800 OLED
    Hard Drives
    M.2 512GB
    Other Info
    …still on a horse.
Maybe you could just create a dummy IconCache.db for the sake of the script if it isn’t there, but that would seem odd, it must be there somewhere.

I had also read that creating a new user account has fixed issues (first reply) in the above MS thread.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 Build: 22631.3374
    Computer type
    PC/Desktop
    Manufacturer/Model
    Sin-built
    CPU
    Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz (4th Gen?)
    Motherboard
    ASUS ROG Maximus VI Formula
    Memory
    32.0 GB of I forget and the box is in storage.
    Graphics Card(s)
    Gigabyte nVidia GeForce GTX 1660 Super OC 6GB
    Sound Card
    Onboard
    Monitor(s) Displays
    4 x LG 23MP75 1 x 24" LG M38H 1 x 32" LF6300 TV Monitor 1 x Wacom Pro 22" Tablet
    Screen Resolution
    All over the place
    Hard Drives
    2 x WD something Something 8TB HDD's / 2 x WD something Something 4TB HDD's / 1 x EVO 1TB SSD / 2 x QVO 1TB SSD's / 1 x EVO 250 GB SSD / 2 x QVO 1TB (External Hub) / 1 x EVO 1TB (Portable Backup Case)
    PSU
    Silverstone 1500
    Case
    NZXT Phantom 820 Full-Tower Case
    Cooling
    Noctua NH-D15 Elite Class Dual Tower CPU Cooler / 6 x EziDIY 120mm / 2 x Corsair 140mm somethings / 1 x 140mm Thermaltake something / 2 x 200mm Corsair.
    Keyboard
    Corsair K95 / Logitech diNovo Edge Wireless
    Mouse
    Logitech G402 / G502 / Mx Masters / MX Air Cordless
    Internet Speed
    100/40Mbps
    Browser
    All sorts
    Antivirus
    Kaspersky Premium
    Other Info
    I’m on a horse.
  • Operating System
    Windows 11 Pro 22621.2215
    Computer type
    Laptop
    Manufacturer/Model
    LENOVO Yoga 7i EVO OLED 14" Touchscreen i5 12 Core 16GB/512GB
    CPU
    Intel Core 12th Gen i5-1240P Processor (1.7 - 4.4GHz)
    Memory
    16GB LPDDR5 RAM
    Graphics card(s)
    Graphics processor is an Intel Iris Xe
    Sound Card
    optimized with Dolby Atmos®
    Screen Resolution
    QHD 2880 x 1800 OLED
    Hard Drives
    M.2 512GB
    Other Info
    …still on a horse.
Have you tried unpinning an icon and re-pinning it to taskbar as a test. If it works you can then do it for each icon. Laborious I know but if it works then it is worth the effort.
 
Last edited:

My Computers

System One System Two

  • OS
    Windows 11 Pro
    Computer type
    PC/Desktop
    Manufacturer/Model
    HP EliteDesk 705 G5
    CPU
    AMD Ryzen 5 Pro 3400GE
    Memory
    8GB DDR4 SDRAM
    Graphics Card(s)
    Integrated AMD Radeon Vega 11
    Hard Drives
    256 GB PCIe NVMe M.2 SSD
  • Operating System
    Windows 11 Home
    Computer type
    Laptop
    Manufacturer/Model
    DELL Inspiron 15-3576
    CPU
    Intel Core i5-8250U
    Memory
    8 GB DDR4 - 2400 SODIMM
    Graphics card(s)
    Intel UHD Graphics 620
    Hard Drives
    256GB SK Hynix SC311 SATA SSD
I appreciate everyone's help on this but none of the suggestions worked. Some of my icons show up fine but Amazon Kindle and Google Chrome didn't so I uninstalled and re-installed both and now the icons show.

genericicons.png
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell
    CPU
    12th Gen Intel(R) Core(TM) i7-1255U 1.70 GHz
    Memory
    16.0 GB
I would be looking in to this;
IconCache.db" says this is not found when I run it.
In the address bar of File Explorer, type or paste %userprofile%/AppData\Local . Scroll through all of the files until you find a file named IconCache or IconCache.db. You may have to show hidden/system files.

Unless you deleted it already with a script and then ran another before it had been rebuilt.
 

My Computers

System One System Two

  • OS
    Windows 11 Pro 23H2 Build: 22631.3374
    Computer type
    PC/Desktop
    Manufacturer/Model
    Sin-built
    CPU
    Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz (4th Gen?)
    Motherboard
    ASUS ROG Maximus VI Formula
    Memory
    32.0 GB of I forget and the box is in storage.
    Graphics Card(s)
    Gigabyte nVidia GeForce GTX 1660 Super OC 6GB
    Sound Card
    Onboard
    Monitor(s) Displays
    4 x LG 23MP75 1 x 24" LG M38H 1 x 32" LF6300 TV Monitor 1 x Wacom Pro 22" Tablet
    Screen Resolution
    All over the place
    Hard Drives
    2 x WD something Something 8TB HDD's / 2 x WD something Something 4TB HDD's / 1 x EVO 1TB SSD / 2 x QVO 1TB SSD's / 1 x EVO 250 GB SSD / 2 x QVO 1TB (External Hub) / 1 x EVO 1TB (Portable Backup Case)
    PSU
    Silverstone 1500
    Case
    NZXT Phantom 820 Full-Tower Case
    Cooling
    Noctua NH-D15 Elite Class Dual Tower CPU Cooler / 6 x EziDIY 120mm / 2 x Corsair 140mm somethings / 1 x 140mm Thermaltake something / 2 x 200mm Corsair.
    Keyboard
    Corsair K95 / Logitech diNovo Edge Wireless
    Mouse
    Logitech G402 / G502 / Mx Masters / MX Air Cordless
    Internet Speed
    100/40Mbps
    Browser
    All sorts
    Antivirus
    Kaspersky Premium
    Other Info
    I’m on a horse.
  • Operating System
    Windows 11 Pro 22621.2215
    Computer type
    Laptop
    Manufacturer/Model
    LENOVO Yoga 7i EVO OLED 14" Touchscreen i5 12 Core 16GB/512GB
    CPU
    Intel Core 12th Gen i5-1240P Processor (1.7 - 4.4GHz)
    Memory
    16GB LPDDR5 RAM
    Graphics card(s)
    Graphics processor is an Intel Iris Xe
    Sound Card
    optimized with Dolby Atmos®
    Screen Resolution
    QHD 2880 x 1800 OLED
    Hard Drives
    M.2 512GB
    Other Info
    …still on a horse.
I would be looking in to this;

In the address bar of File Explorer, type or paste %userprofile%/AppData\Local . Scroll through all of the files until you find a file named IconCache or IconCache.db. You may have to show hidden/system files.

Unless you deleted it already with a script and then ran another before it had been rebuilt.
Yes I see it and didn't have to do show hidden files.
 

My Computer

System One

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    Dell
    CPU
    12th Gen Intel(R) Core(TM) i7-1255U 1.70 GHz
    Memory
    16.0 GB
Yes I see it and didn't have to do show hidden files.
I had a similar problem. Created by registry cleaning (with ASC). If you did registry cleaning before the problem, keep that in mind.
 

My Computer

System One

  • OS
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    HP Pavilion 17 cd2205nw
    CPU
    Intel 113700H
    Memory
    16GB
    Graphics Card(s)
    NVIDIA RTX 3050 ti
    Screen Resolution
    1980x1020
    Hard Drives
    Micron 512GB
    Mouse
    Logitech
    Internet Speed
    100Mbs
    Browser
    Vivaldi , Edge
    Antivirus
    Norton Plus
Back
Top Bottom