Hyper-V Password Problem


Winuser

Well-known member
Pro User
VIP
Local time
9:51 AM
Posts
2,910
OS
Windows 11
I installed Windows 10 in Hyper-V and now I can't log-in. I tried deleting the first VM and reinstalling which led me to calling MS to reactivate. Now it's doing it again. I have the log-in screen but no option to type in my password. Is there a way for me to fix this without reinstalling? If I understood the tech correctly, I can only use the key three times.
 

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    PowerSpec B746
    CPU
    Intel Core i7-10700K
    Motherboard
    ASRock Z490 Phantom Gaming 4/ax
    Memory
    16GB (8GB PC4-19200 DDR4 SDRAM x2)
    Graphics Card(s)
    NVIDIA GeForce GTX 1050 TI
    Sound Card
    Realtek Audio
    Monitor(s) Displays
    Samsung SAM0A87 Samsung SAM0D32
    Screen Resolution
    1920 x 1080
    Hard Drives
    NVMe WDC WDS100T2B0C-00PXH0 1TB
    Samsung SSD 860 EVO 1TB
    PSU
    750 Watts (62.5A)
    Case
    PowerSpec/Lian Li ATX 205
    Keyboard
    Logitech K270
    Mouse
    Logitech M185
    Browser
    Microsoft Edge and Firefox
    Antivirus
    ESET Internet Security
  • Operating System
    Windows 11 Dev
    Computer type
    Laptop
    Manufacturer/Model
    HP Envy x360 15-ds1083cl
    CPU
    AMD Ryzen 7 4700U 2.0GHZ
    Memory
    16 MB DDR 4-2666
    Graphics card(s)
    AMD Radeon
    Monitor(s) Displays
    15.6"
    Screen Resolution
    1920x1080
    Hard Drives
    PCIe NVMe M.2 512GB
    Browser
    Firefox, Edge and Edge Canary
    Antivirus
    ESET Internet Security

Winuser

Well-known member
Pro User
VIP
Thread Starter
Local time
9:51 AM
Posts
2,910
OS
Windows 11
I managed to log-in. There is an option in Hyper-V to use a Basic Session. When I clicked on it the VM restarted and I had the sign-in box. Does anyone know what I need to do to be able to sign in normally? I'm not going to mark this as solved because it's only half solved.
 

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    PowerSpec B746
    CPU
    Intel Core i7-10700K
    Motherboard
    ASRock Z490 Phantom Gaming 4/ax
    Memory
    16GB (8GB PC4-19200 DDR4 SDRAM x2)
    Graphics Card(s)
    NVIDIA GeForce GTX 1050 TI
    Sound Card
    Realtek Audio
    Monitor(s) Displays
    Samsung SAM0A87 Samsung SAM0D32
    Screen Resolution
    1920 x 1080
    Hard Drives
    NVMe WDC WDS100T2B0C-00PXH0 1TB
    Samsung SSD 860 EVO 1TB
    PSU
    750 Watts (62.5A)
    Case
    PowerSpec/Lian Li ATX 205
    Keyboard
    Logitech K270
    Mouse
    Logitech M185
    Browser
    Microsoft Edge and Firefox
    Antivirus
    ESET Internet Security
  • Operating System
    Windows 11 Dev
    Computer type
    Laptop
    Manufacturer/Model
    HP Envy x360 15-ds1083cl
    CPU
    AMD Ryzen 7 4700U 2.0GHZ
    Memory
    16 MB DDR 4-2666
    Graphics card(s)
    AMD Radeon
    Monitor(s) Displays
    15.6"
    Screen Resolution
    1920x1080
    Hard Drives
    PCIe NVMe M.2 512GB
    Browser
    Firefox, Edge and Edge Canary
    Antivirus
    ESET Internet Security

Bree

Well-known member
Pro User
VIP
Local time
2:51 PM
Posts
2,736
Location
S/E England, UK
OS
Windows 11 Home
Does anyone know what I need to do to be able to sign in normally?
This is a known problem, with a known solution from Kari.

Kari said:
The problem is, that Enhanced Mode in Hyper-V is based on Remote Desktop Protocol (RDP), basically exactly the same than a remote desktop connection. RDP requires a password sign-in, it does not accept PIN. As W11 OOBE / setup, when user uses an MS account, requires user to create a PIN, and enforces Windows Hello at sign-in by default, Hyper-V VM enhanced mode sign-in fails, only showing an empty screen. The system is awaiting a PIN as Windows Hello has disabled password sign-in. PIN is not allowed becase of the remote desktop protocol, system cannot show sign-in screen.

The solution really is simple. Sign in once in normal mode, disable Windows Hello enforcement, and switch to enhanced mode. Sign-in screen will be shown, and user can sign in to VM with password.
Trying to install Windows 11 in Hyper-V problem - post #9


Edit: actually that reply from Kari was to a post by you, so you seem to have forgotten his advice :D
 

My Computers

System One System Two

  • OS
    Windows 11 Home
    Computer type
    Laptop
    Manufacturer/Model
    Acer Aspire 3 A315-23
    CPU
    AMD Athlon Silver 3050U
    Memory
    8GB
    Graphics Card(s)
    Radeon Graphics
    Monitor(s) Displays
    laptop screen
    Screen Resolution
    1366x768 native resolution, up to 2560x1440 with Radeon Virtual Super Resolution
    Hard Drives
    1TB HDD
    Browser
    Edge, Firefox
    Antivirus
    Defender
    Other Info
    fully 'Windows 11 ready' laptop. Windows 10 C: partition migrated from my old unsupported 'main machine' then upgraded to 11. A test migration ran Insider builds for 2 months. When 11 was released on 5th October it was re-imaged back to 10 and was offered the upgrade in Windows Update on 20th October.


    My SYSTEM THREE is a Dell Latitude 5410, i7-10610U, 32GB RAM, 512GB ssd, Windows 11 Pro.
  • Operating System
    Windows 11 Pro
    Computer type
    Laptop
    Manufacturer/Model
    Dell Lattitude E4310
    CPU
    i5 M 520
    Motherboard
    0T6M8G
    Memory
    4GB
    Screen Resolution
    1366x768
    Hard Drives
    500GB HDD
    Browser
    Firefox, Edge
    Antivirus
    Defender
    Other Info
    unsupported machine: Legacy bios, MBR, TPM 1.2, upgraded from W10 to W11 using W10/W11 hybrid install media workaround.


    My SYSTEM THREE is a Dell Latitude 5410, i7-10610U, 32GB RAM, 512GB ssd, Windows 11 Pro.

Winuser

Well-known member
Pro User
VIP
Thread Starter
Local time
9:51 AM
Posts
2,910
OS
Windows 11
I did forget about the time I was trying to run Win 11 Home in a Hyper-V and couldn't get the sound working. Turning off Windows Hello did work. For some reason it took two restarts after turning off Windows Hello before I could get the Win 10 Pro VM to do 1920 X 1080 even though Hyper-V was full screen. One thing that was has me confused is that when I installed Win 10 everything worked. It wasn't until after a couple of restarts that I lost the sign-in box. I tried removing the first VM and starting over. The second install was working except it wouldn't activate. When I called MS, I had a very long wait until I reached a tech. I had to give them a very long ID number and they gave me a new ID number to enter. After Win 10 was activated, they wanted me to do a couple of restarts. The second restart was when I lost the sign-in box again. He transferred me to another tech who didn't know what to do. They suggested that I do another clean install. Not wanting to go through the hassle of reactivaing again I told them I would ask for help from the members on ElevenForums.
 

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    PowerSpec B746
    CPU
    Intel Core i7-10700K
    Motherboard
    ASRock Z490 Phantom Gaming 4/ax
    Memory
    16GB (8GB PC4-19200 DDR4 SDRAM x2)
    Graphics Card(s)
    NVIDIA GeForce GTX 1050 TI
    Sound Card
    Realtek Audio
    Monitor(s) Displays
    Samsung SAM0A87 Samsung SAM0D32
    Screen Resolution
    1920 x 1080
    Hard Drives
    NVMe WDC WDS100T2B0C-00PXH0 1TB
    Samsung SSD 860 EVO 1TB
    PSU
    750 Watts (62.5A)
    Case
    PowerSpec/Lian Li ATX 205
    Keyboard
    Logitech K270
    Mouse
    Logitech M185
    Browser
    Microsoft Edge and Firefox
    Antivirus
    ESET Internet Security
  • Operating System
    Windows 11 Dev
    Computer type
    Laptop
    Manufacturer/Model
    HP Envy x360 15-ds1083cl
    CPU
    AMD Ryzen 7 4700U 2.0GHZ
    Memory
    16 MB DDR 4-2666
    Graphics card(s)
    AMD Radeon
    Monitor(s) Displays
    15.6"
    Screen Resolution
    1920x1080
    Hard Drives
    PCIe NVMe M.2 512GB
    Browser
    Firefox, Edge and Edge Canary
    Antivirus
    ESET Internet Security

Winuser

Well-known member
Pro User
VIP
Thread Starter
Local time
9:51 AM
Posts
2,910
OS
Windows 11
MS surprised me tonight. They called me to see if I was still having a problem. I told them my problem was solved and that I'm once again a very happy Windows user.
 

My Computers

System One System Two

  • OS
    Windows 11
    Computer type
    PC/Desktop
    Manufacturer/Model
    PowerSpec B746
    CPU
    Intel Core i7-10700K
    Motherboard
    ASRock Z490 Phantom Gaming 4/ax
    Memory
    16GB (8GB PC4-19200 DDR4 SDRAM x2)
    Graphics Card(s)
    NVIDIA GeForce GTX 1050 TI
    Sound Card
    Realtek Audio
    Monitor(s) Displays
    Samsung SAM0A87 Samsung SAM0D32
    Screen Resolution
    1920 x 1080
    Hard Drives
    NVMe WDC WDS100T2B0C-00PXH0 1TB
    Samsung SSD 860 EVO 1TB
    PSU
    750 Watts (62.5A)
    Case
    PowerSpec/Lian Li ATX 205
    Keyboard
    Logitech K270
    Mouse
    Logitech M185
    Browser
    Microsoft Edge and Firefox
    Antivirus
    ESET Internet Security
  • Operating System
    Windows 11 Dev
    Computer type
    Laptop
    Manufacturer/Model
    HP Envy x360 15-ds1083cl
    CPU
    AMD Ryzen 7 4700U 2.0GHZ
    Memory
    16 MB DDR 4-2666
    Graphics card(s)
    AMD Radeon
    Monitor(s) Displays
    15.6"
    Screen Resolution
    1920x1080
    Hard Drives
    PCIe NVMe M.2 512GB
    Browser
    Firefox, Edge and Edge Canary
    Antivirus
    ESET Internet Security
Top Bottom